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License Agreement

Please Read Carefully

Please read the terms of this agreement before installing the Software. By installing or otherwise using the Software, you accept all the terms and conditions of this Agreement completely. If you do not agree to these terms, you may, within thirty (30) days of purchase, return the unused software product to the location where you obtained it.

Relex Software License Agreement

1. License. Relex Software Corporation hereby agrees to grant to you, the user, a nonexclusive license to use the enclosed Software, subject to the terms and conditions set forth in this License Agreement.

2. Copyright. The Software and its Documentation are copyrighted. You may not copy or otherwise reproduce any part of the Software and its associated files, except that you may load the Software into a computer as an essential step in executing the Software on the computer.

3. Restrictions on Use and Transfer. Except as set forth here, you may use the Software on a single computer.

· Single User Version. You may store or install a copy of the Software on a storage device, such as a network server, used only to install or run the Software over an internal network; however, you must acquire and dedicate a license for each individual who will use the Software. A License for the Software may not be shared or used concurrently on different computers. 

· Network Version. You may store or install a copy of the Software on a storage device, such as a network server, used only to install or run the Software over an internal network; however, only the number of concurrent users permitted under this License may use the Software at the same time. A LAN network license is intended only for a single corporate entity at a single site and can use only privately owned communication facilities that do not utilize any leased facilities that cross a public right of way.

· General. If the Software is installed on a network server or other system that physically allows shared access to the Software, you agree to provide technical or procedural methods to prevent use of the Software by individuals not specifically licensed to use the Software pursuant to this Agreement. You may not use, copy, modify, or transfer the Software or its associated files, or any copy, modification, or merged portion, in whole or in part, except as expressly provided for in this license.

· Transfer. You may physically transfer the Software from one computer to another, provided that the Software is only used on one (1) computer at a time. You may transfer the license together with the Software and Documentation to another company or site only with written approval from Relex Software Corporation. The transferee agrees to be bound by the terms of this License Agreement.

4. Warranty. The Software and its documentation are distributed as is, without warranties as to performance or merchantability. The seller’s salespersons may have made statements about this software. Any such statements do not constitute warranties and shall not be relied on by the buyer in deciding whether to purchase the Software. The Software is sold without any express or implied warranties whatsoever. Because of the diversity of conditions and hardware under which the Software may be used, no warranty of fitness for a particular purpose is offered. The user is advised to test the Software thoroughly before relying on it. The user must accept the entire risk of using the Software. In no event shall Relex Software Corporation be liable for any damages whatsoever resulting from the use of the Software. Some states do not allow the exclusion or limitation of incidental or consequential damages so the above limitation or exclusion may not apply to you.

5. General Terms. This is the only agreement between you, the user, and Relex Software Corporation regarding this Software product and it may be modified only by a written agreement between those parties. This agreement cannot be modified by purchase orders, advertising, or other representations by any person. If any provision of this agreement shall be held invalid, illegal or unenforceable, then the validity, legality, and enforceability of the remaining provisions shall not be affected or impaired thereby. This agreement shall be governed by the laws of the State of Pennsylvania. By installing or retaining the Software, you acknowledge that you have read this agreement, understand it, and agree to be bound by its terms and conditions.

Copyright ( 1986-1999 Relex Software Corporation. All rights reserved.  Portions Copyright ( 1985-1999 Microsoft Corporation. All rights reserved.

Relex( is a registered trademark and CAD Import/ExportWizard is a trademark of Relex Software Corporation. All other brand and product names are trademarks or registered trademarks of their respective holders.
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Chapter 1 Getting Started

Read Me First!

Welcome

Thank you for choosing Relex! 

This chapter is intended to get you up and running with Relex in minimal time. Use this “Read Me First” section for installation instructions and quick startupxe "Quick Startup" procedures.

Also included in this chapter is a section titled “Introduction to Relex and Reliability”. This section is intended to provide you with background on general reliability topics and procedures and how Relex fits into your analysis tool set.

For details on using the specific Relex modules, refer to the appropriate chapter in your documentation package.

Installation

Hardware Requirements

The minimum requirements to operate Relex are:

· 486 or greater PC compatible

· 32MB RAM

· 75MB Hard Disk Space

· CD-ROM drive

· 32-bit Windows

It should be noted that increased memory, processor speed, and hard drive space always improves the performance of any software package.

xe "Installing Relex"Installing Relex
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Figure 1 - 1. Relex Installation Options

There are two installation modes available when installing Relex. 

The Express installation, recommended for most single-user installations, installs Relex with minimal user input.

The Custom installationxe "Custom Installation" \r "D2HBCustom_Insta2" allows the customization of all available setup options. The Custom installation is required for network installations and recommended only for advanced users and/or system administrators. For additional instructions on custom installations, refer to the section titled “Custom Installation”.

For both installations, Relex requests the location of the Relex files and all associated directories. The primary directory may be read-only, but the other directories must be read/write accessible.

Note: During installation, if you receive the message, “A read only file <file name> was found while attempting to copy files to the destination location”, select <Yes> to overwrite the file.

xe "Single-User Installation"Single-User Installation

Follow these steps to install Relex on a stand-alone computer:

1. Startup Windows. If you are installing under Windows NT,xe "Windows NT" you must log on to an account with Administrator privileges. Make sure all applications are closed.

2. Insert the Relex CD. If Setup runs automatically, follow the on-screen instructions. Otherwise, run Setup by selecting Run from the Start menu and entering X:\Setup.exe where X: is the drive letter of your CD-ROM drive. If you install this upgrade in the same directory as a previous Relex version, that previous version will be unusable.

3. After installation is complete, you need to license your Relex package. Refer to the section titled “Licensing Relex” for instructions on licensing Relex.

Note: If you are installing a single-user version under Windows NT, you must log on to an account with Administrator privileges to install Relex properly.

xe "Network Installation"Network Installation

To install Relex on a network, refer to the Docs directory on your Relex CD. This file gives you detailed instructions necessary for installing your network version of Relex.

Custom Installation

When performing a custom installation, Relex allows you to specify the installation path of certain file folders. These folders or directories are described as follows:

	Folder
	Description

	Files Folder
	The Files Folder contains all Relex Sample files and supplied Relex files (Report Design files, Derating files, Modes files,xe "Modes files" etc). This directory is also the default location where new data files are stored. This directory must be read/write accessible.

	Relex Librariesxe "Relex Libraries" Folder
	The Relex Libraries Folder contains Library filesxe "Library files" \r "D2HBLibrary_file3" that are supplied with Relex. It is also be the default location where new Library files are stored. This directory must be read/write accessible.

	Auxiliary Files Folder
	This folder contains special filesxe "Special files" that are required to be read/write accessible by Relex.


Once the paths for the above folders are selected, you have the option to include or exclude certain files from the installation process. Below is a brief description of each option that can be included or excluded during the installation:

	Option
	Description

	Program Files

	Files required by Relex to operate. Under this category,xe "Category" specific file typesxe "File Types" can be included or excluded. (It is advised to install all file types under this category. If selected improperly, error messages and various problems in operating the program may occur.) These file types are:

	
	Demoxe "Demo" Libraries. Libraries used by the Relex Demo program. These Libraries are limited versions of the full Relex Libraries.

	
	Data Access Objects Core Components. Required for Relex to operate properly.

	
	Data Access Objects. Required for Relex to operate properly.

	
	Shared DLLs. Required for Relex to operate properly.

	
	ActiveX Controls. Required for Relex to operate properly.

	Report Design Files
	Report Design files supplied by Relex. If these files are being re-installed, they may overwrite the existing Report Design files, and therefore, overwrite any changes that you have made to Relex supplied Report Design files.

	Sample Files
	Sample files used as examples. These files are referred to in the Relex Tutorial,xe "Tutorial" and provide a good source of reference for new users.

	Template Files
	Template files provide a format by which new files are created. If these files are being re-installed, they overwrite the existing Template files, and therefore, overwrite any changes that you have made to Relex supplied Template files.

	Integrated Circuit Libraries


	The files that are required to access the Relex Integrated Circuit Library. If these files are being re-installed, they overwrite the existing Relex Integrated Circuit Library files, and therefore, overwrite any changes that you have made to the Relex IC Library.

	Semiconductor / Resistorxe "Resistor" / Capacitorxe "Capacitor" Libraries


	The files that are required to access the Relex Semiconductor, Resistor, and Capacitor Libraries. If these files are being re-installed, they overwrite the existing Semiconductor, Resistor, and Capacitor Library files, and therefore, overwrite any changes that you have made to these Relex supplied files.

	Non-Electronic Partsxe "Non-Electronic Parts" Libraries
	The files that are required to access the Non-Electronic Parts Library. 



	FMEA Files
	The files that are included with Relex FMEA. 

	Maintainability Predictionxe "Maintainability Prediction" Files
	The files that are included with Relex Maintainability Prediction.

	LCC Files
	The files that are included with Relex Life Cycle Cost.

	Network Setup
	The files required for a network installation.xe "Network Installation" In order for this to work properly, a network version of Relex must have been purchased.


xe "Relex Libraries Installation"Relex Libraries Installation

When the Relex Libraries are installed, they cannot be edited. If necessary, the Library files can be changed to have read/write access using Microsoft Explorer. Although this is an option, it is advised that changes to Relex Libraries be limited in order to ensure the integrity of the data in these files.

xe "Short File Names"Short File Names Supported 

The Relex installation procedure supports both long file names and short file names. During the installation process, Relex analyzes your system to see if it supports long file names. If your system does not support long file names, Relex returns a message stating that short file names will be used for the installation.

Long file names are advantageous because the long name allows for a better explanation of the file contents. For a complete listing of all Relex supplied files and their corresponding long and short filenames, refer to the Docs directory on your Relex CD.

Licensing Relex

Once Relex has been successfully installed, you need to license your Relex package in order to operate Relex on your computer. Until you have received an authorized license, Relex will operate in demo mode. Your Relex license is keyed to a particular computer, so you must license Relex on the computer you are going to be using to operate Relex. For information on licensing Relex, see the installation sheets that you received with your Relex purchase. This information is also available in the Docs directory on your Relex CD.

xe "Starting Relex"Starting Relex

Starting Relex is just like starting any Windows program. To start Relex, select Relex from the Start>Programs menu.

When first starting, Relex displays the Tip of the Dayxe "Tip of the Day" window. This feature provides helpful tips on using Relex. From this window, select the Startup tab. This tab presents several options. When just starting, it may be helpful to select the Open Sample Projectxe "Sample Project" option. This automatically opens a supplied sample Relex data file, called a Project file,xe "Project file" which you can use to view example data, calculate results and generate reports. You may also select the Create New Project option to open a new Relex Project file that you can use to start your analyses.

For first time users, it is useful to go through the Relex tutorial. This is a brief overview of Relex features and functions. If you do not have the printed version of the Relex Tutorial manual, you can access it online by selecting Help>Help Tutorial from the menu.

Converting from Previous Versions of Relex

xe "Converting Relex Files"Converting Relex Files from Relex Version 6.x

Relex 7 includes many new features and functions that require your current data files to be converted. Before converting your files, create back up copies of all your original files. Once a file has been converted, the converted file can no longer be opened in previous Relex versions.

Relex 7 includes a completely redesigned FMEA module.xe "FMEA Module" Because the conversion is not simply a one-to-one type of conversion, you may consider completing your current FMEAs with Relex 6 and then starting new FMEAs in Relex 7. The conversion process will convert your FMEAs, however, you should read the “FMEA” chapter of this manual to become familiar with the new Relex FMEA module to use Relex 7 FMEA.

Converting Project Files
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Figure 1 - 2. Converting Relex 6.x Project Files

Converting Relex Project files from Relex 6 to Relex 7 is a multi-step process that Relex guides you through. The procedure to convert a Project file is as follows:

1. Open the Project that you wish to convert.

2. Relex asks if you are sure you want to convert the Project. Press <Yes>.

3. At this point, you may skip all further questionsxe "Questions" and have Relex convert your Project file with a set of default conditions. To do this, press <Convert Now!>, and all further steps will be skipped. Otherwise, to go to the next step, press <Next>.

4. For Project conversions, Relex 7 automatically creates a backup copy of your file. By default Relex names this file “6.x Backup of <filename>”. To change the name of the backup file, enter a new name. Press <Next>.

5. In Relex 7, you may choose the information that is stored in your Project file. This allows you to enable only the required components within a Project file to keep file sizes to a minimum. The conversion process displays what information is currently in your Relex 6 Project file, and allows you to select what information you want to include in your Relex 7 Project file. Select the information that you want and press <Next> when complete.

6. In Relex 6, Modes files and Tasks filesxe "Tasks file" were based on internal ID generated by Relex. In Relex 7, you assign a unique alphanumeric code to items in these files. The Relex 7 conversion automatically creates new files using these codes from the description fields in your Relex 6 files. You can select how many characters to use for these codes. For example, you may have failure modes in your Relex 6 files such as “Resistor fails open” and “Resistor fails shorted”. In this case, it would be useful to have Relex use the first 25 characters for code creation since the first parts of these modes are identical. If your failure modes are “Open” and “Shorted”, 10 characters may be sufficient. Relex does not duplicate codes, so in the first case, if only 8 characters are used, the first failure mode code would be “Resistor1”, and the second failure mode code “Resistor2”.

7. Relex 7 includes new Input Format filesxe "Input Format Files" for the configuration of the Parts Tablexe "Parts Table" and the FMEA Data tab.xe "FMEA Data tab" Relex 7 automatically converts your Relex 6 Parts Table Format and Relex 6 FMECA Input Format to these new formats. You may select the name of these new files. When complete, press <Next>.

8. In Relex 6, several files were embedded within the Project file itself. Relex 7 now uses external files so that this data is easily accessible across multiple Projects. These files are now also based on a unique user assigned code instead of a Relex generated internal ID. As described in Step #5, you need to specify how many characters Relex should use when generating these new codes. Enter the names for the new files and the number of characters to use for creating codes. When complete, press <Next>.

9. Press <Finish> to complete the conversion. Relex displays a progress bar during the conversion.

Converting Parts Table and FMECA Input Files

Relex 7 uses a general Input Format filexe "Format file" for configuring input forms. To convert Relex 6 Parts Table files and FMECA Input files to this new format, follow these steps:

1. Select File>New>Format>Input Format from the menu and enter the name of the new file.

2. To convert a FMECA Input file, select FMEA for the Table Type. Select Prediction to convert a Parts Table filexe "Parts Table file" to an Input Format File for use in a Project file. Select Library or Default to convert a Parts Table file to an Input Format file for use in a Library or Default file.

3. When the file is opened, select Tools>Convert Version 6.x File from the menu. 

4. Select the file to be converted.

Converting All File Types Other Than Project, Parts Table, and FMECA Input Files

To convert data files other than Relex Project, Parts Table, and FMECA Input files from Relex 6 to Relex 7, select File>Open from the menu and enter the name of the Relex 6 file. A message appears stating that the data file was created with a previous version of Relex, and asking if you are sure you want to convert it. To convert the file press <Yes>, to cancel the process, press <No>. Please note that you should always save a backup of your files before converting them.

xe "Reliability Prediction"

xe "Converting Reliability Prediction Files"Converting Reliability Prediction Files from Relex Version 5.x
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Figure 1 - 3. Converting Relex 5.x Files

For Subassembly, Library, and Correlation filesxe "Correlation files" \r "D2HBCorrelation_8" created with Relex version 5.x, these files must be converted. This feature is accessed by selecting Tools>Convert from the menu in Relex. To convert your Relex 5.x files follow these steps:

1. Backup all of your existing files.

2. Start Relex and select Tools>Convert.

3. In the File Open dialog box, select the Relex 5.x Subassembly, Library, or Correlation files that you wish to convert and press <Open>. Go to Step 4 if you are converting a Library or a Correlation file. Go to Step 5 if you are converting a Subassembly.

4. If you are converting a Library or a Correlation file, Relex immediately begins the conversion, naming the new Library or Correlation file with the same name.

5. If you are converting a Subassembly, Relex allows you to create a new Project or append the assembly to an existing Project. Enter the name of a new Project or enter the name of an existing Project (to add a new assembly to an existing Project). Then enter the name of the assembly that you wish to create and press <OK> to perform the conversion.

6. Repeat steps 2-5 for any additional files that you wish to convert.

7. When you open the new files, Relex performs all other conversions automatically.

The Relex 5.x conversion process also includes the ability to convert an entire directory of Relex 5.x files. This function automatically converts all contents of the directory into one Relex Project file. To convert an entire directory of Relex 5.x files, follow these steps:

1. Start Relex and select Tools>Convert from the main menu.

2. When the Convert Data File to Relex window appears, select Relex 5.x Directory from the choice list labeled Convert.

3. In the Directory field, use the <Browse> button to browse to the directory of files which is to be converted.

4. Select <OK> when all options are set appropriately.

5. A window appears asking that a Project name be entered for the new Relex file that is created. Enter the new Project name into the field.

6. Select <OK> to perform the conversion.

7. When you open the new Project, Relex performs all other conversions automatically.

Note: Once the Relex 5.x files have all been converted into a Project file, the assemblies that are created can be copied and pasted into other Project files as needed, or moved within the same Project file.

Basic User Interface

Using Relex is much like using any Windows application. It is first important to notice common features like a standard title barxe "Title Bar" and minimize and maximize buttons, but Relex also uses common menu configurations and toolbars.xe "Toolbars" 

xe "File Management"File Management

Like standard Windows applications, the Relex files are managed by using the File option on the main menu. The File option includes the ability to create new files, open existing files, save files, and save files as different names.

Relex Project Files

Project files in Relex are the main storage areas for all data pertaining to your analysis. Relex Project files include Reliability Prediction data, FMEA data, Maintainability Prediction data, RBD data and Fault Tree data. There are sample Project files supplied for review, but you eventually need to create your own Project files.
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Figure 1 - 4. Relex Sample Project File

xe "Value-Added files"Relex Value-Added Files

In addition to Project files, there are many different file types used in Relex. Although the Project file in Relex is where the majority of your work is focused, the various other files that are available give you the ability to customize the features of Relex, and provide for performing modular analyses.

Value-Added files can range from Library filesxe "Library files" and Correlation files (which allows you to store data regarding components) to Derating and Default files (which give you more control over the handling and review of data). The Value-Added files in Relex offer additional flexibility to the software. The use of Value-Added files is dependent on the Relex modules enabled. For more information on these various file types, refer to the appropriate chapter in this manual.

Relex Documentation

The Relex Documentation is organized as follows:

Chapter 1 – Getting Started

The “Read Me First!” section is intended to get you up and running with Relex in minimal time. The “Introduction to Relex and Reliability” section is directed towards those who are new to Relex and new to reliability. This document outlines some basics about reliability including a description of Reliability Prediction, Reliability Block Diagrams, Fault Tree, FMEA, Maintainability Prediction, and Life Cycle Cost. This is useful for those who have no direct knowledge of Relex or reliability, and for those readers that are interested in learning more about Relex Software Corporation, the Relex products, and general reliability terminology and techniques.

Chapter 2 – General 

This is the general reference chapter for all Relex products. It consists of three main sections that cover operations that are commonly used in Relex including the Relex desktop,xe "Relex Desktop" right mouse support,xe "Right Mouse Support" conventions,xe "Conventions" and keyboard options.xe "Keyboard Options" Also, it includes information on managing files in Relex, and some of the various options available to you in Relex.

Chapter 3 – File Types

This chapter covers the all of the file types used in Relex.

Chapter 4 – Reporting and Graphing

This chapter provides you with information on the reporting and graphing features included in Relex.

Chapter 5 – Importing and Exporting

The CAD Interfacexe "CAD Interface" module includes the importing and exporting functions of Relex. This chapter outlines the importing and exporting processes in detail.

Chapter 6 – Common Features

This section outlines the use of macros, find and replace, spell check,xe "Spell Check" revision control,xe "Revision Control" and password protection.

Chapter 7 – Reliability Prediction

This chapter provides product specific details on the Relex Reliability Prediction module.xe "Reliability Prediction Module"
Chapter 8 – Reliability Block Diagram (RBD)

This chapter provides product specific details on the Relex Reliability Block Diagram (RBD) module.

Chapter 9 – FMEA

This chapter provides product specific details on the Relex Failure Mode and Effects Analysis (FMEA) module.

Chapter 10 – Fault Tree

This chapter provides product specific details on the Relex Fault Tree module.

Chapter 11 – Maintainability Prediction

This chapter provides product specific details on the Relex Maintainability Prediction module.

Chapter 12 – Life Cycle Cost (LCC)

This chapter provides product specific details on the Relex Life Cycle Cost module.

Documentation Conventions

There are three categories of conventions used in this manual and the online help system.

General Conventions

Following are General Conventions used in this manual and the online help system.

	Convention
	Description

	<ENTER>
	The keyboard keys are designated by <> characters. For example, the notation <ENTER> means to press the key marked Enter on your keyboard.

	<OK>
	Buttons in windows are designated by <> characters. For example <OK> means to press the “OK” button in the active window.

	Press <OK>
	When the term Press <OK> is used, it means to click the “OK” button with your mouse to perform the action.

	Enabled
	A dialog box option is enabled when a check mark appears beside it, or its button contains a black dot. The absence of a check mark or black dot means the option is disabled.

	Choice List Button
	Refers to the small button to the right of a field that is marked with an arrow. When pressed, this button displays a choice list of all valid options for the selected field.


xe "Mouse Conventions"Mouse Conventions

Relex uses both mouse buttons. It is assumed that you have programmed the left mouse button as the primary mouse button. Whenever a procedure requires you to use the secondary mouse button, it is referred to as the right mouse button.

xe "Menu Conventions"Menu Conventions

When referring to menu and sub-menu items in Relex, this guide directs you one step at a time through each menu choice. For instance File>New>Project means to select File from the main menu at the top of the window, and then select the sub-menu item titled New, and finally the sub-menu item titled Project.

xe "Keyboard Conventions"Keyboard Conventions

	Convention
	Description

	Accelerator Keysxe "Accelerator Keys"
	Many features that can be accessed from the menus have accelerator keys assigned to them. Accelerator keys are keyboard key combinations that offer shortcuts to frequently used functions. The accelerator keys are shown on the Relex menu. For example, when you select the File menu, you find the notation of Ctrl+S to the right of the Save menu option. This notation shows that Ctrl+S is an accelerator key for the File>Save command. Ctrl+S can be used rather than selecting File>Save from the menu as a shortcut.

	CTRL+F1
	Carrying out commands or procedures frequently involves pressing two or three keys together. For example <Ctrl> + <F1> means to hold down the <Ctrl> key and press the <F1> key simultaneously.

	<Arrow Keys>
	The notation <Arrow Keys> means the keys marked with either left/right or up/down arrows on your keyboard.


Where to Find Help

There are many sources for accessing information when using Relex. You may first want to begin with the easiest source of reference, which is the Relex online help system. Below is a brief description of how to access the Relex online help system.

Online Help

Information included in the online help system includes descriptions of all fields required for the completion of reliability analyses, helpful hints, and step-by-step instructions for completing tasks.

There are three basic techniques used to access the Relex help system. 

· You can access the Relex online help system by selecting Help>Relex Help from any menu. This particular method for activating the help system accesses the standard help interface that consists of three tabs. Each of these three tabs provides a different way to access information in the Relex help system. The Contents tab divides the information in the help system by chapters (similar to the organization of the printed documentation). The Index tab is an alphabetic listing of all of the main topics in the Relex help system. Lastly, the Find tabxe "Find tab" is a simple search feature that allows you to find any word or phrase in all of the text in the online help system. Select the tab that best suits your needs.

· On most dialog boxes, you have the ability to click the <Help> button. Upon selecting the <Help> button, the Relex online help system displays the specific online help topic associated with the current window.

· Pressing the <F1> key brings up the context sensitive help for the current activity.

Printed Documentation

The printed documentation includes all information available through the online help system. It is provided in printed form for easy access.

xe "Technical Support" \r "D2HBTechnical_Su14"

xe "Contacting Relex Technical Support"Contacting Relex Technical Support

If you find that you are unable to find all of the answers that you are looking for, don’t hesitate to contact the Relex Technical Support Department. 

	Mail Address:
	Relex Software Corporation
540 Pellis Road
Greensburg, PA 15601 USA

	Phone Number:
	724-836-8800

	Fax Number:
	724-836-8844

	Our Home Page:
	http://www.relexsoftware.com

	Support E-Mail:
	support@relexsoftware.com


When contacting Technical Support, have the following information available:

· Product version number, found by choosing Help>About Relex from the main menu in Relex (specific incremental version numbers can also be found by accessing the File Versions tab under Help>About Relex).

· A copy of this manual for possible cross-reference.

· The type of computer hardware you are using.

· The version of your operating system.

· Exact wording of any messages that appear on your screen.

Introduction to Relex and Reliability

The level of information and description in this section is geared towards those who are new to reliability, and also to those who feel that a review of reliability and an introduction to Relex would be helpful. Below is a list of the main chapters in this document along with a brief description of each.

Who, What, and Why? – The basics of reliability are reviewed along with a brief introduction to Relex Software Corporation and the Relex products. This section is intended to provide a brief overview of the concept of reliability and to explain why reliability is important.

Reliability Techniquesxe "Reliability Techniques" – This section provides a list of several common reliability techniques along with a brief explanation of each technique and its use.

Introduction to Reliability Prediction – Describes the basics of performing a reliability prediction analysis, and includes reviews of the models used and the general calculations that are performed.

Introduction to Reliability Block Diagram (RBD) – Describes the benefits of modeling a system using a reliability block diagram, and reviews the various redundancyxe "Redundancy" types that might be included.
Introduction to FMEA – Describes the basics of performing a failure mode and effects analysis (FMEA). Includes a brief description of the steps involved in performing a FMEA or FMECA, and an outline of some of the calculations that may be required.
Introduction to Fault Tree – Explains the basics of a fault tree analysis, and defines the differences between qualitative and quantitative analyses.
Introduction to Maintainability Prediction – Outlines the purpose of performing a maintainability prediction analysis, and explains simple steps that are to be followed.

Introduction to Life Cycle Cost (LCC) – Provides a definition of a Life Cycle Cost analysisxe "Life Cycle Cost Analysis"

xe "Cost Analysis" along with a common sense explanation of how LCC relates to reliability and maintainability prediction analyses.

Who, What, and Why?

Who is Relex Software Corporation?

Relex Software Corporation was incorporated in 1986 as Innovative Software Designs, Inc. Our goal from the start was to combine an expertise in reliability analysis with expertise in software engineering to produce a set of superior, user-friendly reliability analysis software tools.

The first product, Relex 217, a DOS-based reliability prediction package based on MIL-HDBK-217,xe "MIL-HDBK-217" was released in 1987. The name Relex was derived from the term Reliability Excellence. The popularity of this product lead to the development of Relex Bellcore, Relex FMEA/FMECA and Relex Maintainability Prediction in the following years.

In 1993, the entire Relex product line was redeveloped for Windows 3.1. This release solidified Relex's reputation as a leader in the development of reliability software packages.

In 1997, the entire Relex product line was again redesigned for the Windows 95 and Windows NTxe "Windows NT" platforms. At this time, the Relex products were integrated into a singular modularized application. With the introduction of Relex Version 6.0, our Windows 95/NT product, Relex Software introduced our innovative integrated solution concept.

In 1997, the Relex Reliability Block Diagram tool was introduced to the product suite. Also in 1997, we began our comprehensive, well-received training courses on reliability engineering and using Relex.

In 1998, our name was officially changed from Innovative Software Designs, Inc. to Relex Software Corporation to reflect our ongoing commitment to Reliability Excellence. In 1998, we released the Relex Life Cycle Cost package.

Relex Software Corporation is headquartered in Greensburg, PA, a suburb of Pittsburgh, PA. All of our products are developed and supported in-house. All software development, technical support and US sales are handled from our corporate office. Other sales offices are in place throughout the world, to support our international network of users.

Relex has grown into a worldwide leader in reliability analysis tools. Our reputation for technical excellence is unmatched. Our high quality,xe "Quality" state-of-the art product line and unparalleled customer satisfaction is representative of our commitment to excellence.

What is Relex?

Relex is a completely integrated set of reliability analysis tools. Relex performs reliability predictions and analyses on electrical, electronic, mechanical, and electro-mechanical equipment. Relex also provides the ability to perform Design and Process FMEAs, Reliability Block Diagrams, Fault Tree Analyses, Maintainability Predictions, and Life Cycle Cost Analyses. Relex provides all these capabilities in a unique, fully integrated framework. Relex has become an industry standard tool set for performing R&M analyses.

What is Reliability?
The textbook definition for reliability is the probability that an item will perform a required function without failure under stated conditions for a stated period of time. As illustrated by this definition, reliability is a very broad term that focuses on the ability of a product to perform its intended function. In general, the process of performing a reliability analysis can actually include a number of different analyses on a product in order to anticipate how reliable that product is. It is then possible to anticipate the effects of design changes and corrections in order to improve reliability. The different analyses that can be performed are all related and analyze different aspects of product reliability. Each of these different analyses looks at a product from a different angle in order to determine possible problems, and assist in analyzing corrections and improvements. Some types of reliability analyses include reliability predictions, failure mode and effect analyses, and fault tree analyses. 

Why is Reliability Important?

There are several reasons why analyzing reliability is important; a few of the most common are outlined below.

Reputation

A Company’s reputation is very closely related to the reliability of their products. If the products that are manufactured are very reliable and perform the required function without failure under stated conditions for a stated period of time, then the reputation of the company experiences a direct benefit. Therefore, the more reliable a product is, the more likely a company is to have a very favorable reputation.

xe "Warranty Costs"Warranty Costs

Oftentimes, a company may begin to produce a product but never has performed a serious reliability analysis on that product. Unfortunately, after the product is distributed, it could be found that it is not performing its required function without failure for a stated period of time. If the product fails prematurely, there may be an issue of warranty or replacement costs involved. These types of premature failures inevitably cause a negative impact on profits. This type of problem often gains negative attention, and introducing reliability analysis measures can be an important step in taking corrective action. Even if the only initial purpose of performing a reliability analysis is to decrease costs alone, the end result is a better product that is more reliable.

xe "Future Business"Future Business

In order to keep customers, it is very important that you remain satisfied. A concentrated effort towards improved reliability proves to customers that a manufacturer is serious about their product, and committed to customer satisfaction. Needless to say, this type of attitude has a positive impact on the stability of future business.

xe "Contract Requirement"Contract Requirement

Sometimes contracts may involve one or more of the following requirements:

· a reliability prediction based on a specific model

· a reliability prediction that meets specific failure rate or MTBFxe "MTBF" requirements

· a failure mode and effects analysis performed and presented with specific report formats

· a life cycle cost analysis analyzing all future costs including maintenance and spare parts

Even if these issues are not contractually required, performing any or all of these tasks is beneficial to any product manufacturer.

Cost Analysis

Companies are finding the ability to perform a cost analysis to be a very valuable analysis tool. In order to illustrate the cost effectiveness of their products, a manufacturer may take reliability data regarding the product and combine it with other cost information in order to illustrate the overall life cycle cost of their products. This type of analysis can prove that although the initial cost of the product may be higher, the overall lifetime cost of that product is actually lower than a competitor’s because their product requires fewer repairs and/or maintenance.

xe "Reliability Techniques"Reliability Techniques

Now that you have received a brief introduction to Relex Software Corporation, Relex, and reliability, it is important to understand some of the many different reliability techniques that can be performed. As mentioned earlier, the definition of reliability is very broad. Reliability is not one type of analysis. Instead, reliability can be examined by a number of different types of analyses.

Reliability Prediction

A Reliability Prediction is one of the most common forms of reliability analyses. A reliability prediction is the analysis of parts and components in an effort to predict the rate at which an item fails. A reliability prediction is usually based on an established model. Common models are MIL-HDBK-217 or Telcordiaxe "Telcordia (Bellcore)" (previously Bellcore). These models provide procedures for calculating failure rates for components. Failures rates are calculated by gathering information regarding components (like stress data,xe "Stress Data" quality information, temperature, and environment factors), and performing a calculation based on standard equations.xe "Equations"
The failure rates that are generated from a reliability prediction can then be used in other reliability analyses to further review the reliability of the item. For instance, failure rates can be used in a FMEA, a maintainability prediction, a life cycle cost analysis, or a reliability block diagram. In Relex, all of these different analyses are integrated together so that data, like failure rate, is automatically shared from one analysis type to another.

Reliability Block Diagram (RBD) Analysis

A Reliability Block Diagram is a tool for analyzing more complex systems and configurations. When performing a reliability prediction analysis, failure rates for components, assemblies, and systems are calculated. However, the models used for reliability prediction assume that all components and assemblies are configured in series, and failure rate calculations are based on that assumption. However, many systems are designed with various redundancies of key assemblies in order to improve the overall reliability of that system. The analysis of these types of redundanciesxe "Types of Redundancies" requires the use of sophisticated mathematical algorithms. Relex RBD is a complete graphical block diagram evaluator that is integrated with the other Relex modules for the complete analysis of these types of configurations.

Relex RBD analytically analyzes systems to compute failure rate, MTBF, reliability and availability,xe "Availability" unreliability, and unavailability. For more complex configurations, when an analytical solution is not possible, Relex RBD uses a built-in Monte Carlo simulationxe "Simulation"

xe "Monte Carlo Simulation" engine to analyze these systems. Relex RBD also includes the ability to perform a spares optimization calculation. This feature automates the process of determining the number of spares required for a system for optimum availability and minimal cost.

Failure Mode and Effects Analysis (FMEA, FMECA)

A Failure Mode and Effects Analysis (also referred to as a FMEA or FMECA) is a bottoms up approach to analyzing system design and performance. To begin a FMEA, a particular level of a system is analyzed. This can be the component level (referred to as a piece part FMEA) or at a higher level (referred to as a functional FMEA). For each lowest level, a list of potential failure modes is generated. Effects of each potential failure mode are then determined. 

For example, perhaps you are performing a piece part FMEA on a computer monitor. One component in that computer monitor might be a capacitor. You have determined that there are 2 potential failure modes for the capacitor, and they are that the capacitor could fail open or it could fail short. If the capacitor fails open, the effect might be that the monitor appears with wavy lines. However, if the capacitor fails short, the effect might be that the monitor goes completely blank. In this case, if the capacitor fails short and the monitor goes blank, that failure mode could be considered more severe or critical than if the capacitor fails open and wavy lines appear. In this case, you attempt to find ways to prevent these failures from happening or lessen the criticality.

A FMEA can use failure rate calculations that were performed during the reliability prediction portion of an analysis to determine probability of occurrence. Failure rate is a value describing how often a component or assembly fails. In a FMEA, failure rates are used to compute mode criticality, or the probability that a particular failure mode is actually going to occur. 

Like reliability prediction analyses, FMEAs and FMECAs are performed based on models too. There are primarily three types of FMEAs or FMECAs. First, there are MIL-STD-1629 FMECAs, which are based on the military standard for performing FMEAs. Second, there are automotive stylexe "Style" FMEAs,xe "Automotive Style FMEAs" which are based on various automotive FMEA models.xe "FMEA Models" In addition, there is a third standard, SAExe "SAE" ARP5580 that outlines a general approach for FMEA analysis. Relex supports all of these accepted FMEA/FMECA standards.

Fault Tree Analysis

A Fault Tree analysis is yet another reliability technique. Like a FMEA, a Fault Tree analysis focuses on failures. However, a Fault Tree analysis is a top down approach (rather than a bottom up approach like FMEA). A Fault Tree analysis is a graphical analysis that assumes a system failure, and traces down through the hierarchy to find what could have caused it.

Very often, in order to be complete, both a Fault Tree analysis and FMEA are performed on a system. This enables every possible failure to be analyzed and corrected or minimized. In Relex, you can perform a fault tree analysis along with a reliability prediction and FMEA on the same system in one integrated software package. Failure modes from a FMEA and items from a reliability prediction can be included in a fault tree analysis.

Maintainability Prediction

Maintainability Predictions provide calculated information regarding various aspects of maintenance. The goal of performing a maintainability prediction is to determine the amount of time required performing repairs and maintenance tasks. Maintainability predictions enable you to analyze how long a repair takes in the case of a system failure.

Relex provides you with the ability to perform a maintainability prediction based on accepted standards. Relex supports MIL-HDBK-472xe "MIL-HDBK-472" Procedures 2, 5A and 5B, and generic maintenance procedures. Relex Maintainability Prediction automatically performs all the maintenance-related calculations. For example, a common maintainability parameter is Mean Time to Repair (or MTTRxe "MTTR"). This is the most common measurement for a maintainability prediction, and it is the mean time to repair all of the removable items in a system for corrective maintenance. More importantly, MTTR can then be used in a reliability prediction in order to calculate availability. Availability is the probability that an item is in an operable state at any time, and is based on a combination of failure rate and MTTR. Since Relex Maintainability Prediction is integrated with Relex Reliability Prediction, these types of calculations can be performed.

Life Cycle Cost Analysis

A Life Cycle Cost Analysis is a method of calculating the cost of a system over its entire life span. The analysis of a typical system could include such costs as System Planning and Concept Design, Preliminary System Design Cost, Design and Development Costs, Product Costs, Maintenance Costs, and Disposal Costs. This type of analysis often uses values calculated from other reliability analyses like failure rate, cost of spares,xe "Cost of Spares" repair times, and component costs.

A company could use a life cycle cost analysis to determine warranty costs,xe "Warranty Costs" for instance. This type of analysis could be based on anticipated failures, repair times, and costs of repairs. Many companies are finding that a life cycle cost analysis is a valuable tool during the design phase of a project in order to determine the most cost-effective solutions before substantial costs are incurred. 

Introduction to Reliability Prediction

Generally, the first step to analyzing reliability is to perform a reliability prediction analysis. This section provides some background information on performing reliability predictions.

xe "Measures of Reliability"Measures of Reliability

When performing a reliability prediction analysis, there are several calculated values that provide measures of reliability. These values include failure rate, MTBF, reliability and availability.

Failure Rate

Failure rate is defined as the rate of occurrence of failures. This value is normally expressed as failures per million hours, but it can also be expressed as a FIT Rate (Failures in Time) or failures per billion hours. Failure rate is basically the anticipated number of times that an item fails in a specified period of time. For example, if a component has a failure rate of 2 failures per million hours, then it is anticipated that the component fails 2 times in a million hour time period.

A calculated failure ratexe "Calculated Failure Rate" is generally based on an established reliability prediction model (like MIL-HDBK-217 or Telcordiaxe "Telcordia (Bellcore)"). Calculations are generally based on component data such as temperature, environment, and stress. Calculated failure rates for assemblies are a sum of the failure rates for components within the assembly.

A component manufacturer may sometimes provide a specified failure rate. This failure rate is usually based on field or laboratory test data. Similarly, a manufacturer can also provide a specified failure rate for an assembly.

MTBF

MTBF stands for Mean Time Between Failures.xe "Mean Time Between Failures" MTBF is the inverse of the failure rate for constant failure rate systems. As a simple summary, MTBF can be described as the number of hours to pass before a failure for a component, assembly, or system. For example, if a component has a failure rate of 2 failures per million hours, then the MTBF would be the inverse of that failure rate. Therefore, 1,000,000 divided by the failure rate of 2 would calculate as an MTBF of 500,000 hours (1,000,000 / 2 = 500,000). This value states that the component is to fail approximately every 500,000 hours.

It is important to understand that MTBF is not a definite value. If a component has an MTBF of 8,000 hours, it means that on average that component fails every 8,000 hours.

Another calculation that is very similar to MTBF is MTTF. MTTF stands for Mean Time To Failure, and this value is used when evaluating non-repairablexe "Repairable" systems. Mean Time Between Failure (MTBF) assumes that a device is to experience multiple failures in a lifetime, and after each failure a repair occurs. For non-repairable systems, there is no repair. Therefore, in the lifetime of a device, the device fails once. A typical example is a satellite in orbit. If a satellite fails, generally no one is sent to repair the device. Instead, it may be that a new satellite would be launched to replace the failed unit. MTTF represents the average time until this failure occurs.

Reliability

Another important measure is termed reliability. The definition of reliability is the probability that an item will perform a required function without failure under stated conditions for a stated period of time. When calculating reliability, the important factor is time. The calculation of reliability takes into account a value called mission time, or time of operation. 

For constant failure rate systems, the equation for the calculation of reliability is: R = e-t.

Where t is the mission time, and  is the failure rate in failures per hour. Reliability is expressed as a probability value (a value between 0 and 1). A reliability value of 0 means that your system definitely fails within its mission time. A reliability value of 1 means that your system does not fail during its operational lifetime.

Reliability is the probability that an item will perform its required function for a stated period of time. As an example, perhaps you have calculated an MTBF for a device to be 500,000 hours. In this case, it would be anticipated that the device would last 500,000 hours before failure. If the mission time for the device was 100 hours (in other words, it needs to function for a 100 hour mission), the probability that the device would last its 100 hour mission would be very high. However, if that same device had an MTBF of 50 hours, and a mission time of 100 hours, the probability that the device would complete its 100-hour mission would be significantly lower.

Availability

The calculated value of availability takes the analysis yet one step further. Availability is defined as the probability that an item is in an operable state at any time. Like reliability, availability is a probability value ranging from 0 to 1. Unlike reliability, however, availability takes into account repairs.

When repairs are applicable for a device, a value referred to as MTTRxe "MTTR" can be applied. MTTR stands for Mean Time To Repair, and basically refers to the downtime required to repair a device. Again, like failure rate, MTTR can be calculated (through the use of a maintainability prediction), or it can be specified. The value of MTTR is then used in the calculation of availability to determine the probability that an item will be operable when needed.

The equation for the calculation of steady-state availability is: Availability = MTBF/(MTBF + MTTR)

As another simple example, imagine that you have a device with an MTBF of 50 hours. This, again, means that the device may be operational (without failure) for approximately 50 hours. When the unit fails, it then needs to be repaired. If the MTTR (or time required for repair) is 10 hours, then that means that every time the unit fails, it needs to be down for about 10 hours before it can be repaired and put back online. 

Systems with high MTBF in conjunction with low MTTR have high availability. As MTBF decreases and/or MTTR increases, system availability decreases. This means that at a certain time, your system is more likely to be down, or in a failed state. This becomes especially important for critical systems. The value of availability also becomes very important when analyzing various modeling options and the implementation of redundant components.

xe "Reliability Prediction Models"Reliability Prediction Models

When performing a reliability prediction analysis, the calculations that are performed are based on established reliability models. For electronic components, the two most popular and widely accepted models are MIL-HDBK-217 and Telcordiaxe "Telcordia (Bellcore)" \r "D2HBTelcordia21" (formerly Bellcore). Relex supports the use of both of these models.

MIL-HDBK-217

MIL-HDBK-217 was the original standard for reliability predictions. It was designed to provide reliability math models for nearly every conceivable type of electronic device. It is used by both commercial companies and the defense industry, and is accepted and known worldwide.

MIL-HDBK-217 includes the ability to perform a parts countxe "Parts Count" analysis or a part stress analysis. A parts count analysis is not as detailed as a part stress analysis, and is normally used early in a design when detailed information is not available, or a rough estimate of failure rate is all that is required. A part stress analysis takes into account more detailed information regarding the components, and, therefore, offers a more accurate estimate of failure rate.

Telcordia (Bellcore)

The Telcordia reliability prediction model was originally developed by AT&T Bell Labs. Bell Labs modified the equations from MIL-HDBK-217 to better represent what their equipment was experiencing in the field. The main concepts between MIL-HDBK-217 and Telcordia are very similar, but Telcordia added the ability to take into account burn-in,xe "Burn-In" field, and laboratory testing. This added ability made the Telcordia standard very popular with commercial organizations. In 1998, Bell Communications Research (Bellcore) became Telcordia Technologies.

Telcordia also supports the ability to perform parts count or part stress analyses, but in Telcordia, these different calculations are referred to as calculation methods.xe "Calculation Methods" Each method is designed to take into account different information. This information can include stress data,xe "Stress Data" burn-in data, field test data, or laboratory test data.

Although the use of calculation methods originated with the Telcordia model, Relex allows you to implement these calculation methods with the Telcordia or MIL-HDBK-217 models.

xe "Mechanical Model"Mechanical Model

The “Handbook of Reliability Prediction Procedures for Mechanical Equipment” (NSWC-98/LE1) provides reliability prediction models for mechanical components. This model, which was developed under the direction of the United States Navy, provides models for various types of mechanical devices including springs, bearings, seals, motors, brakes, and clutches. This standard is currently the only one of its kind.

xe "Bathtub Curve" \r "D2HBBathtub_Curv21"Reliability Prediction and the Bathtub Curve

Oftentimes, when discussing reliability prediction, the bathtub curve is used. It is important to understand the bathtub curve, and how it applies to the calculation of failure rate.

The bathtub curve is a simple graph of failure rate versus time that illustrates the failure rate tendencies for the life span of an item. During the life span of an item, the rate at which that item fails may vary as it goes through the various phase of life. The three phases of life that are compared on a bathtub curve are the infant mortality region,xe "Infant Mortality Region" \r "D2HBInfant_Morta21" the wear-out region,xe "Wear-Out Region" and the constant failure rate region.xe "Constant Failure Rate Region" \r "D2HBConstant_Fai21" Each of these phases represents a different phase in the life of an item, and each phase can represent very different tendencies with regard to failures.

Infant Mortality Region

The infant mortality region (sometimes referred to as a region of DFR or Decreasing Failure Rate) is typically a curve, which begins with high failures initially, but drops drastically during the infancy of an item. These high failures are typically caused by poor design and are generally eliminated, as the design becomes mature.

Wear-Out Region

The wear-out region (sometimes referred to as a region of IFR or Increasing Failure Rate) is typically a curve that is very low and consistent initially, but begins to increase drastically as the item begins to age. Fatigue or wear-out typically causes these failures.

Constant Failure Rate Region

The constant failure rate region (CFR) is typically a flat graph representing the constant failure rate of an item. Failures in the constant failure rate region are typically caused by stress. Constant failure rate is the type of failure rate calculation performed when using the MIL-HDBK-217 and Telcordia calculations.
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The Bathtub Curve

The combination of these three curves produces the bathtub curve. The bathtub curve is a curve which takes all three of these curves into account. Therefore, as an item goes through all of the phases of life, all three of these phases would be taken into account.

It is important to note again, however, that the calculations that are performed by the calculation models (MIL-HDBK-217 and Telcordia) do not consider all of the phases of life included in the bathtub curve. The calculation models are based on the constant failure rate region of the curve. This is the portion of the curve in which a product spends most of its lifetime. 

The Telcordia calculation modelxe "Calculation Model" provides the ability to calculate a first year drop out value, which is a summary of infant mortality. This calculation, however, is a separate analysis, and is not included in the failure rate calculations provided by the Telcordia model. In Relex, you are able to calculate first year drop out using both the MIL-HDBK-217 and Telcordia models, but again, this is a separate analysis and is not included in the failure rate calculations.

Introduction to Reliability Block Diagram (RBD)

As system configurations become more complex, more complex calculation methodsxe "Calculation Methods" are required to calculate values like failure rate, MTBF, reliability, and availability. Performing these complex calculations is the purpose of a Reliability Block Diagram analysis.

What is a Reliability Block Diagram (RBD)?

At the core, an RBD is a drawing and calculation tool used to model complex systems. The goal of an RBD is to produce a series of figures representing portions of a system that is to be analyzed. Once the figures are configured properly, and data for these figures is provided, calculations can be performed in order to calculate failure rate, MTBF, reliability, and availability. As the configuration of the block changes, the calculation results also change. Therefore, an RBD provides a simple way to compare various configurations in an attempt to find the best overall system design.

Using prediction methods, it is assumed that all components, assemblies, and sub-systems in a system are in a series configuration. Oftentimes, great benefits in reliability can be achieved by using redundancy or duplicates of assemblies or subsystems in an effort to prevent failure of an entire system.

xe "Types of Redundancies"Types of Redundancies

There are generally three different types of configurations that would be used in system design. These configuration types are:

Series

Series describes a configuration of several items performing a task, but all systems or components are fully operational at all times and are all required for successful operation.

xe "Parallel Operating"Parallel Operating

Parallel operating describes a redundancy of several items performing the same task, but all redundant systems or components are fully operational at all times. In a parallel operating system, not all units are required for successful operation. As a failure occurs, the other units take over to perform the required function so the system remains operational.

xe "Standby Non-Operating"

xe "Non-Operating"Standby Non-Operating

Standby non-operating describes a redundancy of several items performing the same task, but all redundant systems or components are not fully operational at all times. Only those that are required are in an on state. In a standby non-operating configuration, not all units are required for successful operation. As a failure occurs, one of the standby units is turned on to perform the required function so the system remains operational.

xe "RBD Calculations"RBD Calculations

Depending on the configuration of the blocks in an RBD, calculations are performed in different ways. The more complex the configuration, the more complex the calculation style. In the Relex RBD, Relex analyzes the configuration of your blocks and determines if a standard analytical method can be used for the calculation, or if it is necessary to analyze the diagram using a Monte Carlo simulation.xe "Monte Carlo Simulation"
Introduction to FMEA

A FMEA is a Failure Mode and Effects Analysis. Depending on the details of the analysis being performed, a FMEA can be referred to by several other terms like FMECA (Failure Mode, Effects and Criticality Analysis) or a Criticality Analysis. In general, these analysis types are very similar. 

What is FMEA?

FMEA (normally pronounced fa mee' a) is an acronym which stands for Failure Mode and Effects Analysis. Sometimes criticality is added to the analysis, and is then called a FMECA (normally pronounced fa mee' ka). Relex generally uses the term FMEA to be more inclusive. There are several other variations of this term and other pronunciations, but the methodology is the same.

A FMEA is an inductive bottom up method of analyzing a system design or manufacturing process to properly evaluate the potential for failures. It involves identifying all potential failure modes, determining the end effect of each potential failure mode, and analyzing the criticality of each failure effect. FMEAs can take many forms, but at the core, these analyses are used to study a particular system and determine how that system can be modified to improve overall reliability and avoid failures. 

In a very simple design FMEA example, you may have a computer monitor that has a capacitor as one component. By looking at the design, you determine that if that capacitor was open (one failure mode), the display would appear with wavy lines (the failure effect). If shorted (a second failure mode), the effect would be that the monitor goes blank. Then rank the second failure mode to be more critical than the first since the monitor becomes completely unusable. At this point, you could try to find ways to prevent this failure, or at least to lessen its criticality.

You can see from this simple example how a complete analysis could grow and become hard to manage, and how vital it is for targeting potential design problems.

xe "FMEA Models"FMEA Models

xe "MIL-STD-1629 Style FMECAs"MIL-STD-1629 Style FMECAs

MIL-STD-1629 is a long recognized standard that describes a method of performing Failure Mode, Effects, and Criticality Analyses. It is used by government, military, and commercial organizations worldwide. MIL-STD-1629 provides calculations for criticality that allows ranking of failure modes dependent on severity classification. 

MIL-STD-1629 itself is broken down into various types of analysis. The methods are similar to each other, but generally analyze different data. With Relex FMEA, all of the following analyses from MIL-STD-1629 can be performed:

	Task
	Description

	Task 101
	Failure Mode and Effects Analysis. The purpose of the Failure Mode and Effects Analysis (FMEA) is to study the results or effects of item failure on system operation and to classify each potential failure according to its severity.

	Task 102
	Criticality Analysis. The purpose of the Criticality Analysis (CA) is to rank each potential failure mode identified in the FMEA according to the combined influence of severity classification and its probability of occurrence.

	Task 103
	FMEA – Maintainability Information. The purpose of the FMEA – Maintainability Information is to supply early criteria for maintenance planning, logistics support analysis, test planning, inspection and checkout requirements, and to identify maintainability design features that require corrective action.

	Task 104
	Damage Mode and Effects Analysis. The purpose of the Damage Mode and Effects Analysis (DMEA) is to provide early criteria for survivability and vulnerability assessments.


xe "Automotive Style FMEAs"Automotive Style FMEAs

Many organizations, notably companies in the automotive industry, perform FMEAs according to several very similar standards, i.e., the SAE, AIAG, and Ford FMEA Manuals. For the sake of simplicity, these types of FMEAs are referred to as Automotive FMEAs in this manual. 

There are two general categories of Automotive FMEAs: Design and Process FMEAs. 

xe "Design FMEAs"Design FMEAs

Design FMEAs are used to analyze a system design and determine how the various failure modes affect the system operation. A system design can be analyzed at any level, from the piece part level up to the system level. At the lowest level, a FMEA can be performed by looking at every component on a board, determining the ways in which the components can fail, and then seeing how these failures affect the system. At higher levels, a FMEA is generally performed by looking at functions of a black box, determining ways in which these functions can fail, and then seeing how these failures affect the system. The lowest level FMEA is sometimes referred to as a piece part FMEA, while the higher level FMEA is called a functional FMEA.

You can create low-level analyses where you look at each component and study the failure effects on the design. You can also analyze the effects of lower level failures on your assembly, and even assembly failures on your system. You can use FMEAs to evaluate the reliability of your equipment at any level, and Relex FMEA provides this flexibility.

Process FMEAs

Process FMEAs are similar to Design FMEAs, except that they are used to analyze how failures in the manufacturing or service process affect the system operation. Using the same computer monitor from the example above, identify what problems in the manufacturing process could potentially affect the operation of the system. One potential problem could be improper soldering of the wires to the CRT. A potential effect of this failure mode would be that the monitor goes completely blank. Identify the probability of this occurrence and its severity, and then try to find ways to prevent or minimize the probability of this failure occurring.

Relex FMEA provides the ability of performing both Design and Process FMEAs, with many variations of each.

xe "FMEA Calculations"FMEA Calculations

Data collected during a FMEA can also be used to perform various FMEA calculations. Some typical calculations that might need to be performed are:

· Mode Criticality 

· Item Criticalityxe "Item Criticality"
· Risk Priority Number (RPN)

· Risk Priority Number Results (RPN Results)

· Detection Percentxe "Detection Percent"
· Isolation Percentxe "Isolation Percent"
The calculations that you choose to perform are generally based on your needs and analysis requirements. Relex supports all of the above FMEA calculations in addition to others.

Introduction to Fault Tree

A Fault Tree analysis is performed in order to analyze a system in an effort to determine possible improvements or corrections that can be made. 

A Fault Tree analysis is often performed in combination with other reliability analyses, but it can also be performed on its own as a fast method of analysis. This flexibility and speed is achieved due to the simple and logical approach that is used in a Fault Tree analysis process.

What is a Fault Tree Analysis?

Fault Tree Analysis (FTA) is one of the most widely used methods in system reliability analysis. It is a deductive procedure for determining the various combinations of component failures that could result in the occurrence of a specified undesired event (or top event) at the system level. 

A deductive approach begins with a general conclusion, and the final goal is the determination of the specific causes of this conclusion. With Fault Tree, this is often described as a top down approach. This is different from a FMEA, which is considered an inductive approach. An inductive approach begins with the specific in order to find the generic (which is why a FMEA is referred to as a bottoms up approach).

The main purpose of fault tree analysis is to evaluate the reliability parameters of the top event using analytical or statistical methods. A fault tree provides a convenient symbolic representation of the combination of events resulting in the occurrence of the top event. Events in fault tree analysis are represented by symbols. The major objective of a fault tree analysis is to evaluate the probability of the occurrence of the top event. To perform this task, system quantitative reliability information such as failure probability, failure rate, or repair rate, is used. Component failure parameters are evaluated first, then critical paths are determined, and finally top event likelihood is completed. Information about minimal cut setsxe "Cut Sets" obtained in the qualitative stage of the analysis can be used for computing the availability and reliability of the system. Relex Fault Tree supports both qualitative and quantitative analyses.

Introduction to Maintainability

What is a Maintainability Prediction?

The purpose of a maintainability prediction is to provide calculated information concerning various aspects of maintenance. You supply the repair information for your system and then calculate various maintainability parameters. Information required for maintainability predictions consists of the following:

xe "Basic Maintenance Tasks"Basic Maintenance Tasks

A basic task is generally defined as a simple task or one step of a task performed as part of repairing a failed item. For instance, a sample basic task would be to remove a screw or to strip a wire. Relex is supplied with a Tasks filexe "Tasks file" which contains all basic tasks (and their associated times) outlined in MIL-HDBK-472. 

xe "Super Maintenance Tasks"Super Maintenance Tasks

Several basic tasks together create a super task. For instance, an example of a super task would be the replacement of a video card. This super task, sometimes called a maintenance action, would probably include several of the following basic tasks:

1. Removal of Screw.

2. Removal of Card.

3. Replacement of Card.

4. Replacement of Screw.

xe "FD&I Outputs"FD&I Outputs

FD&I Outputs, or Fault Detection and Isolation Outputs, are defined as those indications, symptoms, printouts, readouts, or the results of manual procedures which separately or in combination, identify to the maintenance technician the procedure to be followed. For instance, once a failure occurs, the failure must be detected, and then the technician must determine which components or assembly needs repaired. The process of isolating the failed unit and performing the repair is defined as a list of tasks in an FD&I output.

Maintainability Prediction Information
The maintainability prediction data file is used to store information about the particular design that is being analyzed. Included is a listing of replaceable items in the design with their associated part numbers, reference designators, and failure rates. Also listed with each replaceable item are the FD&I outputs that identify that particular item or the tasks associated with that replaceable item. In Relex, this information is stored in the Project file.

Maintainability Prediction Models

Maintainability Predictions are based on generic maintenance procedures and also on the following models:

MIL-STD-472xe "MIL-STD-472" Procedure 2 – used to predict the corrective, preventative and active maintenance parameters.

MIL-STD-472 Procedure 5A – used to predict maintainability parameters of avionics, ground and shipboard electronics at the organizational, intermediate and depot levels of maintenance. It can also be applied to any application environment and type of equipment including mechanical equipment. Procedure 5A is more structured than Procedure 5B and segregates maintainability dataxe "Maintainability Data" by both a Maintenance Philosophy and Maintainability Groups.

MIL-STD-472 Procedure 5B – used to predict maintainability parameters of avionics, ground and shipboard electronics at the organizational, intermediate and depot levels of maintenance. It can also be applied to any application environment and type of equipment including mechanical equipment. Procedure 5B calculations are similar to those in Procedure 5A but are greatly simplified and far less structured. 

xe "Maintainability Prediction Calculations"Maintainability Prediction Calculations

In general, the most common maintainability calculation that is performed is MTTRxe "MTTR" or Mean Time To Repair. This is basically the time required to perform repairs and maintenance on a system. In addition to this basic calculation, there are several other maintainability parameters which can be computed. Some examples of maintainability parameters Relex Maintainability Prediction calculates are:

· Mean Time to Repair (MTTR)

· Percent Isolationxe "Percent Isolation" to a Single Removable Item

· Percent Isolation to a Group of Removable Items

· Mean Maintenance Man-hours per Repair (MMH/Repair)

· Mean Maintenance Man-hours per Maintenance Action (MMH/MA)

· Mean Maintenance Man-hours per Operating Hour (MMH/OH)

· Mean Maintenance Man-hours per Flight Hour (MMH/FH)

· Maximum Corrective Maintenance Timexe "Maximum Corrective Maintenance Time" for the Sigma Percentile

· Mean Preventive Maintenance Timexe "Mean Preventative Maintenance Time" (MPMT)

· Mean Corrective Maintenance Time (MCMT)

· Mean Active Maintenance Timexe "Mean Active Maintenance Time" (MAMT)

· Maintainability Index (MI)

Introduction to Life Cycle Cost (LCC)

The purpose of performing an LCC analysis is to determine the total cost of a system over its entire life span. Although this type of analysis is focused on cost parameters, it takes into account other values that were calculated in the other reliability and maintainability analyses that have already been discussed.

What is a Life Cycle Cost Analysis (LCC)?

The purpose of the LCC is to provide the ability to compute the cost of a system over its entire life span. As an example, a common breakdown of the life cycle of a large system may include:

· Research and Development

· Investment

· Operations and Maintenance

· System Phase Out and Disposal

Relex LCC would compute the total life cycle cost of this system based on the total sum of each of these units. 

The general technique for performing an LCC analysis is to first create a hierarchical structure of the system being analyzed. That hierarchical structure is broken down to lower levels for clearer understanding. At the lowest levels of the structure, equations are implemented using variables representing various cost factors. By itself, an LCC analysis appears to be a unique and separate analysis. On the surface, it seems as though a cost analysis would not have anything to do with reliability and maintainability analyses. However, reliability and maintainability parameters are an integral part of a life cycle cost analysis. For instance, reliability data like how often a system fails is very important when determining the cost of spare parts or the cost of downtime for certain systems. Similarly, maintainability data like the man-hour costs for repairs would be critical in calculating overall maintenance costs of a system.

For this reason, the Relex LCC module is an integral part of Relex. This system integration allows reliability and maintainability data to be used in a cost analysis seamlessly.

xe "LCC Calculations"LCC Calculations

A standard life cycle cost calculation would be the calculation of the total cost of a system over its entire life span. However, a life cycle cost analysis can be used to perform other very important calculations regarding cost. Common calculations that might be required would be the calculation of Net Present Valuexe "Net Present Value" (NPV) or the completion of a Sensitivity Analysisxe "Sensitivity Analysis" \r "D2HBSensitivity_29" on the LCC data. 

Net Present Value

A life cycle cost analysis is often performed over a series of time intervals, typically a series of years. With each time interval, an interest rate, or inflation rate, can be defined. Relex LCC then uses these values to determine the Net Present Value (NPV) or the cost in today’s currency, of your system. This can be useful to determine if a particular cost would be better incurred this year, or waiting for a future time when costs may be lower.

Sensitivity Analysis

Relex LCC also offers the ability to perform a Sensitivity Analysis on an LCC analysis. A Sensitivity Analysis is used to determine how robust a particular alternative is, and how sensitive the overall cost is to certain variables. When performing a Sensitivity Analysis, you specify a variable to modify and a percentage ranges over which to modify the variable. Perhaps one alternative is not greatly effected by changes in this variable, but another alternative is largely effected if the variable changes a certain amount. As an example, it may be necessary to perform a Sensitivity Analysis on failure rates for a system. This analysis would determine how sensitive the overall cost of the system is to failure rate. For instance, if a system fails more often, the cost of repairs or spare parts may increase, therefore, increasing the overall system cost.

Chapter 2 General

Relex Basics

This general overview describes the basic features found in your Relex product. These features are common to all Relex modules and are part of the standard Relex Graphical User Interface (GUI).

xe "Starting Relex" \r "D2HBStarting_Rel1"Starting Relex

Starting Relex is just like starting any Windows program. To start Relex, select Relex from the Start>Programs menu.

In addition to this standard method of starting Relex, you can also start Relex by using any of the following optional methods:

· Start Relex from a shortcut on your desktop. Use Microsoft Explorer to browse to the location of the Relex.exe file. Once it is located, right mouse click on the file and select Copy. Next, go back to your desktop and select Paste Shortcut from the right mouse menu. A shortcut to Relex is placed on your desktop. To use this shortcut, double-click on the shortcut.

· Double-click on the Relex.exe file. Use Microsoft Explorer to browse to the location of your Relex.exe file. Double-click on this file to execute Relex.

· Double-click on any Relex file in Explorer. Use Microsoft Explorer to browse to the location of any Relex data file. Relex files can be identified visually by the Relex icon that is used to illustrate the file type. Double-click on any Relex file, and Relex is executed and the selected file is opened.

· Start Relex by automatically creating a new Relex file from the desktop. Click the right mouse button anywhere from the Windows Desktop. When the right mouse menu appears, select New from the menu. From the list of file typesxe "File Types" to create, select a Relex Project file.xe "Project file"
xe "Tip of the Day" \r "D2HBTip_of_the_D1"Tip of the Day

The Tip of the Day window consists of three tabs of information regarding the initial set up of Relex described as follows:

Tip of the Day Tab

Upon starting Relex, you are greeted by the Tip of the Day. These tips are intended to provide helpful hints for using Relex. Each time you start Relex, a new tip appears. 

· You have the option of viewing each of the tips consecutively by clicking on the <Next Tip> button at the bottom of the window. This button takes you one by one through each of the tips.

· If you do not wish to have the Tip of the Day display automatically each time you start Relex, you can disable the Show Tips on Startup checkbox.

· If you want to access the Tip of the Day feature while Relex is active,xe "Active" select Help>Tip of the Day from the main menu.

xe "Product Options tab"Product Options Tab

On the Product Options tab, you have the ability to enable or disable the various Program Options of Relex. A check mark in the box beside each Program Option means that this particular option is selected when Relex is started. You can change any of these options to suit your needs. You can also enable and disable the various Program Options by using Tools>Options and selecting the Product Options tab.

Startup Tab

On the Startup tab, you have the ability to select what files Relex automatically opens on startup. By default, Relex starts without any files open for editing. The Startup tab provides the ability to automatically open a Relex file when initially starting. From the Startup tab, select which file you wish to activate.

Note: The Startup tab is only available when the Tip of the Day is displayed upon startup. It is not available when the Tip of the Day is activated by selecting Help>Tip of the Day from the main menu.
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Figure 2 - 1. Tip of the Day

xe "Relex Desktop"Relex Desktop

The Relex desktop consists of a few standard areas.

xe "Title Bar"Title Bar

The title bar shows that you are using Relex. When the Relex window is selected, the title bar is highlighted.

Menu

Upon starting Relex, the standard Relex menu appears. Depending on the features that are currently activated, the items on the menu differ.

Minimize/Maximize/Close

The minimize, maximize, and close buttons are standard Windows buttons used to minimize, maximize, or close the active window.

Toolbar

Upon starting Relex, the standard Relex toolbar appears. This toolbar contains shortcuts to the most common functions in Relex. There are various toolbarsxe "Toolbars" available in Relex. These toolbars can be enabled and disabled as needed by selecting View>Toolbars from the main menu. Toolbars are customizable.

xe "Right Mouse Support"Right Mouse Support

In various locations throughout the program, the right mouse button offers various shortcuts to commonly used options. To activate the context-sensitive right mouse menu at any time, position your cursor over an active Relex window and click the right button on your mouse. The options available on the right mouse menu vary depending on the active window.

xe "Guide Conventions"

xe "Conventions"Guide Conventions

Following are general conventions used throughout the Relex documentation:

	Convention
	Description

	<ENTER>
	The keyboard keys are designated by <> characters. For example, the notation <ENTER> means to press the key marked “Enter” on your keyboard.

	<OK>
	Buttons in windows are designated by <> characters. For example <OK> means to press the <OK> button in the active window.

	Press <OK>
	When the term “Press <OK>” is used, it means to click the <OK> button with your mouse to carry out the action.

	Enabled
	A dialog box option is enabled when a check mark appears beside it, or its button contains a black dot. The absence of a check mark or black dot means the option is disabled.

	Choice List Button
	Refers to the small button to the right of a field that is marked with an arrow. When pressed, this button displays a choice list of all valid options for the selected field.


xe "Mouse Conventions"Mouse Conventions

Relex uses both mouse buttons, but assumes that you've programmed the left mouse button as the primary mouse button. Whenever a procedure requires you to use the secondary mouse button, the documentation refers to it as the right mouse button.

xe "Menu Conventions"Menu Conventions

When referring to menu and sub-menu items in Relex, this guide directs you one step at a time through each menu choice. For instance File>New>Project means to select File from the main menu, and then select the sub-menu item titled New, and finally the sub-menu item titled Project.

xe "Keyboard Options"Keyboard Options

xe "Keyboard Conventions"Keyboard Conventions

	Convention
	Description

	CTRL+F1
	Carrying out commands or procedures with keys frequently involves pressing two or three keys either together or in succession. For example CTRL+F1 means to hold down the CTRL key while pressing F1.

	Accelerator Keysxe "Accelerator Keys"
	Many features that can be accessed from the menus have accelerator keys assigned to them. Accelerator keys are keyboard key combinations that offer shortcuts to frequently used functions. The accelerator keys are shown on the Relex menu. For example, when you select the File menu, note the notation of CTRL+S to the right of the Save menu option. This notation means that pressing the CTRL key while pressing the ‘S’ on the keyboard is an accelerator key for the File>Save command. CTRL+S can be used as a shortcut, rather than selecting File>Save from the menu.

	<Arrow Keys>
	The notation <Arrow Keys> denotes the keys marked with either left/right or up/down arrows on your keyboard.


List of Keyboard Shortcuts and/or Accelerator Keys

General

	Save
	CTRL+S

	Print
	CTRL+P

	Cut
	CTRL+X

	Copy
	CTRL+C

	Paste
	CTRL+V

	Delete
	<Delete> key on the keyboard


xe "System Tree"System Tree Only

	Paste as Child
	Shift+CTRL+V

	Find
	CTRL+F


xe "Parts Table"Parts Table Only

	Find
	CTRL+F

	Find Next
	F3

	Insert
	CTRL+I

	Delete
	CTRL+D

	Re-Search Libraries
	ALT+F3

	Undo
	CTRL+Z

	Redoxe "Redo"
	CTRL+Y

	Refresh
	F5


RBD Only
	Select All
	CTRL+A

	Calculation Propertiesxe "Calculation Properties"
	ALT+ENTER

	Size to Text
	F7


xe "Report Designer"Report Designer Only

	Undo
	CTRL+Z

	Redo
	CTRL+Y

	Select All
	CTRL+A

	Properties
	ALT+ENTER 

	Size to Text
	F7

	Insert Databasxe "Database Field"e field
	CTRL+D

	Center Horizontal
	F8


xe "Choice Lists"Selecting from Choice Lists

· Press the choice list button with your mouse and click on your selection.

· Press <Alt + Down Arrow> on your keyboard, scroll to your selection with the <Up Arrow> and <Down Arrow>, and then press <Enter> on your selection.

· Type your selection. When you type, Relex automatically selects the choice that matches your entry. 

· Press F2 to edit the field and use the <Up Arrow> and <Down Arrow> keys to scroll through the list (on the Categoryxe "Category" and Subcategoryxe "Subcategory" fields in the Parts Table).

xe "Selecting Multiple Items"Selecting Multiple Items in the RBD or Report Designer

· Hold the <SHIFT> key while clicking each of the figures to be selected. As each item is selected with your mouse, handles surround the item to highlight it.

· Click and drag your mouse to create a box enclosing all of the figures to be selected. Upon releasing your mouse button, all of the enclosed items are selected.

· Select Edit>Select All to automatically select all figures in the current diagram.

Accessing Visual and Calculation Properties of a Figure in the RBD

· Double-click on the figure in the RBD to access the Calculation Properties for the figure.

· Select the figure in the RBD, and select View>Properties from the menu to access Calculation Properties.

· Select the figure in the RBD, and select View>Figure Visual Propertiesxe "Visual Properties" from the menu to access Visual Properties.

· Select the figure in the RBD, and select Calculation Properties from the right mouse menu to access Calculation Properties.

· Select the figure in the RBD, and select Visual Properties from the right mouse menu to access Visual Properties.

· Select the figure in the RBD, and select <ALT>+<Enter> from the keyboard to access Calculation Properties.

xe "Diagram Properties"Accessing Diagram Properties of the RBD

· Deselect all items in the diagram by selecting an area of the diagram containing no figures or items, and select Edit>Properties from the menu to access the properties of the diagram.

· Deselect all items in the diagram by selecting an area of the diagram containing no figures or items, and select Properties from the right mouse menu to access the properties of the diagram.

· Deselect all items in the diagram by selecting an area of the diagram containing no figures or items, and select <ALT>+<Enter> from the keyboard to access the properties of the diagram.

Accessing Properties of Items in a Report Design

· Double-click on the item in the report design to access the properties for the item.

· Select the item in the report design, and select View>Properties from the menu.

· Select the item in the report design, and select Properties from the right mouse menu.

· Select the item in the report design, and select <ALT >+< Enter> from the keyboard.

Accessing Properties of the Report Design

· Deselect all items in the design by selecting an area of the design containing no items, and select View>Properties from the menu to access the properties of the report design.

· Deselect all items in the design by selecting an area of the design containing no items and select Properties from the right mouse menu to access the properties of the report design.

· Deselect all items in the design by selecting an area of the design containing no items, and select <ALT>+<Enter> from the keyboard to access the properties of the report design.

xe "File Management"File Management

Like many standard software programs, Relex files are managed by using the File option on the main menu. The File option includes the ability to create new files, open existing files, save files, and save files as different names. The techniques used to perform the various file management functions in Relex are very similar to other Windows applications.

xe "Creating Files"Creating Files

There are several different techniques that can be used to create a new Relex file. These are described briefly below:

Create a File (and Start Relex) from Microsoft Explorer or the Desktop

Browse to any directory using Microsoft Explorer. Once the desired directory is displayed in Explorer, select New>Relex Project File from the right mouse menu. This process automatically starts Relex and creates a new Project file. This step can also be performed from the Windows desktop. In this case, an icon for the new file would also be created on the desktop.

Create a File Using the File>New Menu

A common technique for creating files is to make use of the File>New option on the main menu. In Relex, you must also provide Relex with the type of file that you wish to create. Upon selecting File>New from the main menu, a submenu appears listing all of the various file types that can be created. 

Submenus appearing when File>New is selected is an optional feature in Relex. To disable this option, select Tools>Options, access the Settings tab,xe "Settings tab" and disable the List file types on New/Open Submenus option. In this case, when File>New is selected from the main menu, the New File dialog box automatically appears and you must select the file type and file to be opened. 

Create a File Using the <New> Button on the Toolbar 

By selecting the <New> button on the standard toolbar, the New File dialog box automatically opens. The New File dialog box allows you to select the file type and file name to be created. 

First, it is necessary to select the type of file to be created. By selecting from the choice list field labeled Save as type, you can select the specific file type that you wish to create. After selecting the file type, a list of all files of that particular file type that are found in the current directory is displayed. If you select a file name from the list of files, and press the <Create> button, you overwrite the existing file. To create a new file without overwriting, enter the new file name in the File name field.

xe "Opening Files"Opening Files

There are several different techniques that can be used to open a Relex file. Each of these different techniques is described briefly below.

Open a File (and start Relex) from Microsoft Explorer

Browse to any Relex file using Microsoft Explorer. Once the desired file is found, double-click on it to automatically start Relex and open the selected file.

Open a File Using the File>Open Menu

A common technique for opening files is to make use of the File>Open option on the main menu. In Relex, you must also specify the type of file that you wish to open. Upon selecting File>Open from the main menu, a submenu appears listing all of the various file types that can be opened. 

Submenus appearing when File>Open is selected is an optional feature in Relex. To disable this option, select Tools>Options, access the Settings tab, and disable the List file types on New/Open Submenus option. In this case, when File>Open is selected from the main menu, the New File dialog box automatically appears and you must select the file type and file to be opened. 

Open a File Using the <Open> Button on the Toolbar 

By selecting the <Open> button on the standard toolbar, the Open File dialog box automatically opens. The Open File dialog box allows you to select the file type and file name to be opened. 

Select the file type you wish to open by using the choice list of the Files of Type field. After selecting the file type, a list of all files of that particular file type that are found in the current directory is displayed. From the list of files, select the specific file name that you wish to open and click the <Open> button.

xe "Saving Files"Saving Files

While working on any file in Relex, you can save the changes to the file in one of several different ways. Each technique is described as follows:

Save the File by Selecting File>Save from the Menu

While working on any file in Relex, select File>Save from the main menu to save the active file.

Save the File by Selecting File>Save As from the Menu

While working on any file in Relex, select File>Save As from the main menu to save the active file as a different file name.

Save the File Using the Toolbar

The Standard Relex Toolbar includes a <Save> button that saves the active file. 

Save the File upon Closing

When closing a modified file in Relex, a message is displayed asking if you wish to save the changes with the prompt “Do you wish to save <filename>”. By answering yes, the changes are saved to the file. By answering no, all changes are ignored, and the file is restored to its original state. 

There are two instances when this message window does not appear. In the first instance, no changes have been made to the file since the time that it was opened, and therefore no changes need to be saved. The second instance is when the Create Backup File option in Relex Options has been disabled. This is often the case in a network environment.

xe "Closing Files"Closing Files

In Relex, an open file can be closed in one of the following ways:

Press the <Close> Button for the Active File Window

By clicking the <Close> button (displayed as an X) in the upper right hand corner of the active file window, you can close the active file. If changes have been made to the file, a window appears asking if you wish to save the changes to the file.

Press the <Close> Button for Relex

By clicking the <Close> button (displayed as an X) in the upper right hand corner of the application window, you can close both Relex and any active files. If changes have been made to any of the open files, a window may appear asking if you wish to save the changes to the file. This window appears for each file in which changes were made.

Select File>Close from the Menu

Select File>Close from the menu to close the current active file. If changes have been made to the file, a window may appear asking if you wish to save the changes to the file.

Select File>Exit from the Menu

Select File>Exit from the menu to close both Relex and any active files. If changes have been made to any of the open files, a window may appear asking if you wish to save the changes to the file. This window appears for each file in which changes were made.

xe "Copying Files"Copying Files

It is possible to make a copy of any Relex file. The easiest way to accomplish this is by using Microsoft Explorer, but it is possible to complete this particular task from within Relex. To make a copy of a file, press the <Open> button on the toolbar. When the Open File dialog box appears, select the file to copy and select Copy from the right mouse menu. Then select Paste from the right mouse menu to paste a copy of the file into the current directory. A copy is created with the name “Copy of <file name>”.

xe "Renaming Files"Renaming Files

It is possible to rename any Relex file. The easiest way to accomplish this is by using Microsoft Explorer, but it is possible to complete this particular task from within Relex. To rename a file, press the <Open> button on the toolbar. When the Open File dialog box appears, select the file that you wish to rename and select Rename from the right mouse menu. Then type the new name of the file.

xe "Moving Files"Moving Files

It is possible to move any Relex file. The easiest way to accomplish this is by using Microsoft Explorer, but it is possible to complete this particular task from within Relex. To move a file, press the <Open> button on the toolbar. When the Open File dialog box appears, select the file that you wish to move and select Cut from the right mouse menu. Then navigate to the new location by using the navigation options at the top of the Open File window. Once the desired directory is displayed, select Paste from the right mouse menu to paste the file to its new location.

Options

As a first step to becoming familiar with Relex, access the Options tab to review the various items that can be customized in Relex.

To access Options, select Tools>Options from any Relex menu. Options consist of several tabs of information that give you the flexibility to customize Relex to your own specific requirements. The options range from enabling user librariesxe "User Libraries" to configuring the Relex windows. The following sections outline each of the Options tabs in detail.

Library Searches Tab
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Figure 2 - 2. Options, Library Searches

The Library Searches tab allows you to customize certain information pertaining to Libraries and Correlation files.xe "Correlation files" The Library Searches tab consists of three main areas of interest:

xe "Part Number"

xe "Alternate Part Number Search" \r "D2HBAlternate_Pa9"

xe "Alternate Part Number" \r "D2HBAlternate_Pa9"Alternate Part Number Search

When the Alternate Part Number Search is enabled, during library searching,xe "Library Searching" Relex searches the Alternate Part Number field and the Part Number field in the libraries. Relex first searches the Part Number field in all user libraries. If the part is not found, Relex searches the Alternate Part Number field in all user libraries. If the part is not found, Relex searches its own libraries. 

Note that duplicate part numbers are not allowed in Relex libraries,xe "Relex Libraries" but duplicate alternate part numbers are. Relex always stops searching and retrieves the first matching part so, ideally, you should not have duplicate alternate part numbers in your libraries. If this selection is disabled, no Alternate Part Number search occurs.

Relex Libraries
The Relex Libraries Directory field is automatically assigned when the software is installed, and only needs to be changed if the location of the Relex libraries changes.

The library search checkboxes allow you to enable and disable the searching of the Relex libraries. Click the appropriate box to enable or disable the particular libraries for searching.

User Libraries

The User Library fields allow you to enable three different user-created libraries for searching. Relex searches the user libraries before searching the Relex libraries. This area also allows you to designate one Correlation file for searching. The Correlation file is used if you have more than one part number that refers to the same or a similar part. You can create a one-to-one correspondence between in-house part numbers and Relex or user library part numbers.

xe "Settings tab"Settings Tab
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Figure 2 - 3. Options, Settings

The Settings tab provides the ability to customize the way certain functions operate in Relex.
The following table outlines each of these options in detail:

	Option
	Description

	Automatic Calculations
	The Automatic Calculations checkbox is used to select whether you want Relex to automatically calculate your files before generating reports. When enabled, Relex calculates a project if it has been modified since the last calculation. If you disable Automatic Calculations, Relex uses the calculated numbers from the most recent calculation, which may not be correct. If Automatic Calculations is disabled, select Project>Calculate from the main menu prior to generating a reportxe "Generating a Report" anytime that calculation recorded data is modified.

	Uppercase Part Number
	When enabled, the Part Number and Alternate part Number fields are always forced to be in capital letters. When disabled, lower-case letters can be used.

	Enter Default Values for New Parts
	When enabled, Relex automatically enters default values for all new parts entered into the Parts Table. If disabled, default values are entered from the selected Defaults filexe "Defaults file" into the fields on the Prediction Data tabxe "Prediction Data tab" for all new parts entered into the Parts Table. If disabled, default values are only displayed on the Prediction Data tab if the <Defaults> button is selected.

Note: Even if the default values are not made visible or saved permanently with the part by selecting the <Defaults> button, the defaults values are still accessed during calculations.

	Expand Multi-Line Table Rows
	When enabled, Relex automatically displays all fields with wrapped text as expanded multi-line rows in the table. If disabled, Relex displays wrapped rows as single rows until an item in that row is selected. The table row expands to display all text.

	Create Backup File
	If enabled, every time you close a Relex file, you are asked if you wish to save your changes. You may answer <Yes> (yes, you wish to save the changes, <No> (no, I do not wish to save the changes, and I wish to revert to my last saved copy of the file), or <Cancel> (I want to cancel this process and return to my file). You must select <Yes> in order to save the most recent changes to the file. If you select <No>, all changes are lost. If disabled, you are not prompted to save changes. Instead, changes are saved automatically. However, when disabled, you do not have the ability to revert to the previous version of the file by aborting changes.

When enabled, Relex creates a backup file of any Relex file when it is opened. The file is named “Backup of <File Name>”. In most circumstances, you do not need to access this backup file. However, if, for some reason, you exit Relex improperly, the backup file is saved. For instance, if you lose power to your computer during operation, you still have your backup file available (your file without your most recent changes).

	Verify Database Table Structures
	If enabled, Relex automatically verifies the integrity of each table every time a Project file is opened. This option does not correct any problems with your file, but notifies you if a problem exists.

Note: The use of this option may slow down the File>Open process. For this reason, it is recommended that you only use this option if you suspect a file has been corrupted.

	Maximize Windows on Open
	If enabled, when a file is opened, the window size is automatically maximized.

	List File Types on Open/New Submenus
	If enabled, when File>New or File>Open is selected from the main menu, a submenu appears listing the file types that can be opened or created.

If disabled, when File>New or File>Open is selected form the main menu, the New File or Open File window appears. In this window, you can specify the name of the file to be created or opened, and you may specify the type of file to be created or opened.

	Show Captions on Tabbed Windows
	If enabled, a title barxe "Title Bar" \r "D2HBTitle_Bar12" with the name of the window will appear at the top of windows for various file types.

	Data Files Directory
	The Data Files Directory field defines the default location of all Relex Data files.

	Auxiliary Files Directory
	The Auxiliary Files Directory field defines the default location of all Relex Auxiliary files.

	Spell Checkxe "Spell Check"
	Relex Custom Dictionary. If enabled, the Relex Custom Dictionary is activated and used during the Spell Check process. The Relex Custom Dictionary includes nearly 1,500 reliability and maintainability terms.

User Custom Dictionary. You can create your own custom dictionary. A dictionary is a simple text filexe "Text file" that lists all spell check words. This text file lists all additional dictionary words listed one per line.


xe "Display Tab"Display Tab
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Figure 2 - 4. Options, Display

You can specify various display options on this tab, including:

Label Part Window With

By selecting any of the available options, you control what information is displayed in the title bar of the Parts Table window. When the Parts Table tab is active, the specified information displayed is that of the assembly to which the parts on the Parts Table tab belong. For instance, if Name (Assemblies Only) is selected, the name of the assembly displays in the title bar. If Part Number and Reference Designatorxe "Reference Designator" are selected, both appear in the title bar. When the General Data, Prediction Data or Remarks tabs are active, the specified information displayed is that of the part that is selected on the Parts Table tab. The same part information is displayed in the title bar of the FMEA Treexe "FMEA Tree" window. 

xe "Highlighting"Project Tree Highlighting

This section controls the colors used on the Relex windows. You can customize the background and text colors applied to the following areas:

	Option
	Description

	Assembly Rows 
	Refers to the assembly rows in the System Tree. The background color controls the color of the table, and the text color controls the color of the text in each cell.

	Part Rows


	Refers to the part rows in the Parts Table. The background color controls the color of the table, and the text color controls the color of the text in each cell.

	FMEA Mode Rows
	Refers to the failure mode rows in the FMEA Tree window. The background color controls the color of the table, and the text color controls the color of the text in each cell.

	FMEA Item Rows
	Refers to the item rows in the FMEA Tree window. The background color controls the color of the table, and the text color controls the color of the text in each cell.


Fault Tree Highlighting

This section controls the colors used on the Fault Tree Tablexe "Fault Tree Table" window. You can customize the background and text colors applied to the following areas:

	Option
	Description

	Top Gate Rows
	Refers to the Top Gate rows in the Fault Tree Table window. The background color controls the color of the table, and the text color controls the color of the text in each cell.

	Transfer Gatexe "Transfer Gate" Rows
	Refers to the Transfer Gate rows in the Fault Tree Table window. The background color controls the color of the table, and the text color controls the color of the text in each cell.


xe "Library Updates tab" \r "D2HBLibrary_Upda14"Library Updates Tab

[image: image10.png]Lbary Searches | Sstings | Diplay Lrary Updates | prodct Optens | Fots | sehavier | Faut Tres |

Library Build/Update
I~ fgrore Duplicats Part Nrrbers)
¥ Ignore Relex Part Nurmbers

Do not update these data fislds
I™ Additive Adjustrent
I™ Alternate Part Nurnber
W CAGE Code
I~ cost
I™ Description
7 LeN
I™ Multiplicative Adjustrment
W Quantity
¥ Reference Designator
I™ Qperating Parameters from Relex Libraries
I™ Operating Parareters from User Libraries

oK Cancel Help





Figure 2 - 5. Options, Library Updates

The Library Updates tab provides control over how data in the libraries and the project is updated. The Update to Library feature allows you to update or create a library from information in a Project file. The update feature also allows you to update a project with the information from a library. When updating, it is important to specify how certain information is handled. The options are categorized under two headings. 

xe "Library Build/Update"Library Build/Update

The Library Build/Update selections provide you with options regarding the handling of duplicate parts. Because duplicate part numbers are not permitted in libraries, it is important to determine how duplicate part numbers are handled when included in an update to a library. These options are:

	Option
	Description

	Ignore Duplicate Part Numbers
	Because duplicate part numbers are not permitted in libraries, Ignore Duplicate Part Numbers allows you to control how Relex handles duplicate part numbers when found during an update. If this option is enabled, duplicate part numbers are ignored. In other words, the first part of a given number added to the library is the final part of that number written to the library. If disabled, duplicate part numbers overwrite the existing part numbers in the libraries. In other words, the last part of a given number added to the library is the final part of that number written to the library.

	Ignore Relex Part Numbers
	Normally, you do not want parts in the Relex libraries to be also included in your user libraries when you perform a library update. If this option is enabled, Relex part numbers that appear in your Project file are ignored and are not added to your user libraries. If this option is disabled, Relex part numbers are added to your user libraries.


Do Not Update These Data Fields

This option allows you to determine exactly what information is updated in a Library file when a library update is performed, and what information is updated in a Project file when a project update is performed. Items that are selected are not updated. For instance, when adding parts to a user library using the update feature, it is quite common that you do not want the reference designator or quantity from your current Project file added to the Library file. Likewise, you also would not want this information to be added to your Project file from your Library file. In this case, enable the Reference Designator and Quantity on this tab so that this information is not updated during the update process.

An additional option is available which prevents operating parameters from a Project file from being added or updated during a Build/Update to a Library file. In using this feature, operating parameters would include the following fields for the following part categories:

	Category of Part
	Operating Parameter Field

	Integrated Circuits
	Operating Power

	Semiconductorsxe "Semiconductors"
	Operating Power

	Resistors
	Operating Power

	Capacitors
	Applied DC Voltage

	Relays
	Operating Current

	Switching Devices
	Operating Current


To prevent operating parameters from being added to Relex libraries, follow these steps:

1. Access options by selecting Tools>Options from the main menu.

2. Select the Library Updates tab.

3. Select one of the two Do Not Update These Data Fields options:

	Option
	Description

	Operating Parameters from Relex Libraries
	If enabled, operating parameters for any part that exists in a Relex library are not included in the Project being updated.

If disabled, the operating parameters for any part that exists in a Relex library are added to the Project being updated.

	Operating Parameters from User Libraries
	If enabled, operating parameters for any part that exists in a user library are not included in the Project being updated.

If disabled, the operating parameters for any part that exists in a user library are added to the Project being updated.


xe "Product Options tab"Product Options Tab
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Figure 2 - 6. Options, Product Options

The Product Options tab provides you with the ability to enable or disable specific program options. The Product Options tab can also be used to verify exactly what options have been installed with Relex. The items marked with check marks are installed and enabled on your computer. 

You can enable or disable any of the features that you purchased with your Relex installation. You may also select Demo,xe "Demo" which allows you to enable any Relex module even if it was not purchased. When in demo mode, certain limitations apply.

Note: Any items that are disabled are not available in your particular Relex configuration.

	Option
	Description

	Demo Mode
	A check mark indicates that Relex is operating in demo mode. Relex runs with limitations, but all product options are available. When the demo is active, the word DEMO appears in the status bar on the lower right hand corner of the Relex window.

	Reliability Predictionxe "Reliability Prediction" Base
	A check mark indicates that the Reliability Prediction Base portion of Relex is installed and enabled.

	Reliability Prediction Plus
	A check mark indicates that the Reliability Prediction Plus portion of Relex is installed and enabled. This provides access to all general features outlined in the reliability prediction chapter. 

	MIL-HDBK-217xe "MIL-HDBK-217"
	A check mark indicates that the ability to perform MIL-HDBK-217 calculations is installed and enabled. 

	Telcordiaxe "Telcordia (Bellcore)" (Bellcore)
	A check mark indicates that the ability to perform Telcordia (Bellcore) calculations is installed and enabled.

	Mechanical
	A check mark indicates that the ability to perform Mechanical calculations is installed and enabled.

	Parts Countxe "Parts Count"
	A check mark indicates that the ability to perform Parts Count calculations is installed and enabled. 

	Reliability Block Diagram (RBD)
	A check mark indicates that the Reliability Block Diagram (RBD) option is installed and enabled. This option is disabled if a Project file is currently open in Relex. To make a change to this option, all Project files must be closed.

	Failure Mode and Effects Analysis (FMEA)
	A check markxe "FMEA Module" indicates that the FMEA portion of Relex is installed and enabled. This provides access to all the functionality of the Relex FMEA module.

	Fault Tree
	A check mark indicates that the Fault Tree option is installed and enabled. This option is disabled if a Project file is currently open in Relex. To make a change to this option, all Project files must be closed.

	Maintainability Predictionxe "Maintainability Prediction"
	A check mark indicates that the Maintainability Prediction portion of Relex is installed and enabled. This provides access to all functions of the Relex Maintainability module.

	Life Cycle Cost
	A check mark indicates that the Life Cycle Cost portion of Relex is installed and enabled. This provides access to all features available in the Relex Life Cycle Cost module.


xe "Fonts tab"Fonts Tab

Relex offers you the ability to select the font size and stylexe "Style" used on Relex data entry windows. The Fonts tab has the following options:

General

	Option
	Description

	Tables
	Allows you to select the font size and type that is used in tables. This includes the Parts Table and FMEA Table.

	Tabs
	Allows you to select the font size and type that is used on the tabs of the Parts Table.


Report Designs

	Option
	Description

	Report Headerxe "Header" Font
	Allows you to select the font size and type that is used in report designs for Report Header objects. 

	Page Header Font
	Allows you to select the font size and type that is used in report designs for Page Header objects. 

	Details Font
	Allows you to select the font size and type that is used in report designs for objects included in the Details section. 

	Footerxe "Footer" Font
	Allows you to select the font size and type that is used in report designs for objects included in the Footer section.


Behavior Tab
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Figure 2 - 7. Options, Behavior

The Behavior tab allows you to customize certain features in the RBD, Fault Tree, and report designs.

Report Designs, RBDs, and Fault Trees

	Property
	Description

	Show Grid
	If As Lines is enabled, the grid displays as lines

If As Dots is enabled, the grid displays as dots.

	Objects Snap to Grid
	If enabled, objects automatically align to grid markers. If disabled, objects may be placed without any reference to the grid. When enabled, specify the snap spacing (described as follows).

	Show Rulers
	If enabled, the horizontal and vertical rulers are displayed on the diagram.

	Show Page Boundaries
	If enabled, the specified page boundaries are displayed. If disabled, the non-printable area is not displayed.

	Create One Object at a Time


	If enabled, when adding figures to the diagram, your cursor is automatically changed to a normal cursor when the first object is placed in the diagram, so only one figure is created at a time. If disabled, multiple figures of the selected type may be inserted into the diagram. 

	Print Crop Marks
	If enabled, crop marks are printed with the diagram. Crop marks are helpful for combining multiple page diagrams into one large poster style diagram.

	Grid Spacing
	Sets the amount of space between grid markers. Select from the choice list.

	Snap Spacing
	Specifies the spacing of the grid to which items automatically snap (this value can be different than the grid spacing). Select from the choice list. 

	English or Metric Measurements
	If English Measurements is enabled, the rulers are displayed in English units (inches). If Metric Measurements is enabled, the rulers are displayed in Metric units (centimeters).

	Create Heading on Database Field Insert (report designs only)
	If enabled, when a database field is inserted in a report design, a heading for that database field is inserted automatically into the column header. If disabled, no column header is added automatically, and it is necessary to create the column header manually.


Note: Snap spacing, page boundaries, and print crop marks settings do not apply to report designs.

Fault Trees

	Property
	Description

	Gate/Event Symbol Size (in.)
	The default size of Gate/Event Symbols.

	Text Box Size
	The height and width of text boxes.

	Show Property Tab after Inserting Gate/Event/Figure
	If enabled, as new gates, events, and figures are created, Property tabs for the new items are automatically displayed for editing. If disabled, as new items are added, the Property tabs need to be accessed through the menu.

	All Inputs Align to Center of Gate
	Determines how the inputs are drawn to a gate. If enabled, all inputs are automatically aligned to the center of the gate.


Fault Tree Tab
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Figure 2 - 8. Options, Fault Tree

The Fault Tree tab allows you to customize certain features of the Relex Fault Tree module.

	Property
	Description

	Autonaming - Gates
	Allows you to set the default naming conventions for new gates by specifying the prefix, minimum digits and suffix.

Prefix. Alphanumeric prefix of gate name.

Minimum Digits. Specifies the minimum number of digits used in the autonaming convention. The minimum number of digits may be between 1 and 9.

Suffix. Alphanumeric suffix of gate name.

Sample. Displays a sample gate name based on prefix, minimum digits and suffix specified above.

	Autonaming - Events
	Allows you to set the default naming conventions for new events by specifying the prefix, minimum digits and suffix.

Prefix. Alphanumeric prefix of event name.

Minimum Digits. Specifies the minimum number of digits used in the autonaming convention. The minimum number of digits may be between 1 and 9.

Suffix. Alphanumeric suffix of event name.

Sample. Displays a sample event name based on prefix, minimum digits and suffix specified above.

	Symbol Colors
	Allows you to select specific colors for true gates and events, false gates and events, and cut set highlights for both coherent and non-coherent paths.

	On Insert Input Command
	Allows you to customize the Insert Input command used when creating a Fault Tree. The Insert Input command is available on the right mouse menu when a gate is selected in a Fault Tree. 

Prompt for Gate/Event Type. With the Prompt for Gate/Event Type option enabled, the Insert Input window appears, allowing you to select the Input Type.

Insert Basic Event.xe "Basic Event" With the Insert Basic Event option enabled, a basic event is added by default when the Insert Input command is executed.


Chapter 3 xe "File Types"File Types

Introduction

There are several file types available in Relex. Each file type has its own unique purpose and provides extended functionality to your Relex analysis package.

Relex Project files are the main storage area for your analysis information. Project files are the primary file type and can contain a hierarchical outline of the system being analyzed, parts lists for the assemblies within the system, and details regarding the assemblies and components in the system. A Project filexe "Project file" can also include RBD and Fault Tree diagrams, if these modules are installed. For a complete description of Relex Project files, refer to the section titled “Project Files”. 

Relex Life Cycle Cost filesxe "Life Cycle Cost files" are available with the Relex LCC module. Life Cycle Cost files contain a Cost Breakdown Structure (CBS) of the system being analyzed and custom equationsxe "Equations" which are used for the calculation of cost. For a complete description of LCC files, refer to the “Life Cycle Cost (LCC)” chapter of this manual.

Relex Input Format filesxe "Input Format Files" and Report Design files allow you to format your input screens and your output reports to suit your needs. 

There is a wide range of file types referred to in combination as “Relex Value-Added filesxe "Value-Added files"” which supplement your Relex product to offer extended functionality, as well as provide for organization of your analysis. The particular Value-Added files available depend on the Relex modules that are active.xe "Active" This section includes listings of the Value-Added files associated with each particular Relex module. The Value-Added files are described in detail in the appropriate module specific chapter of this manual.

Lastly, Miscellaneous files provide extra capability for text-based and graphical image files.

Project Files

Project files in Relex are the main storage areas for all data pertaining to your analysis. Project files include reliability prediction,xe "Reliability Prediction" FMEA, maintainability prediction,xe "Maintainability Prediction" RBD, and Fault Tree data. There are sample Projectxe "Sample Project" files supplied for review.

When a Project file is opened in Relex, the Relex window is divided into separate work areas.xe "Work Areas" It is important that you become familiar with the characteristics of a Project file, since it is the most commonly used file in Relex.

Sample Project File

Before you begin to create your own Project file, it may be helpful to see one that already exists. Relex supplies a Project file named Sample Relex Project that includes reliability prediction, FMEA, maintainability, RBD, and fault tree data.

To review the Sample Relex Project, follow these steps: 

1. Open the Sample Relex Project file by selecting File>Open>Project from the main menu. Select Sample Relex Project.RPJ and press <Open>.

2. When the sample project appears the System Treexe "System Tree" and Parts Tablexe "Parts Table" windows are shown. The FMEA Treexe "FMEA Tree" also appears if Relex FMEA is enabled.

Creating/Opening a Project File

1. Select File>New>Project or File>Open>Project from the main menu. Enter the new file name or select the file to be opened and press <Create> or <Open> to continue.

2. If creating a new file, the tabs displaying the properties of the Project file are shown. Edit these properties if necessary and press <OK> when ready. For more information on the Project Properties tabs, refer to the following section titled “Project File Properties”.

3. The main Project file window appears. This window is comprised of the System Tree and Parts Table windows. If Relex FMEA is enabled, the FMEA Tree also appears. For more information on these sections, refer to the sections titled, “System Tree”, “Parts Table”, and “FMEA Tree”.

Project File Properties

Project Options Tab
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Figure 3 - 1. Project File Properties, Product Options Tabxe "Product Options tab"
The Project Options tab provides you with the ability to enable and disable specific features or modules of Relex. A check mark beside the associated module signifies that the module is selected for the current Project file. No check mark signifies that the associated module is disabled for the current Project file.

Note: Prediction/general information must be included for either FMEA or Maintainability to be included. It is advantageous to enable only the modules you are using in a Project file in order to keep Project file size to a minimum. 

xe "Prediction/General Files tab"Prediction/General Files Tab
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Figure 3 - 2. Project File Properties, Prediction/General Files Tab

The Prediction/General Files tab provides you with the ability to activate customized files to be used with a Project file. These special filesxe "Special files" \r "D2HBSpecial_file3" are associated with the general and prediction data in a Project file. The <Browse> button to the right of each field can be used to select the file to be activated for the Project file. The options are:

	File
	Description

	Defaults
	Selects the User-Defined Defaults filexe "Defaults file" to be used for the System. Relex has its own Defaults file that is always active. The information in the user Defaults file overrides the Relex defaults if you leave part parameters blank during data entry.

	User Defined Values
	User Defined Values file provides you with the ability to create user defined qualityxe "Quality" levels and environments. 

	Mission Profilexe "Mission Profile"
	A Mission Profile provides you with the ability to segment the calculations into separate mission phases. Each mission phase can have a different environment and temperature associated with it.

	Derating
	The Derating filexe "Derating file" allows you to specify your own derating criteria for the various stress parameters. During calculations Relex checks to see which parts are over your derating requirements. Relex has a built-in set of derating parameters that are always checked. 

	Derating Calculationsxe "Derating Calculations"
	If a Derating file is selected, you can also choose between nominal or worst case analysis. If nominal is selected, the nominal values in the Derating file are used for derating purposes. If worst case is selected, the worst case values in the Derating file are used for derating purposes.


xe "FMEA Files tab"FMEA Files Tab
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Figure 3 - 3. Project File Properties, FMEA Files Tab

The FMEA Files tab provides you with the ability to activate customized files to be used with a Project file. These special files are associated with the FMEA data in a Project file. The <Browse> button to the right of each field can be used to select the file to be activated for the Project file. The files available for selection are:

	File
	Description

	Modes 
	The Modes file contains failure modes and the percentage of time that each mode of failure will occur for various part types. The Modes file may also contain corresponding causes for each failure mode. 

	FIN Definitionxe "FIN Definition"

	The FIN Definition file allows you to define various Fault Identification Numbers (FINS) and associated data for use in a FMEA. FINS allow you to group failure modes into fault equivalence groups.

	Phrases
	The Phrases filexe "Phrases file" \r "D2HBPhrases_file4" contains common phrases that are used throughout a Relex FMEA. The Phrases file makes it possible to select common phrases from a choice list while performing data entry rather than having to type the data manually.

	Automatically add new phrases to Phrases file
	When enabled, Relex automatically adds all new text entries into the Phrases file. If disabled, Relex tracks all text entries, and if a text entry is not found in the active Phrases file, Relex asks if you wish to add the new text to the Phrases file. 


Maintainability Files Tab
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Figure 3 - 4. Project File Properties, Maintainability Files Tab

The Maintainability Files tab provides you with the ability to activate customized files to be used with a Project file. These special files are associated with the maintainability dataxe "Maintainability Data" in a Project file. The <Browse> button to the right of each field can be used to select the file to be activated for the Project file. The files available for selection are:

	File
	Description

	Tasks
	Tasks filesxe "Tasks file" are used to storexe "Maintainability Calculations" \r "D2HBMaintainabil5" the basic and supertasks and associated times. The repair times stored in the Tasks file are used as the basis for all of the maintainability calculations.

	FD&I Outputsxe "FD&I Outputs"
	FD&I Outputs files are used to store Fault Detection and Isolation (FD&I) Outputs that are to be used with a Project file. Each FD&I Output definition also includes the list of associated tasks.

	Maintainability Groups
	Maintainability Group files are used to store maintainability groups that are used with a Project file. Maintainability groups are only used when maintainability calculations are to be based on MIL-HDBK-472xe "MIL-HDBK-472" Procedure 5A. MIL-HDBK-472 Procedure 5B calculations do not use Maintainability Groups.


xe "Fault Tree Files tab"Fault Tree Files Tab
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Figure 3 - 5. Project File Properties, Fault Tree Files Tab

The Fault Tree Files tab provides you with the ability to activate customized files to be used with a Project file. These special files are associated with the Fault Tree portion of a Project file. The <Browse> button to the right of each field can be used to select the file to be activated for the Project file. The files available for selection are:

	File
	Description

	CCF Groups
	Common Cause Failure Groups files allow you to include fault tree events in multiple common cause failure groups.

	Event Parameters
	Event Parameters files are a storxe "Failure with Periodic Inspection"age area for commonly used events and associated event parameters for constant probability,xe "Constant Probability" failure rate/MTBF,xe "MTBF" frequency, failure with repairxe "Failure with Repair" or failure with periodic inspection.


xe "Format Files tab"Format Files Tab
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Figure 3 - 6. Project File Properties, Format Files Tab

The Format Files tab provides the ability to activate customized files to be used with a Project file. These special files are associated with the format of both input windows and output reports. The <Browse> button to the right of each field can be used to select the file to be activated for the Project file. The files available for selection are:

	File
	Description

	Report Format
	When printing a Project file report, the Report Format entered here is automatically selected, but this may be overridden at the time of report generation.

	Parts Table Format
	Provides the ability to customize the appearance of the Parts Table. Allows you to specify which fields are used, and the order for data entry.

	FMEA Input Format
	Provides the ability to customize the input windows for FMEA data. Allows you to specify which fields are used and the order during FMEA data entry.

	System Tree Format
	Provides the ability to customize the format of the System Tree window. Allows you to specify which fields are used, and the order for data entry.

	Fault Tree Format
	Provides the ability to customize the format of the Fault Tree Tablexe "Fault Tree Table" window. Allows you to specify which fields are used and the order for data entry.

	Fault Tree Report Format
	When printing a Fault Tree file report, the Fault Tree Report Format entered here is automatically selected, but this may be overridden at the time of report generation.

	RBD Report Format
	When printing an RBD file report, the RBD Report Format entered here is automatically selected, but this may be overridden at the time of report generation.


xe "Project Definitions tab"Project Definitions Tab
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Figure 3 - 7. Project File Properties, Project Definitions Tab

The data on the Project Definitions tab is used to specify global information that applies to the entire project.

	Property
	Description

	Failure Rate Multiplierxe "Failure Rate Multiplier"
	Specifies the units for calculating failure rate. Generally, the MIL-HDBK-217xe "MIL-HDBK-217" calculations are based on failures per million hours (the value in the field would be 1,000,000); Telcordiaxe "Telcordia (Bellcore)" (Bellcore) calculations are based on failures per billion hours (the value in this field would be 1,000,000,000). The unit that you select here is used for all items in the Project file.

Note: MTBF is always in hours.

	Maintainability Data
	The following options are used for maintainability predictions only:

	
	Procedure 5A. When enabled, the maintainability calculationsxe "Maintainability Calculations" that are performed are based on MIL-HDBK-472 Procedure 5A. If disabled, all calculations are based on MIL-HDBK-472 Procedure 5B.

	
	Repair Time. Allows the selection of units to be used in the entry of repair times. You may select between minutes or hours. 

	
	Results Time. Allows the selection of units to be used in the entry of results time. You may select between minutes or hours.

	Repair Times Adjustmentxe "Repair Times Adjustment"
	The following options are related to maintainability predictions only.

	
	None. When enabled, there is no adjustment to the repair time.

	
	Multiply. When enabled, the entered repair times are all multiplied by the value.

	
	Add. When enabled, the value is added to the entered repair times.

	Frequency of Type 1xe "Type 1 False Alarms" False Alarms
	Used for maintainability predictions only. The frequency of occurrence of type 1 false alarms is expressed in ratio units (a value from 0 to 100) of type 1 false alarms to actual failures. Type 1 false alarms are detected during normal operation but cannot be repeated during the fault isolation process. This information is used in the Mean Maintenance Hours per Maintenance Action, Mean Maintenance Hours per Operating Hour, and Mean Maintenance Hours per Flight Hour calculations.

	Frequency of Type 2xe "Type 2 False Alarms" False Alarms
	Used for maintainability predictions only. The frequency of occurrence of type 2 false alarms is expressed in ratio units (a value from 0 to 100) of type 2 false alarms to actual failures. Type 2 false alarms are detected and isolated to a removable item when the removable item does not have an actual fault. This information is used in the Mean Maintenance Hours per Maintenance Action, Mean Maintenance Hours per Operating Hour, and Mean Maintenance Hours per Flight Hour calculations.


xe "FMEA tab"FMEA Tab
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Figure 3 - 8. Project File Properties, FMEA Tab

The FMEA tab is used to specify global information that applies to Relex FMEA only. It provides the ability to customize your FMEA.

	Property
	Description

	Criticality Matrixxe "Criticality Matrix" \r "D2HBCriticality_10" Options
	Criticality Matrix X Axis. The choice list can be used to select the criteria for the X-axis of the criticality matrix.

	
	Criticality Matrix Y Axis. The choice list can be used to select the criteria for the Y-axis of the criticality matrix.

	High Risk Graph Options
	High Risk X Level. The point where the high risk line crosses the X-axis.

	
	High Risk Y Level. The point where the high risk line crosses the Y-axis.

	Low Risk Graph Options
	Low Risk X Level. The point where the low risk line crosses the X-axis.

	
	Low Risk Y Level. The point where the low risk line crosses the Y-axis.

	Severity Options
	The Severity provides a measure of the worst potential consequences resulting from the failure mode's occurrence. A sample definition of severity levels based on MIL-STD-1629 is (this is the Relex default):

I. Catastrophic. A failure which may cause death or system loss (i.e. aircraft, tank, missile, ship, etc.)

II. Critical. Failures that may cause severe injury, major property damage, or major system damage that result in mission loss.

III. Marginal. Failures that may cause minor injury, minor property damage, or minor system damage that result in delay or loss of availabilityxe "Availability" or mission degradation.

IV. Minor. A failure not serious enough to cause injury, property damage, or system damage, but which results in an unscheduled maintenance or repair.

Name. Used to specify the name of the severity level. For automotive FMEAs, the names are normally a number from 1 to 10. Relex allows you to define descriptive text also.

	
	Value. Used to specify the value of the severity level. 10 signifies the most critical level, and 1 signifies the least critical. For automotive FMEAs, the values range from 1 to 10. The values associated with each severity level are used in the calculation of RPN.

	Occurrence Options
	Basis. The choice list allows you to select the basis of the occurrence value. You can select from a choice list including: None, Mode Criticality, Occurrence Rank, Failure Mode Probability and Process Variation.

None – Selecting this option allows you to build a criticality matrix based on the Occurrence field. The Occurrence field in Relex FMEA is a choice list which allows you to select from the following predefined list of entries:

A – Frequent

B – Reasonably Probable

C – Occasional

D – Remote

E – Extremely Unlikely

For each of the remaining options, the occurrence is determined from the specified or calculated value. Relex considers the occurrence definition (Name and Level). For example, an occurrence name may be A – Frequent and its value 100. If mode criticality is used as the basis for the occurrence, then if the specified or calculated mode criticality is greater than or equal to 100 (the defined Value), then the occurrence for that mode is considered to be A – Frequent.

Each of the occurrence basis option equations are described as follows:

Mode Criticality = Effect Probability * Mode Failure Rate * Operating Time

Occurrence Rank = Severity * Occurrence * Detection

Failure Mode Probability = 1 – e-t, where  is the Mode Failure Rate and t is the Mission Time

Process Variation – The probability that an item parameter is out of specification due to variations in the manufacturing process (based on the Process Capability Index, CPK).

Name. Specifies the name of the occurrence level. For automotive FMEAs, the names are normally a number from 1 to 10. Relex allows you to define descriptive text also.

	
	Value. Specifies the value of the occurrence level. 10 would signify the most critical level, and 1 would signify the least critical. For automotive FMEAs, the values range from 1 to 10.

	Detection Options
	Name. Specifies the name of the detection level. For automotive FMEAs, the names are normally a number from 1 to 10. Relex allows you to define descriptive text also.

	
	Value. Specifies the value of the detection level. 10 would signify the most critical level, and 1 would signify the least critical. For automotive FMEAs, the values range from 1 to 10.


Project File Window

When a Project file has been opened, several windows are displayed, separated by resizable splitter bars. These windows are the System Tree, the Parts Table, and, if Relex FMEA is enabled, the FMEA Tree.
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Figure 3 - 9. Sample Relex Project File

The System Tree portion operates much like the File Manager or Explorer applications from Windows. Instead of drives and directories, the System Tree contains all of the assemblies and components within a hardware/software system arranged in a system hierarchy. Because there is no limit to the size of your System Tree, you can model small and large complex systems. The System Tree window may contain several tabs, including the System Tree tab, RBD Table tab, and the Fault Tree tab.

The Parts Table portion displays a listing of all components contained in each assembly. You can experiment with the Parts Table by selecting various assemblies in the System Tree. As you select individual components in the System Tree, that component is selected in the Parts Table. The System Tree and the Parts Table are completely synchronized. 

The FMEA Tree portion displays the FMEA data associated with the currently selected item. As assemblies and parts are selected in the System Tree and Parts Table, the FMEA Tree displays the corresponding data. The FMEA Tree is synchronized with the System Tree and Parts Table.

The following sections describe the System Tree and Parts Table in detail. For information on the FMEA Tree, refer to the “FMEA” chapter of this manual.

System Tree

Relex’s System Tree contains all of the assemblies and components within a hardware/software system arranged in a system hierarchy. Because there is no limit to the size of your System Tree, you can model small and large complex systems.

Viewing a System Tree

Selecting the System Tree as the Active Window

In order to make the System Tree portion of the Relex Desktopxe "Relex Desktop" active, click your mouse anywhere in the System Tree window. 

Review of the System Tree Structure

The items in the system are displayed in a hierarchical format. The top level of the system is displayed at the top of the hierarchy, and all levels of indenture in the system are shown as branches off of the main system. An item in a hierarchy can be displayed as an assembly (illustrated with an icon that looks like a book) or a part (illustrated with an icon that looks like a nut and bolt).

Any assembly in a system structure can be expanded or collapsed. When a branch is expanded, all parts and assemblies beneath it are displayed. When a branch is collapsed, only the assembly level is displayed. You can collapse or expand any portion of a system by using one of these techniques:

· Single-click the + (plus) or – (minus) sign beside any item to expand (+) or collapse (–) it.

· Select the item with your cursor, and select Tree>Expand Branch or Tree>Collapse Branch from the main menu.

From the main menu, Tree>Expand All and Tree>Collapse All expands and collapses all items in the current system. 

Customizing the System Tree

The data that is displayed for each item in a System Tree can be customized. By default, Relex displays assembly names for all assemblies and part numbers for all parts in a System Tree. In addition, you can customize the additional columns that are available for display. This customization is done through an Input Format file.xe "Format file" 

Editing a System Tree

System Tree Menus 

Relex has a pull down menu on the main menu designed specifically for editing and viewing the System Tree. This pull down menu, titled Tree is only visible when the Tree window is the active window in Relex. Also, the right mouse provides access to various System Tree functions. 

Adding Items to the System Tree

Items within a system are added as either a sibling or a child of another item. A sibling is an item that resides at the same indenture level as another item. A child is an item that resides at a lower level of indenture than another item.

Upon creating a new Project file, the top level of the System Tree is automatically defined. You may then build the structure of your system. The top level of the system is special in that it may only contain children. The top level of the System Tree can contain a sibling.

To add an item in a System Tree, you may use either of the following techniques:

· Select the item with your cursor, and select Insert>Child or Insert>Sibling from the main menu.

· Select the item with your cursor, and select Insert Child or Insert Sibling from the right mouse menu.

Moving/Copying Items in a System Tree

You have various options for copying and moving items in a System Tree:

	Function
	Steps to Follow

	Drag and Drop to Move


	1. Click and drag the item to be moved.

2. Place your cursor over an existing System Tree item where the selected item is to be moved. The selected item is positioned as a sibling of the existing item.

3. Release your cursor to move the selected item to its new location.

	Drag and Drop with SHIFT to Move as Child


	1. Click and drag the item to be moved.

2. Place your cursor over an existing System Tree item where the selected item is to be moved and hold the <SHIFT> key. The selected item is positioned as a child of the existing item.

3. Release your cursor to move the selected item to its new location.

	Drag and Drop with CTRL to Copy


	1. Click and drag the item to be copied.

2. Place your cursor over an existing System Tree item where the selected item is to be copied and hold the <CTRL> key. The selected item is positioned as a sibling of the existing item.

3. Release your cursor to move the selected item to its new location. 

	Cut and Pastexe "Cut and Paste"

	1. Select the item to be cut by clicking it with your cursor (it appears as highlighted).

2. Select Cut from the right mouse menu, or select Edit>Cut from the main menu.

3. Select the item where the cut item is to be placed by clicking it with your cursor. The item is positioned as a sibling of the selected item.

4. Select Paste from the right mouse menu, or select Edit>Paste from the main menu.

5. The item is moved to its new location.

	Cut and Paste as Child


	1. Select the item to be cut by clicking it with your cursor (it appears as highlighted).

2. Select Cut from the right mouse menu, or select Edit>Cut from the main menu.

3. Select the item where the cut is to be placed by clicking it with your cursor. The item is positioned as a child of the selected item.

4. Select Paste as Child from the right mouse menu, or select Edit>Paste as Child from the main menu.

5. The item is moved to its new location.

	Copy and Pastexe "Copy and Paste"

	1. Select the item to be copied by clicking it with your cursor (it appears as highlighted).

2. Select Copy from the right mouse menu, or select Edit>Copy from the main menu.

3. Select the item where the copied item is to be placed by clicking it with your cursor. The item is positioned as a sibling of the selected item.

4. Select Paste from the right mouse menu, or select Edit>Paste from the main menu.

5. The item is copied to its new location.

	Copy and Paste as Child


	1. Select the item to be copied by clicking it with your cursor (it appears as highlighted).

2. Select Copy from the right mouse menu, or select Edit>Copy from the main menu.

3. Select the item where the copied file is to be placed by clicking it with your cursor. The item is positioned as a child of the selected item.

4. Select Paste as Child from the right mouse menu, or select Edit>Paste as Child from the main menu.

5. The item is copied to its new location.


Deleting Items from the System Tree
Items in the System Tree can be deleted, by using either of the following techniques:

· Select the item with your cursor, and select Edit>Delete from the main menu.

· Select the item with your cursor, and select Delete from the right mouse menu.

Note: Deleting an item in the tree deletes that element and all of its children.

Parts Table

The Parts Table is a table that displays a list of the individual parts or components for the corresponding assembly in the System Tree. The Parts Table displays basic information regarding the list of parts for the selected assembly. That general information may include part number,xe "Part Number" category,xe "Category" subcategory,xe "Subcategory" and quantity. The format of the Parts Table can be customized through the use of an Input Format file. An Input Format file allows you to select the columns to be displayed, and the order and headings of these columns. Since the Parts Table’s appearance is customized, it may include any data fields you desire.

In addition to this general information regarding parts, the Parts Table window also provides access to various other tabs that include information on the assemblies and components.

In order to make the Parts Table portion of the Relex Desktopxe "Relex Desktop" active, click your mouse anywhere in the Parts Table window. 

Parts Table Information

By default the Parts Table is configured with the following fields:

	Field Name
	Description and Options Associated with the Field

	Part Number
	Represents the part number of the item in the parts list. You may enter an alphanumeric part number up to 255 characters in length.

Options:

· Enter a part number and press <TAB> to search the active libraries for a matching part number. If a match is found, all parameters for that part number are retrieved. If no match is found, your cursor advances to the next field. 

· Leave the field blank and press <TAB> to advance to the next field. The Part Number field is not required and can be left blank.

· Enter a portion of the part number you wish to retrieve from the libraries and select Browse Librariesxe "Browse libraries" from the right mouse menu to search for the part based on specified parameters. When the list of matching part numbers is retrieved, select the desired part number with your mouse and press <Insert> to insert that part number into the Parts Table.

· Leave the field blank and select Browse Libraries from the right mouse menu to browse all parts in the libraries based on specified parameters. When the Browse Library window appears either browse through the list to find a part or enter the desired filter parameters and press <Filter> to search the selected libraries based on the specified parameters. Select the desired part number with your mouse and press <Insert> to insert that part number into the Parts Table or <Update> to replace the current part.

	Category
	If the part number is found in the active Libraries, a category is automatically filled in. If not, press the choice list in the Category column to display a list of all possible part categories. Select a part category from the list and press <TAB> to advance to the next field. From this field, you may also type the desired category to display that entry in the Category field, or you may press the <DOWN ARROW> key to cycle through choices.

	Subcategory
	If the part number is found in the active Libraries, a subcategory is automatically filled in. If not, press the choice list in the Subcategory column to display a list of all possible part subcategories. This list varies depending on the part category that was selected in the previous field. Select a part subcategory from the list and press <TAB> to advance to the next field. You may also type the desired subcategory to display that entry in the Subcategory field, or you may press the <DOWN ARROW> key to cycle through the choices.

	Reference Designatorxe "Reference Designator"
	Enter the refexe "CAD Interface"rence designator, e.g. U1, R22, C1-C15, for the part, and press <TAB> to advance to the next field. Up to 255 characters can be entered. This field is not required, but it is used for updating an assembly of parts when using the CAD Interface.

	Quantity
	Enter the quantity for the part, and press <TAB> to advance to the next field. You have the option of entering fractional quantities.

	Model
	You may select a different reliability prediction model on a part by part basis. If no model is selected, the calculation for the part is based on the model selected for the assembly in the System Tree. If no model is selected at one level, the model of the next higher level is used. To select a different model for this part, press the choice list in the column to display a list of available models. Select a model from the list and press <TAB> to advance to the next field.

	Failure Rate
	The calculated failure ratexe "Calculated Failure Rate" for this part is displayed in the field.

	% Failure Rate
	This non-editable calculated value is based on the failure rate of the part and the failure rate of all parts in the current assembly. A percentage is calculated as follows:

% FR = FR of the Individual Part / Total FR for the Assembly * 100


Assembly Property Tabs

In addition to the information entered on the Parts Table, you may also enter or view the data or properties related to each assembly from the System Tree. By selecting the assembly in the System Tree, and then selecting the properties tabs at the bottom of the Parts Table window, you can view the properties for an assembly.

The information available for assemblies is found on the following tabs:

· General Data

· Calculation Data

· Maintainability

· Hybrid

· Calculation Results

· FMEA Data

· Method Data

· Remarks

xe "General Data tab"General Data Tab
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Figure 3 - 10. Assembly Properties, General Data Tab

The General Data tab includes descriptive information regarding the selected item. This information can be assigned at any level in the System Tree.

	Property
	Description

	Name
	The name of the selected item

	Description
	A description of the item.

	Reference Designator
	The reference designator of the selected item, such as A1.

	Part Number
	The part number of the selected item.

	Alternate Part Numberxe "Alternate Part Number"
	The alternate part number of the selected item.

	CAGE Codexe "CAGE Code"
	Commercial and Government Entity Code of the selected item. Normally a 5-digit code, but you can enter up to 255 characters.

	Logistics Control Number (LCN)
	The Logistics Control Number, LCN, of the selected item. The LCN is normally an 18-digit number and is used during the LSAR report generation.

	Operating Environmentxe "Operating Environment"
	Environment of the selected item. When the environment is selected for the top level of the tree, it serves as the environment for all levels below it. If an environment is selected in the Properties of a lower level item, that selection overrides the environment at the higher level. It is also the environment for all lower levels below the selected item. The list of environments available is based on those outlined in the MIL-HDBK-217 and Telcordiaxe "Telcordia (Bellcore)" \r "D2HBTelcordia20" (Bellcore) standards. 

	Dormantxe "Dormant" Environment
	Dormant or passivexe "Passive" environment of the selected item. You can select from four choices in the list: Ground, Airborne, Naval, Space. This information is used to calculate the passive failure rate for components in the System Tree item. For more information regarding the dormant environment and passive failure rate, refer to the “Reliability Prediction” chapter of this manual.

	Temperature
	Operating temperature (in degrees Celsius) of the selected item. When the operating temperature is selected for the top level of the tree, it also serves as the operating temperature for all levels below it. If an operating temperature is selected in the properties of a lower level item, that selection overrides the operating temperature at the higher level. It is also the temperature for all lower levels below the selected item. The operating temperature can correspond to an ambient temperature, a case temperature, or any other temperature you choose, just be sure this basis is consistent throughout your system.

	Temperature Risexe "Temperature Rise"
	Temperature rise from the next higher assembly (in degrees Celsius). If this field is left blank, there is no temperature rise from the calculated operating temperature of the next higher assembly. As an example, if the operating temperature of the top level of the System Tree is 30 degrees Celsius, and the temperature rise of a child assembly is 10 degrees Celsius, then the operating temperature of the child is 40 degrees Celsius (30+10).

Note: The calculated operating temperature of any component can be viewed using the <Pi Factorsxe "Pi Factors"> button on the Prediction Data tabxe "Prediction Data tab" of any part in an assembly. This temperature includes the initial operating temperature of the System Tree, plus any temperature rises of higher levels, plus the temperature rise of the individual component.

	Calculation Modelxe "Calculation Model" \r "D2HBCalculation_19"
	Calculation model for the selected item. When the calculation model is selected for the top level of the tree, it serves as the model for the top of the tree and all levels below it. If a calculation model is selected in the properties of a lower level item, that selection overrides the model at the higher level. It also serves as the model for all lower levels below the selected item. The list of models that appears is dependent on the options that have been purchased with your Relex package.

	Calculation Method
	Method for the calculation. The list of methods is based on the Telcordia (Bellcore) standard. However, regardless of the calculation model that was selected (MIL-HDBK-217 or Telcordia (Bellcore)), these calculation methodsxe "Calculation Methods" can still be applied. Therefore, you can apply a Telcordia calculation method to a MIL-HDBK-217 calculation.

	User-Defined Textxe "User-Defined Text"
	A text field used to store any additional data for the selected item. You may enter any alphanumeric information up to 255 characters. The information stored in this field may be included on reports.

	User-Defined Valuexe "User-Defined Value"
	A numeric field used to store any additional data for the selected item. The information stored in this field may be included on reports.


Note: The override data values on the General Property tab for the top level of the System Tree are also the values for lower levels. However, if different selections are made at lower levels, these selections override the selections made at the higher levels. For instance, if a calculation model of MIL-HDBK-217 FN2 is selected at the top level of the tree, that is the default calculation model for all lower levels. However, if at some lower level of the System Tree (or even at the part level) a calculation model of Bellcore Issue 5 is selected, that calculation model overrides the MIL-HDBK-217 FN2 selection that was made at the higher level. The override value affects the component of the System Tree that was changed and all levels beneath it.

xe "Calculation Data tab"Calculation Data Tab
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Figure 3 - 11. Assembly Properties, Calculation Data Tab

The Calculation Data tab includes calculation options regarding the selected item. This information can be assigned at the top level of the System Tree, and can also be assigned for each assembly within the System Tree.

	Property
	Description

	Repairablexe "Repairable" Item
	If enabled, the sxe "RBD Calculations"elected item is a repairable item. If disabled, the selected item is not repairable. This information is used in maintainability and RBD calculations.

	Quantity
	The quantity of the selected item.

	Duty Cyclexe "Duty Cycle"
	Used to specify the percentage of time that the element is in an on state. The duty cycle is used when computing failure rates based on active and dormant environment settings. The duty cycle is equal to the percentage of total time the item is in the active environment. The percentage of time in the dormant environment is equal to 100 – duty cycle. The duty cycle defaults to 100%.

	Failure Rate
	Calculated. Used to specify that the failure rate is to be calculated based the selected calculation models. This is the default selection. The failure rate multiplier assigned on the Project Definition tab specifies the failure rate units.

Failure Rate Specified. Used to specify the failure rate for the item. If a value is entered, no calculation is completed for the element. The failure rate multiplier assigned on the Project Definition tab specifies the failure rate units.

MTBF Specified. Used to specify the MTBF of the element. If a value is entered, no calculation is completed for the element. MTBF is always specified in hours.

	MTTRxe "MTTR"
	Calculated. Used to specify that the MTTR is to be calculated based on the maintainability data. This is the default selection. 

Specified. Used to specify the MTTR for the element. If a value is entered, no calculation is completed for the item. 

	Cost
	Calculated. Used to specify that the cost is to be calculated based on the cost data entered for the item’s children. This is the default selection. 

Specified. Used to specify the cost for the element. If a value is entered, no calculation is completed for the item. 

	Number of Spares
	Used to enter the number of spares available for the item. Used in spares and cost calculations when linked to an RBD. 


xe "Calculation Results tab"Calculation Results Tab

The Calculation Results tab displays the current calculation results for the selected assembly. If no calculations have been performed, no values are displayed.

xe "FMEA Data tab"FMEA Data Tab

The FMEA Data tab is used to gather information required to perform a Failure Mode and Effects Analysis. The fields of information on the FMEA Data tab depend entirely on the FMEA Input Format file that was selected for this particular project. Refer to the “FMEA” chapter of this manual for more information on the purpose and use of the FMEA Data tab.

xe "Maintainability tab"Maintainability Tab

The Maintainability tab is used to gather information required to perform a maintainability prediction. Refer to the “Maintainability Prediction” chapter of this manual for more information on the purpose of the Maintainability tab.

Hybrid Data Tab
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Figure 3 - 12. Assembly Properties, Hybrid Tab

A hybrid is a component in a relatively large package that contains other parts mounted on a substrate. A hybrid is added as an assembly to the System Tree, and the parts are added through the Parts Table. The information on the Hybrid Data tab is used in modifying the overall failure rate for the hybrid package. This modification is a calculation that takes place in addition to the calculation of failure rate for the individual parts in the hybrid. For more information on hybrids,xe "Hybrids" refer to either the MIL-HDBK-217 or Telcordiaxe "Telcordia (Bellcore)" \r "D2HBTelcordia24" (Bellcore) standard. 

MIL-HDBK-217 Data

These items are required for MIL-HDBK-217 hybrid calculations only:

	Property
	Description

	Circuit Type
	Used to specify the circuit type of the hybrid.

	Quality
	Select the quality value of the hybrid.

	Pi Q Value
	Used to override the Q value for the hybrid.

	Years in Production
	Years in production of the hybrid.

	Max Case Temperature
	Maximum case temperature of the hybrid.


Telcordia (Bellcore) Data

These items are required for Telcordia (Bellcore) hybrid calculations only:

	Property
	Description

	Circuit Type
	Used to specify the circuit type of the hybrid.

	Internal Interconnections
	Used to specify the number of internal interconnections of the hybrid.

	Film Resistors
	Used to specify the number of film resistors of the hybrid.

	Film Capacitors
	Used to specify the number of film capacitors of the hybrid.


xe "Method Data tab" \r "D2HBMethod_Data_24"Method Data Tab
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Figure 3 - 13. Assembly Properties, Method Data Tab

The Method Data tab includes method data values regarding the selected item. This information can be assigned at the top level of the System Tree, and can also be assigned for each assembly within the tree. The method data that is gathered is based on the Telcordia (Bellcore) standard. This standard offers additional flexibility by taking into account field and laboratory test data. Relex allows you to apply this flexibility to both Telcordia and MIL-HDBK-217 calculations by assigning the method data regardless of the selected calculation model.xe "Calculation Model" For a detailed description of the calculation methods,xe "Calculation Methods" refer to the Telcordia (Bellcore) standard.

	Property
	Description

	Burn-Inxe "Burn-In" Data
	System Burn-in. Time and temperature of the burn-in of the system. This is used in the calculation of the first year multiplierxe "First Year Multiplier" and is not used in the steady state failure rate calculation. The system burn-in information is only requested at the top level of the Project.

Unit Burn-in. Time and temperature of the burn-in of the unit or assembly. This is used in the calculation of the first year multiplier and is not used in the steady state failure rate calculation.

Average Burn-in. Time and temperature of the average burn-in. This is used in Method II Case L4 only and is not used in the steady state failure rate calculation.

	Laboratory Dataxe "Laboratory Data"
	Number of Test Units. Used for Method II calculations only. Number of units in the laboratory test.

Number of Failures. Used for Method II calculations only. Number of failures in the laboratory test.

Test Time. Used for Method II calculations only. The actual time on test in hours. Used in the calculation of effective time on test. 

Test Temperature. Used for Method II calculations only. The test temperature. Used in the calculation of the acceleration factor and effective time on test.

	Field Dataxe "Field Data"
	Operating Time. Used for Method III calculations only. The total operating hours of the unit in the tracked systems.

Number of Failures. Used for Method III calculations only. The number of failures observed in the tracked systems.

Tracked Unit Temperature. Used for Method III(b) calculations only. The test temperature of the unit or assembly.

Tracked Unit Failure Rate. Used for Method III(c) calculations only. The Method I Case 3 steady-state failure rate prediction.


xe "Remarks tab"Remarks Tab

The Remarks tab is used to enter remarks and comments regarding the selected item. The Remarks tab includes one field that allows for up to 32 thousand characters. The Remarks tab is a good place to store notes and comments regarding the various portions of the project.

Part Property Tabs

In addition to the information entered on the Parts Table, you may also enter or view the data or properties related to each part. The properties for a part can be viewed by using the Properties tabs at the bottom of the Parts Table window.

General Data Tab
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Figure 3 - 14. Part Properties, General Data Tab

The General Data tab specifies general information regarding the selected part. The general data includes:

	Field
	Description

	Taggedxe "Tagged" Part
	If marked, specifies the part as a tagged part. The designation of tagged part is used as an option in reporting, allowing you to report on tagged parts only.

	Repairable Item
	Enable the repairable item checkbox if the part is repairable. Otherwise, disable it. This information is used only for maintainability calculations.

	Part Number
	Represents the part number of the item in the parts list. You may enter an alphanumeric part number up to 255 characters in length.

	Category
	The category for the part.

	Subcategory
	The subcategory for the part.

	Reference Designator
	The reference designator, e.g. U1, R22, C1-C15, for the part.

	Quantity
	The quantity for the part. You have the option of entering fractional quantities.

	Model
	You may select a different reliability prediction model on a part by part basis. If no model is selected, the calculation for the part is based on the model selected for the assembly in the System Tree. If no model is selected at one level, the model of the next higher level is used.

	Alternate Part Numberxe "Alternate Part Number"
	Alternate part number for the selected part. You may enter any alphanumeric information up to 255 characters.

	CAGE Codexe "CAGE Code"
	Commercial and Government Entity Code of the selected item. Normally a 5-digit code, but you can enter up to 255 characters.

	Description
	Description of the selected part. You may enter any alphanumeric information up to 255 characters.

	Logistics Control Number (LCN)
	Used when exporting information to a MIL-STD-1388 2B compatible format. The Logistics Control Number field allows you to specify the LCN.

	Cost
	Cost of the selected part. The cost can be entered in any unit that you select, but you should be consistent.

	User-defined Textxe "User-Defined Text"
	Text field of information for your own use, storing up to 255 characters.

	User-defined Valuexe "User-Defined Value"
	Numerical field of information for your own use.

	Failure Rate
	Calculated. Specifies that the failure rate is to be calculated based on the selected calculation models.

Failure Rate Specified. Specifies the failure rate for the part. If a value is entered, no calculation is completed for the part. The unit of the failure rate entered is based on the failure rate multiplier specified on the Project Definition Tab in the System Properties.

MTBF Specified. Specifies the Mean Time Between Failuresxe "Mean Time Between Failures" (MTBF) of the element. If a value is entered, no calculation is completed for the part. The unit for MTBF is always hours.

	Multiplicative Adjustment
	An adjustment factor that is multiplied by the failure rate to calculate the adjusted failure rate.

	Additive Adjustmentxe "Additive adjustment"
	An adjustment factor which is added to (or subtracted from) the failure rate to calculate the adjusted failure rate. You may enter a positive or negative value.


Prediction Data Tab

The Prediction Data tab is used to enter information required to perform a reliability prediction. The appearance and items on the Prediction Data tab depend entirely on which category and subcategory are entered on the Parts Table for the selected part. Information on these specific forms is obtained by accessing the online help system by pressing <F1>.

FMEA Data Tab

The FMEA Data tab is used to enter information required to perform a Failure Mode and Effects Analysis (FMEA). The fields of information on the FMEA Data tab depend entirely on the FMEA Input Format file that was selected for the particular project.

xe "Maintainability tab"Maintainability Tab

The Maintainability tab is used to gather information required to perform a maintainability prediction. 

xe "Remarks tab"Remarks Tab

The Remarks tab is used to enter remarks and comments regarding the selected part. The Remarks tab includes one field that allows for up to 32 thousand characters. The Remarks tab is a good place to store notes and comments regarding the parts.

NPRD Data Tab
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Figure 3 - 15. Part Properties, NPRD Data Tab

If a category of Other and subcategory of NPRD95 Part is selected for a part in the Parts Table, a tab labeled NPRD Data displays in place of the Prediction Data tab. For more information on entering NPRD95 parts,xe "NPRD95 Parts" refer to the “Reliability Prediction” chapter of this manual.

xe "Method Data tab"Method Data Tab

The Method Data tab appears only for parts in an assembly for which the current calculation method requires additional information. Method I Case 1 and Method I Case 2 do not require additional information for calculation. Therefore, if Method I Case 1 or Case 2 are selected for an assembly, the Method Data tab does not appear for parts in that assembly. However, all other methods require additional information for calculations. The Method Data tab contains these additional fields of information. 

The fields that appear on the Method Data tab are always the same. However, depending on the additional data required by the selected calculation method, only certain fields are active for data entry. 

There are three main areas of data on the Method Data tab. These areas are:

xe "Device Burn-In"

xe "Burn-In"Device Burn-In

Device burn-in data is used for all calculation methodsxe "Calculation Methods" (with the exception of Method I Case 1 and Case 2). This device burn-in data is used in the calculation of the first-year multiplier (which is used to calculate the first year drop out or infant mortality rate). The following fields are active:

	Field
	When Used

	Time
	The device burn-in time in hours. Used for Method 1 Case 3, Method 2 Case L3 and L4, and Method 3 (a), (b), and (c).

	Temperature


	The device burn-in temperature. Used for Method 1 Case 3, Method 2 Case L3 and L4, and Method 3 (a), (b), and (c).


Note: Burn-in data does not affect the predicted steady state failure rate. It impacts the first year multiplier only.

Laboratory Data

Laboratory data is generally used for Method II calculations. The purpose of Method II is to predict unit or device reliability using laboratory data. Method II is calculated as a weighted average of the measured laboratory failure rate and the Parts Countxe "Parts Count" generic failure rate, with the weights determined by the laboratory data. When laboratory tests are very informative, the Method II base failure rate is determined primarily from the laboratory data. When laboratory tests are less informative, the Method II base failure rate is heavily influenced by the Parts Count generic failure rate. The following fields are active:

	Field
	When Used

	Number of Failures
	The number of failures in the laboratory test. Used for Method II Case L1, L2, L3, and L4.

	Number of Test Devices
	The number of devices on test. Used for Method II Case L1, L2, L3, and L4.



	Test Time
	The actual time on test in hours. This value is used in combination with test temperature to determine the effective time on test, which is the product of the actual time on test and the laboratory test temperature acceleration factor. Used for Method II Case L1, L2, L3, and L4.

	Test Temperature
	The test temperature in degrees Celsius. This value is used in combination with test time to determine the effective time on test, which is the product of the actual time on test and the laboratory test temperature acceleration factor. Used for Method II Case L1, L2, L3, and L4.


Field Data

Field Data is used for Method III calculations. The purpose of Method III is to predict unit or device reliability using field-tracking data. Method III is calculated as a weighted average of the observed field failure rate and the Parts Count prediction, with the weights determined by the field data. When there is a large number of total operating hours for a device or unit during a field tracking study, the Method III failure rate prediction is heavily influenced by the field data. When there is a small number of total operating hours, the Method III failure rate prediction is more heavily influenced by the Parts Count prediction. The following fields are active:

	Field
	When Used

	Operating Time
	The total operating hours of the device or unit in the tracked systems (t). Used for Method III (a), (b), and (c).

	Number of Failures
	The number of failures observed in the tracked systems in time t (field failure count). Used for Method III (a), (b), and (c).

	Tracked Temperature
	The operating temperature of the tracked system in degrees Celsius. Used for Method III (b).

	Tracked Failure Rate
	Used when the tracked unit is different from the subject unit. Tracked failure rate is the Method I, Case 3 steady-state failure rate prediction for the tracked unit. Used for Method III (c) only.


Editing the Contents of the Parts Table

Adding Parts to the Parts Table

To add a new item to the Parts Table, place your cursor in the Part Number field on the first blank row on the table and begin to enter data. 

Inserting Parts to the Parts Table

To insert an item between two others in the Parts Table, follow these steps:

1. Place your cursor anywhere in the row that you wish to insert a new item before. For instance, if you wish to insert a part between records #5 and #6, place your cursor on record #6 (as you wish to insert the item before #6) and select Insert from the right mouse menu or Insert>Insert Part from the main menu.

2. A blank record is inserted. The new part may now be entered.

Deleting Parts from the Parts Table

To delete a part or parts from the Parts Table, follow these steps:

1. Place your cursor anywhere in the row that you wish to delete (the Record Number column is the first column that displays consecutive numbers beginning with 1). You may also select multiple items by click and dragging your cursor down the list to highlight a series of records. 

2. Once the records to be deleted are highlighted, select Delete from the right mouse menu (or Edit>Delete from the main menu).

3. A prompt displays asking you to verify that you wish to delete the part. Press <Yes> to proceed.

4. The part or parts are deleted from the Parts Table.

Note: You cannot undo a delete.

Sorting the Parts in the Parts Table

Relex also provides you with the ability to sort the parts in the Parts Table to suit your needs. You may select to sort using various criteria by following these steps:

1. Place your cursor in the heading of the column that represents the field you wish to sort by. For instance, if like to sort the records in the Parts Table by part number, place your cursor at the top of the column labeled Part Number.

2. To sort by the selected column, double-click your mouse on the column heading.

3. A prompt appears asking you to verify that you wish to sort your data by the selected criteria.

4. Select <Yes> to proceed.

5. The selected field now sorts your data.

Note: As you add new parts or change information, you may need to perform this sort again.

Life Cycle Cost Files

Relex Life Cycle Cost files are available with the Relex LCC module only. Life Cycle Cost files contain a Cost Breakdown Structure (CBS) of the system being analyzed. A Life Cycle Cost file also contains custom equations which are used for the calculation of cost. For a complete description of LCC files, refer to the “Life Cycle Cost (LCC)” chapter of this manual.

xe "Input Format Files" \r "D2HBInput_Format32"Input Format Files

Format files in Relex provide the ability to customize the look of the data entry windows. You can customize the following Relex windows: System Tree, Parts Table, FMEA Data, and Fault Tree table.xe "Fault Tree Table" \r "D2HBFault_Tree_T32" 

Input Format Files

Input Format files determine the appearance of the input window in Relex for components. They specify which fields appear and in what order. There are formats provided with Relex. You may override these defaults by defining your own Input Format files. You can define the fields to appear on the form, headings of the columns of information for the form, and the order of the fields on the form. Once you have created your own Input Format files, you can use them in any Project file, or any other file that can be configured through Input Format files (Libraries or Default files, for instance).
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Figure 3 - 16. Sample Input Format File, Prediction

Creating/Opening an Input Format File

To create a new Input Format file, follow these steps:

1. Select File>New>Format>Input Format or File>Open>Format>Input Format from the main menu. Enter the name in the File name field and press <Create> or <Open>.

2. If creating a new Input Format, a window appears displaying all of the Input Format file types that can be created. Select Tree to configure the fields that appear in System Tree when an assembly is selected. Select Prediction, Library, or Default to configure which fields appear in the Parts Table for Project files, Library files,xe "Library files" and Default files respectively. Select FMEA to configure the fields which appear on the FMEA Data tab. Select Fault Tree to configure which fields appear in the Fault Tree table. Press <OK> when ready.

3. The Input Format window appears. In each row of the table, you may select the fields that you want to include on the form (in the proper order). Supply the additional information for each field as described as follows:


	Field
	When Used

	Field
	From the choice list, select the field to be displayed. The list of fields varies depending on the type of format selected.

	Title
	By default, the name of the field is entered into this field. This is the text that is displayed as the header of the column in the appropriate table. You may edit this entry if you wish.

	Width
	A width for the column is entered by default. This value can be edited if you wish. The widths of the columns are adjustable while editing, so you do not need to be accurate. A width of zero causes the column to be hidden. This field is not available for FMEA formats.

	Precision
	For use with numeric fields only. Specifies the number of digits to the right of the decimal point to be included for the numeric value. This field is not available for FMEA formats.

	Default Value
	Allows you to select a default value for each field. Each time a new record is added, the default values (if any) are entered in the columns. This field is not available for FMEA and Fault Tree formats.

	Tree/Table Display
	Allows you to identify where the field appears for Prediction, Library, and Default format types. Select Table from the choice list if you only want to see the field displayed in the table window for a part. Select Tree if from the choice list if you only want to see the field displayed in the System Tree window for a part. Select Tree and Table from the choice list if you want the field to be displayed in both the Parts Table and System Tree windows.

	Level
	Level appears only for FMEA formats. Specifies the level at which the FMEA field appears on the FMEA Data tab. Select Item if you want the field to display when a FMEA item is selected, select Mode to display the field when a FMEA mode is selected, or select Cause to display the field when a FMEA cause is selected.

	Phrases Filexe "Phrases file"
	Phrases File appears only for FMEA formats. Specifies whether a text field is to be stored and retrieved from the Phrases file. If enabled, a button appears next to this field on the FMEA Data tab to allow you to choose a phrase from the list of phrases defined for this field in the Phrases file. If disabled, the text data is stored directly in the FMEA database. This field is enabled for text fields only.


Adding a Field to an Input Format File

To add a new field to an Input Format file, select the next available blank row, and select a field name from the choice list available from the Field Name column. Upon selecting a field name, default information is entered in the title, width, precision, default value, level, and phrase table columns. You can change any of these values. Rather than entering one field at a time, you can have Relex automatically enter all available fields by selecting Tools>Add All Fields.

Deleting a Field from an Input Format File

To delete a field from an Input Format file, select the row (by selecting the cell containing the row number), and select Delete from the right mouse menu, or press the <Delete> key from the keyboard.

Inserting a Field to an Input Format File

To insert a field into an Input Format file, select the row where you want the new field inserted (by selecting any cell in the row), and select Insert from the right mouse menu.

Moving a Field in an Input Format File

A field in an Input Format file can be moved using one of two different techniques, described as follows:

Click and Drag

Select the row to be moved by selecting the cell containing the row number. After the row is highlighted, click and drag the row with your cursor. A horizontal line displays the current location of the row. When the row is in its proper location, release your mouse button to drop the row.

xe "Cut and Paste"Cut and Paste

Select the row to be moved by selecting the cell containing the row number. After the row is highlighted, select Cut from the right mouse menu. With the row cut, move to the new location of the row, and select any cell within the new row. Select Paste from the right mouse menu to paste the row to its new location.

Report Design Files

Relex Report Design files allow you to create customized reports for your analyses. Refer to the “Reporting and Graphing” chapter of this manual for details regarding creating and editing Report Design files.

Reliability Prediction Value-Added Files

For a complete description of the files listed below, refer to the “Reliability Prediction” chapter of this manual.

	File
	Description

	Parts Libraryxe "Library files" files
	A database of components along with part numbers and associated data. Libraries are used to retrieve complete information for components when entering part lists.

	Correlation filesxe "Correlation files"
	A database that matches in-house part numbers to library part numbers for easy reference and retrieval.

	Derating files
	A listing of minimum and maximum stress values for components. A Derating file can be used to find problematic components in a reliability prediction analysis.

	Defaults files
	Default values that can be applied to components when data parameters are not entered.

	User-Defined Values files
	Provides the ability to create custom environments and quality levels to be used in an analysis when standard settings are not adequate.

	Mission Profile files
	Contains the total mission time (total operating time of system) and a listing of mission phases and descriptive information regarding each phase. The information for each phase includes the percentage of time that the phase is active, the environment and temperature of the phase, and any descriptive remarks about the phase.


FMEA Value-Added Files

For a complete description of the files listed below, refer to the “FMEA” chapter of this manual.

	File
	Description

	Modes filesxe "Modes files"
	A database of common failure modes for various component types. Modes files are generally used during a piece part FMEA.

	FIN Definition files
	FIN Definition files are used to store sets of common failure consequences. This includes local effect, next effect, end effect, compensating provision, failure detection monitor, failure detection method, severity, effect probability, and exposure percentage. FIN Definition files are used in a FMEA Project in order to assign a set of failure modes as equivalent faults. This eliminates repetition and insures consistency.

	Phrases files
	A common storage area for frequently used phrases.

	Mission Profile files
	Contains the total mission time (total operating time of system) and a listing of mission phases and descriptive information regarding each phase. The information for each phase includes the percentage of time that the phase is active, the environment and temperature of the phase, and any descriptive remarks about the phase.


Fault Tree Value-Added Files

For a complete description of the files listed below, refer to the “Fault Tree” chapter of this manual.

	File
	Description

	CCF Groups files
	This is the Common Cause Failure Groups file that allows you to include fault tree events in multiple common cause failure groups.

	Event Parameters files
	A storage area for commonly used xe "Failure with Periodic Inspection"events and associated event parameters for constant probability,xe "Constant Probability" failure rate/MTBF, frequency, failure with repair,xe "Failure with Repair" or failure with periodic inspection.


Maintainability Value-Added Files

For a complete description of the files listed below, refer to the “Maintainability Prediction” chapter of this manual. 

	File
	Description

	Tasks filesxe "Tasks file"
	A listing of basic and super tasks which can be used when performing a maintainability prediction.

	FD&I Outputs files
	A listing of Fault Detection and Isolation (FD&I) outputs that include the various tasks involved.

	Maintainability Groups files
	Groups used when performing a MIL-HDBK-472 5A calculation.


Life Cycle Cost Value-Added Files

For a complete description of the files listed below, refer to the “Life Cycle Cost (LCC)” chapter of this manual.

Note: The Time Intervals,xe "Time Interval" Alternatives and Variables files are integral parts of the Life Cycle Cost file.

	File
	Description

	Time Intervals
	A listing of the time intervals to be used during an LCC analysis.

	Alternatives
	A listing of the various alternatives that can be compared during an LCC analysis. Each alternative can also be associated with any portion of a Project file.

	Variables
	A complete listing of all variables that are used during the creation of equations in an LCC analysis.


Miscellaneous Files

The miscellaneous file types that are available in Relex are:

	File
	Description

	Macro filesxe "Macro files"
	Macros in Relex are simple programs which automate otherwise time consuming processes. Macros can be created in Relex using the built-in macro editor,xe "Macro Editor" or from an outside source that supports OLE automation.

	Rich Text Formatxe "Rich Text Format" files (RTF)
	Rich Text Format (RTF) files are a standard file type used by many word processors. An RTF file includes text and data, special formatting, lines, and graphics. Reports in Relex can be generated to an RTF file. Relex includes a built-in RTF editor for viewing and making changes to RTF files.

	Text files
	Text files are standard ASCII text files that can be generated by most software programs, and that can be edited using a text editor or word processor. Reports in Relex can be generated to a Text file.xe "Text file" Relex can also import data from Text files. Relex includes a built-in text editor for viewing and making changes to Text files.

	Graph files
	Graph files are a special file type specific to Relex that allows scientific graphs to be saved and referenced later. When generating a scientific graph in Relex, you have the ability to save the graph as a Graph file, bitmapxe "Bitmap" image, or Windows Metafile. If saved as a Graph file, the graph can be opened, edited, and printed later.


Chapter 4 Reporting and Graphing

Reporting

When generating a report,xe "Generating a Report" you may use any of the Report Design files that are included with Relex, or you can create your own Report Design files using the built-in report designer.xe "Report Designer" (Relex Report Design files are files that indicate the format of the data included on a report.) When creating your own Report Design files, you have the capability of customizing fonts and headings and the way in which information is included. All of this is done in a visual, easy to understand WYSIWYGxe "WYSIWYG" format. The Report Design files are customizable using a simple click, drag and drop method. You can customize headings and titles. You can even include pictures or bitmapxe "Bitmap" images in your reports. Every item included in a Report Design file has properties associated with it which allow you to design reports according to your requirements. 

Generating a Report in Relex

When generating a report in Relex, you may select to generate a standard report, or a report of your own design. Standard reports in Relex are created based on the Report Design files that have already been designed for you using the report designer. Relex includes many standard reports that can be used for the Relex Reliability Prediction,xe "Reliability Prediction" RBD, FMEA, Maintainability Prediction,xe "Maintainability Prediction" Fault Tree, and Life Cycle Cost modules. The steps for generating all of these reports are identical. A list of the Report Design files supplied with Relex is included on the Relex CD in the Docs directory. If you want to create your own Report Design files or customize those which already exist, refer to the section titled “Relex Report Designer
”.

Follow the steps below for generating a report in Relex:

1. Open the Relex file from which to generate a report (make sure it is the activexe "Active" window).

2. To begin the reporting process, select File>Print Preview from the main menu to display the report, or select File>Print to print the report without previewing.

3. The Select Report to Preview window or Select Report to Print window is displayed. Either of these windows allows you to select the report format (Report Design file) for outputting. The list displays all reports that are available for printing in the current directory. The default report design is highlighted (the default report design is assigned in File Properties on the Format Files tabxe "Format Files tab"). You may select one of the Report Design files displayed on the list, or you may use the <Browse> button to browse additional directories for other Report Design files. Select the Report Design file to be used in generating the desired report.

4. There are additional options available on the Select Report to Preview window or Select Report to Print window. These options are described in the following table:

	Option
	Description

	Override Report Propertiesxe "Override Report Properties"
	If enabled, you may override the properties of the Report Design file. A window displaying the report properties appears. The properties of the Report Design file can be changed for this particular report. 

	Print All Assemblies
	If enabled, all assemblies within the current Project filexe "Project file" are included in the report.

	Print Current Assembly
	If enabled, only the assembly currently selected in the System Treexe "System Tree" is included in the report.

	Print Current Assembly and Children
	If enabled, only the assembly currently selected in the System Tree and all of its lower level children are included in the report.

	Suppress Tree Section Output
	If enabled, only the assembly section of the report is included in the report. The first page (which contains the tree information) is not included in the report. For more information about the assembly and tree sections of a report, review the section titled “Tree and Assembly Sections of a Report Design for a Project File”.

	Print to File
	This option is only available on the Select Report to Print window. If selected, you have the option to generate the report in an electronic form rather than generating a printed copy via the selected printer. For more information about printing a report to a file,xe "Printing a Report to a File" review the section titled “Generating a Report to a File”.


5. Once a report has been selected for outputting, press <OK> to generate the report to the screen. 
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Figure 4 - 1. Preview of Sample Relex Report

6. When your report is displayed, an additional toolbar appears with the following buttons:

	Button Label
	Description

	Print
	Prints the report output to the printer.

	Previous Page
	Displays the previous page of the report output.

	Next Page
	Displays the next page of the report output.

	Toggle Number of Pages
	Allows you to select the number of concurrently visible pages. One or two pages may be displayed at the same time.

	Zoom In
	Zooms in on the page that is currently displayed.

	Zoom Out
	Zooms out on the page that is currently displayed.

	Close
	Closes the print preview window


7. You may view your report, page up and down, and zoom it if you like. When you are ready, press the <Print> button to print your report or press the <Close> button to close the report.

xe "Printing a Report to a Printer"Printing a Report to a Printer

You can print a report in one of two ways:

· Once a report has been generated to the screen by following the steps outlined in the section titled “Generating a Report in Relex”, the process of printing that report is simple. To print the report while the preview version is on the screen, press the <Print> button on the toolbar or select Preview>Print from the main menu. The standard Print window is displayed. Identify the printer to use, the pages to be printed, the number of copies and whether to print to file (see the section titled “Generating a Report to a File”), then press <OK> to print the previewed report.

· Select File>Print from the main menu. Select the report to be printed. The standard Print window is displayed. Identify the printer to use, the pages to be printed, the number of copies and whether to print to file (see the section titled “Generating a Report to a File”), then press <OK> to print the report immediately, rather than displaying on the screen for review. 

Generating a Report to a File

When print is selected, a Print to File option is available on the Print window. This option allows for the report to be generated to a file rather than to a printer. Relex supports the following file formats:

	File
	Description

	Rich Text Formatxe "Rich Text Format"
	The report is saved as an RTF file. This file type includes all formatting and font information, and can be opened by most popular word processing programs.

	Text Format
	The report is saved as an ASCII text file.xe "Text file" \r "D2HBText_file4" This file type is very generic and can be opened by all word processors and text editors. This file type does not, however, save formatting and font information from the report design.

	Printer Formatxe "Printer Format"
	The report is saved as a PRN file.xe "PRN File" These files can be sent to a printer for printing and cannot be opened in a word processor or text editor.


To generate a report to any of these possible file formats, follow these steps:

1. Select File>Print from the main menu.

2. Select the Report Design file to be used on the Select Report to Print window, and enable the Print to File checkbox in the lower left-hand corner of the window. Press <OK> to continue.

3. When the Print to File window appears, select the file type to be created in the Save as Type field. 

4. If a file type of RTF or Text is selected, the option Open File in Editor After Printing is available. If enabled, Relex automatically opens the saved RTF or TXT file in the Relex RTF or Text editor after it is created.

It is also possible to generate a report to a file with the Print Preview main menu option. To use this method, follow these steps:

1. Select File>Print Preview from the menu, and perform a print preview as usual.

2. To save the report to a file, select Preview>Print from the main menu.

3. When the Print window appears, enable the Print to File option to the right and press <OK>.

4. When the Print to File window appears, select the file type to be created in the Save as Type field. 

5. If a file type of RTF or Text is selected, the option Open File in Editor After Printing is available. If enabled, Relex automatically opens the saved RTF or TXT file in the Relex RTF or Text editor after it is created.

xe "Microsoft Excel"

xe "Excel file"Generating a Report to a Microsoft Excel File

In Relex, if you would like the data from your report in a Microsoft Excel format, use the CAD Interfacexe "CAD Interface" to export the data from Relex into the desired format in Excel. For more information regarding exporting data from Relex to Excel, refer to the “Importing and Exporting” chapter of this manual.

E-Mailing a Relex Report

One of the many purposes of the Print to File option in Relex reporting is to provide an easy way to share Relex data with co-workers, colleagues, and customers. This option provides the ability to e-mail Relex generated reports. Once a report has been generated to a file, it can be sent as an attachment to an e-mail message. It is not necessary for the recipient of the message to have access to Relex. The recipient can open the file in a word processor or text editor. Refer to the section titled “Generating a Report to a File” for information on using the Print to File option.

xe "Microsoft Word"Opening an RTF File or Text File in Microsoft Word

Once a RTF file or text file has been generated with Relex, it can be opened using the built-in RTF editor or a text editor. It is also common to open these files in a word processor such as Microsoft Word. However, sometimes word processors may force certain formatting styles on the files when opened. These formatting styles are described in the following sections along with methods for reformatting the file back to its desired style.xe "Style"
xe "Opening an RTF File in Microsoft Word"Opening an RTF File in Microsoft Word

When Relex generates an RTF file, it is generated with all of the fonts, graphics, and color customization included in the Report Design file. The RTF format includes all necessary formatting. In most cases, when an RTF file is opened in Microsoft Word, it appears to be formatted correctly. You may, however, experience a problem with the formatting of an RTF file when you insert the RTF file into an existing document in Microsoft Word. Microsoft Word applies the margins and paper orientation of the existing document to the RTF file being inserted. If the margins and paper orientation are incorrect, the data from the RTF file displays improperly.

Because every instance is different, it is impossible to give step-by-step instructions for correcting this anomaly. However, there are a few formatting basics below that you should review:

· If there is text in the existing Microsoft Word document, first add a Section Break Next Page after the text. To add a break, select Insert>Break from the main menu in Microsoft Word and identify the proper break to be inserted in the Break window. The RTF file can then be inserted after the existing text and section break.

· If the RTF file is to be inserted between text in the existing Microsoft Word document, you must add Section Break Next Page twice: one after the text but before the RTF file insertion point, and one before the text but after the RTF file insertion point. This enables you to adjust the margins on the text separately from the margins on the RTF file section. To add a break, select Insert>Break from the main menu in Microsoft Word and identify the proper break to be inserted in the Break window.

xe "Opening a Text File in Microsoft Word"Opening a Text File in Microsoft Word

When Relex generates a text file, it is generated with a standard fixed width font (like courier). When this type of file is opened in a standard text editor, the text appears as a neat report with headers and columns of data. When this simple file type is opened in Microsoft Word, Word applies its own margins, paper orientation, and font. The result varies, but you generally end up with overflowing text that has no visible organized format.

Because every instance is different, it is impossible to give step-by-step instructions for correcting this anomaly. However, there are a few formatting basics you may wish to review:

· In Microsoft Word, select File>Page Setup and review the page formatting. Specifically, review the Margins tab and Paper Size tab.xe "Size tab" If the margins are too large, the text wraps incorrectly. If the report was designed for landscape printing, but the page setup is set to portrait, the text wraps incorrectly. Change the page setup as necessary.

· In Microsoft Word, select Edit>Select All from the main menu. This selects all of the text in your document. With the text selected, change the font style and size. If the font is too large, text wraps incorrectly. If the font is not a fixed width font (like Courier), the columns do not align properly.

xe "PRN File"

xe "PDF File"

xe "Converting a PRN File to a PDF File"Converting a PRN File to a PDF File

If you like to generate a PDF file, first generate your Relex report to a PRN file. You can then create a PDF file from the PRN file using Adobe’s Acrobat Distiller program. For more information on Adobe Acrobat Distiller, contact Adobe on the worldwide web at http://www.adobe.com/.

xe "Report Designer" \r "D2HBReport_Desig6"Relex Report Designer

The Relex report designer is a tool that allows for the custom design of reports that allow you to output Relex data. The report designer displays the various components of a report in a WYSIWYG format allowing you to view the report format change as you add new features. 

This section walks you through all of the specifics involved in customizing reports in Relex. It is divided into a few main sections that outline the common techniques used in customizing reports. 

xe "Relex Supplied Report Designs"Relex Supplied Report Designs

Many report design formats are supplied with your Relex package. These Report Design files can be used as are, or can be customized to suit your specific needs. The supplied Report Design files and the descriptions are listed on your Relex CD.

Opening an Existing Report Design

Any of the standard reports available from Relex can be customized to suit your needs. You may edit any of the existing Report Design files, or you may create a new Report Design file if you prefer. The process of editing an existing Report Design file is especially convenient if you want to make minor changes to a Report Design file that already exists. To open and edit an existing Report Design file, follow these steps:

1. Select File>Open>Format>Report Design from the main menu. 

2. When the Open File window displays, select the file to be opened and press <Open>. 

3. This displays the Report Design file in a WYSIWYG format. 

4. Edit the design as desired. For more information on editing a report design, refer to the section titled “Editing a Report Design”.

Creating a New Report Design

To create a new Report Design file, follow these steps:

1. Select File>New>Format>Report Design from the main menu. 

2. When the New File window displays, enter the name of the file to be created and press <Create>.

3. The Create Report – Select Database Type window appears. You are required to identify the type of database for use with the new report. Press <OK> to continue.

4. This displays a blank Report Design file in a WYSIWYG format. 

5. Add fields as desired. For more information on creating a report design, refer to the section titled “Adding Items to a Report Design”.

Tree and Assembly Sections of a Report Design for a Project File

When a Report Design file displays, there are two different tabs on which you can customize the report. You may edit the report format for the tree or assembly levels of a Project file. 

· The Tree tab is used to provide an overview of the system structure showing the various components of the System Tree in a summary format. 

· The Assembly tab is used to show the details and components of each assembly within the System Tree. This is generally where the parts list for the assemblies, and the failure modes and maintainability information are included.

xe "Work Areas"Work Areas in a Report Design

Both the Assembly and Tree tabs are divided into four main areas:

	Area Title
	Description of Area

	Reportxe "Header" Header
	Used to place information that appears on the first page of the entire report. It is typically a summary of the report contents, and can also include a company name or logo. There is only one report header per report. The same information is displayed under both the Tree and Assembly tabs.

	Page Header
	Includes the page header or the information that appears at the top of each page of the report. This header usually includes details about the contents of the report (like system and/or assembly name,xe "Assembly Name" date, and page number). The bottom line of this portion of the report is to include the headers for each of the columns of data to be displayed (i.e. part number,xe "Part Number" quantity, and reference designatorxe "Reference Designator"). The page headers for the tree and assembly portions of the report are defined separately.

	Details
	Contains the columns of data which are to be included in the report. Relex retrieves the data from the database as needed. The details for the tree and assembly portions of the report are defined separately.

	Page Fxe "Footer"ooter
	Includes the page footer or extra information that appears at the bottom of each page of the report (i.e. page number or date information). The page footers for the tree and assembly portions of the report are defined separately.


Each of these areas in the report can be individually sized. By placing your cursor on any of the dividing lines within the report designer grid (until you get a sizing cursor), you may click and drag any of the dividing lines on the report. In this way, you can specify the size of each of the areas to suit your needs.
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Figure 4 - 2. Relex Report Designer

Editing a Report Design

In order to edit or customize a Report Design file, it is first necessary to open a Report Design file. Follow the steps outlined in the sections titled “Opening an Existing Report Design” or “Creating a New Report Design”.

Once a Report Design file is opened and active in Relex, changes can be made to customize the format of the design. To edit Report Design files, the following tasks may be performed:

· Adding items to a report design 

· Deleting items from a report design 

· Moving items within a report design 

· Sizing itemsxe "Sizing Items" within a report design 

· Editing the properties of items in a report design 

· Editing the properties of the Report Design file 

· Editing the format of sections in the report design 

· Editing the page setup of a report design

· Customizing the text filexe "Text file" report

Adding Items to a Report Design

Items can be added to any of the four main areas of the report design by using the various options included on the Insert main menu. Items that can be added to a Report Design file fall under the following categories:

	Type of Field
	Description

	Database Fieldxe "Database Field"
	Provides the abilixe "Value-Added files"ty to insert the data from any Relex field. This can be a field of information from the System Tree, Parts Table,xe "Parts Table" RBD, FMEA, Fault Tree, Maintainability Prediction, or LCC portions of Relex, including data from the many Value-Added files.

	Label
	Provides the ability to enter a simple text label. This is especially helpful when assigning custom titles and column headers.

	Picture
	Provides the ability to add a pictorial image to a report. The picture may be stored in a JPEG file, Bitmap file, PCX file, Targa file or TIFF file. This image may be a company logo or even a product photo or drawing.

	Special Field
	Provides the ability to add special fields like file names, dates, time, operating time, page numbers, and revision controlxe "Revision Control" fields.

	Line
	Provides the ability to add vertical or horizontal lines of various styles and colors. These lines may serve as visual dividers on the report.

	Box
	Provides the ability to add a box of any size or color. These boxes may serve as visual separators on the report.


To add an item to a Report Design file, follow these steps:

1. Select the type of item to be added from the Insert menu or Insert Report Objects toolbar. 

2. Depending on the type of item you have selected to add, you may be asked for additional information and your cursor style may change. Below is a table outlining the next steps for each type of item which can be added:

	Type of Field
	Instructions for Adding this Item

	Database
	a. Upon selecting to add a Database field, the Insert Database Field window appears. First select the type of field you wish to insert from the Field Type choice list. Then select the specific field that you wish to include in the report. Scroll through the list and select the field that you wish to add.

b. Once the desired field is selected, press <Insert> to add the field to the Report Design file. At this point, your cursor turns into a box type symbol. You may select the <Close> button on the Insert Database Field window or move it to another location (if you intend to add multiple database fields).

c. To place the database field, move your cursor to the desired location and press the left mouse button to drop the field. The page header area of the Assembly tab of the report may include tree fields, while the details section may include the other field types. On the Tree tab, only tree fields can be placed in the page header and details areas.

	Label
	a. When adding a label, the standard cursor turns into an I-beam cursor. 

b. Place the I-beam cursor in the desired location of the label, and click the left mouse button. This places a label with the text Label at the spot of your cursor. To edit the label, begin typing. 

	Picture
	a. Upon selecting to add a Picture, the Insert Picture window appears. The window displays a standard file selection option that allows you to browse for the image file that is to be used. 

b. Select the desired file and press <Open>.

c. The standard cursor now turns into a block that represents your graphic.

Place the block in the desired location of the picture(s), and click the left mouse button to release. The picture is placed in the Report Design file.

	Special Field
	When adding a Special Field from the Report Objects menu, a list of available fields displays. You may select from a number of fields including page number, page count, print date, file name, and more. When a selection is made, your cursor turns into a box type symbol. To place the Special field, move your cursor to the desired location and click the left mouse button to drop the field. The field is displayed with a descriptive label.

	Line
	a. Upon selecting to add a Line, your cursor displays as a pencil. This is symbolic for a drawing tool.

To create the line, move your cursor to the desired starting point of the line, and click and hold the left mouse button. Drag your mouse until the line is the desired size. Once the line is displayed at its desired size, release the left mouse button. Once you have successfully added the desired line(s), click the right mouse button to return to a standard cursor.

	Box
	a. Upon selecting to add a box, your cursor displays as a pencil. This is symbolic for a drawing tool.

To create the box, move your cursor to the desired starting point of the box, and click and hold the left mouse button. Drag your mouse until the box is the desired size and shape. Once the box is displayed at its desired size, release the left mouse button. Place additional boxes if you desire. Once you have successfully added the desired box(es), click the right mouse button to return to a standard cursor.


Deleting Items from a Report Design

The process of deleting items from a Report Design file is the same, regardless of the type of item you are deleting. Therefore, the following steps are the same for database fields, labels, pictures, special fields, lines, and boxes.

1. Select the item to be deleted by placing your cursor over it until it becomes a move cursor. Click the left mouse button. The item is selected when the box enclosing the item is displayed with handles.

2. Select Delete from the right mouse menu, or select Edit>Delete from the main menu, or press the <Delete> button on the keyboard. The item is deleted from the Report Design file.

Moving Items within a Report Design

The process of moving items within a Report Design file is the same, regardless of the type of item you are moving. Therefore, the following steps are the same for database fields, labels, pictures, special fields, lines, and boxes. 

1. Select the item to be moved by placing your cursor over it until it becomes a move cursor. Click and hold the left mouse button. The item is selected when the box enclosing the item is displayed with handles.

2. Drag the item to its desired location and release the left mouse button to place the item.

Note: You can select multiple items and move them simultaneously. To select multiple items, use either of the following techniques:

· Click and drag your cursor to create a box enclosing the items to be selected. Upon releasing your cursor the items are highlighted. Click and drag the items to the new location.

· Click to select the first item, then hold down the <Shift> key on the keyboard and continue selecting the other items. Selected items display with handles. Once all items are selected, click and drag them to the new location. 

xe "Sizing Items"Sizing Items within a Report Design

The process of sizing items (making them larger or smaller) within a Report Design file is the same regardless of the type of item you are resizing. Therefore, the following steps are the same for database fields, labels, pictures, special fields, lines, and boxes. 

1. Select the item to be sized by placing your cursor over it until it becomes a move cursor. Click the left mouse button. The item is selected when the box enclosing the item is displayed with handles.

2. When sizing an item, you may choose from any of the following techniques:

	Purpose
	Technique

	Size an item to a selected size
	Place your cursor over any of the handles of the item to be resized to get a sizing cursor. Click and hold the left mouse button down. Drag the selected point of the item to make the object its desired size. Release the left mouse button when the desired size is reached.

	Size an object proportionately
	Place your cursor over any of the handles to get a sizing cursor. Click and hold the left mouse button down. Drag while also holding down the shift key. This sizes the item both horizontally and vertically while retaining the basic proportions of the item. Release the left mouse button when the desired size is reached.

	Re-size an Image to True Sizexe "Re-size an Image to True Size"
	Select any picture item and select Size to True Bitmap Size from the right mouse menu. This feature restores the picture to its original size.


Editing the Properties of Items in a Report Design

Each of the items in the Report Design file has individual properties. These properties determine exactly how the output data is displayed on a report. These properties can affect the size and color of graphics and fonts, and the sorting of database fields among other characteristics of a report. The process of accessing the properties of an item is the same regardless of type. However, the features that can be changed vary from one type of item to another. The following instructions walk you through the general process of editing properties:

1. Select the item to be edited by placing your cursor over it until it becomes a move cursor. Click the left mouse button. The item is selected when the box enclosing the item is displayed with handles.

2. Select Properties from the right mouse menu, or select View>Properties from the main menu, or double-click with the left mouse button while an item is selected to access the properties.

3. The Properties window for the item is displayed. The properties available are based on the item type that is selected. For example, the Currency tab only appears on the Database Field Properties window if the selected item is a field to which currency specifications apply. The following tables explain the editable properties for each of the item types:

Database Field Properties
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Figure 4 - 3. Database Field Properties

	Tab Title
	Properties

	General
	Hide When Printing. If enabled, the field is not printed on reports. 

Suppress If Duplicated. If enabled, the field is not printed if the information in the field is the same as the previous record in the details section of the report.

Suppress if Zero. For numeric fields only. If enabled, the field is not printed if the information in the field is zero.

Alignment. Allows you to select left, centered, or right justification from a choice list.

	Database Field
	Allows you to select the database field to be included on the report. Select the field type from the choice list, then select the specific field from the supplied list.

	Color
	Allows you to select text color, background color and border colors for the data field. The Use Background Color checkbox must be selected in order for the selected border color to be used on the report. You may enable the Left, Right, Top, and Bottom checkboxes to place a borderline along the selected side.

	Font
	Allows you to select a font and size for the text. You may also enable the appropriate checkboxes to have the text displayed as bold or italic print.

	Currency
	Currency Symbol. If enabled, the symbol displayed in the text box field to the right is used for the selected currency fields.

Position. The choice list allows you to select where the currency symbol is positioned.

	Number
	Decimals. The choice list allows you to select how many decimal places are printed on the report for the selected numeric field. Select the example that displays the desired number of decimal places.

Decimal Separator. In this text box field, enter the desired decimal separator. The default is a dot (.).

Rounding. The choice list allows you to select the number of decimal places to which the selected numeric field is rounded. Select the example that displays how the numeric field is to be rounded. You may also specify that the numeric field is not to be rounded.

Negatives. The choice list allows you to select how negative values display on reports for the selected numeric field.

Thousands Separator. If a thousands separator is desired for the selected numeric field, enable the checkbox for Thousands Separator. In the text box field, enter the desired thousands separator. The default is a comma (,).

Leading Zero. This checkbox option allows you to print a leading zero for decimal values. If selected, the value of .123 would print as 0.123. If disabled, the value of .123 would print as .123.

Use Scientific Notation. Allows you to specify whether to use scientific notation. If the value is set to For small numbers, scientific notation will be used only when necessary. If set to Never, Relex will always use a decimal representation. If the number is too small, its value will be shown as zero. If set to Always, Relex will always display this field using scientific notation.

	Align Elements
	No Alignment. Applicable for database fields including multiple elements, like pi factorsxe "Pi Factors" or specific data. The individual pieces of data are not aligned in any fashion, but commas separate them.

Align Elements Every. The number of inches specified separates fields that include multiple segments of data.

One Element per Line. Each segment of data is placed on a separate line.

	String
	Print On Multiple Lines. Enables word wrapping for string fields.

	
	Maximum Number Of Lines. Sets the maximum number of lines onto which a lengthy text string may wrap. Enter 0 (the default value) if you do not wish to specify a maximum number of lines for the string field.

	File Output
	Start Column. Specifies the starting character column for the selected database field. This is special formatting used when generating a report to a text file.xe "Text file"
Width. Specifies the width of the column for the selected database field. This is special formatting used when generating a report to a text file.

Column Separator After Field. If enabled, a column separator is placed after the column on the output report. If disabled, no separator is placed after the column.

	Other Options

(available from the right mouse menu) 
	No Sort. No sorting of data is performed.

Sort Ascending. Sorts the data in the column in ascending order. 

Sort Descending. Sorts the data in the column in descending order.

	Multi-field sorting

(additional menu option)
	Allows sorting of multiple data fields on a report. With no items selected on a Report Design file, select View>Sorting from the main menu. The Edit Sort Order window appears including the available fields and the fields to sort on. The list of available fields may include only the fields on the specific report, all fields, System Tree fields, FMEA fields, Maintainability Prediction fields or Prediction fields. To move a field from the list of available fields to the list of fields on which to sort, press <Add Ascending> or <Add Descending>. You may also move a field from the list of available fields to the list of fields on which to sort by double-clicking on the field. Once a field has been placed in the list of fields on which to sort, double-click on the field to change between sort ascending and sort descending. You may also rearrange the sort by selecting a field, dragging it to a new location in the sort order window and releasing the left mouse button. You can return a field to the list of available fields by pressing <Remove>. You may also remove all fields included in the list on which to sort by pressing <Remove All>. When you are satisfied with the sort order established, press <OK> to save any changes. If you do not wish to save any changes, press <Cancel>.


xe "Label Field Properties"Label Field Properties
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Figure 4 - 4. Label Propertiesxe "Label Properties"
	Tab Title
	Properties

	General
	Hide When Printing. If enabled, the field is not printed.

Alignment. Allows you to select left, centered, or right justification from a choice list.

	Color
	Allows you to select text color, background color and border colors for the data field. The Use Background Color checkbox must be selected in order for the selected border color to be used on the report. Enable the Left, Right, Top, and Bottom checkboxes to place a borderline along the selected side.

	Font
	Allows you to select a font and size for the text. You may also enable the appropriate checkboxes to have the text displayed as bold or italic print.

	File Output
	Start Coluxe "Text file" \r "D2HBText_file15"mn. Specifies the starting character column for the selected database field. This is special formatting used when generating a report to a text file.

	
	Width. Specifies the width of the column for the selected database field. This is special formatting used when generating a report to a text file.

	Other Options

(available from the right mouse menu)
	Edit Text. Provides the ability to edit the text of the label. By selecting Edit Text, the text for the label is highlighted for editing. Press <Enter> when you are finished editing the text.


xe "Picture Field Properties"Picture Field Properties

	Tab Title
	Properties



	Picture
	Provides the ability to change the file associated with the picture. Enter the name and path of an alternate picture. Use the <Browse> feature to search other directories as needed. Press <OK> when finished to save changes or press <Cancel> to exit the Picture Properties window without saving changes.

	Other Options 

(available from the right mouse menu)
	Size to True Bitmap Size. This feature restores the picture to its original size.


xe "Special Field Properties"Special Field Properties

	Tab Title
	Properties

	General
	Hide When Printing. If enabled, the field is not printed.

	
	Alignment. Allows you to select left, centered, or right justification from a choice list.

	Color
	Allows you to select text color, background color and border colors for the data field. The Use Background Color checkbox must be selected in order for the selected border color to be used on the report. Enable the Left, Right, Top, and Bottom checkboxes to place a borderline along the selected side.

	Font
	Allows you to select a Font and Size for the text. You may also enable the appropriate checkboxes to have the text displayed as bold or italic print.

	Date
	Applicable for the Date special field type only. It provides the ability to assign the format of the printed date.

	Time
	Applicable for the Time special field type only. It provides the ability to assign the format of the printed time for the report. Options are either 12-hour format or 24-hour format (military time).

	Number
	Applicable for the Operating Time special field type only. It provides the ability to assign the format of the printed operating time for the report. Options include the selection of how many decimal places are displayed, to what decimal place values are rounded, and how negative values are displayed. You may also select decimal and thousands separators, and whether a leading zero is to be used for printed values.

	File Output
	Start Column. Specifies the starting character column for the selected database field. This is special formatting used when generating a report to a text file.

	
	Width. Specifies the width of the column for the selected database field. This is special formatting used when generating a report to a text file.

Column Separator After Field. If enabled, a column separator is placed after the column on the report. If disabled, no separator is placed when outputting to a text file.


xe "Line Properties"Line Properties

The Line tab allows you to specify the color, thickness and style of the line.

xe "Box Properties"Box Properties

The Box tab allows you to specify the background color, border color, and line style of the box.

Editing the Properties of the Report Design File

Just as the individual items in the Report Design file have properties, the entire Report Design file has a set of properties also. These properties allow you to customize specific characteristics regarding the entire report, rather than individual items.
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Figure 4 - 5. Report Properties

Accessing the properties of the Report Design file is similar to accessing the properties of individual items. With individual items, you select the item first, and then access the properties. In order to access the properties for the Report Design file, it is important that no individual item is selected. If an item is selected, click your mouse in an area on the report where no items are located. Once no items are highlighted, select View>Properties from the main menu (or select Properties from the right mouse menu). The Report Properties window that appears is applicable to the entire Report Design file. The Report Properties window consists of the following tabs:

	Tab Title
	Description

	General
	Description. Allows you to enter a detailed description of the report. This information does not print on the report, it serves only as reference. The Relex Database type is also displayed for reference.

	
	Print Headers Each Page. If enabled, the page header is printed on each page of the report. If disabled, the page header is only printed on the first page of the report. 

	
	Page number to appear on the first page of the report. Enter the page number on which you would like Relex to start your report.

	
	Expand Time Intervals.xe "Time Interval" If enabled, the calculated results for each time interval of a CBS item are included on the report. This option only appears when the Relex Database Type is an LCC file.

	
	Sensitivity Analysisxe "Sensitivity Analysis" Results. If enabled, the results of the calculated sensitivity analysis are included on the report. This option only appears when the Relex Database Type is an LCC file.

	Output Options
	Print Both Assemblies and Tree Sections. When enabled, both the assembly and tree portions of the report are printed. This option only appears when the Relex Database Type is a Project file.

	
	Print Only Assemblies Section. When enabled, only the assembly portion of the report is printed. A tree summary is not included. This option only appears when the Relex Database Type is a Project file.

	
	Print Only Tree Section. When enabled, only the tree portion of the report is printed. The detailed information regarding the individual assemblies is not included. This option only appears when the Relex Database Type is a Project file.

	
	Expand items. When disabled, no sub-items are included on FMEA or maintainability related reports. If enabled, modes, causes, tasks and/or FD&I outputsxe "FD&I Outputs" may be included on FMEA or maintainability reports. This option only appears when the Relex Database Type is a Project file.

	
	Expand failure modes for each item. When enabled, FMEA modes are included on FMEA reports. This option only appears when the Relex Database Type is a Project file.

	
	Expand causes for each failure mode. When enabled, FMEA causes are included on FMEA reports. This option only appears when the Relex Database Type is a Project file.

	
	Expand tasks for each item. Maintainability FD&I outputs or tasks are included on maintainability reports. This option only appears when the Relex Database Type is a Project file.

	
	Include defaulted data. This option is valid if including specific reliability prediction part data on the report. Normally, when specific part data is included on a report, only the data entered is actually printed. When this option is enabled if you have not entered a value for a specified data parameter, the default data is included on the report. This default data is derived either from a Defaults filexe "Defaults file" that you have activated, or from the built-in Relex defaults. This option only appears when the Relex Database Type is a Project file.

	
	Include all Specific Data fields, even if empty. All Specific Data fields are included on reports, even if empty. If this option is enabled, you may enable the One Field per Line option if you want to print one specific data field per line. This option only appears when the Relex Database Type is a Project file.

	
	Print All Sections. If enabled, the printed report includes the information from the Figures, Calculation Results, and Diagram tabs. This option only appears when the Relex Database Type is RBD or Fault Tree.

	
	Print Selected Sections – Figures (or Gate/Eventsxe "OR Gate") Section. If enabled, the printed report only includes data from the Figures tab. This option only appears when the Relex Database Type is RBD (Figures Section) or Fault Tree (Gates/Events Section).

	
	Print Selected Sections – Calculation Results Section. If enabled, the printed report only includes data from the Calculation Results tab.xe "Calculation Results tab" This option only appears when the Relex Database Type is RBD or Fault Tree.

Print Selected Sections – Graphical Diagram Section. If enabled, the printed report only includes data from the Diagram tab. This option only appears when the Relex Database Type is RBD or Fault Tree.

Print Figures in Linked Diagrams. If enabled, the data from the Figures tab is also included in the printed report for any linked configurations. The figures data for each RBD configuration is displayed on a separate page in the report. This option only appears when the Relex Database Type is RBD.

	Ancillary Reportsxe "Ancillary Reports"
	General – Revision Listing. Provides a complete list of all revisions made to the active file. The report includes columns representing the following fields: File Name, Revision Number, User, Date/Time, and Comments.

	
	General – File Properties. Provides a summary of all of the file properties of the active file.

	
	Prediction – Percentage Summary. If this option is enabled, the Percentage Summary is automatically printed at the end of the report (for reliability prediction reports only). This report displays the part type, quantity, percentage quantity, failure rate and percentage failure rate for each part type in the selected assembly. This option only appears when the Relex Database Type is a Project file.

	
	Prediction – First Year Drop Out. If this option is enabled, the first year drop out report automatically prints at the end of the report. This report lists, for each month of the first year, the instantaneous failure rate at the end of the month, expected number of failures at the end of the month, and the average cumulative failure rate. After one year, the failure rate is assumed to be constant. This option only appears when the Relex Database Type is a Project file.

	
	FMEA – Criticality Matrix.xe "Criticality Matrix" If this option is selected, the Criticality Matrix report automatically prints at the end of the report. For more information on the FMEA Criticality Matrix, refer to the assessing criticalityxe "Assessing Criticality" section of the FMEA chapter. This option only appears when the Relex Database Type is a Project file.

	
	FMEA – Screening Matrix. If this option is selected, the Screening Matrix report automatically prints at the end of the report. This report lists failure causes and their associated failure modes.

	
	Maintainability – Mmax Summary. If this option is enabled, the Mmax summary automatically prints at the end of the report. The Mmax summary is a summary report of the Maximum Corrective Maintenance Timexe "Maximum Corrective Maintenance Time" (MCMT) for sigma percentiles between 60 and 100%. This option only appears when the Relex Database Type is a Project file.

	General Record Select
	Record Number. If this option is enabled, you may specify a range of records to be included in the report.

	
	Taggedxe "Tagged" Parts. xe "Defaults file"If this option is enabled, only the parts that have been marked as tagged parts, are included on the report. Individual parts are tagged by enabling the Tagged checkbox on the General Data tabxe "General Data tab" in the Parts Table window. This option only appears when the Relex Database Type is a Project, Parts Library, or Defaults file.

	Prediction Record Select
	Overstressed Parts. If this option is enabled, the report includes only the parts that are overstressed (exceed derating criteria). This option only appears when the Relex Database Type is a Project file.

	
	Parts with Zero Failure Rate. If this option is enabled, the report includes only the parts with failure rates of zero. This option only appears when the Relex Database Type is a Project file.

	FMEA Record Select
	Single-Point. If this option is enabled, only items that are marked as single point failure in FMEA are included in the report. Single point failure is a special field available for FMEA. Single point failure is used when the failure of a part cannot be circumvented by any method such as switching in a backup part. This option only appears when the Relex Database Type is a Project file.

	
	Critical Items. If this option is enabled, only items that are marked as critical items in FMEA are included in the report. Critical item is a special field available for FMEA. The critical items field provides the ability to mark an item or part as critical. This option only appears when the Relex Database Type is a Project file.

	
	Mission Phase. If this option is enabled, only items with the specified mission phase are included in the report. Be sure to enter the mission phase code exactly as it appears in the Mission Profilexe "Mission Profile" file. This option only appears when the Relex Database Type is a Project file.

	
	Severity. If this option is enabled, only items with the selected severity level are included in the report. This option only appears when the Relex Database Type is a Project file.


Editing the Format of Sections in the Report Design

In addition to having the ability to change the properties of the Report Design file and each of the items included in the design, you can also apply special formatting capabilities to main sections of the reports. These sections include the report header, page header, detail, and page footer.xe "Footer" Change the format properties of these sections by following these steps:

1. To select a section for a formatting change, place your cursor over the title of the section (report header, page heading, details, or page footer), and click the right mouse button. When the menu appears, select Format Section.

2. The Format Section tab appears. The General tab includes the following options:

	Property
	Description

	Hide Section
	Allows you to hixe "Report Designer"de a particular section of the report. That section is not shown in the report designer.

	Force New Page After
	Forces a page break after the selected section. If enabled in the details section, each record of information is output on its own page.

	Reset Page Number After 
	When enabled, resets page numbering to 1 after the selected section.

	Space After Section
	Allows you to specify an amount of space (in inches) to be placed after the specified section, as a visual break. 


Other options are also available on the right mouse menu for each section, allowing you to show and hide sections, display long or short section names, and add or delete lines from each section.

Note: You cannot hide sections that contain data.

Editing the Page Setup of a Report Design

All aspects of a Report Design file can be customized, including the set up of the printed page. By selecting File>Page Setup from the main menu in the report designer window, the printing properties can be reviewed and edited. These properties are as follows:

	Option
	Description

	Size
	This choice list allows for the selection of the paper size to be used for output and design. All paper sizes available for the selected printer are listed. To select a different printer, use the <Printer> button at the bottom of the window.

	Source
	The choice list allows for the selection of the paper source to be used for output and design. All paper sources available for the selected printer are listed. To select a different printer, use the <Printer> button at the bottom of the window.

	Orientation
	A paper orientation of portrait or landscape can be selected. Upon changing the paper orientation, the report design work area changes to suit the selected orientation.

	Margins
	Right, left, top, and bottom margins can be defined. Upon changing the margins, the report design work area changes to suit the selected margins.


xe "Text file"Customizing the Text File Report

When generating a report in Relex, you have the option of generating the report to a file. The file typesxe "File Types" supported by this type of output are Printer Formatxe "Printer Format" files (.prn), Rich Text Formatxe "Rich Text Format" \r "D2HBRich_Text_Fo20" files (.rtf) or Text files (.txt). When the option to generate to a text file is selected, Relex generates the data in the report to a text report. This format uses a fixed space font and aligns the text in columns. There are times when you might prefer to fine tune the layout of that output. To customize the text file and save it with a specific Report Design file, follow these steps:

1. Open an existing report design by selecting File>Open>Format>Report Design from the main menu.

2. Select Format>Format For File Output from the main menu. The Format For File Output window appears requesting a number of columns. Relex automatically analyzes the report and assigns the start columns and widths for each of the text fields of information included in the Report Design file. 

3. Once the start columns and widths have been assigned, you can edit the information by selecting View>File Output Properties from the main menu. A window appears that allows you to edit the start columns and widths for all of the fields on the report in a table format.

4. If you wish to individually edit start columns and widths, you may also select any of the text fields on the report and select Properties from the right mouse menu. When the Properties tabs appear, select the File Output tab to edit the individual format settings for the selected field.

Customizable RBD and Fault Tree Reports

The RBD and Fault Tree report design is similar to the other report designs that can be created in Relex. The RBD and Fault Tree report design organizes information based on the components of an RBD or Fault Tree.

Figures and Calculation Results Sections of a Report Design for an RBD or Fault Tree

When the Report Design file for an RBD or Fault Tree window displays, there are three different tabs of information: 

· The Figures tab is used to provide an overview of figures in the RBD, while the Gates/Events tab allows you to report on the figures in a Fault Tree.

· The Calculation Results tab is used to show the details and calculation results of each RBD or Fault Tree figure.

· The Diagram tab is used to generate a graphical report for the RBD or Fault Tree.

RBD and Fault Tree Report Design Properties

As with other Report Design files in Relex, items can be added, moved, and deleted from the report design. The report design is displayed in a WYSIWYG format that allows you to view how the data is presented. Like other Report Design files, every displayed item has properties associated with it. These properties can be edited by selecting Properties from the right mouse menu for a selected item.

In addition to the properties associated with each of the items in the Report Design file, there are also properties associated with the Report Design file itself. These properties are accessed by selecting View>Properties from the main menu when no item is selected. 

The properties associated with an RBD or Fault Tree report design are described in the section titled “Editing the Properties of the Report Design File”.

Relex RTF Editor

The Relex RTF Editor provides integrated word processing capabilities. The Relex RTF Editor can be used to create or edit Rich Text Format (RTF) files. The following table describes some of the key features of the Relex RTF Editor. Note that the features described are accessed from the main menu when the active file is an RTF file.

	Feature
	Accessed By
	Description

	Margin Control
	File>Page Setup
	Page margins can be specified (in inches). These margins are applied to the entire file.

	Global Editingxe "Global Editing"
	Edit>Select All
	All text within the file can be selected, and formatting or font changes can be applied to that selected text. Individual blocks of text can also be selected for the same purpose by highlightingxe "Highlighting" \r "D2HBHighlighting22" the desired area.

	Find and Replacexe "Find and Replace" Features
	Edit>Find

Edit>Find Next

Edit>Find Previous

Edit>Replace
	Various find, and find and replace options are available for editing the file.

	Cursor Movement
	Edit>Go To
	The Go To command can be used to navigate your cursor. The keyboard can also be used for the same types of tasks. <CTRL> + <Up Arrow>, <CTRL> + <Down Arrow>, <CTRL> + <Right Arrow>, and <CTRL> + <Left Arrow> automatically moves your cursor up and down a paragraph at a time, or right and left between words.

	Workspace Customization
	View>Page Mode

View>Page Border

View>Rulerxe "Ruler"
View>Paragraph Marker
	The work area can be customized using these options to suit the needs of the file.

	Headers and Footers
	View>Header/Footerxe "Footer"
Tools>Edit Header/Footer
	Headers and footers can be added to the file. By selecting View>Header and Footer, the headers and footers can be displayed. Tools>Edit Header/Footer allows for the header/footer contents to be added or edited.

	Images
	Insert>Picture


	Bitmap files (.bmp), Metafiles (.wmf), or Jpeg (.jpg) files can be included in a RTF file. Insert them by selecting Insert>Picture from the main menu. Once inserted, the images can be sized by clicking and dragging the handles of the image.

	Custom Workspace Background
	Insert>Background Picture
	When working in the RTF editor, it is possible to select a custom background image that appears behind your text as you are working. This image is for display only and does not print.

	Page Control
	Insert>Page Break

Insert>Section Break
	Page breaks and sections breaks can be included for better document control.

	Footnotes
	Insert>Footnote

Tools>Edit Footnote
	Footnotes can be added and/or edited.

	Page Numbering
	Insert>Page Number

Insert>Page Count
	Page numbers can automatically be inserted onto a page, and the Insert>Page Count main menu option allows you to include the total number of pages. Therefore, a page number like Page 1 of 5 can be inserted.

	Non-Breaking Characters
	Insert>Non-breaking Space

Insert>Non-breaking Dash
	For additional control over word wrapping, non-breaking characters can be inserted. Lines do not wrap at these points. This is applicable for spaces in proper names and dates, for example.

	Font Control
	Format>Font

Format>Font Properties
	The font style and type of selected text can be edited. Any font style or size supported by Windows can be used.

	Paragraph Format Control
	Format>Paragraph
	The format of a paragraph or selected text can be controlled. Options include justification, indenting, window/orphan control, spacing, borders, and background color.

	Bullets and Numbering
	Format>Bullets

Format>Numbers
	Items can be grouped and displayed either with bullets or numbers.

	Custom Tab Settings
	Format>Set Tab
	Tab settings can be identified and customized. This includes the ability to set justification to a tab (like decimal, right, left, or centered).

	Section Customization
	Tools>Edit Section
	Sections within the file can be formatted separately. This includes column settings and page orientation.

	Custom Styles
	Tools>Edit Style
	Custom paragraph and font attributes can be defined under a style and reused.

	Spell Checkxe "Spell Check"
	Tools>Check Spelling
	The built-in spell check feature checks the spelling of the active file.

	Tables
	Table >
	Tables can be inserted, customized, and edited. Options include inserting of rows and columns, merging and splitting of cells, and the customization of cell borders and shading.


Relex Text Editor

The Relex text editor provides integrated text editing capabilities. The Relex text editor can be used to create or edit Text files. Below is a description of some of the key features of the Relex text editor. Note that the features described are accessed from the main menu while the active file is a text file.xe "Text file" \r "D2HBText_file24"
	Feature
	How Accessed
	Description

	Global Editingxe "Global Editing"
	Edit>Select All
	All text within the file can be selected, and formatting or font changes can be applied to that selected text. Individual blocks of text can also be selected for the same purpose by highlighting the desired area.

	Find and Replace Features
	Edit>Find

Edit>Find Next

Edit>Find Previous

Edit>Replace
	Various find, and find and replace options are available for editing the file.

	Cursor Movement
	Edit>Go To Line

Edit>Go To
	The Go To Line and Go To options allow you to move to a particular place or location within the text file.

	Workspace Customization
	View>Page Mode

View>Page Border

View>Wrap Text to Window
	The work area can be customized using these options to suit the needs of the file.

	Spell Check
	Tools>Check Spelling
	The built-in spell check feature checks the spelling of the active file.


Graphing

The Relex graphical features can be used to automatically generate a wide range of presentation qualityxe "Quality" scientific graphs. You can create bar graphs, line graphs, stacked bar graphs, pie graphs, and others using the many customization options. Once a graph has been created, it can be printed, saved as a graphic file, or even saved as a bitmap file so it can be used in a word processing or other application.

Remember that the online help system is available to answer your questions.xe "Questions" When using the graphical features, press the <Help> button at any time for additional information regarding the available features.

xe "Graph Wizard" \r "D2HBGraph_Wizard24"Graph Wizard

The Relex Graph Wizard walks you through the steps involved in creating all types of graphs. The Graph Wizard asks a series of questions. Your responses to these questions configure the graph. Some sample graphs that you can generate include:

· 3D Line Graph of Failure Rate vs. Temperature

· 3D Bar Graph of the MTBFs of all assemblies in your Project

· 2D Pie graph of the contribution of each Part Categoryxe "Category"
· 2D Line Graph of Reliability vs. Time

· Doughnut Graph of the % Failure Rate of all parts in an assembly
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Figure 4 - 6. Relex Sample Graph

Creating a Graph using the Graph Wizard

The Graph Wizard is designed to create a graph based on your specifications by asking a series of questions. To create a graph, follow these steps:

1. To graph assembly or part data of a Project file, first make the System Tree window or Parts Table window the active window. Select Tools>Graph from the menu (or select the Graph button from the standard toolbar). This starts the Graph Wizard.

Note: If a file other than a Project file is selected (like a Library file or Default file), Relex generates a sample graph with random data (referred to as a blank graph). This graph can then be edited to include any data in any format. For more information regarding blank graphs, refer to the section titled “Creating a Custom Graph
”.

2. When the Graph Wizard begins, the Graph Wizard - Select Data window is displayed. Relex provides a wide range of graphing options. The options available include:

· Failure Rate over Temperaturexe "Failure Rate over Temperature" \r "D2HBFailure_Rate25"
· Failure Rate over Environmentxe "Failure Rate over Environment" \r "D2HBFailure_Rate25"
· Failure Rate over Stressxe "Failure Rate over Stress" \r "D2HBFailure_Rate25"
· Failure Rate Only

· MTBFxe "MTBF" over Temperature

· MTBF over Environmentxe "MTBF over Environment"
· MTBF over Stressxe "MTBF over Stress"
· MTBF Onlyxe "MTBF Only"
· % Failure Rate over Temperature

· % Failure Rate over Environment

· % Failure Rate over Stress

· % Failure Rate Only

· Reliability over Timexe "Reliability over Time"
· Unavailability over Timexe "Unavailability over Time"
· Unreliability over Timexe "Unreliability over Time"
· Frequency over Timexe "Frequency over Time"
· FMEA Criticality Matrixxe "Criticality Matrix" \r "D2HBCustom_Graph25"
· FMEA Risk Levelsxe "FMEA Risk Levels"
· Mission Reliability

· None (Blank Graph) *
Select the desired data for the graph. 

* For more information regarding blank graphs, refer to the section titled “Creating a Custom Graph
”.
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Figure 4 - 7. Graph Wizard, Select Data

3. Depending on your graph type selection, you are then given a few additional options regarding the graphing of the data. These options include:

	Option
	Description

	Select most significant items
	Relex automatically graphs only the most significant items. Enter the total number of items to be included on the graph in the limit text box.

	Limit number of data series per graph
	Relex automatically limits the number of data series per graph. Data series correspond to curves on a line graph. Enter the total number of data series to be included on each graph in the limit text box. (For example, five graphs are generated if there are 50 series and the series per graph is limited to 10.)

	Use quantities in calculations
	Relex normally includes quantities in the calculations for the graph. An example would be a graph of Failure Rate vs. Temperature. If this option is disabled, the calculated values used in the graph are based on quantities of 1 for each part or assembly rather than the actual quantities as entered in the Project file.


After selecting the appropriate options, press <Next> to continue.

4. The Graph Wizard - Select Data Source window displays. This window allows you to define exactly what information is to be included in the graph. Select whether you want to graph assemblies, or graph the parts within each assembly. If you select to graph assemblies, you find the following two options:

	Option
	Description

	All Assemblies
	When enabled, Relex graphs all of the assemblies in the System Tree as calculated totals (combined failure rates including all parts in each assembly, rather than individual failure rates for individual parts in the assembly).

	Selected Assemblies
	When enabled, Relex graphs selected assemblies in the System Tree as calculated totals (combined failure rates including all parts in each assembly, rather than individual failure rates for individual parts in the assembly). The assemblies are selected by using the lists marked Available Assemblies and Selected Assemblies at the bottom of the window. These boxes are used to specifically select which assemblies are to be included in the graph. Click on the assemblies that you want to appear on the graph and press <Add>.


Rather than graphing entire assemblies, you can graph individual parts within an assembly by selecting the Parts option. The parts in the currently selected assembly are available for graphing. When graphing parts, the following options display:

	Option
	Description

	Part Categories
	When enabled, Relex graphs the individual parts of the selected assembly by part type. 

	Part Recordsxe "Part Records" 
	When enabled, Relex graphs the individual parts of the selected assemblies by part records. You may select the range of part records to be included in the graph.


Once all of the options have been selected, press <Next> to continue with the Graph Wizard.
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Figure 4 - 8. Graph Wizard, Select Data Source

5. The Graph Wizard - Set Overrides window appears for all graph types where one parameter is plotted versus another parameter to allow you to select the data to be included in the graph. The options that display are dependent on the data selected on the Graph Wizard – Select Data window for this particular graph. Below are the possible options that can be displayed:

	Selected Data
	Override Options

	Temperature
	Select Range of Temperatures and enter the From, To, and Increment values to graph over a temperature range. Enable Selected Temperatures and enter the temperature values separated by commas to generate a graph based on specific temperature values. 

	Environment
	Select Range of Environments and enter the From and To environments from the choice listsxe "Choice Lists" to graph over a range of environments. When graphing over an environment range, Relex starts on the first environment and proceeds through the environments in the order in which they appear in the choice list until the end environment is reached. Enable Selected Environments and choose the environments to generate a graph based on specific environments. 

	Stress
	Select Range of Stresses and enter the From, To, and Increment values to graph over a stress range. Enable Selected Stresses and enter the stress values separated by commas to generate a graph based on specific stress values. Enter stress values as percentages.

	Time
	Select Range of Times and enter the From, To, and Increment values to graph over a time range. Enable Selected Times and enter the time values separated by commas to generate a graph based on specific time points.


6. Once all options have been properly selected, press <Next> to continue.
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Figure 4 - 9. Graph Wizard, Set Overrides Example

6. The Select Graph Options appears. You may select from any of the following graph types: 

	2 Dimensional Graphsxe "2 Dimensional Graphs"
	3 Dimensional Graphsxe "3 Dimensional Graphs"

	Area (2D)
	Area (3D)

	Bar (2D)
	Bar (3D)

	Bubble (2D)
	Clustered Bar (3D)

	Combination (2D)
	Combination (3D)

	Contour (2D)
	Doughnut (3D)

	Gantt (2D)
	Gantt (3D)

	Hi-Lo (2D)
	Horizontal Bar (3D)

	Horizontal Bar (2D)
	Line (3D)

	Line (2D)
	Pie (3D)

	Pie (2D)
	Scatter (3D)

	Polar (2D)
	Step (3D)

	Radar (2D)
	Surface (3D)

	Step (2D)
	XYZ (3D)

	XY (2D)
	


In addition to selecting a graph type, you also have the ability to select other options regarding the creation of the graph:

· For the Failure Rate only, MTBF only,xe "MTBF Only" and % Failure Rate only, you can select Pareto Plot to generate a graph ordered by the most significant items.

· You also have the option of outputting the generated data to a text filexe "Text file" \r "D2HBText_file30" in addition to a graph. This text file can be read by another application such as Microsoft Excelxe "Microsoft Excel" or Microsoft Word.
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Figure 4 - 10. Graph Wizard, Select Graph Options

7. Once you have made your final selections, press <Finish> to generate the graph to the screen and/or output the data to a text file. Relex first performs all calculations required for the graph and then generates the graph.

Editing a Graph

Once a graph has been created using the Graph Wizard, you have numerous options regarding editing the appearance of that graph. Because of the large range of options available, it is impossible to outline them all here. However, a full description appears in the online help. In order to edit a graph, follow these steps:

1. With the graph displayed in the active window, select any of the options available on the Graph main menu.

2. The options that display give access to all characteristics of the graph. By selecting different options, you may customize any combination of the following characteristics:

· Edit the data used to create the graph.

· Edit physical characteristics of the graph including colors, legends, titles, and footnotes.

· Edit the appearance of the graph including the plot, axes, rotation, and elevation.

See the following table for a brief description of each menu selection:

	Menu Item
	Description

	Edit Graph Data
	Upon selection, the Edit Chart Data window is displayed. It includes a table containing the data used to produce the graph. You have the ability to edit the values of the data. You can also edit characteristics of the rows and columns of the graph.

	Graph Designerxe "Graph Designer"
	Upon selection, the Chart Designer window appears with Chart option selected. The options on this window allow you to edit the visual setup of some of the key features of the graph. These features include a gallery of graph types and style, layout, and axes customization options. Provides numerous options to allow you to customize the appearance of the graph. Access the online help for more details.

	General
	Upon selection, the Chart Designer window appears with Chart option selected. Lists various options for customizing the display of the entire graph. These options include the ability to show the title, footnote, legend, and second Y axis. You can also specify display characteristics of the backdrop of the graph including fill, frame, and picture characteristics. Access the online help for more details.

	Plot
	Upon selection, the Chart Designer window appears with Plot option selected. This option allows you the freedom of completely customizing the graph as it is currently plotted. Categories of customization options include Type, Location, Backdrop, Order, Options, 3D View, 3D Lighting, and Base & Walls. Access the online help for more details.

	Series
	Allows you to set various options for the data series. These options include changes to the series itself and customizing the look of the label, datapoint, and datapoint labels. Access the online help for more details.

	Axis
	Allows you to set various options for the axis. These options include changes to the axis itself and customizing the labels and titles of the axis. Access the online help for more details.

	Legend
	Upon selection, the Chart Designer window appears with Legend option selected. Allows you to fully customize the legend of the graph. You can make changes to the backdrop of the legend, and specifying the font and location. Access the online help for more details.

	Title
	Upon selection, the Chart Designer window appears with Title option selected. Allows you to fully customize the title of the graph. You can make changes to the backdrop of the title, and specify the text, font, and location. Access the online help for more details.

	Footnote
	Upon selection, the Chart Designer window appears with Footnote option selected. Allows you to fully customize the footnote of the graph. You can make changes to the backdrop of the footnote, and specify the text, font, and location. Access the online help for more details.

	Rotate Left
	Rotates the entire graph to the left.

	Rotate Right
	Rotates the entire graph to the right.

	Increase Elevation
	Increases the elevation angle of the graph.

	Decrease Elevation
	Decreases the elevation angle of the graph.


[image: image40.png]Chart Designer
| Char Type | Backdrop | Picture |

Title
Footnote
Legend

Plat

X dis

Y Axis
Second Y Axis
2 Axis

Series

Series Labels

Reset Char To Defaults

Layout Text
 Forrinting

 ForDisplay

I Datain Bows

Cancel Apply Help





Figure 4 - 11. Chart Designer

3. The items included in the main menu and right mouse menu vary slightly. The Rotate Left and Right options (which allows you to rotate the entire graph to the left or right) and Increase and Decrease Elevation options (which allows you to increase or decrease the angle of the graph) are additional features which are available from the main menu or the Graph toolbar.

4. If you find that you require additional information regarding a specific feature, press <Help> on the corresponding window for more information. The online help system includes descriptions of each of these features in detail.

xe "Printing a graph"Printing a Graph

Once a graph has been created using the Graph Wizard,xe "Graph Wizard" you may print that graph by selecting File>Print from the main menu or select the <Print> button from the toolbar. 

xe "Custom Graph"Creating a Custom Graph

A custom graph is a graph that contains data that is completely independent from the current Project file in Relex. Use this feature if you want to take advantage of the Relex graphing capabilities for data not directly related to a Relex Project file.

Select Tools>Graph from any Relex window, and on the first window of the Graph Wizard, when you are asked to select the data to be included in the graph, choose the option None (Blank Graph). This option also generates a sample graph with random data.

Once the graph has been generated, you may customize the graph using the various editing options that were reviewed in the section titled “Editing a Graph”. Most importantly, you may enter your own data for this graph by selecting Graph>Edit Graph Data from the main menu or Edit Chart Data from the right mouse menu. Enter the new graph data, press the <OK> button and the graph is redisplayed with the new data.
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Figure 4 - 12. Edit Chart Data

Saving a Graph File

Once a graph has been generated, the Graph file can be saved. By saving a graph as a Graph file, the graph can be opened at a later time and edited or printed. To save a graph to a Graph file, follow these steps:

1. Select File>Close from the main menu. 

2. The Save As window is displayed. In the File name field, enter the name of the graph to be saved. Press <Save> to save the Graph file.

Opening a Graph File

Once a Graph file has been saved, it can be opened at any time for review, editing and printing. To open an existing Graph file, follow these steps:

1. Select File>Open>Other>Graph from the main menu.

2. When the Open File window appears, select the name of the Graph file to be opened, and press <Open> to open the file.

xe "Saving a Graph as an Image"Saving a Graph as an Image

Once a graph has been generated, the Graph file can be saved as an image. This image can then be used in any word processor, spreadsheet, or graphics package. To save a graph as an image, follow these steps:

1. Select File>Save As from the main menu.

2. The Save As window appears. In the Save as Type field, select the file type of either Bitmap files (.bmp), JPEG files (.jpg), or Windows Metafiles (.wmf). In the File name field, enter the name of the image to be saved and press <Save> to save the graph as an image.

Copying Portions of a Graph to the Clipboard

Once a graph has been generated, any portion of the graph can be copied to the Windows clipboard. This clipboard image can then be used in any word processor, spreadsheet, or graphics package. To save a portion of a graph to the clipboard, follow these steps:

1. Select the portion of the graph to be copied. The portion of the graph is highlighted with solid bullets illustrating that it is selected.

2. Select Copy from the right mouse menu to copy the selected item to the clipboard. Paste the selection as desired.

Chapter 5 Importing and Exporting

xe "CAD Interface"Introduction to the CAD Interface

The Relex CAD Interface provides an easy and flexible method of importing and exporting Relex files. If you have information in a CAD system, a database, spreadsheet, word processor, or other format, Relex provides the tools necessary to import your data. You can import and export ASCII delimited files,xe "Delimited files" \r "D2HBDelimited_fi1" Keyword files,xe "Keyword files" \r "D2HBKeyword_file1" Bill of Materials (BOM) files,xe "Bill of Materials (BOM) files" database files, and spreadsheet files. You may also import thermal information or stress dataxe "Stress Data" to update existing files and export LSAR data to MIL-STD-1388 2B compatible files.

xe "CAD Import/ExportWizardtm"The CAD Import/ExportWizardtm
The CAD Import/ExportWizardtm walks you through the steps involved in importing or exporting a filexe "Exporting a File" in Relex. The Import/ExportWizardtm asks a series of questions.xe "Questions" Your answers or responses to these questions actually handles the set up and execution of the Import or Export process. In other words, the CAD Import/ExportWizardtm gathers the necessary information required to convert your outside file into a Relex file. 

xe "Supported File Types"

xe "File Types"Supported File Types

Relex Files that Support Importing or Exporting

One of the greatest benefits of importing and exporting data is the decrease in data entry time. By importing or exporting data you may eliminate repetitive data entry and also eliminate the possibility of errors. The Relex file and data types that support the importing or exporting of data are listed below. 

General

· Project filexe "Project file" System Treexe "System Tree"
xe "Reliability Prediction"Reliability Prediction

· Project file including System Tree and reliability prediction data

· Reliability prediction data for a Project file

· Library filesxe "Library files"
· Correlation filesxe "Correlation files"
FMEA

· Project file including System Tree and FMEA data

· FMEA data for a Project file

Maintainability

· Project file including System Tree and Maintainability dataxe "Maintainability Data"
· Maintainability data for a Project file

LCC

· LCC cost breakdown structure(CBS)

· LCC file including cost breakdown structure (CBS), alternatives, time intervals and variables

Fault Tree

· Fault Tree data for a Project file

Types of Files that Can Be Imported or Exported

The file type is the type of file that you are importing into Relex or the type of file that you want Relex to create when exporting. File type refers to the format of files that other programs accept or create. For instance, Microsoft Excelxe "Microsoft Excel" uses a special type of file that ends with the .xls extension, and is immediately recognized by Microsoft Excel without the need for conversion. When a file is saved in Microsoft Excel, it is automatically saved as a .xls file by default. 

When you import a file into Relex, Relex automatically attempts to recognize the type of file you are importing. When you export a file, you select the file type to which Relex exports.

In general, the file types supported by Relex for importing and exporting fall into three categories:

· Program Specific files

· Text files

· Special filesxe "Special files" \r "D2HBSpecial_file2"
Program Specific Files

Program Specific files are files that are in a special format specific to another software program. As with the example referenced above, a Microsoft Excel filexe "Excel file" is specific to Microsoft Excel. Relex can import directly from or export directly to the Program Specific files without the need for any additional conversion. Program Specific files supported by Relex are:

· Microsoft Accessxe "Microsoft Access" 

· Microsoft Excel

· Microsoft FoxProxe "Microsoft FoxPro"
· dBASExe "dBASE" 

· Lotusxe "Lotus" 

· Paradoxxe "Paradox"
Text Files

Text files are very generic file types that can be created by many software programs, or can be created with any text editor program. Relex supports three kinds of text files: Delimited files, Bill of Material files, and Keyword files. Each of these files is described in more detail in the following sections.

Delimited Files

Delimited files, sometimes referred to as ASCII delimited text files, are text files with fields of information separated by a delimiter. Common delimiters include commas and tabs. Delimited files are very standard, and can be generated from nearly any database, spreadsheet or word processing program, and many CAD systems. An example of a delimited text filexe "Text file" is shown below:

74LS00, 1, U1

74LS04, 2, U2-U3

2N2222, 1, Q1

Bill of Materials Files

Bill of Materials (BOM) filesxe "Bill of Materials (BOM) files" are fixed-format text files where each data value appears between certain columns of fixed widths. This type of text file is generally available from CAD systems. An example BOM file is shown below:

74LS00 1 U1

74LS04 2 U2-U3

2N2222 1 Q1

Keyword Files

Keyword files are a special Relex file type designed for use with word processors and text editors. Keyword files are free format ASCII files that have keywords for each field of information. An example keyword file is shown below:

pn=74LS00, qty=1, ref=U1

pn=74LS04, qty=2, ref=U2-U3

pn=2N2222, qty=1, ref=Q1

Special Files

Special files are those that are used for specific importing and exporting purposes in Relex. Relex supports exporting to LSAR formats, and importing of thermal and stress data.xe "Stress Data" These special cases are described as follows:

LSAR Export

LSAR filesxe "LSAR files" are text files that conform to MIL-STD-1388 2B format and are used for Logistics Support Analysis Record information and for importing into LSAR software packages. LSAR data can be exported from Relex automatically.

Thermal Analysis Data Import

Relex allows you to update an existing project with thermal information from an outside source. For example, this information can be generated from a thermal analysis package.

xe "Stress Analysis Data Import"Stress Analysis Data Import

Relex allows you to import files containing operating stresses of your components. Similar to importing thermal files, Relex allows you to update an existing Project file with stress information. For example, this information can be generated from a stress analysis program.xe "Stress Analysis Program"
Importing and Exporting Procedure

Relex uses the CAD Import/ExportWizardtmxe "CAD Import/ExportWizardtm" to simplify the process of importing and exporting. This section provides a set of step-by-step instructions for performing a standard import or export. For more information on advanced features available in the Import/ExportWizardtm , refer to the section titled “Advanced Importing and Exporting
”.

Note: When importing, the file that is being imported is often called the source file. When exporting, the file that is being created is often called the target file.

xe "CAD Interface"Importing with the Relex CAD Interface

The steps outlined here apply generally to all types of imports within Relex. In some cases, you have the opportunity to update existing Relex files as an additional feature. Additional information and hints are provided in the section titled “Importing and Exporting Relex Files”.

1. To begin the import process, select File>Import from the main menu or select Import from the right mouse menu where applicable. This starts the CAD ImportWizardtm.

2. The Import window appears and requires that you select the file to be imported. Select the file type from the choice list, identify the specific file to be imported and press <Import> to continue.

3. The first window of the CAD ImportWizardtm is used to determine the type of import you wish to perform. The choices displayed in the window are different depending on how the import process began.

4. On the next window, the CAD ImportWizardtm attempts to determine the type of file that you are importing. It makes this determination based on the format of the file and the file extension. If the selection is correct, press <Next> to continue. If the selection is incorrect, select the appropriate file type being imported from the choice list. Depending on the type of file selected, additional information may be required.
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Figure 5 - 1. Relex ImportWizardtm, Source File Type

5. For some file types, the next window that appears requests information verifying the format of the file being imported. Sample data from your import file is displayed. Relex formats the information based on the information that it currently has available regarding your import. If the information is displayed correctly, press <Next> to continue. For most program specific files, the columns of information displayed are based on the fields as defined in the file being imported. Delimited and BOM files display columns of information based on the delimiters selected or noticeable column breaks. If this information is incorrect, edit according to the instructions. If you are importing from an Excel version 5.0 or higher, you must specify which sheet or name ranged includes the data.

6. Once the fields have been properly designated, Relex is ready to begin mapping the data. On the next window that appears, a sample of the data appears, and the designated fields are illustrated. At this point, you tell Relex what the data in each field of information represents. This process is referred to as field mapping. You may also press the button marked <View Map> to review your work so far. When finished, press <Next> to continue. 
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Figure 5 - 2. Relex ImportWizardtm, Field Mapping

7. If the import process is creating a new file, the next window that appears requests information regarding that file. Relex requests different information depending on the type of file you selected to create. At a minimum, Relex asks you for a file name. If, for example, you are creating a new assembly too, Relex asks for the assembly name.xe "Assembly Name"
8. On the final window, you may press <Finish> to complete the import process. On this window, you also have the option of saving the settings that were created by the CAD ImportWizardtm. These settings can then be used for later imports and exports of the same configuration (for more information refer to the section titled “Advanced Importing and Exporting
”). If you wish to save the settings, input a file name for the settings and press <Finish>.
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Figure 5 - 3. Relex ImportWizardtm, Save Settings

9. An Import status window appears, showing the progress of the import. When the import is completed, the status indicator reads 100% and a status icon displays illustrating the success of the import. A report of Records Imported, Errors, and Warnings is also displayed. If errors or warnings were experienced, you may view the Relex Import/Export Logxe "Import/Export Log" \r "D2HBImport_Expor6" (described in the section titled “Relex Import/Export Log”) by pressing <View Log>. When you are finished reviewing the status information, press <Close> to complete the import.

10. Upon closing the Status window, the import is completed. The newly created or updated file is then displayed in the activexe "Active" window for review.

xe "CAD Interface"Exporting with the Relex CAD Interface

The following steps walk you through the process of exporting a filexe "Exporting a File" from Relex using the CAD ExportWizardtm. These steps are be consistent for all types of exports. Additional information and hints are provided in the sections titled “Importing and Exporting Relex Files”, and “Importing and Exporting Details”.

1. To begin the export process, select File>Export from the main menu or select Export from the right mouse menu where applicable. This starts the CAD ExportWizardtm.

2. Depending on where your cursor is when you begin the export process, you may be asked to supply information specifying what information is to be exported. As a general rule, Relex assumes that you wish to export the information for the selected file or window. If this additional information is requested, answer the questions and press <Next> to continue. 

3. The next window that appears provides the ability to select the type of file to be created by Relex during the export. You may select any of the file types that are available from the choice list. On this window, you also select the name of the target file. Depending on the file type selected, Relex may also request additional information on this window. Complete the necessary information and press <Next> to continue.
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Figure 5 - 4. Relex ExportWizardtm, Target File Type and Name

4. The next window that appears depends on the file type that was selected for export. As a general rule, the following windows appear based on the stated file types:

	File Type
	Next Step

	Delimited
	A window appears requesting delimiters and qualifier information.

	LSAR
	Because LSAR is a standardized format that you cannot change, you are automatically advanced to the final step of the CAD ExportWizardtm.

	Keyword
	Because Keyword format exports all information, you are automatically advanced to the final step of the CAD ExportWizardtm.

	All other File Types
	All other file types are advanced to the Field Selection window, which is described in the next step.


5. The next window that appears is used to select the data fields to be exported. A list of all Relex fields available for export is displayed to the left. As you select fields to be exported, these fields are displayed in the box labeled Fields to Export. Select all fields to be exported and arrange the order of the fields as needed (the field at the top of the list is the first field exported for each record, the second field in the list is the second field exported for each record, etc.). For more information regarding the fields labeled All Specific Fields–Long Format, All Specific Fields–Short Format, and Specific Data, see the section “Importing and Exporting Specific Part Data
”xe "Importing and Exporting Specific Part Data". For more information about the <Read Format> button, see the section titled “Format File”xe "Format file". Once all fields have been selected, press <Next> to continue.
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Figure 5 - 5. Relex ExportWizardtm​, Data Fields to Export

6. You may select <Finish> to complete the Export process. You also have the option of saving the settings that were created by the CAD ExportWizardtm. These settings can then be used for later imports and exports of the same configuration (for more information see “Advanced Importing and Exporting
”). If you wish to save the settings, input a file name for the settings and press <Finish>.

7. At this point, a status window appears. This status window shows the progress of the data export. When the export is completed, the status indicator reads 100%, and a status icon displays illustrating the success of the export. A report of Records Exported, Errors, and Warnings are also displayed. If errors or warnings were experienced, you may view the Relex Import/Export Log (described in the section titled “Relex Import/Export Log”) by pressing <View Log>. When you are finished reviewing the status information, press <Close> to complete the export.

8. Relex then returns you to your previous work area in the active file.

Relex Import/Export Log

The Relex import/export log supplies all pertinent information regarding the import or export performed. It identifies the source and target files, the external file type, a description of the import or export and the start and end time of the process. The log also outlines any problems experienced with a brief explanation of the error or warning. The error log may be printed, saved or closed.

Importing and Exporting Relex Files

The following sets of instructions provide information specific to the importing and exporting of certain types of Relex files. The basic steps for importing and exporting are stated in the section titled “Importing and Exporting Procedure”.

Importing Data to a Project File

You have the ability to import any part of a Project file or the entire Project file. When importing to a Project file, one of the selections described in the following tables must be made to specify what data is being imported.

The following is a list of options when importing with no files open: 

	Option
	Description

	I am importing an entire project, including tree information.
	Use when the source file includes data that identifies the System Tree structure and prediction, FMEA or maintainability data associated with the parts to be included in the Project file.

	I am importing only the project tree information.
	Use when the Source file includes only the data necessary to create the System Tree structure.

	I am importing only one assembly.
	Use when the Source file includes data to create a new assembly with prediction, FMEA or maintainability data associated with the parts in that new assembly.


Note: You must specify whether the part data to import is reliability prediction, FMEA or maintainability information.

The following is a list of options when importing with a file open and the System Tree active:

	Option
	Description

	I want to update the selected assembly.
	Use when the source file is to update the contents of the selected assembly. Updates are based on the reference designatorxe "Reference Designator" field. The reference designator in the Project file and in the file to import must match exactly.

	I want to append records to the selected assembly.
	Use when the parts in the source file are to be added to the selected assembly.

	I want to create a new assembly.
	Use when you wish to create a new assembly with the imported information.

	I want to update the system hierarchy information.
	Use when the information being imported is to update the System Tree information. Updates are based on the reference designator field for the assemblies. The reference designator in the Project file and in the file to import must match exactly.

	I want to append records to the project Tree information.
	Use when the information being imported is to be added to the selected System Tree.

	I want to update the entire project.
	Use when the source file is to update the System Tree information and the contents of assemblies. Updates are based on the reference designator field. The reference designator in the Project file and in the source file must match exactly. 


Note: You must specify whether the part data to import is reliability prediction, FMEA or maintainability information.

The following is a list of options when importing with a file open and the Parts Tablexe "Parts Table" active:

	Option
	Description

	I want to update the selected assembly.
	Use when the source file is to update the contents of the selected assembly. Updates are based on the reference designator field. The reference designator in the Project file and in the file to import must match exactly.

	I want to append records to the selected assembly.
	Use when the parts in the source file are to be added to the selected assembly.


xe "Importing and Exporting Reliability Prediction Data"Importing and Exporting Reliability Prediction Data

The steps outlined in the section titled “Importing and Exporting Procedure” are sufficient if the main intent is to import a parts list from some outside source. The only special feature regarding the importing and exporting of reliability prediction data is the inclusion of specific part data. Specific part data refers to the data included on the Prediction Data tabxe "Prediction Data tab" for any component. If this data regarding parts is available from another data source, it is very important to be able to include it during importing since this data is required for accurate failure rate calculations.

xe "Importing and Exporting Specific Part Data"Importing and Exporting Specific Part Data

In general, there are three different ways to import or export specific part data to or from a Project file or Library file. The information included on the Prediction Data tab differs depending on the part categoryxe "Category" and subcategoryxe "Subcategory" selected for the part.

During the process of mapping fields in the import/export process, there are three different fields that can be selected to import or export specific part data. These field names are:

· All Specific Fields - Long Formatxe "All Specific Fields - Long Format" \r "D2HBAll_Specific9"
· All Specific Fields - Short Formatxe "All Specific Fields - Short Format" \r "D2HBAll_Specific9"
· Specific Data

The specific purposes and specifications of these fields are outlined below:

All Specific Fields - Long Format

The field designation of All Specific Fields - Long Format is used when each of the fields of information from the Prediction Data tab are to be imported or exported. Long format refers to the format of the data upon importing or exporting. The long format includes one field for each data parameter, but the format of the data is in a fixed file structure. This special format is useful when sharing information with another program that requires that all records contain the same number of fields, with each field being the same type, e.g. database applications such as Access, dBase,xe "dBASE" and FoxPro.

The information and number of fields contained on the Prediction Data tab varies for each part category and subcategory. This can cause confusion when sharing information with a database that requires that all records to have the same number of fields. Therefore, the All-Specific Fields - Long Format is provided.

The information for each part, regardless of part category and subcategory, is imported or exported with specific part data in the same format. This format includes over 90 fields of information. The specific data mapped to these fields is outlined in a document supplied on the Relex CD in the Docs directory titled CAD Interfacexe "CAD Interface" \r "D2HBCAD_Interfac10" Supplement. Listed in this document is the offset where each particular data field is located when using both the long and short formats.

Note: The long or short formats must be imported or exported as the last field for each part.

All Specific Fields - Short Format

The field designation of All Specific Fields - Short Format is used when each of the fields of information from the Prediction Data tab are to be imported or exported. Short format refers to the format of the data upon importing or exporting. The short format includes one field for each data parameter, but the format of the data varies for each part type. This format is used when sharing information with a program that does not require that all records contain the same number of fields.

The information and number of fields contained on the Prediction Data tab varies for each part category and subcategory. The All Specific Fields - Long Format discussed previously works well for programs that require a fixed number of fields for each record. However, if you do not have that particular requirement, you may find that the length using the long format is cumbersome. Therefore, the All-Specific Fields - Short Format is available.

The information for each record in the short format contains the exact number of fields required to import or export the specific part data. The number of fields required differs depending on the part category and subcategory. The specific data mapped to the fields is outlined in the document supplied on the Relex CD in the Docs directory titled CAD Interface Supplement. Generally, fewer fields are imported and exported in the short format, but the records vary in length. Listed in the CAD Interface document is the offset where each particular data field is located when using both the long and short formats.

Specific Data
All Specific Fields - Short Format and All Specific Fields - Long Format are useful when you wish to import all specific part data fields. However, you may want to include only individual specific part data fields in your import or export. The Specific Data option offers you the flexibility of specifying the definition of any data value.

During the field-mapping portion of the CAD Import/ExportWizardtm,xe "CAD Import/ExportWizardtm" if you specify a field as Specific Data, an additional button labeled <Edit> appears on the Import/ExportWizardtm window. This feature provides the ability to specify exactly what information is contained in that particular field.

When the <Edit> button is pressed, the Specific Data List window appears. The purpose of this window is to specify the contents of the specific data field upon import or export. You can specify a different content for the same field for each part category and subcategory. For instance, assume you are importing a file into Relex, and that file contains one field of information for every part that designates the qualityxe "Quality" level of the part. For this example, during the import process, specify that the field includes specific data, and press <Edit >. On the Specific Data List window, select each part category and subcategory that was included in the import, and specify that this field represents the quality level for that part type. As the part categories and subcategories are being added, a list is displayed at the bottom of the window for your reference.

Note: If a field represents the same specific data for all subcategories of the selected category, there is a shortcut that can be used. When entering categories and subcategories, Relex recognizes the first subcategory of each category as the default part information for each part. As in the above example, when selecting the field that represents quality level for all part types, you can select the category for each part, and only select the first subcategory for each of these categories. In the above example, if Relex imports a category and subcategory that is not listed, it uses the first subcategory of the category as the default for that part.
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Figure 5 - 6: Relex Import/ExportWizardtm, Importing or Exporting Specific Data

Using the CAD Interface Supplement

The CAD Interface Supplement supplied on the Relex CD is a set of tables that provide the details required for importing specific part data for components. This document lists all part types and the associated data that is requested for each part type. The CAD Interface Supplement provides descriptions for all MIL-HDBK-217,xe "MIL-HDBK-217" Telcordiaxe "Telcordia (Bellcore)" (Bellcore), and Mechanical part types. Before entering partsxe "Entering Parts" into Relex, you may find it useful to print these tables and fill in the blanks. A description of the tables in this CAD Interface Supplement is as follows:

Page #1 contains the general part information, or the data that is the same for each part type. The rest of the pages contain the specific data for each particular part type.

On page #1, the top row lists the Item or field name. The next row is the Keyword that is used in the keyword files.xe "Keyword files" \r "D2HBKeyword_file11" This keyword is also used in the creation of the Format file that describes the format of the import and export data. The third row lists the type of Data, whether it is a string, a list, an integer, or a real number.

On all subsequent pages, the first three rows are the same as on page #1. The fourth row and the fifth row are used if you are importing or exporting part data in the All Long or All Short format. The fourth row, Short #, is the offset of that particular item from the beginning of the specific part data if using All Specific Fields - Short Format for importing or exporting. For example, if a particular data item has a Short # of 3, it means that Relex expects this value to be the third value of the specific data fields. The fifth row, Long #, is the offset of that particular item from the beginning of the specific part data if using All Specific Fields - Long Format for importing or exporting. Note that there are generally many unused fields when exporting All Specific Fields - Long Format. 

After each table, all of the items that are choice listsxe "Choice Lists" in Relex are shown with all of the available choices. You need to enter the correct item from the list. If you are importing or exporting a keyword file and wish to enter a value for an item that has a list, enter the character string from the list (e.g. Integrated Circuit), not the offset. You do not need to enter the entire string, only enough of the string to make it unique from all of the other items in the particular list. If you are using any other type of importing and exporting except for keyword files, then Relex expects the offset only (e.g. 1) to be entered, not the character string.

Note: Prior to importing files, it is helpful to export an existing file to see the resulting output. You can use this as a basis for creating your own file.

Also, note that the Relex context-sensitive online help provides a more detailed description of each field or item of information. Press the <F1> key while the Prediction Data tab is active to view the associated help for that part type.

Importing and Exporting FMEA Data

Relex supports the importing and exporting of FMEA data. The procedure for import and export of this data is very similar to that procedure outlined in the section titled “Importing and Exporting Procedure” in that it also uses the Import/ExportWizard to simplify the task. During the import/export process, it is necessary to select the option to import/export FMEA information.

FMEA Fields Required for Importing

When importing Relex FMEA files, the following fields are required: 

· Item Record Numberxe "Item Record Number"
· Mode Record Numberxe "Mode Record Number"
· Cause Record Numberxe "Cause Record Number"
· Assembly Name

Therefore, when exporting Relex FMEA files with the intention of eventually re-importing them, you should make sure that these fields are included in the export. These same fields are the basis of comparison when performing an update during an import of FMEA data.

FMEA Keywords for Importing and Exporting

When using a keyword file for import or export, or when you wish to modify your Format file manually, you must know the keywords used by Relex FMEA. All of the FMEA keywords are supplied on the Relex CD in the Docs directory.

Importing and Exporting Maintainability Data

Relex supports the importing and exporting of maintainability data. The procedure for import and export of this data is very similar to the procedures outlined in the section titled “Importing and Exporting Procedure” in that it also uses the Import/ExportWizard to simplify the task. During the import/export process, it is necessary to select the option to import/export maintainability information.

Maintainability Fields Required for Importing

When importing Relex Maintainability files, the following fields are required: 

· Item Record Number

· Task Record Number

· Assembly Name

Therefore, when exporting Relex Maintainability files with the intention of eventually re-importing them, you should make sure that these fields are included in the export. These fields are the basis of comparison when performing an update during an import of Maintainability data.

Maintainability Keywords for Importing and Exporting

When using a keyword file for importing or exporting, or when you wish to modify your Format file manually, you must know the keywords used by Relex Maintainability. All of the maintainability keywords are supplied on the Relex CD in the Docs directory.

Importing and Exporting a Parts Library File

Relex supports the importing and exporting of Parts Library files.xe "Library files" Import and export of Parts Library files is described in the section titled “Importing and Exporting Procedure”. 

Importing Data into a Parts Library File

In order to import data for a Parts Library file, you must first have either all files closed in Relex, or a Library file open. If you are importing into an open Library file, select File>Import from the menu, and step through the CAD ImportWizardtm. Because the file is open and active, Relex automatically assumes that the parts you are importing are to be included in the active Library file. If you are importing when all files are closed in Relex, select File>Import from the menu, and select Library as the file type to import before continuing with the next step in the CAD Import/ExportWizardtm.xe "CAD Import/ExportWizardtm"
Importing Specific Part Data to a Library File

As mentioned in the section titled “Importing and Exporting Reliability Prediction Data
”xe "Importing and Exporting Reliability Prediction Data", it is possible to import detailed reliability prediction data regarding components in a Project file. This feature is also available when importing components into a Parts Library. Follow the same procedure to import part data to libraries that is used to import part data into Project files. For detailed instructions regarding this feature, refer to the section titled “Importing and Exporting Specific Part Data
”xe "Importing and Exporting Specific Part Data".

Importing Duplicate Part Numbers into a Parts Library File

Duplicate part numbers are not supported in libraries. Therefore, when importing data into a Library file, only the first instance of a part numberxe "Part Number" is imported. The second instance of any part number generates an error message in the error log and is not imported.

Exporting Data from a Parts Library File

In order to export general or specific data from a Parts Library file, select File>Export from the main menu while the particular Library file is open and active. Allow the CAD Import/ExportWizardtm to step you through the process of exporting library part data.

Importing and Exporting a Correlation File

Relex supports importing and exporting of Correlation files.xe "Correlation files" \r "D2HBCorrelation_13" The procedure for importing and exporting correlation data is described in the section titled “Importing and Exporting Procedure”. 

Importing Data into a Correlation File

In order to import data into a Correlation file, you must first have either all files closed in Relex, or a Correlation file open. If you are importing into an open Correlation file, select File>Import from the main menu, and step through the CAD Import/ExportWizardtm. Because the file is open and active, Relex automatically assumes that the part numbers you are importing are to be included in the active Correlation file. If you are importing when all files are closed in Relex, select File>Import from the main menu and select Correlation file as the database type to be created.

Importing Part Numbers into a Correlation File

When importing parts into a Correlation file, there are two basic rules that apply:

1. Correlation files cannot contain more than one instance of any in-house part number. Duplicate in-house part numbers are not supported in Correlation files. Therefore, when importing into a Correlation file, the first instance of a part number is imported. The second instance of any part number generates an error message in the error log and is not imported.

2. Part numbers in Correlation files must be located in an enabled Library file. When an in-house part number and library part number are imported, Relex automatically checks to see if the library part number exists in an active library. If a matching library part number is not found, an error message is generated in the error log, and the record is not imported.

Exporting Data from a Correlation File

In order to export correlation data from a Correlation file, select File>Export from the main menu while the particular Correlation file is open and active. Allow the CAD ExportWizardtm to step you through the process of exporting correlation data. 

xe "Importing and Exporting an LCC File"Importing and Exporting an LCC File

Relex supports importing and exporting of Life Cycle Cost files.xe "Life Cycle Cost files" The procedure for importing and exporting LCC data is described in the section titled “Importing and Exporting Procedure”.

Importing Data into an LCC File

In order to import data into a Life Cycle Cost file, you must first have either all files closed in Relex, or a Life Cycle Cost file open. If you are importing into an open Life Cycle Cost file, select File>Import from the main menu, and step through the Import/ExportWizard. Because the file is open and active, Relex automatically assumes that the data you are importing is to be included in the active Life Cycle Cost file. If you are importing when all files are closed in Relex, select File>Import from the main menu and select Life Cycle Cost as the Relex database type you wish to create or update by importing. When importing data into a Life Cycle Cost file, you may import an entire Life Cycle Cost file, including the cost breakdown structure (CBS). To do so, your source file must include the CBS data and the alternatives, intervals and variables data. You may also choose to import only the cost breakdown structure. Allow the CAD Import/ExportWizard to step you through the process of importing LCC data. 

Exporting Data from an LCC File

In order to export LCC data from an LCC file, select File>Export from the main menu while the particular LCC file is open and active. Allow the CAD Import/ExportWizard to step you through the process of exporting CBS, alternative, interval and/or variables data. You must specify whether you want to export the entire LCC file (including CBS, alternatives, intervals and variables data) or only the cost breakdown structure data.

xe "Importing and Exporting Fault Tree Data"Importing and Exporting Fault Tree Data

You may import Fault Tree data either as a new top gate or as an input of the currently selected gate. The rest of the import process is described in the section titled “Importing and Exporting Procedure”.

When exporting Fault Tree data, you may export all Fault Trees in the Project file, the currently selected Fault Tree, the currently selected gate or event with all children, or the currently selected gate or event without children. The rest of the export process is described in the section titled “Importing and Exporting Procedure”.

Importing and Exporting Other File Types

In addition to the standard importing and exporting of data, Relex also handles importing and exporting some unique file types. The special import/export cases Relex supports are:

· Importing thermal dataxe "Thermal Data" \r "D2HBThermal_Data16"

xe "Importing Thermal Data" \r "D2HBImporting_Th15" from a thermal analysis program.xe "Thermal Analysis Program"
· Importing stress dataxe "Stress Data" \r "D2HBStress_Data16"

xe "Importing Stress Data" \r "D2HBImporting_St15" from a stress analysis program.xe "Stress Analysis Program" \r "D2HBStress_Analy16"
· Exporting LSAR dataxe "Exporting LSAR Data" \r "D2HBExporting_LS15" to a logistics program.xe "Logistics Program"
· Importing Relex files from a version of Relex prior to 6.0.

· Importing RPP files.xe "RPP Files"

xe "Importing RPP Files"
· Importing and exporting Mentor Graphics files.xe "Mentor Graphics Files"
Importing Thermal Data from a Thermal Analysis Program

Relex allows you to update an existing Project file with thermal information from an outside source. This information can be generated from a thermal analysis package or from any other source.

When thermal analysis information is to be imported, follow the standard steps for an advanced import. The import of thermal analysis data requires that you select a format or Settings file.xe "Settings file" There are two standard thermal import Format files predefined for you:

· Temperature Rise:xe "Temperature Rise" imports temperature rise values.

· Temperature Override: imports temperature override values.

The thermal analysis data needs to be in the following format: reference designator followed by a comma and temperature value (either rise or override). An example thermal import file is shown below:

U1, 27.0

U2, 36.2

R1, 6.5

C1, 0.5

xe "Analysis files"Import of BetaSoft Thermal Analysis Files 

Relex can automatically import BetaSoft files. BetaSoft is a thermal analysis package that is distributed by Relex Software Corporation.xe "Relex Software Corporation" The import process allows you to update an existing Project file with temperature data from the BetaSoft thermal analysis file. To automatically import a BetaSoft file into an existing Relex Project file, follow these steps:

1. Open the Relex Project file that is to be updated.

2. In the System Tree window, select the assembly to be updated.

3. Select File>Import from the main menu.

4. Select the BetaSoft file to be imported and select <Import> to begin the import process (BetaSoft output files end with an .out extension).

5. In the ImportWizard, select Update the selected assembly and press <Next>.

6. From the list of file types displayed by the ImportWizard, select BetaSoft and press <Next>.

7. At this point, Relex automatically handles all mapping regarding the BetaSoft file, and displays an option for the import settings to be saved for future use. Select <Finish> to complete the import.

The update process during the BetaSoft import is based on the reference designator of the components in the assembly. Each component is updated with the junctionxe "Junction" temperature values from the BetaSoft file. These values are placed in the Junction Temperature Override field in Relex.

Importing Stress Data from a Stress Analysis Program

Relex allows you to import files containing operating stresses of your components, which have been generated from stress analysis programs or any other source. Similar to importing thermal data, Relex allows you to update an existing Project with stress information.

When stress analysis information is to be imported, follow the standard steps for an advanced import. The import of stress analysis data requires that you select the Operating Stresses Format file. This Format file, supplied with Relex, expects the stress analysis data to be in a delimited text filexe "Text file" with a listing of reference designators followed by the associated stress value.

The stress values imported for each of the part types are predefined as follows:

	Part Type
	Value

	Integrated Circuits, except SAW 
	Temperature Rise

	Semiconductor
	Temperature Rise

	Resistor,xe "Resistor" except Network (RZ)
	Operating Power

	Network Resistor (RZ)
	Temperature Rise 

	Capacitorxe "Capacitor"
	DC Voltage

	Inductor 
	Temperature Rise

	Rotating Device
	Temperature Rise

	Switches, except Circuit Breaker
	Load Current 

	Relay, except Solid State
	Load Current

	General and Printed Circuit Board Connectors
	Temperature Rise

	User-Defined
	Temperature Rise

	Mechanical Part, Seal 
	Temperature Rise

	Mechanical Part, Bearing
	Radial Load

	Mechanical Part, Gear, Spline
	Operating Speed

	Mechanical Part, Filter 
	Temperature Rise 

	Mechanical Part, Piston 
	Temperature Rise

	Mechanical Part, Diaphragm 
	Temperature Rise

	Mechanical Part, Winding 
	Temperature Rise 

	Mechanical Part, Threaded Fastener (Screw)
	Temperature Rise 

	Mechanical Part, Poppet, Spool, Shaft 
	Actual Flow 


xe "Logistics Program"Exporting LSAR Data to a Logistics Program

The LSAR filesxe "LSAR files" are ASCII files that conform to MIL-STD-1388 2B and are used for Logistics Support Analysis Record information and for importing into LSAR software packages. LSAR data can be exported from Relex automatically.

To export LSAR data, follow the normal steps for exporting using the CAD ExportWizardtm. When prompted to select the type of export, select LSAR. The LSAR export automatically exports the LSA data to a MIL-STD-1388 2B format.

Note: Be sure to include the LCN (Logistics Control Number) data for each assembly and part in the file if you intend to export the data from Relex to the LSAR format.

Importing Relex Files from an Older Version of Relex

Relex can automatically convert data files created with older versions of Relex. This conversion process is handled through a conversion utility accessed from Tools>Convert on the main menu. For more information on converting, refer to the “Getting Started” chapter of this manual.

xe "RPP Files"

xe "Importing RPP Files"Importing RPP Files

Relex can automatically import data files created with RPP. This conversion process is handled through a conversion utility accessed from Tools>Convert on the main menu. For more information on converting, refer to the “Getting Started” chapter of this manual.

xe "Mentor Graphics Files"Importing and Exporting Mentor Graphics Files

The Relex Import/Export module allows you to import Mentor Graphics Board Architect schematic dataxe "Mentor Graphics Board Architect schematic data" into Relex in order to create a project and perform reliability prediction calculations.xe "Reliability Prediction Calculations" It also allows the exporting of reliability prediction data from a reliability Project file to a schematic within Board Architect. Please reference documentation contained on your Relex CD for detailed instructions.

Importing and Exporting Details

The following sets of instructions provide information specific to the importing and exporting of certain types of files. The general steps for importing and exporting are described in the section titled “Importing and Exporting Procedure”. The instructions contained in this section are special instructions applicable for only certain file types.

This section includes details on:

· Importing and exporting of Delimited text files 

· Importing and exporting of BOM text files 

· Importing and exporting of Keyword text files 

· Importing and exporting of spreadsheet files

· Importing and exporting database files

· Importing and exporting an entire Project file 

· Special Notes

Importing and Exporting Delimited Text Files

Delimited files,xe "Delimited files" sometimes referred to as ASCII delimited text files, are text files with fields of information separated by a separator called a delimiter. Common delimiters include commas and tabs. Delimited files are very standard throughout the industry and can be generated as output from nearly any database, spreadsheet, word processor, or CAD program. An example of a delimited file is shown below:

74SL00, 1, U1

74LS04, 2, U2-U3

2N2222, 1, Q1

In this example, you see that each line of information represents an individual record in Relex. For that reason, importing this file would result in three part recordsxe "Part Records" being added to a Project or Library file. Each line in this example includes three data values separated or delimited by commas. In this example, each line includes a part number, quantity, and reference designator. Below is an example of the same delimited file in a slightly different form:

"74LS00", 1, "U1"

"74LS04", 2, "U2-U3"

"2N2222", 1, "Q1"

This file includes quotation marks (") around string fields (part number and reference designator). The quotation marks in this case are referred to as text qualifiers. Some text files include qualifiers and others do not. Relex accepts either type of delimited text file.xe "Text file" \r "D2HBText_file19"
Importing a Delimited Text File

When importing a delimited text file, the Relex CAD ImportWizardtm requests information regarding the delimiters and qualifiers. Sample data is displayed, and columns are designated based on the currently selected delimiter. If the information in the columns is not divided properly, switch the selected delimiter to view the outcome of the change. During the import process, the CAD ImportWizardtm also asks for information regarding additional lines that may be included in the import. Sometimes a file may have an extra header or footerxe "Footer" line. If you specify that there are headers or footers, Relex ignores these lines of information during the import process.

Exporting a Delimited Text File

When exporting a delimited text file, the Relex CAD ExportWizardtm requests information regarding the delimiter and text qualifiers. You may select from a list of standard delimiters (comma, semicolon, etc.), and you may also select from a standard list of qualifiers (single quote, double quote, or no qualifier). 

Importing and Exporting BOM Text Files

Bill of Materials (BOM) filesxe "Bill of Materials (BOM) files" are fixed-format ASCII files where each data value appears in a fixed-width column. This type of file can often be generated as output from a CAD program. Below is an example BOM file:

74LS00 1 U1

74LS04 2 U2-U3

2N2222 1 Q1

The main feature of a BOM file is its columnar format. Each line or record is formatted identically.

Importing BOM Text Files

When importing a BOM file, you may also specify header and footer information, and Relex ignores these lines of information during the import process.

Also, when importing BOM files, Relex attempts to examine the file and determine where column breaks occur. A diagram of the file is displayed and the columns are marked with vertical lines. Review these column markers for correctness. If the columns need to be adjusted, follow the instructions to format them correctly. The options for editing the column markers are as follows:

	Column Editing Option
	Keystroke Required

	Add a field break
	Click your mouse in the table at the location of the new marker.

	Move a field break
	Click and drag the vertical line to its new location.

	Delete a field break
	Double-click your mouse on the vertical marker that is to be removed.


Exporting BOM Text Files

During the export of BOM text files, you are responsible for confirming that the column settings are suitable for the target file. For each Relex field, you must identify the starting and ending column and whether the field is either left or right justified. You can accept the default settings that Relex generates or edit the column settings to suit your needs.

xe "Keyword files"Notes Regarding Importing and Exporting Keyword Files

Keyword files are free format ASCII files that have keywords for each field of information. An example keyword file is displayed below:

pn=74LS00, qty=1, ref=U1

pn=74LS04, qty=2, ref=U2-U3

pn=2N2222, qty=1, ref=Q1

As shown in this illustration, each line of the file consists of one record. Each data value in each record is labeled with a keyword. This keyword designates the data field the value is associated with. The values in each line do not need to be in the same order because each data value is labeled. 

When importing data in a Keyword file using the CAD ImportWizardtm, you are asked if you are using a Keyword Format file. A Keyword Format file is necessary only if the keywords used in your keyword file (the source file for the import) are not the same as the Relex default keywords. A list of the general Relex keywords and keywords for all specific fields are supplied on the Relex CD in the CAD Interfacexe "CAD Interface" Supplement. For example, in your keyword file, you may want to use keywords like p/n and refdes to represent part number and reference designator. The default keywords in Relex are pn and ref. The Keyword Format file allows you to give Relex a list of alternate or replacement keywords when analyzing your keyword file.

The process of creating a Keyword Format file is very simple. The file can be created using a text editor (or word processor with the capability of saving the file as a text file). 

The first line of the Keyword Format file consists of a comma (,), which is the delimiter to be used to separate the fields of information when importing or exporting. Next is a quotation mark (") which designates the text qualifier which is to be used when importing or exporting. The text qualifier encloses text items included in the keyword file.

Below is a sample Keyword file that instructs Relex to recognize p/n instead of pn as the keyword for part number, and to use refdes in place of ref for reference designator.

, "

pn, p/n

ref, refdes

When importing from or exporting to a keyword file, you find that the Relex CAD Import/ExportWizardtmxe "CAD Import/ExportWizardtm" requests less information than other file types. When exporting, Relex automatically exports all data fields, so there is no need to specify the fields to be exported. When importing, Relex recognizes the data in the file based on the keyword assignments, so there is no need to specify field mappings. 

Importing and Exporting Spreadsheet Files

Excel Prior to Version 5 Files

Excel files are program specific files that are created by the Microsoft Excelxe "Microsoft Excel" program. The Relex CAD Interface supports several different versions of Microsoft Excel. When exporting information from Relex using the CAD ExportWizardtm, Microsoft Excel files version 5 and above requires that a sheet be defined in the Excel file. Relex automatically requests this additional information. This sheet is not required for older versions of Microsoft Excel.

Importing an Entire Project from Microsoft Excel Version 5.0 or Higher

When importing an entire Project filexe "Importing an Entire Project File" \r "D2HBImporting_an20" from Microsoft Excel Version 5.0 and higher, Relex requires the following:

· All of the information regarding the Project must be in the same set of worksheets (within the same Excel file).

· All System Tree information must be placed in one worksheet.

· Parts lists for each assembly must be defined in their own worksheet.

· The name of the worksheet designates the name assigned to assemblies.

xe "Lotus"Exporting an Entire Project from Microsoft Excel Versions 3 & 4 or Lotus 1-2-3 WK1

When exporting an entire Project file to Microsoft Excel Versions 3 & 4 or Lotus 1-2-3 WK1, Relex creates the following:

· All of the files associated with the project are combined in one directory referred to as the target directory.

· A separate file is created for the System Tree information.

· Parts lists for each assembly are defined in a separate file for each assembly.

· When exporting, it is recommended that the target directory be empty.

Importing and Exporting Database Files

xe "Paradox"

xe "dBASE"Exporting an Entire Project from dBASE or Paradox

When exporting an entire Project file from dBASE or Paradox, Relex creates the following:

· All of the files associated with the Project are combined in one directory, referred to as the target directory.

· A separate file is created for the System Tree information.

· Parts lists for each assembly are defined in a separate file for each assembly.

· When exporting, it is recommend that the target directory be empty.

Importing an Entire Project File

When importing an entire Project file, you must provide Relex with the System Tree structure information and the parts or components for each assembly in the Project file. If you are importing from a delimited text file,xe "Text file" Relex expects the information to be in the format described as follows.

For this illustration, the following structure is used:

TOP


BOX 1



CARD 1 



CARD 2


BOX 2



CARD 3



CARD 4

For this example, assume that every component of the System Tree has 2 individual parts associated with it that need to be imported. Each assembly includes part numbers 2N2222 and 74LS00 with various quantities.

In the delimited file, the information must appear as System Tree structure first, followed by details for each assembly.

The following fields for the System Tree are to be imported:



Name (the name of the assembly in the System Tree)



Level (meaning the indenture level in the hierarchical structure of the system tree)

The following fields are to be imported for each part in each assembly:



Part Number



Quantity

The following example shows how the data appears for a delimited text import.

Example Delimited File

To import our example using a delimited text format, the file appears as follows (this example is tab delimited for easier viewing):

	0 TOP
	This is the beginning of the System Tree structure data.

	1

BOX 1
2

CARD 1
2

CARD 2
	The first item located in column 1 (1), is the Level of the item. The top level of the system is marked with a zero. All other levels increment by 1.

	1

BOX 2
2

CARD 3
2

CARD 4
	The second element located in column 2 (Box 2) is the assembly name.

	[TOP]
2N2222

1
74LS00

2
[BOX 1]
2N2222

2
74LS00

2
	After the System Tree structure information has been defined, assembly components are specified. The first assembly in this example is named TOP. The assembly name must be enclosed in brackets. The parts included in that assembly are then listed after the assembly name.

	[CARD 1]
2N2222

1
74LS00

3
[CARD 2]
2N2222

4
74LS00

1
[BOX 2]
2N2222

1
74LS00

2
[CARD 3]
2N2222

3
74LS00

2
[CARD 4]
2N2222

1
74LS00

1
	The first element located in column 1 is the part number. The second element located in column 2 is the quantity.

Note: If an assembly in the import does not include any parts, it is not necessary to list it in this portion of the import. It only needs to be listed in the System Tree structure portion.


Hints Regarding Importing of an Entire Project from a Program Specific File

When importing an entire Project file, you must provide Relex with the System Tree structure information and the parts or components for each assembly in the Project. If you are importing from a program specific file like Microsoft Excel,xe "Microsoft Excel" Lotusxe "Lotus" 1-2-3, Xbase, or Paradox,xe "Paradox" Relex expects the information to be in the formats described in the following sections.

For Microsoft Excel Version 5.0 and Higher

When importing an entire Project file from Microsoft Excel Version 5.0 and higher, Relex expects the following:

· All of the information regarding the Project must be in the same set of worksheets.

· All System Tree information must be placed in one worksheet.

· Parts lists for each assembly must be defined in their own worksheet.

· The name of the worksheet designates the name assigned to assemblies.

xe "dBASE"dBASE, Paradox, Microsoft Excel Versions 3 & 4, and Lotus 1-2-3 WK1

When importing an entire Project file from one of these file formats, Relex requires the following:

· All of the files associated with the project must be combined in one directory, referred to as the source directory.

· A separate file must be created for the System Tree information.

· Parts lists for each assembly must be defined in a separate file for each assembly.

Special Notes

xe "Support of Text Entries with Hard Returns"Support of Text Entries with Hard Returns

Importing and exporting text files in Relex supports multi-line fields. For instance, you may want to export a multi-line field such as remarks to a text file.xe "Text file" In this case, Relex inserts a | (pipe character) in the place of each hard return. Also, on importing Relex automatically interprets the | (pipe character) as a hard return.

Note: This applies to text files only (keyword files,xe "Keyword files" delimited files,xe "Delimited files" and BOM files). This feature does not apply to program specific files (like Excel, Access, or dBASE).
Importing Part Numbers Not Found in Active Libraries

Any time an imported part number is not located in the active libraries, Relex adds the part with a category of Other and a subcategory of User-Defined. Once imported, you can edit these parts and select the correct category and subcategory. Alternatively, you can specify the category and subcategory of the part in the source file. If the source file is a keyword text file, the category and subcategory can be assigned the appropriate string names. For other file types, the category and subcategory may be referenced as an integer value or string value. For a complete list of these integer values refer to the CAD Interfacexe "CAD Interface" Supplement on the Relex CD. For additional information regarding the import/export of choice list fields from/to descriptive strings, refer to the next section.

Importing and Exporting Choice List Fields as Descriptive Strings

By default, choice list fields are exported as integer values. Likewise, by default, Relex expects integer values for choice list fields when importing. Relex does allow the option to import and export using string values rather than integer values.

When importing data, you must specify whether the choice list fields in the file are defined as integer values or descriptive strings. This specification is required during the import process when the source file type is identified (enable the checkbox next to the statement, “I am importing choice list fields as descriptive strings”). For example, instead of including the integer value 1 in the Category field to specify a part as an Integrated Circuit, you may include string text such as Integrated Circuit. You may even include partial strings (i.e. Cap for Capacitor) as long as the partial string contains enough characters to make it unique in the event of similar choice list options.

Note: This feature does not apply when importing source files that are BetaSoft files or Keyword files.

You can also specify to export choice list fields as descriptive strings, rather than integer values. When specifying the target file during the export process, enable the checkbox next to the statement, “Export descriptive strings for choice list fields”. 

Note: This feature does not apply when exporting to Keyword files.

xe "Advanced Importing" \r "D2HBAdvanced_Imp23"Advanced Importing and Exporting

The CAD Import/ExportWizardtmxe "CAD Import/ExportWizardtm" is designed to step you through the process of properly selecting and formatting data for import or export. However, you may wish to bypass the step-by-step instructions. This is very common if you repeat the same import or export on a regular basis. 

The final step of every import or export allows you to save a Settings filexe "Settings file" \r "D2HBSettings_fil23" that contains all information regarding the import or export. This is the information Relex gathers during the use of the CAD Import/ExportWizardtm. Upon saving a Settings file, Relex also saves a Format file, which stores the field mapping information. The Settings files and Format files are explained further in the next two sections.

Settings File

The Settings file that is created by the Import/ExportWizardtm contains all information regarding the import or export process. A Settings file for an import includes, for instance, the name of the file being imported (source file), the name of the file to be created (target file), and the Format file used for the import.

Format File

In Relex, a Format file serves as a template which tells Relex what type of information is being imported or exported, the order of the fields of information of that data, and other information about the format of the data. It can save you time in the field mapping process. During the process of importing or exporting, the CAD Import/ExportWizardtm can automatically create the Format file for you.

Once you have successfully imported or exported information, you have the option to save the format of the import or export for future use by saving the settings. The Relex generated Format file is saved for you automatically when you save the settings of an import or export.

Note: Depending on the type of import or export, Relex may create multiple Format files. For example, Relex creates a tree Format file for assembly data and a Format file for part data when importing or exporting an entire Project file.

The easiest way to access a saved Format file is to select it on the field mapping window during the import process or the field selection window during the export process. Selecting the Format file via the <Read Format> button simplifies the field mapping or field selection process. This immediately recognizes the order of the fields to be imported or exported. When importing, the fields are mapped automatically. When exporting, the list of fields is included in the Fields to Export list automatically. 

Advanced Importing

The following is a step-by-step procedure for importing a file into Relex using the advanced features option. These steps are consistent for all types of imports. 

1. Select File>Import from the main menu or select Import from the right mouse menu. 

2. Select the file to be imported from the list that appears. To use the advanced import press <Advanced>.

3. The Advanced Import window appears, including the following tabs:

	Tab
	Tab Description

	Files
	Allows you to specify the source file name and type, and the target file name and type. Use the <Browse> button, as needed.

	Format

FMEA Format

Maintainability Format
	Allows you to specify the Format file for the prediction, FMEA or maintainability data. It also allows you to specify whether the import is meant to append data or update records. You may save the settings of the current import with the <Save Settings> button. You may access previously saved settings via the <Get Saved Settings> button. By accessing previously saved settings, the pertinent data on all the tabs of the Advanced Import window is populated automatically.

Note: Only one of the three tabs is selected at any given time. The tab selected is based on the selection made on the Project Options tab identifying the part data as prediction, FMEA or maintainability data.

	Calculation Parameters
	Allows you to specify the calculation modelxe "Calculation Model" and method if importing to a Project or Library file.

	Project Options
	Allows you to specify the type of Project import, if applicable. The data to be imported may represent the whole project, the System Tree only or one assembly. If part data is being imported, you must also specify whether that part data is prediction, FMEA or maintainability information. You may identify the Tree Format file as needed on this tab.

	LCC Options
	Allows you to specify the type of LCC import. The data to be imported may include the CBS, alternative, intervals and variables data, or may represent only the CBS. You must also specify the appropriate Format files (CBS, alternatives, intervals, and variables). Lastly, specify whether the import is meant to append data or update records.

	Fault Tree Options
	Allows you to specify the type of Fault Tree import. The data can be imported as a new top gate or as an input to the selected gate.
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Figure 5 - 7. Advanced Importing

4. After all information has been properly assigned, press <OK> to complete the import. The import proceeds from this point as described in the section titled “Importing and Exporting Procedure”.

Note: If you know that you want to perform the exact process that was performed in a previously saved import or export, you can select File>Import from the main menu. When the window appears to select the file for importing, select Files of Type for display as Relex Import/Export Settings. From the list of files displayed, select the name of the saved Settings file that was used in the previous import or export, and press <Import>. By following these steps, you completely bypass the use of the CAD Import/ExportWizardtm.xe "CAD Import/ExportWizardtm" 

xe "Advanced Exporting" \r "D2HBAdvanced_Exp25"Advanced Exporting

The following steps walk you through the process of exporting a filexe "Exporting a File" from Relex using the advanced feature. These steps are consistent for all types of exports. 

1. Select File>Export from the main menu or select Export from the right mouse menu. This starts the CAD Export process. As a general rule, Relex assumes that you wish to export the information for the active file. For instance, if your cursor is located in the Parts Table, Relex assumes that you wish to export the contents of the Parts Table for the selected assembly. In the case of a Project file, if the System Tree is selected, Relex verifies what information is to be exported. You are asked if you intend to export the selected assembly, the entire tree, or the system hierarchy information. If this additional information is requested, answer the questions. On this window, you may also select to <Use Saved Settings> or you may press <Advanced> to access the Advanced Export tab.

2. The Use Saved Settings option allows you to select a previously created Settings file. The information in that Settings file (including file names and locations, file types, format information, and system information) is used to complete an export. Upon pressing <Use Saved Settings> you are asked to specify the name of the Settings file. Once the file is selected, press <Open> and Relex performs the export. 

3. The Advanced Export window appears if the <Advanced> button is pressed. The Advanced Export window includes the following tabs: 

	Tab
	Tab Description

	Files
	Allows you to specify the target file name and type. Use the <Browse> button. The source file and type are populated based on the Relex file from which data is to be exported.

	Format

FMEA Format

Maintainability Format
	Allows you to specify the Format file for the prediction, FMEA or maintainability data. You may save the settings of the current import with the <Save Settings> button. You may access previously saved settings via the <Get Saved Settings> button. Only one of the three tabs is selected at any time.

	LSAR
	Allows you to specify the Update Code (UC) and/or End Item Acronym Code (EIAC) if exporting to the LSAR format. If the target file type was not identified as LSAR format on the Files tab, then this tab is blank.

	Project Options
	Allows you to specify the type of Project export, if applicable. The data to be exported may represent the whole Project, the System Tree only or one assembly. If part data is being exported, then you must also specify whether that part data is prediction, FMEA or maintainability information. You may identify the tree Format file as needed on this tab.

	LCC Options
	Allows you to specify the type of LCC export. The data to be exported may include the CBS, alternative, intervals and variables data, or may represent only the CBS. You must also specify the appropriate Format files (CBS, alternatives, intervals, and variables).

	Fault Tree Options
	Allows you to specify the type of Fault Tree export. You can export all fault trees, the current fault tree, the current selection with children, or the current selection w/o children.
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Figure 5 - 8. Advanced Exporting

4. After all information has been properly assigned, press <OK> to complete the export. The export proceeds from this point as described in the section titled “Importing and Exporting Procedure”.

Note: Once a Format file is selected, you may manually edit it by pressing the <Edit> button.

Chapter 6 Common Features

xe "Macro Function"Macro Function

Macros can be used to automate repetitious or time-consuming tasks. In these cases, macros can be used to run the process automatically. A few examples of tasks that can be automated by using macros are:

· Importing or exporting data into Relex.

· Performing a find and replace on a key word or phrase throughout a Project file.xe "Project file"
· Performing various global changes,xe "Global Changes" and outputting reports on each of the changes.

· Calculating a very complex RBD with a large number of simulationxe "Simulation" iterations.

· Clearing data from a particular field in every record of a Project file.

· Converting a series of Relex files from a previous version.

Processes that can be completed by accessing the Relex menu commands can be completed with a macro.

Relex uses the Visual Basic for Applications (VBA) Language for the creation of macros. Macros are generally written using Relex’s Macro Editor,xe "Macro Editor" \r "D2HBMacro_Editor1" but you may also write Relex macros using a third party application that supports OLE Automation, such as Microsoft Excel.xe "Microsoft Excel" There are basically two types of macros that can be created in Relex:

xe "Document Interface Macro"Document Interface Macro

A Document Interface Macro is designed to operate on a specific document (i.e., a Project file, Library file, Correlation file, etc.). When a Document Interface Macro is run, the file on which the macro is operating is never displayed. Instead, all processes occur in the background. These types of macros are generally initiated from a blank screen in Relex, through Microsoft Explorer, or from a DOS batch file.

xe "Command Macro"Command Macro

A Command Macro is generally designed to perform repetitive tasks that include a combination of basic commands from the menu and toolbar. 

Macro Editor

A Macro file is created by selecting File>New>Other>Macro from the main menu. After assigning a file name to the macro, the macro editor displays. The Macro Editor window is divided into three main areas:

xe "Immediate Window" \r "D2HBImmediate_Wi2"Immediate Window

The Immediate window is used to evaluate an expression, assign a variable, or call a subroutine. It allows you to evaluate any basic statement and attain immediate results. It can be useful while debugging.

Examples:

· Type “?expr” <ENTER> to show the value of “expr”. For example, typing “?1+1”<ENTER> yields a result of “2”.

· Type “var=expr” <ENTER> to change the value of “var”.

· Type “Set var=expr” <ENTER> to change the reference of “var”.

· Type “subname args” <ENTER> to call a subroutine or built-in instruction.

· Type “Trace” <ENTER> to toggle trace mode. Trace mode prints each statement in the immediate window when a macro/module is running.

xe "Object and Proc Lists"Object and Proc Lists

The Object listxe "Object list" shows all the objects for the current module (the Macro file that is being edited). The Proc listxe "Proc list" shows all the procedures for the current object. Note the following:

· The (general) object groups all of the procedures that are not part of any specific object.

· Selecting a procedure that is not bold inserts the proper procedure definition for that procedure.

xe "Edit Area"Edit Area

The current macro/module is edited/viewed in this area. Note the following:

· Macros/modules that are not currently loaded may be edited.

· Changes to a line are automatically capitalized and highlighted when a different line is selected.

· Break points may be toggled on/off. A dot at the front of the line indicates a break point. To set or remove a breakpoint, place your cursor on the line where the breakpoint is to be added or removed and select Debug>Toggle Break from the main menu (or press F9).

The built-in help system assists with specific instructions regarding the Basic editor and language. For general information regarding Basic, press <F1> in a new macro. 

Supplied Example Macros

Several macros are supplied with Relex for reference. It is recommended to review these files before creating your own. This supplies you with a basic understanding of the programming language and use of syntax.xe "Syntax" Refer to the Docs directory on your Relex CD for a listing and description of the supplied macros.

xe "Macro Browse Feature"Macro Browse Feature

In addition to using the supplied Macro filesxe "Macro files" for reference, the Relex macro editor includes a browse feature to offer additional assistance. The browse feature lists each of the methods/properties that are available, and provides a brief description of each. To access this feature, select Debug>Browse from the main menu, or from the right mouse menu. The items on the Object Browser window are described as follows:

	Item
	Description

	<BACK>
	Backs up to the previous item.

	<PASTE>
	Pastes the current method/property into the Edit or Immediate window.

	Library
	List of all the libraries.

	Data Type
	List of all the special data types.

	Methods/Properties
	List of all methods/properties for the current data type.

	Help String
	Displays a short description of the method/property.

	<?>
	Accesses context sensitive help regarding the selected command.

	<CLOSE>
	Closes the OLE Automation Members window and returns to the macro.


xe "Running a Macro"Running a Macro

Once a macro is created, it can be run in any of the following ways:

· Select Tools>Run Macro from the main menu, and select the name of the macro to be run.

· Double-click on the Macro file using Microsoft Explorer.

· Call the Macro in a DOS Batch file as follows: 

relex /run “filename.rmc”

Debugging

The macro editor in Relex includes debugging capabilities. With a Macro file opened, the following options are available from the Debug menu:

	Option
	Description

	Step Into
	Execute the current line. If the current line is a subroutine or function call, stop on the first line of that subroutine or function. (If the macro is not active,xe "Active" start it.)

	Step Over
	Execute the next line. If the current line is a subroutine or function call, execute that subroutine or function completely.

	Step Out
	Step out of the current subroutine or function call.

	Step to Cursor
	Execute until the line of your cursor is on the current line. (If the macro is not active, start it.)

	Toggle Break
	Set or remove break point on the current line.

	Clear All Breaks
	Clear all break points.

	Quick Watch
	Show the value of the expression under your cursor in the immediate window.

	Add Watch
	Add the expression under your cursor in the watch window.

	Browse
	Show the methods of the expression under your cursor.

	Set Next
	Set the next statement to be executed. Only statements in the current subroutine/function can be selected.

	Show Next
	Show the next statement to be executed.


The debug process in Relex involves the use of other tabbed windows in the top portion of the macro editor. These windows are described as follows:

Watch Window

The Watch window lists the variables, functions and expressions that are used and whose values you wish to view as the macro is executed. Note the following:

· Each time execution pauses, the value of each line in the window is updated.

· The expression to the left of -> may be edited.

· Pressing <Enter> updates all the values immediately.

· Pressing <CTRL + Y> deletes the line.

xe "Stack Window"Stack Window

The Stack window lists the functions executed up to the current statement. Note the following:

· The first line is the current statement. The second line is the one that called the first, and so on.

· Clicking on a line brings that macro/module into a tab and highlights the line in the edit window.

xe "Loaded Window"Loaded Window

The Loaded window lists all of the currently active macros and loaded modules. Note the following:

· These macros/modules are locked and can only be viewed (not edited).

· Clicking on a line brings that macro/module into a tab and activates the tab.

Checking Syntax

The macro editor in Relex also provides the opportunity to check the syntax of the macro. To do this, select Macro>Check Syntax from the main menu. If any errors are found, the errors are highlighted in red, and an error message appears.

xe "Stopping a Macro"Stopping a Macro

When a macro is running, the macro icon appears in the Windows taskbar. To stop a macro while it is running, double-click on the macro icon.

Important Notes Regarding Macros

· Refer to the supplied Relex macros as a guide when creating your own macros, and access the online macro help by pressing <F1> for additional instruction.

· If a dialog box appears while a macro is executing, the macro pauses until you dismiss the dialog. There is no way to automate the dismissal of a dialog box. This is to be taken into consideration during the planning and programming of a macro.

· If a macro is being used to edit or change data in a file, it is recommended that a backup copy be made of the file being changed. There are no safety checks or validation procedures performed while executing a macro, so you could inadvertently end up with invalid data in your file.

· If performing an import or export with a macro, the saved settings from a previous import/export can be used. In this case, the macro needs to include the Load command, the name of the saved Settings file,xe "Settings file" and the Run command. 

xe "Spell Check"Find, Replace, & Spell Check

Relex has the capability of performing a find, a search and replace,xe "Search and Replace" \r "D2HBSearch_and_R6" or a spell check. Each of these features are closely related, and therefore, share many of the same steps and procedures. The following sections describe each of the features in detail. 

Find

With your cursor in either the System Treexe "System Tree" or Parts Tablexe "Parts Table" window, select Edit>Find from the main menu. The Find window is displayed.

The Find window consists of several different tabs of options to allow full customization of the Find capability. The tabs are described in the section titled “Find/Replace/Check Spelling Windows”. After all options on all tabs are assigned as needed, press <OK> to begin the Find process. 

Note: Once a find is performed, <F3> can be pressed to do a find next using the same search criteria.

If you wish to perform a simple search for a specific part in the Parts Table, there is another option. First select the Parts Table as the active window. Select Locate Part from the right mouse menu or Assembly>Locate Part from the main menu. Supply the criteria for the part(s) you are interested in finding on the Locate Part window.
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Figure 6 - 1. Find Window

Search and Replace

The search and replace feature is very closely related to the find feature. With your cursor in either the System Tree or Parts Table window, select Edit>Replace from the main menu. The Replace window is displayed.

The Replace window consists of several different tabs of options to allow full customization of the replace process. The tabs are described in the section titled “Find/Replace/Check Spelling Windows”. After all options on all tabs are assigned as needed, press <OK> to begin the replace process. The options used throughout the search and replace process are described in the section titled “Find or Replace Tab
”.
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Figure 6 - 2. Search/Replace Window

Spell Check

The spell check feature is very closely related to the find and search and replace features. The Relex spell check feature includes a built-in dictionary of standard words and a custom Relex Dictionary that contains terms specific to reliability.

To begin a spell check, with your cursor in either the System Tree or Parts Table window, select Tools>Check Spelling from the main menu. The Check Spelling window is displayed.

The Check Spelling window consists of several different tabs of options to allow full customization of the spell check process. The tabs are described in the section titled “Find/Replace/Check Spelling Windows”. After all options on all tabs are assigned as needed, press <OK> to begin the spelling check. 
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Figure 6 - 3. Check Spelling Window

When a misspelled word is found, a window appears with the following fields:

	Option
	Description

	Word
	The misspelled word is displayed.

	Replace With
	This field contains the first recommended replacement for the misspelled word. If a different replacement is to be used, it can be typed in or selected from the list of suggestionsxe "Suggestions" below. Once entered, select <Replace> to replace the word.

	Suggestions
	This field contains a list of similar spellings. Any of the words in the list can be listed as a replacement for the misspelled word.

	Record
	Displays the record number in which the misspelled word was found.

	Table
	Displays the table in which the misspelled word was found.

	Assembly
	Displays the name of the assembly in which the misspelled word was found.

	Field
	Displays the name of the field in which the misspelled word was found.

	Field Text
	Displays the information in the field, and highlights the misspelled word.


On the misspelled word that is currently displayed, the following options are available from the buttons to the right:

	Option
	Description

	Ignore
	Skips this instance of the misspelled word and continues with the spell check. If another instance of the misspelled word is found, it is displayed.

	Ignore All
	Skips this instance of the misspelled word and continues with the spell check. If another instance of the misspelled word is found, it is also skipped automatically.

	Replace
	Replaces the misspelled word with the word that is displayed in the Replace With field to the left.

	Replace All
	Replaces the misspelled word (and all others identical to it) with the word that is displayed in the Replace field to the left.

	Suggest
	Alters the contents of the Suggestions field to more closely match the misspelled word.

	Add Word
	Used when the misspelled word is correctly spelled, but is not found in the available dictionaries. If <Add Word> is selected, the Add Word to Custom Dictionary appears. This window offers two possible options. Relex Custom Dictionary adds the word to the Relex Dictionary. User Custom Dictionary adds the word to the User Dictionary that was assigned under Tools>Options on the Settings tab.xe "Settings tab" If no User Dictionary is active in the Options, the Add Word to Custom Dictionary is disabled.

	Cancel
	Cancels spell checking.


Relex includes a Custom Dictionary of common reliability terms. The Custom Dictionary can be edited to include additional words, or new custom dictionaries can be created. A custom dictionary is a text filexe "Text file" that contains a list of words. Each word is on its own line in the file. A custom dictionary can be created in Relex by selecting File>New>Other>Text from the main menu. 

Find/Replace/Check Spelling Windows

Each of the individual tabs regarding the find, replace, and spell check features are described as follows:

xe "Replace tab"Find or Replace Tab

The Find tabxe "Find tab" displays when the find command is selected. The Replace tab displays when the replace command is selected. A description of each of the fields that display on the Find and Replacexe "Find and Replace" tabs (many of the fields are similar) is included in the following table:

	Option
	Description

	Find
	Displayed on the Find tab only. Enter the string of characters to be located.

	Search for
	Displayed on the Replace tab only. Enter the string of characters to be located.

	Replace with
	Displayed on the Replace tab only. Enter the string of characters that are replacing an occurrence of the string that is identified in the Search For field.

	Match Case
	If enabled, the search is case sensitive. If disabled, the search is not case sensitive.

	Replace all without Prompting
	Displayed on the Replace tab only. If enabled, as each match is found, it is automatically replaced. If disabled, each time a match is found, it is displayed and you have the option to replace or skip.

	Match 
	From the choice list, select one of the available options: 

	
	Any Part of Field. If enabled, Relex attempts to match the specified text string in any part of the fields being searched. Fields with extraneous characters are still considered a match. For example, “test” is found in “Testability Analysis”.

	
	Whole Field. If enabled, Relex attempts to match the specified text string to an entire field exactly. Fields with extraneous characters are not considered a match. For example, “test” is found in “test”, but not “Testability” or “Perform a test”.

	
	Whole Word. If enabled, Relex attempts to match the specified text string, and the entire word is required to be an exact match. For example, “test” is found in “Perform a Test”, but not in “Testability”.

	
	Start of Field. If enabled, Relex attempts to match the specified string to a field beginning at the start of the field. For example, “test” is found in “Testability”, but not “Perform a test”.

	Process Numeric Fields (convert to text)
	The find feature in Relex searches for the specified text string. For example, if Relex is asked to search for “1”, Relex does not find “1” in numeric fields such as Quantity. If this option is enabled, numeric fields are treated as text fields for the searching process. 


xe "Option tab"Option Tab

The Option tab displays only when performing a spell check. A description of each of the fields that display on the Option tab is included in the following table: 

	Option
	Description

	Ignore words in all capital letters 
	If enabled, Relex does not check the spelling of all words that are entered in all capital letters. This can be helpful if there are part numbers that consist of all capital characters.

	Ignore words containing any numbers
	If enabled, Relex does not check the spelling of any word that contains a numeric character. This skips the spelling of most part numbers.

	Ignore words composed of all numbers
	If enabled, Relex does not check the spelling of any word that is composed of all numbers. This skips all numeric fields and part numbers consisting of numbers only.

	Check hyphenated words separately
	If enabled, all portions of a hyphenated entry are spell checked separately.

	Require exact match (case sensitive)
	If enabled, Relex performs a case sensitive search.

	Recheck typed replacement words
	If enabled, Relex not only finds misspelled words that are in the Project, but also checks words that are entered to replace misspelled words.

	Spelling Preference
	This feature allows you to specify whether you prefer the American English or British English spelling.


xe "Tables tab"Tables Tab

The Tables tab displays when performing a find, replace, or spell check within a Project file. A description of each field on the Tables tab is included in the following table:

	Option
	Description

	System Tree Table
	If enabled, the search is performed on the Properties tabs of the assemblies in the System Tree window.

	Prediction/General Tables
	If enabled, the search is performed on the Parts Table and General Data tabs for all parts.

	FMEA Tables 

	If enabled, the search is performed on the FMEA Table for all parts and assemblies. In addition, other FMEA related files/tables can be selected for searching. These files include Modes file, Phrases file,xe "Phrases file" FIN Definitionxe "FIN Definition" file and Mission Profilexe "Mission Profile" file active in the current Project file. 

	Maintainability Tables 
	If enabled, the search is performed on the Maintainability Table for all parts and assemblies. In addition, other maintainability related files can be selected for searching. These files would include Tasks file,xe "Tasks file" FD&I Outputsxe "FD&I Outputs" file, and Maintainability Groups file activated in the current Project file. 

	Fault Tree Tables
	If enabled, the search is performed on the Fault Tree Table.xe "Fault Tree Table" In addition, other Fault Tree related files can be selected for searching. These files include the CCF Groups filexe "CCF Groups file" and Event Parameters filexe "Event Parameters file" activated in the current Project file.


Assemblies Tab

The Assemblies tab displays when performing a find, replace, or spell check within a Project file. A description of each field on the Assemblies tab is included in the following table:

	Option
	Description

	All Assemblies
	If enabled, all assemblies in the Project file are included in the search.

	Selected Assemblies
	If enabled, you can select from the list of assemblies in the Project file. The assemblies which are to be included in the search can be selected with your cursor and appear as highlighted when selected. At least one assembly must be selected if Selected Assemblies is enabled.


xe "Record Select tab"Record Select Tab

The Record Select tab displays when performing a find, replace, or spell check. Below is a description of each field on the Record Select tab:

	Option
	Description

	All Records
	All records in the file are searched for a match.

	Current Record
	Only the currently selected record is searched for a match.

	Range of Record Numbers
	Allows you to specify a selected range of records to be searched for a match.


Tree, Prediction/General, FMEA, LCC, Fault Tree & Maintainability Fields Tabs

The Fields tabs displays when performing a find, replace, or spell check within a Project file. Below is a description of each field on the Fields tabs:

	Option
	Description

	All Fields
	If enabled, all fields associated with the System Tree, Prediction/General, FMEA, LCC, Fault Tree or Maintainability are included in the search.

	Selected Fields
	If enabled, you can select from the list of fields available for that data type. The fields which are to be included in the search can be selected with your cursor and appear as highlighted when selected. At least one field must be selected if Selected Fields is enabled.


xe "Revision Control" \r "D2HBRevision_Con11"Revision Control

Relex includes the ability to track changes to Relex files. Revision control is a property of a file and is accessed by selecting View>File Properties from the main menu.

The Revision Control tabxe "Revision Control tab" includes three fields of information:

	Field
	Description

	Last User
	Automatically displays the computer name of the last user who made changes to the file.

	Revision
	Automatically displays the revision number of the current version of the file. This number automatically increments by one each time a change is made. If necessary, the revision number can be changed manually by typing the new value in this field.

	Comments
	Allows you to enter remarks regarding the particular revision.


Notes Regarding Revision Control

· The revision control history can be viewed by selecting View>Revision Listing from the main menu. The Revision Listing window appears displaying a chart that includes the revision number, user, date/time and comments of each revision.

· The revision control information can be included in report designs. The revision control information can be included as an ancillary report. For more information on including revision control information in a report, review the “Reporting and Graphing” chapter of this manual. 

· If a File>Save As is performed on a file, the revision control data on the new file is reset as though the file was newly created.

Opening a File as Exclusive

When opening a file in Relex, you have the option of opening that file with exclusive privileges. Once the file is opened exclusively, no one else can open the file until you have closed it. This is especially helpful in a network environment, where multiple users have the ability to share and edit files at the same time. The Open Exclusive option prevents a file from being opened by multiple users simultaneously.

To use this feature, follow these steps:

1. Select File>Open from the main menu.

2. Select the file name to be opened, enable the option in the lower left hand corner labeled Open Exclusive and press <Open>.

3. From this point, until the file is closed, no other user is able to access the selected file.

xe "Password Protection"Password Protection

Relex allows you to assign password protection to files. A password can prevent access to a file by other users, or it can limit access to read-only. The instructions for using password protection are included in the following sections.
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Figure 6 - 4. Set Password Window

xe "Assigning a Password" \r "D2HBAssigning_a_11"Assigning a Password

1. Open the file to be password protected. Select File>Set Password from the main menu.

2. The Set Password window is displayed. In the first field labeled “Enter the new database password here”, enter the desired password. Any combination of characters (alphanumeric and symbol) can be used, and it should be noted that the password feature is case sensitive. Therefore, it is important that you pay special attention to the use of upper and lower case.

3. After initially entering the password, re-enter the same password in the field labeled “Confirm the new database password by retyping it here”. Relex confirms that the password was entered identically in both fields.

4. Press <OK> to save the newly assigned password.

Note: Be sure to remember your password! If you forget it, you can not open the file.

xe "Read-Only Access"

xe "Allowing Read-Only Access"Allowing Read-Only Access

When password protecting a file, you also have the option of allowing other users to view a file in read-only mode if you do not have the password available. Follow these steps:

1. With the file open, select File>Set Password from the main menu.

2. As described in the previous section, the Set Password window appears for you to enter and confirm your password. If you want to allow other users without the password to be able to access the file in read-only mode, enable the checkbox labeled “Allow opening in read-only mode without password”.

3. Complete steps 2 & 3 from “Assigning a Password” to assign the password to the file.

4. Press <OK> to continue.

xe "Password Protected File"Opening a Password Protected File

1. Open the file as usual.

2. If the file is password protected, the Password Required window appears stating “This file is password protected. You must enter a valid password to open the file”. 

3. At this point, if the password is available, enter it in the Password field. If no password is available, but the option at the bottom of the window labeled “Bypass password and open read-only” is available, you can select this option and open the file in read-only mode. Press <OK> to open the file in a read-only mode. If this option is not available, and the password is not available, select <Cancel> to end this operation.

xe "Changing a Password"Changing a Password

To change the password associated with a file, you must have access to the original password. To change the password, follow these steps:

1. Open the file that is password protected as described in the previous section.

2. With the file open, select File>Set Password from the main menu.

3. When the Set Password window appears, the original password must first be entered. 

4. After entering the current password, you can change the password by entering the new password in the field “Enter the new database password here, leave blank to remove”. If you leave this field blank, the password protection is removed.

5. Confirm the new password in the field labeled “Confirm the new database password by retyping it here”. If you are removing the password, this field is also to be left blank.

6. Press <OK> to continue.

Chapter 7 xe "Reliability Prediction"Reliability Prediction

Introduction

A primary component of reliability analysis is referred to as the failure rate, or the number of failures expected during a certain period of time. Calculation of equipment failure rate, and the related MTBFxe "MTBF" (Mean Time Between Failuresxe "Mean Time Between Failures"), is the basis of the Relex Reliability Prediction Software. Relex performs reliability predictions and analyses on electrical, electronic, mechanical, and electro-mechanical equipment. Reliability mathematical models for nearly every conceivable device type are available in Relex, including everything from common parts such as integrated circuits and resistors to others such as laser devices, clutches, and bearings. The exact device types supported depend on your particular version of Relex. Relex allows you to evaluate the reliability of your equipment and to experiment with different methods of improving this reliability.

The Relex Reliability Prediction Software is available based on various standards, including Telcordiaxe "Telcordia (Bellcore)" (Bellcore) and MIL-HDBK-217.xe "MIL-HDBK-217" You may purchase these standards individually, or in combination. The use of Relex is the same regardless of the standard(s) that you have selected. Any important differences that apply to the various standards are reviewed where applicable.

Throughout this chapter, a particular Relex element, such as Relex Reliability Prediction, may be mentioned as if it were a separate software package. This is done for ease of explanation. Any of the Relex elements may be used independently, or in an integrated manner. This section is devoted to the explanation of the Reliability Prediction portion of Relex. 

This chapter is divided into the following sections:

Getting Started with Reliability Prediction

Provides introductory information regarding reliability prediction analyses, and offers a general list of steps to getting started with the Relex Reliability Prediction module.xe "Reliability Prediction Module" \r "D2HBReliability_1"
Reliability Prediction Reference

Provides detailed instructions for performing various tasks in the Relex Reliability Prediction module.

Reliability Prediction Calculationsxe "Reliability Prediction Calculations"
Provides instructions on performing calculations in Relex Reliability Prediction, along with an explanation of each of the calculations that can be performed.

Generating Reports in Reliability Prediction

Provides instructions for generating reports, and explains the various report options.

Getting Started with Reliability Prediction

What is the Goal of a Reliability Prediction Analysis?

A reliability prediction analysis is the analysis of parts and components in an effort to predict the rate at which an assembly or system will fail. The basis of the analysis is generally a reliability prediction model. There are several different models that exist, but the goal of each of them is the same. Reliability prediction modelsxe "Reliability Prediction Models" \r "D2HBReliability_2" offer standard equationsxe "Equations" that allow you to calculate the failure rate of components based on component data and parameters. These parameters often include (but are not limited to) environment, temperature, quality,xe "Quality" and stress. These parameters are used to establish pi factors,xe "Pi Factors" which are the variables used in the reliability prediction equations.

Once the individual failure rates for components are established, a simple summation of the component failure rates provides the failure rate for the higher level assemblies and system. 

How Do You Begin a Reliability Prediction Analysis?

Before you begin using the Reliability Prediction portion of Relex, it is important to understand how Relex operates, and how to make changes to the options to suit your needs. Refer to the “General” chapter of this manual for more information. This section outlines how to configure Relex to suit your needs using the settings under Tools>Options.

The “File Types” chapter of this manual discusses the Project file,xe "Project file" System Tree,xe "System Tree" and Parts Table.xe "Parts Table" The Project file is the top level of organization in Relex. The Project file contains all elements of a particular system. The System Tree and Parts Table are components of the Project file. The System Tree illustrates the structure of the system, and the Parts Table is used to enter the individual parts of each assembly. If you require additional assistance regarding entering information into a Project file, System Tree, or Parts Table, refer to the appropriate portion of the “File Types” chapter of this manual that describes these features in detail.

The next step in performing a reliability prediction analysis is to input the parts list of each assembly or system, and begin entering component data regarding each of the parts. This data is then used to compute the failure rate of the components, the higher level assemblies, and the entire system.

Activating the Reliability Prediction Module

Starting Relexxe "Starting Relex" \r "D2HBStarting_Rel2" is just like starting any Windows program. To start Relex, select Relex from the Start menu.

In order to access the Reliability Prediction module, first confirm that the Reliability Prediction option has been purchased and installed. Upon confirmation, you must also enable the Reliability Prediction capability. Follow these steps to verify that the Relex Prediction option is available with your Relex installation and enable the Reliability Prediction module, if necessary:

1. Close any files or windows that are currently open in Relex.

2. Select Help>About Relex from the main menu. Press the Authorized Options tab and confirm that reliability prediction is one of the listed authorized options. If the Reliability Prediction module has been installed, the list includes Reliability Prediction Base or Reliability Prediction Plus. Press <OK>.

3. Select Tools>Options from the main menu. Press the Product Options tab.xe "Product Options tab" Confirm that the checkbox next to Reliability Prediction Base or Reliability Prediction Plus is enabled. If necessary, click on the checkbox to enable the appropriate Reliability Prediction module. Press <OK>.

Once a Reliability Prediction module has been enabled through the Relex options, you can access the reliability prediction data for any component or assembly. The Parts Table provides access to all data associated with a component.

Which Reliability Prediction Model Will be Used?

An important component of a reliability prediction analysis is the selection of a reliability prediction model. There are several different reliability prediction models available, and the one that is best suited to your part types and requirements should be selected. For more information regarding the reliability prediction models supported by Relex, refer to the “General” chapter of this manual.

What is the Most Efficient Way to Enter Parts Lists?

In Relex, you have the ability to enter a parts list manually, or to import the parts list from an external source. It is important to make this decision early, so that time is not wasted in performing unnecessary tasks. For more information about automatically importing your parts list, refer to the “Importing and Exporting” chapter of this manual.

What Are the Main Steps in Performing a Reliability Prediction in Relex?

The main steps required to perform a reliability prediction are as follows:

1. Start Relex.

2. Create the Project file.

3. Set up the structure of the System Tree in the Project file and review the properties of the components in the System Tree.

4. Enter the parts for each assembly into the Parts Table.

5. Enter the General Data and Prediction Data through the Parts Table for all parts.

6. Calculate the reliability prediction.

7. Generate reports.

Some of these steps were outlined in detail in other sections of this manual, but the entire process will be reviewed here for completeness. This section is intended to serve as a review. If you require additional information regarding subjects that are covered, you may refer to other sections of the manuals for further details.

Step #1 – Start Relex

Starting Relex is just like starting any Windows program. To start Relex, select Relex from the Start Menu.
Step #2 – Create the Project File

Create the Project file by selecting File>New>Project from the main menu. This process requires only that you give the file a name in the File name field. Press <Create> when finished. The New Project Properties window appears. Edit the properties of the new Project file, or accept the defaults. Press <OK> when you are satisfied with the assigned properties.

Step #3 – Set up the Structure of the System Tree in the Project File and Review the Properties of the Components of the System Tree

Once the Project file has been created, you should determine the structure of the system in your Project file. The System Tree portion of the window is used for this task. Using the various features of the System Tree, add children and siblings to create the hierarchical structure of your system. Continue to build your System Tree until it includes all key components.

There are properties associated with every item represented in the System Tree, including the entire tree itself. These properties may be accessed using the tabs in the Parts Table window. These properties are to be reviewed carefully to make sure that they best represent your system, although they may be changed at any time in the future. Pay special attention to the General tab and Calculation Data tab.xe "Calculation Data tab" 

The General tab allows you to specify the environment, temperature, calculation modelxe "Calculation Model" \r "D2HBCalculation_4" and calculation method for each assembly in the System Tree. These properties are very important for accurate reliability prediction calculations.xe "Reliability Prediction Calculations" \r "D2HBReliability_4" The Calculation Data tab further allows you to customize your reliability prediction calculation.

Step #4 – Enter the Parts for Each Assembly into the Parts Table

Once you have defined the structure of your System Tree, you may start entering individual components into the Parts Table. The Parts Table is a table that contains the list of parts for each assembly in your system. For each part, you may enter the basic information that is requested. The most important parameters are the Part Number,xe "Part Number" Category,xe "Category" Subcategory,xe "Subcategory" and Quantity fields. 

The first field is the Part Number field. From the Part Number field, you have the option of entering any part number, performing a search of the activexe "Active" libraries for a part number, or leaving the field blank, since it is not required. Upon entering a part number, press <TAB> to advance to the next field. Upon pressing <TAB>, Relex performs a search on all active libraries in an effort to match the part number to data in one of the libraries. If a match is found, the corresponding information for that part is retrieved, including category, subcategory, and any information that is available for the General Data and Prediction Data tabs. If no match is found, your cursor advances to the Category field. In this case, select a category and subcategory from the choice listsxe "Choice Lists" that are available. Another option on the Part Number field is to perform a search of the active libraries for a specific part.

Based on these simple parameters regarding each part (part number, category, and subcategory), Relex is able to prepare a preliminary calculation based on default data. When you supply Relex with a part category and subcategory, Relex automatically decides what specific parameters are required to calculate the reliability of the part. Relex also assumes certain values for these parameters based on a set of defaults. You may use the defaults built into Relex, or you may define defaults of your own. 

As more data becomes available, you may enter these parameters in the appropriate fields on the Prediction Data tab.xe "Prediction Data tab" As you fine-tune the data with your own actual specifications, as described in Step #5, the prediction calculations become more accurate.

Step #5 – Enter the General Data and Prediction Data through the Parts Table

Through the Parts Table, you may also access additional tabs of information. The information that applies to a reliability prediction is located on two main tabs, General Data and Prediction Data.

The General Data tabxe "General Data tab" includes additional general part information. The General Data tab includes such information as alternate part number,xe "Alternate Part Number" description, and cost. The General Data tab also provides the ability to enter in a specified failure rate or MTBF for a part, and also adjustment factors to be used in adjusting failure rate calculations.

The Prediction Data tab includes all of the data required to perform a reliability calculation on the parts. The information displayed on this window is based on the category and subcategory that was selected on the Parts Table. Based on that information, Relex displays all fields of information that are required to complete a calculation for the selected part under the specified calculation model.

Note: If a category of Other and subcategory of NPRD95 Part is selected, the NPRD Data tab displays rather than Prediction Data. For more information on entering NPRD95 parts,xe "NPRD95 Parts" see the section titled “NPRD95 Parts
”.

Step #6 – Calculate the Parts, Assembly, or Project

Once the data for all parts has been entered, you may perform a calculation. In Relex, you may perform a calculation at the part level, assembly level, or any part of the System Tree level. For more details regarding calculating, refer to the section titled “Reliability Prediction Calculations
”.

Step #7 – Generate Reports

Once all information in your analysis has been entered, you may want to output the information for review. There are various report designs available, but additional custom reports can be created. The reports are generated using the File>Print Preview option, as in other Relex modules. The report designs can be customized by selecting File>New>Format>Report Design or File>Open>Format>Report Design from the main menu.

Is the Reliability Prediction Component Oriented or Will COTS Assemblies be Used?

Relex supports reliability prediction analyses performed at the component level, assembly level, or any combination of the two. COTS (Commercial Off the Shelf) units are becoming more commonplace, and you should plan for the use of COTS data in the reliability prediction analysis. If you intend to include COTS units in your System Tree, it is recommended that research be done in advance to gather failure rate data to be used in the reliability prediction process. It is often necessary to contact the COTS manufacturer for this information, and this may require additional time.

Which Parts or Assemblies Will Have Calculated Failure Rates, and Which Will Have Specified Failure Rates?

When structuring your reliability prediction system in Relex, you have the option to select whether a component or assembly has a calculated failure ratexe "Calculated Failure Rate" or a specified failure rate. A calculated failure rate is computed by Relex and is generally based on component data and a reliability prediction model. A specified failure rate is one that you enter directly and originates from an outside source (component or assembly manufacturer, databook, etc.). If failure rates for components and assemblies are to be calculated, you have the ability to complete this task by using only Relex. If, however, the failure rates are going to be specified, you should plan ahead so that the required time for research of this information is taken into account.

Reliability Prediction Reference

Relex Sample Reliability Prediction File

Relex offers a sample file named Sample Relex Project that includes sample data for reliability prediction, FMEA, maintainability, RBD, and fault tree analyses. This file can be opened by selecting File>Open>Project from the main menu and selecting the file name Sample Relex Project.
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Figure 7 - 1. Sample Relex Project File

Creating/Opening a Reliability Prediction File

Data regarding a reliability prediction is stored in a Project file. Details regarding Project files are provided in the “File Types” chapter of this manual. Creating or opening a Project file is performed by selecting File>New>Project or File>Open>Project from the main menu.

Entry of Part Lists

The list of components being analyzed is entered on the Parts Table in Relex. This list can be entered manually into the table, or it can be imported automatically through the use of the CAD Interface.xe "CAD Interface"
The Parts Table provides a simple spreadsheet format for data entry. The format of the Parts Table can be modified through the use of an Input Format file.xe "Format file" Simple information regarding each part can be entered directly on the Parts Table at the time of entry (part number, category, subcategory, reference designator,xe "Reference Designator" etc.), or the General Data tab can be used to enter this data.

The General Data Tab
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Figure 7 - 2. General Data Tab for Components

The General Data tab specifies general information regarding the selected part. The General Data includes:

	Field
	Description

	Part Number
	Represents the part number of the item in the parts list. You may enter an alphanumeric part number of up to 255 characters.

	Category
	General part category for the part based on the part types supported by the various calculation models. With this field, you can categorize each part as an integrated circuit, semiconductor, resistor,xe "Resistor" etc. The category may be selected from a choice list.

	Subcategory
	General part subcategory for the part based on the part types supported by the various calculation models. With this field, you can further categorize each part. For example, a part that has a category of Semiconductor may have a subcategory of Diode, Microwave Diode, etc. The subcategory may be selected from a choice list. This list varies depending on the part category that was selected in the previous field. The combination of part category and part subcategory define the type of part.

	Reference Designator
	A unique identxe "CAD Interface"ifier for each part, for example, U1, R22, C1-C15. Up to 255 characters can be entered. This field is not required, but is used for updating an assembly of parts when using the CAD Interface.

	Quantity
	The total number of a particular part in the selected assembly. 

	Model
	Calculation modelxe "Calculation Model" for the selected part. Entering a selection here allows you to override the calculation model at the part level, otherwise, the calculation model for the parent assembly is used to calculate the part failure rate.

	Alternate Part Numberxe "Alternate Part Number"
	Alternate part number for the selected part. You may enter any alphanumeric information up to 255 characters.

	CAGE Codexe "CAGE Code"
	Commercial and Government Entity Code of the selected item. Normally a 5-digit code, but you can enter up to 255 characters.

	Description
	Description of the selected part. You may enter any alphanumeric information up to 255 characters.

	Logistics Control Number (LCN)


	Used when exporting information to a MIL-STD-1388 2B compatible format. The Logistics Control Number field allows you to specify the LCN Number.

	Cost
	Cost of the selected part. The cost can be entered in any unit that you select, but you should be consistent.

	User-defined Textxe "User-Defined Text"
	A text field used to store any additional data for the part. You may enter any alphanumeric information up to 255 characters. The information stored in this field may be included on reports.

	User-defined Valuexe "User-Defined Value"
	A numeric field used to store any additional data for the part. The information stored in this field may be included on reports.

	Taggedxe "Tagged"
	If marked, specifies the part as a tagged part. The designation of tagged parts is used as an option in reporting allowing you to report on tagged parts only.

	Repairablexe "Repairable"
	Check Repairable if the part xe "Maintainability Calculations"is repairable. Otherwise, uncheck it. This information is used only for maintainability calculations.

	Failure Rate
	Calculated. Specifies that the failure rate is to be calculated based on the selected calculation models.

Specified Failure Rate. Specifies the failure rate for the part. If a value is entered, no calculation is completed for the part. The unit of the failure rate entered is based on the Failure Rate Multiplierxe "Failure Rate Multiplier" that is assigned on the Project Definitions tabxe "Project Definitions tab" in File Properties.

Specified MTBF. Specifies the Mean Time Between Failures of the element. If a value is entered, no calculation is completed for the element. The unit for MTBF is always hours.

Allocated Weight Factor. A numeric factor used to identify what portion of the parent assembly’s allocated failure ratexe "Allocated Failure Rate" or MTBF is attributed to this part. For more details about this field, see the section titled “Reliability Allocations”xe "Reliability Allocations".

	Adjustment Factors
	Multiplicative. An adjustment factor that is multiplied by the failure rate to calculate the adjusted failure rate. This factor can also be used in combination with the additive adjustmentxe "Additive adjustment" factor.

	
	Additive. An adjustment factor that is added to, or subtracted from, the failure rate to calculate the adjusted failure rate. You may enter a positive or negative value. This factor can also be used in combination with the multiplicative adjustment factor.


Note: When making changes to the General Data tab, original field values can be restored by selecting Restore Original Values from the right mouse menu. This restores the field contents back to the last saved contents.

Entry of Part Data

Once a parts list has been entered on the Parts Table, specific data needs to be assigned to the individual components in order to perform a reliability prediction analysis. To access this data, the Prediction Data tab is used.

Review of the Prediction Data Tab

The Prediction Data tab includes all of the fields of information necessary for performing a reliability calculation on the selected part. The information requested is dependent on the category and subcategory that is specified on the Parts Table. Based on the selected category and subcategory, Relex displays only the fields that are necessary to perform a reliability prediction. Relex’s context-sensitive online help contains detailed information concerning each part parameter. With the Prediction Data tab selected, press <F1> to view this help. The field types vary depending on the type of data that is required. Fields are one of the following types:

	Field
	Description

	Numeric Dataxe "Numeric Data" 
	Allow for the entry of numeric values for the specified parameters.

	Choice Listsxe "Choice Lists"
	Allow for the selection of alphanumeric values from a predefined list. There are three ways to select choice list items:

Press the <Down Arrow> button with your mouse and click on your selection.

Press <Alt> + <Down Arrow> on the keyboard, scroll to your selection with the <Up Arrow> and press <Enter> on your selection.

Type your selection. Relex automatically selects the choice that matches your entry.


Note: The information displayed on the Prediction Data tab is determined by the category and subcategory combination entered on the Parts Table. Certain category/subcategory combinations are related directly to a specific reliability prediction model. For instance, a category of Other and subcategory of Tube is a part which is available through the MIL-HDBK-217 Prediction Model only. In contrast, a part category of Miscellaneous and subcategory of Battery is a part that is available through the Telcordiaxe "Telcordia (Bellcore)" \r "D2HBTelcordia10" (Bellcore) Prediction Model only. Relex allows you to select these types of parts on the Parts Table regardless of the prediction model that is available with your current Relex configuration. However, for part types that your specific model does not support, the Prediction Data tab requests a failure rate for the part, since there is no model available for calculating a failure rate based on specific part parameters. If you have access to both MIL-HDBK-217 and Telcordia (Bellcore) models through Relex, you can change to the required model for that individual part by changing the Model on the Parts Table, so that the specific parameters for that type are available for entry.

Entering Data in the Prediction Data Tab

There are three types of field entries on the Prediction Data tab:

	Field
	Description

	Fields Displaying Data
	For parts that were retrieved from the active libraries, some or all of the information on the Prediction Data tab may be completed. The fields with data values represent information that was retrieved from the active libraries at the time the part was entered in the Parts Table. This information may be changed as desired.

	Blank Fields
	The fields that initially display as blank are alphanumeric fields of information that need to be entered. Because the part that was entered in the Parts Table did not match any entries in the active libraries, or the information retrieved from the library did not include this information, you may want to enter this parameter. If the field is left blank, Relex automatically assigns a value to the field for the purpose of calculating. These values are based on defaults. You may assign your own defaults, but Relex has its own built-in default values.

	Fields with # Signs
	The fields which initially display with # signs are the numeric fields of information that need to be entered. The # signs are used to designate a numeric field which is blank. Any time you delete data from a numeric field, Relex automatically fills the field with # signs. Because the part that was entered in the Parts Table did not match any entries in the active libraries, or the information retrieved from the library did not include this field of data, you may want to enter this parameter. If the field is left as # signs, Relex automatically assigns a value to the field for the purpose of calculating. These values are based on defaults. You may assign your own defaults, but Relex has its own built-in default values.

Note: Deleting data in these fields results in the # signs being placed in the field for you.


Special Buttons on the Prediction Data Tab

The <Pi Factors> button allows you to view each of the Pi Factors that go into the calculation of failure rate for the selected part. Each of the reliability standards (MIL-HDBK-217, Telcordia (Bellcore), and Mechanical Parts) is based on equations. These equations consist of multiple Pi Factors, which when calculated give the failure rate of the part. These Pi Factors are computed based on the information completed on the Prediction Data tab. Each parameter has an effect on one or more of the Pi Factors. Note that mechanical parts display C factors.

The <Defaults> button allows you to display the defaulted data in their respective fields. These defaults may be defined in the user-defined Defaults file,xe "Defaults file" but Relex has its own built-in defaults. These defaults are used in calculating failure rate and MTBF when necessary parameters are not available. By pressing <Defaults>, you may display the default values in the fields that are blank. These values display in a bold font. By pressing <Defaults> again, these defaults disappear. The button works as a toggle allowing you to view the values. If you keep the default values displayed, they are saved with the part information.

If you prefer, you may select “Enter Default Values for New Parts” on the Settings Tabxe "Settings tab" in Tools>Options. This option automatically enters the default values as entries into the fields for new parts. You may then overwrite the values when applicable. Realize, however, that defaults are always used for calculations when a field is left as blank or a # sign, so the option to “Enter Default Values for New Parts” is not a requirement and is offered as a convenience for additional flexibility.

Note: When making changes to the Prediction Data tab, original field values can be restored by selecting Restore Original Values from the right mouse menu. This restores the data fields back to the last saved contents.
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Figure 7 - 3. Sample Prediction Data Tab for Component

xe "NPRD95 Parts"NPRD95 Parts

NPRD95 is a document available from the Reliability Analysis Center. This document lists failure rates primarily for mechanical devices. The Non-Electronic Partsxe "Non-Electronic Parts" Library in Relex is based on this document. NPRD95 parts are often used in reliability predictions when MIL-HDBK-217, Telcordia (Bellcore), or the Mechanical Reliability Handbook does not cover certain specific part types, primarily mechanical or electro-mechanical. NPRD95 provides an easy way to supply failure rates for standard mechanical parts.

Follow these steps to specify an NPRD95 part in Relex:

1. Activate the Parts Table and place your cursor in a blank row. You may enter a part number if you wish.

2. In the Category field for the part, select Other from the category choice list.

3. In the Subcategory field for the part, select NPRD95 Part from the subcategory choice list.

4. Enter all other applicable information in the Parts Table.

5. Select the NPRD Data tab. This tab replaces the usual Prediction Data tab that is available for most parts.

6. On the NPRD Data tab, select the part type from the choice list available in the Part Type field. The choice list displays all of the possible part types that are available in NPRD95. Make a choice by selecting the item with your cursor.

7. In the Part SubType field, use the choice list to select a subtype. The list of subtypes that displays is based on the Part Type that was selected in the previous field. Make a choice by selecting the item with your cursor. You may find Summary part types in the list. Summaries are groupings of subtypes. As an example, select a part type of Accelerometer. In the Part Subtype list see Pendulum (Summary). This is an average of all pendulum accelerometers in NPRD95. The first Part Subtype is Summary and is an average of all accelerometers in NPRD95.

8. Upon selecting a part type and subtype, a list of choices is displayed. The following table lists each option along with other descriptive information regarding that item.
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Figure 7 - 4. Sample NPRD Data for Component

	Field
	Description

	Quality
	The quality level of the part as indicated by:

Mil-Spec. Parts procured in accordance with MIL specifications.

Commercial. Commercial quality parts.

Unknown. Data resulting from a device of unknown quality level. Dashes are similar to the summary wording described previously. Dashes in the Quality field means this is an average of all parts with different quality levels.

	Environment
	Describes the conditions of field operation. These environments are consistent with MIL-HDBK-217. In some cases, environments more generic than those used in MIL-HDBK-217 are used. Dashes in the Environment field means this is an average of all parts with different environments.

	Data Source
	Source of data comprising this entry. The source number may be used as a reference in the NPRD95 Document (Section 5) to review individual data source descriptions.

	Failure Rate
	The failure rate for the entry. For roll-up data entries (i.e., those without sources listed) failure rate is derived using the data merge algorithm described in the NPRD95 Document (Section 5).

	Miles
	A check mark indicates that the failure rate unit is measured in failures per million miles rather than being in failures per million hours.


Choose an item from the table by selecting it with your cursor.

1. When an item is selected from the table, the associated failure rate for the item is entered into the Failure Rate field.

2. Some failure rates are displayed as failures per million miles rather than in failures per million hours (assuming failure rate units are failures per million hours). If a check mark appears in the table under Miles, then a miles per hour value is to be assigned in the Miles/Hour field. This is used to convert failures per million miles to failures per million hours. This field is disabled if not needed.

3. After making your selection, close the NPRD95 Part window and return to the Parts Table.

xe "Hybrids"Hybrids

A hybrid is defined to be a component in a relatively large package that contains other parts mounted on a substrate. Entering partsxe "Entering Parts" in a hybrid is identical to entering parts in an assembly. The hybrid is added as an assembly to the System Tree, and the parts are added through the Parts Table. The only difference is that the assembly needs to be marked as a hybrid. To do that, follow these steps:

1. Select the assembly from the System Tree and access the properties for that assembly by selecting the General Data tab in the Parts Table window.

2. Mark the item labeled Hybrid. This mark specifies that the selected item is a hybrid rather than a typical assembly. Relex displays a new Hybrid tab.

3. On the Hybrid tab enter the information requested.

xe "Value-Added files"Reliability Prediction Value-Added Files

Relex Reliability Prediction has several additional files that aid in analysis. Each of these files is related to a specific function to allow for more organized and streamlined analyses. These files include:

	File Type
	Definition

	Parts Library
	A database or table that contains standard parts and their parameters. There are add-on libraries of parts available from Relex, or you may create your own libraries. When a part number is located in an active library, its data can be retrieved automatically when entering parts. If that part number is entered into the Parts Table or imported, all data associated with the part is retrieved automatically.

	Correlation 
	A list of in-house part numbers which match to library part numbers. This is especially helpful if you have a special in-house part numbering system. Usually these in-house numbers can be matched to widely accepted standard part numbers. The correlation file allows you to match in-house part numbers to library part numbers. When you enter your in-house part number into Relex, all of the data regarding that part is automatically retrieved from the library.

	Defaults 
	A file that contains default part parameters for each part type. These values are used when fields for a part are left as blank (or # signs in the case of numeric fields). Relex has its own system of handling defaults (based on Parts Countxe "Parts Count" parameters for MIL-HDBK-217 calculations), but user-defined default files may be created also. This means that you do not necessarily need the specific parameters for your parts. You can enter your parts and let Relex use its built-in defaults for the calculations.

	Derating 
	A table of maximum stress values allowed for each part type. Stress values include temperature and operating stress. Relex has its own system of derating, but user-defined derating files may be created also. During calculations, Relex automatically flags any part operating over your derating limits.

	User-Defined Values
	Provides the ability to create custom environments and quality levels to be used in an analysis when standard choices are not adequate.

	Mission Profilexe "Mission Profile"
	Used to stored information regarding the various mission phases in which your system operates. The file stores the total mission time and pertinent data regarding each mission phase (phase, environment, temperature, and percentage of mission time).


xe "Parts Libraries"Parts Libraries

A library in Relex is a database or table that contains standard parts and their associated part parameters. When entering parts into the Parts Table, Relex automatically searches all active libraries by part number, and optionally by alternate part number.xe "Alternate Part Number" If the particular part that is being searched is found, all of its associated parameters are read from the library and pulled into the Parts Table. Relex library searches are extremely fast; thousands of parts are searched in a fraction of a second.
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Figure 7 - 5. Sample Parts Library

Retrieving Parts from a Library

There are three ways to retrieve parts from an active library:

· Manually entering parts into the Parts Table.

· Selecting a part from a list based on library search parameters.

· Importing parts into Relex using the Import function.

Regardless of which technique you prefer, the information retrieved is the same. As an overview, each of these techniques is outlined below:

Manually Entering Parts into the Parts Table

Enter the part number into the Part Number field on the Parts Table and press <TAB>. Upon pressing <TAB>, Relex searches all active libraries for a matching part number. If a match is found, all available data is retrieved. If no match is found, your cursor advances to the next field on the Parts Table.

Selecting a Part from a List Based on Library Search Parameters

In the Part Number field, you may access Browse Library from the right mouse menu to browse the contents of the active libraries. For more information on library searchingxe "Library Searching" refer to the section titled "Library Searching".

Importing Parts into Relex Using the Import Feature

When importing parts lists into Relex using the CAD ImportWizardtm, Relex automatically searches the active libraries for all part numbers that are imported. If matches are found, the information is automatically retrieved for each of the parts. If no matches are found, the parts are added to the specified assembly as a category of Other and subcategory of User-defined, unless the category and subcategory information was specified during the import process.

Library Searching

When entering part numbers into the Parts Table, Relex provides you with several options regarding searching the active libraries for matching part numbers. You can search the libraries on an exact part number, or you can browse through all or some of the parts in any or all of the libraries. The general categories of searches are as follows:

· Search all libraries for a specific part number.

· Re-search all libraries for a different specific part number.

· Search all libraries for a partial part number.

· Browse librariesxe "Browse libraries" for a part that matches certain parameters.

Each of these different categories of searches is handled a little differently. Review the following descriptions for more information regarding each technique:

Searching All Libraries for a Specific Part Number

On the Parts Table, you have the option of entering a part number into the Part Number field. After entering the part number, press <TAB> to search the active libraries for a matching part number. This search reviews the part numbers in each of the active libraries for an exact match. If a part number match is found, the part information is retrieved. If a part number match is not found, your cursor advances to the next field in the Parts Table and no information is retrieved.

Re-Searching All Libraries for a Different Specific Part Number

If you have changed a previously located part number in the Part Number field, you may want to perform a re-search in order to search the libraries for this new part number. If the new part number is located after performing a re-search, all data that was previously retrieved or entered is replaced with the new part number data. To perform a re-search, enter the new number into the Part Number field on the Parts Table and select Re-Search Libraries from the right mouse menu or select Assembly>Re-Search Libraries from the main menu. This action re-searches the active libraries on the part number that is now entered in the Part Number field. If a match is found, the corresponding part information is retrieved.

Searching All Libraries for a Partial Part Number

If you do not know the complete part number, but have an portion of it, you can enter that portion and select Browse Libraries from the right mouse menu or Assembly>Browse Libraries from the main menu to search for the part based on specified parameters. Relex then performs a search on the active libraries for all parts that contain the specific characters specified. When the list of matching part numbers is retrieved, select the desired part number with your mouse and press <Insert> to insert the part number into the Parts Table, or double-click your mouse to select and insert the part number.

Browse Libraries for a Part That Matches Certain Parameters
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Figure 7 - 6. Library Browse Feature

For the instances when you wish to browse the active libraries for parts that match certain parameters, you can use the Browse Libraries feature provided by Relex. The Browse Libraries feature allows you to filter a listing of all part numbers based on certain criteria. To access the Browse Library feature, place your cursor in the blank Part Number field of the Parts Table, and select Browse Libraries from the right mouse menu or select Assembly>Browse Libraries from the main menu. The Library Browse window appears with the following filter options:

	Option
	Description

	View – All
	Selects to view thxe "Correlation files" \r "D2HBCorrelation_18"e parts in all active Libraries. This would include all Relex Librariesxe "Relex Libraries" and all active user Librariesxe "User Libraries" and Correlation files.

	View – Relex Libraries
	Selects to view only the parts in the Relex Libraries. The parts from the user libraries and Correlation files are not included.

	View – User Library 1
	Selects to view only the parts in the User Library 1 (defined under Tools>Options). The Relex Libraries, Correlation files and other user libraries are not included.

	View – User Library 2
	Selects to view only the parts in the User Library 2 (defined under Tools>Options). The Relex Libraries, Correlation files and other user libraries are not included.

	View – User Library 3
	Selects to view only the parts in the User Library 3 (defined under Tools>Options). The Relex Libraries, Correlation files and other user libraries are not included.

	View – Correlation File
	Selects to view only the parts in the active Correlation (defined under Tools>Options). The Relex Libraries and other user Libraries are not included.

	Filter Definitionxe "Filter Definition" \r "D2HBFilter_Defin19" – Part Number
	Filters the information from the selected libraries and Correlation file based on the part number designated in the field. You may enter a partial part number using a variety of wild cards and character placeholders as follows:

Asterisk (*) – serves as a wild card. For instance, to search for all parts beginning with a 74, enter 74* into the Part Number field. This lists all parts starting with a 74 or ending with any other combination of characters.

Question mark (?) – serves as a placeholder. For instance, to search for all parts beginning with the first two digits of RC, any second two digits, and the remaining characters of GF153, enter RC??GF153 into the Part Number field.

Number sign (#) – serves as a numerical placeholder. For instance, to search for all parts beginning with the first two digits of RC, any numbers as the second two digits, and the remaining characters of GF153, enter RC##GF153 into the Part Number field.

	Filter Definition – Description
	Filters the information from the selected libraries and Correlation file based on the description designated in the field. You can enter a partial description using a variety of wild cards and character placeholders as described under Filter Definition–Part Number.

	Filter Definition–Category
	Filters the information from the selected libraries and Correlation file based on the category designated in the field. Select the category from the choice list. When the filter is performed, only the parts having the same category are listed. It is common for this filter definition to be used in combination with the Subcategory Filter Definition.

	Filter Definition–Subcategory
	Filters the information from the selected libraries and Correlation file based on the category and subcategory designated in the fields. Select the category from the choice list, and then a corresponding subcategory from the choice list in the Subcategory field. When the filter is performed, only the parts having the same category and subcategory are listed. 

	Filter Definition–Alternate P/N
	Filters the information from the selected libraries and Correlation file based on the alternate part numberxe "Alternate Part Number" \r "D2HBAlternate_Pa19" designated in the field. You can enter a partial alternate part number using a variety of wild cards and character placeholders as described under Filter Definition–Part Number.

	<Filter>
	The <Filter> button is used to perform the search on the libraries based on the selected filter parameters. Press <Filter> after all desired information has been entered.

	<Insert>
	The <Insert> button is used to insert part information from the list displayed at the bottom of the Library Browse window. Once a filter has been performed, a list of all parts matching the filter criteria is displayed at the bottom of the window. Select the desired part and press <Insert> or double-click on the part to insert the information to the Parts Table.

	<Update>
	The <Update> button is used to update the current record in the Parts Table with the selected part on the Library Browse window.

	<Close>
	The <Close> button is used to close the Library Browse window and cancel the current action.


It is important to remember that a filter can be set on any one of the above individual options, or it may be set on any combination of the above options. For instance, you could search on a partial part number and a particular category and subcategory. Set all of the criteria to your specifications and press <Filter>.

Note: Non-electronic parts are accessible in the Parts Table by selecting a category of Other and a subcategory of NPRD95 Part.

Order for Searching Libraries

Relex performs a sequence of steps when searching libraries to find a matching part. Relex first searches for the exact part number. If not found, Relex removes any prefix or suffix on the part and repeats the search. Relex does not require you to enter the exact part number. Relex continues its search until the part is found or all of the enabled libraries have been searched. 

During a search for a part number, Relex follows a very specific order for searching the Correlation file and all libraries. This order is outlined as follows:

	Order and Files Searched
	Library Field Searched
	Description of Search 

	1
	User-Defined Correlation File
	Part Number
	Exact search

	2
	User Libraries 1,2 and 3
	Part Number
	Exact search

	3
	User Libraries 
	Part Number
	Part number without prefix (all alpha characters up to the first digit are stripped)

	4
	User Libraries 
	Part Number
	Part number without suffix (all trailing alpha characters are stripped)

	5
	User Libraries 
	Part Number
	Part number without prefix and suffix 

	6
	User Libraries 
	Part Number
	Part number without dash suffix (all alpha characters following a dash in the suffix)

	7
	User Libraries
	Part Number
	Part number without dash suffix and without dash prefix

	8
	User Libraries 
	Alternate Part Number
	Exact search

	9
	User Libraries
	Alternate Part Number
	Part number without prefix 

	10
	User Libraries 
	Alternate Part Number
	Part number without suffix 

	11
	User Libraries 
	Alternate Part Number
	Part number without prefix and suffix 

	12
	User Libraries
	Alternate Part Number
	Part number without dash suffix 

	13
	User Libraries
	Alternate Part Number
	Part number without dash suffix and without dash prefix.

	14
	Relex Libraries (IC, Semi, and Resistor/Capacitorxe "Capacitor")
	Part Number
	Exact search



	15
	Relex Libraries 
	Part Number
	Part number without prefix 

	16
	Relex Libraries 
	Part Number
	Part number without suffix 

	17
	Relex Libraries 
	Part Number
	Part number without prefix and suffix 

	18
	Relex Libraries 
	Part Number
	Part number without dash suffix 

	
	Relex Libraries
	Part Number
	Part number without dash suffix and without dash prefix.

	19
	Relex Libraries 
	Alternate Part Number
	Exact search

	20
	Relex Libraries
	Alternate Part Number
	Part number without prefix 

	21
	Relex Libraries 
	Alternate Part Number
	Part number without suffix 

	22
	Relex Libraries 
	Alternate Part Number
	Part number without prefix and suffix 

	23
	Relex Libraries 
	Alternate Part Number
	Part number without dash suffix 

	24
	Relex Libraries
	Alternate Part Number
	Part number without dash suffix and without dash prefix.


Entering Parts into a Library

There are three ways to enter parts into a library in Relex:

· Automatically by importing the parts from an external file into Relex.

· Interactively by creating a Library file and entering the parts and parameters.

· Performing an update of a Library file from parts in a Project file.
Importing the Library Parts from an External File into Relex

This process is performed using the CAD Import/ExportWizardtm.xe "CAD Import/ExportWizardtm" You can import parts into a Library similarly to importing parts into a Project file.

Creating a Library File

The process of editing or adding parts in a Library file is very similar to editing or adding parts in the Parts Table. Follow these steps:

1. Select File>New>Prediction>Parts Library from the main menu.

2. In the File name field, enter the name of the new library and press <Create>.

3. Upon creating the new file, a File Properties window appears. This window allows you to specify descriptive information about the library that you are creating. Enter the information, and press <OK> when complete.

4. The Library window appears. This window is divided into two sections. The Parts List window is very similar to a System Tree window in a Project file. The main difference is that the Parts List window displays the list of parts that exist in the file, but assemblies cannot be created as children or siblings. There is also a standard Parts Table window, which is also used in a Project file. It is a simple table that allows you to enter the part numbers for your library. To insert a new part select Insert>Insert Part from the main menu. For each part in the table, you are to enter a part number, category, and subcategory. You may enter a model for any part that has a different model other than that which was selected for the Library file in the previous step.

5. For each part in the Parts Table, you may press the associated tabs to enter the part parameters. The General Data, Prediction Data, Method Data, and Remarks tabs are the same as those available through the Parts Table. Any information that is entered here is retrieved automatically when this part is entered into the Parts Table in a Project file.

6. After entering the parameters for the parts, save and close the Library file.

7. Once a Library file is created, adding it to the list of active libraries enables it. To enable a library, select Tools>Options from the main menu. On the Library Searches tab, enter the name of the desired Library file in one of the User Library fields. To select a Library file, press <Browse> to display a list of Library files.xe "Library files" \r "D2HBLibrary_file23" Choose your new library by selecting it with your cursor and pressing <Open>. Save the changes by pressing <OK>.

Note: The format of the Parts Table in a Library file can be customized, just like the Parts Table in a Project file. A Relex Library uses a Parts Table filexe "Parts Table file" to establish the format of the Parts Table window. This Parts Table file is defined on the Files tab under the properties of the file.

Performing an Update of a Library From a Project

By using the Build/Update feature, you are able to automatically update a Library with information from a Project file. For a detailed description of this feature, refer to the section titled “Building and Updating
”xe "Building and Updating".

Libraries Installed as Read-Only

Upon installation, Relex Libraries are set as read-only. When a file is read-only, changes to the file are not allowed. 

If necessary, the Library files can be changed to have read/write access using Microsoft Explorer. Although this is an option, it is still advised that changes to Relex Libraries be limited in order to insure the integrity of the data in the libraries.

Sorting Library Files

Library files can be sorted by any of the fields of information that display on the Parts Table. To sort on a field, double-click on the column heading for that field. A window appears and asks you to verify that you wish to sort the database on the selected field. 

xe "Correlation files" \r "D2HBCorrelation_23"Correlation Files

A Correlation file in Relex is used to correlate your in-house part numbers to Relex Library part numbers. Enter a listing of your in-house part numbers and the equivalent library part number. During library searchingxe "Library Searching" of a part entered in a Parts Table, Relex searches the Correlation file for the entered part. If it is found in the Correlation file, the corresponding library part number is then used for a search of all active libraries. When found, all of the appropriate part data from the library is pulled into the Project file.
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Figure 7 - 7. Sample Correlation File

There are three steps to using a Correlation file:

1. Create a Correlation file.

2. Enable the Correlation file under Options.

3. Perform a library search.

Creating a Correlation File

1. Select File>New>Prediction>Correlation from the main menu.

2. In the File name field enter the name of the new Correlation file and press <Create>.

3. Upon creating the new file, a File Properties window appears. This window allows you to specify descriptive information about the file that you are creating. Enter the information, and press <OK> when complete.

4. The Correlation window now appears. This is a very simple table that allows you to enter the in-house part numbers, corresponding library part numbers, and any applicable remarks. To insert a new part, select Insert>Insert Record from the main menu.

5. After entering in-house and corresponding library part numbers, save and close the Correlation file.

Note: Library part numbers are always verified against active libraries. Therefore, you cannot enter library part numbers that are not found in libraries. 

Enabling the Correlation File under Options

Once a Correlation file is created, adding it to the list of active library files enables it. To enable the Correlation file, select Tools>Options from the main menu. On the Library Search tab, enter the name of the Correlation file in the Correlation File field. To select a Correlation file, press <Browse> to display a list of Correlation files. Choose your file by selecting it with your cursor and pressing <Open>. Save the changes to options by pressing <OK>.

Performing a Library Search Using the Correlation File

After you have created and enabled a Correlation file, you need to perform a library search. While adding parts to a Parts Table, enter an in-house part number in the Part Number field. When you press <TAB>, Relex searches the Correlation file for your part number, correlates it to the library part number, performs a library search on that library part number, and retrieves the information.

Browsing Libraries from a Correlation File

From the Library Part Number field in a Correlation file, you can select Browse Libraries from the right mouse menu in order to browse the libraries. This is helpful when the exact part number to which an in-house part number is to be referenced is unknown. For more information regarding the library browse feature, refer to the section titled “Retrieving Parts from a Library”.

xe "Defaults file" \r "D2HBDefaults_fil24"Defaults File

A Defaults file is a file that contains values for the part parameters for each part type. When a Defaults file is enabled, Relex uses the default values in the file when a part parameter is left blank (or # signs for numeric fields) during calculations.

Note: If you do not specify a default value, Relex uses its built-in defaults. Relex has defaults built-in for all parameters of all part types. In Relex 217, the defaults correspond to the MIL-HDBK-217 Parts Count defaults specified in the document. Therefore, if you do not enter the part parameters in Relex 217, they automatically default to the Parts Count defaults. Relex uses its own built-in defaults for any part parameter that is left blank and does not have a user-defined default value.
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Figure 7 - 8. Sample Defaults File

There are two steps to using a Defaults file:

1. Create a Defaults file.

2. Enable the Defaults file in the File Properties.

Creating a Defaults File

1. Select File>New>Prediction>Defaults from the main menu.

2. In the File name field enter the name of the new Defaults file and press <Create>.

3. Upon creating the new file, a File Properties window appears. This window allows you to specify descriptive information about the file that you are creating. In addition to the general descriptive information, you are also asked to select a Calculation Modelxe "Calculation Model" on the Default File Information tab. This refers to the reliability prediction model to be used for the Defaults file. Once this model is selected, it cannot be changed, so make your decision carefully. Enter the information, and press <OK> when complete.

4. The Defaults file window now appears. This window is divided into two sections. The Parts List window is very similar to the System Tree in a Project file; the main difference being that the Parts List window displays the list of parts that exist in the file, but assemblies cannot be created as children or siblings. There is also a standard Parts Table window, the same as that used in Project files. This is a simple table that allows you to enter category and subcategory of each type of part for which you want to specify default values. You may also specify a model for each part type if it is different than the model that was selected for the Defaults file in the previous step. A Defaults file may only include one entry for each combination of category, subcategory, and model. If you attempt to enter a duplicate category/subcategory/model combination, you are notified with an error message. 

5. For each part in the table, you may edit the data on the General Data, Prediction Data, and Remarks tabs. These property tabs are the same as those available through the Parts Table in the Project file. Any information entered here is used as default data for any part that is entered into a Parts Table.

6. After entering all default parameters, save and close the Defaults file.

Note: The format of the Parts Table in a Defaults file can be customized, just like the Parts Table in a Project file. A Relex Defaults file uses an Input Format file to establish the format of the Parts Table window. This format file is defined on the Files tab under the Properties of the file.

Enabling the Defaults File in the File Properties

Once a Defaults file is created, it can be enabled by adding it to the list of active files in the File Properties. With a Project file open, access File Properties by selecting View>File Properties from the main menu. Select the Prediction/General Files tab.xe "Prediction/General Files tab" To select a Defaults file, press <Browse> to display a list of Defaults files. Choose your file by selecting it with your cursor and pressing <Open>. Save the changes to properties by pressing <OK>.

Viewing Defaults on the Prediction Data Tab

After you have created a Defaults file and have enabled it, that file supplies data to Relex Project files during calculations and reporting. You may view the defaults by accessing the Prediction Data tab on the Parts Table of the Project file. The defaults are used for all fields that appear as blank (or # signs for numeric fields). If you would like to view the default values, press the <Defaults> button. The Default values appear in a bold font. If you would like to store the default values as the actual data for the part, leave the default values displayed. Otherwise, press the <Defaults> button again to hide these default values. 

As an additional option, Relex can be configured to automatically enter default values into the fields on the Prediction Data tab for all new parts entered into the Parts Table. To enable this option, select Tools>Options from the main menu, select the Settings tabxe "Settings tab" and enable the “Enter Default Values for New Parts” checkbox. When this checkbox is disabled, default values only display on the Prediction Data tab if the <Defaults> button is pressed.

Note: Even if the default values are not made visible or saved permanently with the part by selecting the <Defaults> button, the default values are still used during calculations.

xe "Sorting Defaults Files"Sorting Defaults Files

Library and Defaults files can be sorted by any of the fields of information that are displayed on the Parts Table. To sort a field, select the heading for that field, and double-click on it. A window appears and asks you to verify that you wish to sort the database on the selected field. 

Derating Files

A Derating filexe "Derating file" is a table of maximum stress values allowed for each part type. Derating files are used to set an upper limit for electrical and thermal stresses on each part type. By keeping devices operating at or below the maximum derated level, reliability can be improved. When Relex performs a calculation, it verifies that a part is not over the derating limits that you specify. On reports, you may choose to list only the parts that are over your derating limits, and those over Relex’s overstress limits.

Relex provides a built-in system for derating. The built-in derating feature functions as follows:

· If you do not specify a Derating file on the Prediction/General Files tab of File Properties, Relex uses its built-in derating and overstress checks. If a particular part has a stress ratioxe "Stress Ratio" \r "D2HBStress_Ratio26" over 100%, or the temperature is over the rated temperature for the part, Relex indicates that the part is overstressed. 

· If you do specify a Derating file on the Prediction/General Files tab of File Properties, Relex uses its built-in derating and overstress checks for all parts that are not specified in that Derating file. In this case, if a particular part has a stress ratio over 100%, or if the temperature is over the rated temperature for the part, Relex indicates that the part is overstressed. 

· If you do specify a Derating file on the Prediction/General Files tab of File Properties, Relex uses its built-in derating and overstress checks as a minimum derating level for all parts that are specified in that Derating file. In this case, even if a part has specified derating levels assigned in the Derating file, Relex still indicates the part is being overstressed if it has a stress ratio over 100%, or if the temperature is over the rated temperature for the part.

In addition to built in derating limits, Relex also includes additional Derating files that have been created for your convenience. Any one of these files may be enabled for a Project file. The supplied Derating files are based on a number of derating standards. A list of the supplied Derating files is included in the Docs directory on your Relex CD.
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Figure 7 - 9. Sample Derating File

There are four easy steps to enabling derating analysis:

1. Create a Derating file.

2. Enable the Derating file in the File Properties.

3. Assign additional derating data as required.

4. Perform a calculation or generate a report.

Creating a Derating File

1. Select File>New>Prediction>Derating from the main menu.

2. In the File name field enter the name of the new Derating file and press <Create>.

3. Upon creating the new file, a File Information window appears. This window allows you to specify descriptive information about the file that you are creating. In addition to the general descriptive information, you are asked to select a Calculation Modelxe "Calculation Model" on the Derating File Information tab. This refers to the reliability prediction model to be used for the Derating file. Your choices are MIL-HDBK-217 or Telcordiaxe "Telcordia (Bellcore)" \r "D2HBTelcordia27" (Bellcore). Once this model is selected, it cannot be changed, so make your decision carefully. Enter the information, and press <OK> when complete.

4. The Derating file window appears. The Derating Definition table is designed for the entry of all part types that are to be included in the Derating file. To be absolutely complete, an entry is to be included for every type of part available. However, for the part types that do not have an entry, the Relex built-in derating values are used. The table consists of the following fields of information:

	Field
	Description

	Category
	The category of the part being entered into the Derating file. Select a category from the preset choice list.

	Subcategory
	The subcategory of the part being entered into the Derating file. Select a subcategory from the preset choice list. The list of available subcategories is based on the category that was selected in the Category field. One option on the choice list is labeled All. This option refers to all subcategories available for the selected category. Note that you may select several specific subcategories for any category, and then select a subcategory of All. For all subcategories that are specifically added, derating is based on the specified parameters. All applies to all subcategories that have not been specifically defined.

	Type
	The type of part being entered into the Derating file. Select a type from the preset choice list. The list of available types is based on the category and subcategories that were selected in the previous fields. One option on the choice list is labeled All. This option refers to all types available for the selected category and subcategory. Note that you may select several specific types for any subcategory, and then select a type of All. For all types that were specifically added, derating is based on the specified parameters. All applies to all types that have not been specifically defined.

	Model
	The model of the part being entered into the Derating file if it is different than the model of the Derating file itself. This option provides the ability to enter parts for both MIL-HDBK-217 and Telcordia (Bellcore) in the same Derating file. The model selected in this field affects the list of available parameters in the Parameter field.

	Parameter
	The parameter of the part being entered into the Derating file. Select a parameter from the preset choice list. The list of available parameters is based on the entries in all previous fields. In a Derating file, a part of a specific category/subcategory/type/model/parameter combination may only be entered once. Duplicates of the same combination are not accepted.

	Remarks
	General remarks regarding the entry.


5. After entering the information in the Derating Definition window, complete the information requested in the Derating Data window. The information requested varies depending upon the category and subcategory. The data requested may include the following:

	Option
	Description

	None
	No derating is specified for the selected minimum or maximum rating.

	Constant Derated Value
	A constant derated value is entered. For instance, for temperature derating, if a value of 80 degrees is entered, the constant derated value for that part is 80 degrees. A Nominal and Worst Case value may be specified. When a Project file is created, and the Derating file is enabled, you may select whether the nominal or worst case values are to be used for derating analysis.

	Increment Minimum Rating
	An increment value is entered. This Increment value is added to the specified minimum value for the part (this value is specified on the Prediction Data tab for the part during part entry). A Nominal and Worst Case value may be specified. When a Project file is created, and the Derating file is enabled, you may select whether the nominal or worst case values are to be used for derating analysis.

	Decrement Maximum Rating
	A decrement value is entered. This Decrement value is subtracted from the specified Maximum value for the part (this value is specified on the Prediction Data tab for the part during part entry). A Nominal and Worst Case value may be specified. When a Project file is created, and the Derating file is enabled, you may select whether the nominal or worst case values are to be used for derating analysis.

	Standard Derating Curve
	A Standard Derating Curve is based on three main points: the stress ratioxe "Stress Ratio" \r "D2HBStress_Ratio28" (a value between 0 and 1), the knee temperaturexe "Knee Temperature" \r "D2HBKnee_Tempera28" (the temperature at which derating begins), and the maximum temperature (the temperature at which the derated stress ratio is 0). The Standard Derating Curve allows you to specify these three parameters for the curve. Derating is then based on the curve that is produced. Nominal and Worst Case values may be specified for each of the three parameters. When a Project file is created, and the Derating file is enabled, you may select whether the nominal or worst case values are to be used for derating analysis.

For some parameters, the Standard Derating Curve option has an additional “Calculate Maximum Derated Temperature per AS-4613 Semiconductor Derating Curve” checkbox. When enabled, the maximum temperature for the curve is calculated based on the stress ratio, knee temperature, and maximum temperature specified for the part according to the AS-4613 derating standard. If this checkbox is disabled, the derating curve is based on the entered values.

If the derating curve is calculated per AS-4613, you are to enter the maximum temperature rating of the device. The maximum temperature for the nominal and worst case conditions are also to be the same. Relex then calculates the maximum derated temperature dependent upon the stress ratio at 0 degrees (Celsius), the knee temperature, and the maximum temperature.

As values are added for the Standard Derating Curve, a sample curve is displayed to the right of the fields of data. This curve is based on the entered information. As the entries change, the diagram changes.

	User-defined Derating Curve
	If your derating curve contains more than 3 points, then you are to select User-defined Derating Curve. Stress and temperature values may be entered for up to 10 points to define the derating curve. Enter a stress ratio between 0 and 1, and a temperature (in degrees Celsius) for each point on your curve. A curve may be plotted for Nominal and Worst Case. When a Project file is created, and the Derating file is enabled, you may select whether the Nominal or Worst Case values are to be used for the Project file.

As values are added for the User-defined Derating Curve, a sample curve is displayed to the right of the fields of data. This curve is based on the entered information in the tables. As the entries change, the diagram changes.


6. Once all information has been entered into the Derating file, save and close the Derating file.

Using a Derating File

Enabling the Derating File in the File Properties

Once a Derating file is created, it is enabled by adding it to the list of active files in the File Properties. With a Project file open, access File Properties by selecting View>File Properties from the main menu. On the Prediction/General Files tab,xe "Prediction/General Files tab" enter the desired Derating file. To select a Derating file, press <Browse> to display a list of Derating files. Choose your new file by selecting it with your cursor and pressing <Open>. 

Once a Derating file has been selected, you are to select the option for Derating Calculations,xe "Derating Calculations" \r "D2HBDerating_Cal30" which is located under the Derating field. You may select from the derating calculation options of Nominal or Worst Case. If nominal is selected, the nominal values in the Derating file are used. If worst case is selected, the worst case values in the Derating file are used. Save the changes to File Properties by pressing <OK>.

Assigning Additional Derating Data as Required

When a Derating file is enabled in a Project file, additional parameters of information may be included on the Prediction Data tab for each part. These additional fields are displayed on the right side of the Prediction Data tab in a box marked Derating Parameters. These additional parameters, used for derating purposes only, may include:

	Field
	Description

	Minimum Temperature Rating
	Temperature (in degrees Celsius) below which the device should not be operated. This value is used for parts that use a minimum constant derated value or an increment minimum rating for derating. The increment value specified in the Derating file is added to the value entered in this field to determine the derating limit for the part.

	Knee Temperature
	Temperature (in degrees Celsius) at which derating begins. If a value is entered in this field, it is used to override the knee temperature specified for the standard derating curve in the Derating file. 

	Maximum Temperature Rating 
	Temperature (in degrees Celsius) above which the device should not be operated. This value is used for parts that use a maximum constant derated value or a decrement maximum rating for derating. The decrement value specified in the Derating file is subtracted from the value entered in this field to determine the derating limit for the part.

	Power Ratingxe "Power Rating"
	Rated power of the device in watts. It is used in derating calculations to verify that the device is being operated at or below the derating requirements.


Note: The fields outlined above can be used to specify a derating curve for each part type that has not been specified in that Derating file. To specify the derating curve, first enter an operating power for the part (or an operating voltage for capacitors) on the Prediction Data tab for the part. Then assign the information in the above fields for the part. Relex then uses this information to perform a derating calculation for the part based on a standard derating curve. 

xe "Generating a Report"Performing a Calculation and/or Generating a Report

After you have created a Derating file and enabled it in the File Properties, Relex automatically uses your derating information to perform a derating analysis. When you perform a calculation or generate a report, Relex compares all data regarding the part to the information stored in the active Derating file. After calculating, the failure rate value of all overstressed parts is displayed in red on the Parts Table. You may also view Pi Factors on the part Prediction Data tab. If the part is overstressed, a checkmark appears on the window to the right of the calculated failure rate.xe "Calculated Failure Rate" You may also generate reports that include only the parts that are overstressed.

User-Defined Values Files

Relex provides you with the ability to create your own user-defined environmentsxe "User-Defined Environments" \r "D2HBUser_Defined31" and quality levels. This feature is controlled through the use of a User-Defined Values file.xe "User-Defined Values File" \r "D2HBUser_Defined31" A User-Defined Values file allows various environments and quality levels to be established for use. Once a User-Defined Values file is enabled in a Project file, the environments and quality levels assigned in the User-Defined Values file can be used within the Project file.

[image: image63.png]Sample User Def

ed Values. RUD]

File Edit View Insert Tools Window Help

I [=] B3|
Il x|

L IR IR R

EEA TR

User-Defined ltems
Varizble Narme Type Temp, 1€ Temp, Other | Remarks =
1

B Pser Qualit] Quality 30,00 30,00

2| B userEnvironment Quality 30,00 30,00
er-Defined ltem Definitio
Part Type todel Vale

1 friegrated Circurt |l Models 0.10
B Sermiconductor ] all Modkels 0.20
B Resistor ] all Modkels 0.30
4 ~| 100

For Help, press F1

o

INUM |





Figure 7 - 10. Sample User Defined Values File

Creating a User-Defined Values File

A User-Defined Values file is used to establish user-defined environments and quality levels for use in a Project file. To create a new User-Defined Values file, follow these steps:

1. Select File>New>Prediction>User-Defined Values from the main menu.

2. In the File name field, enter the name of the new User-Defined Values file and press <Create>.

3. Upon creating the new file, the File Properties window appears. This window allows you to specify descriptive information about the User-Defined Values file that you are creating. Enter the information and press <OK> when complete.

4. The User-Defined Values File window appears. This window is divided into the User-Defined Items window and the User-Defined Item Definition window.

5. Complete each of the sections as outlined in the following tables.

6. After entering the parameters, save and close the User-Defined Values file.

7. Once a User-Defined Values file is created, the file can be enabled in any Project file. To enable the User-Defined Values file, access the File Properties of the Project file, and select the Prediction/General Files tab.xe "Prediction/General Files tab" To select a User-Defined Values file, press <Browse> to display a list of User-Defined Values files. Choose your file by selecting it with your cursor and pressing <Open>. Save the changes to properties by pressing <OK>.

User-Defined Environments

User-defined environments are assigned in a User-Defined Values file. User-defined environments are used when the standard environments available from the reliability prediction model do not suit the specific needs of your Project file. 

Any environment that is added to a User-Defined Values file is available at any assembly level within a Project file once that User-Defined Values file has been enabled in the Project file. To select the environment for use, select it from the choice list available on the General Data tab of any assembly.

To insert a new environment select Insert>Insert Record from the main menu and enter a new name. Select Environment from the Type choice list. Also enter values in the Temp, IC and Temp, Other columns. These temperatures are used only when performing MIL-HDBK-217 Parts Count calculations. Enter the temperature values (in degrees Celsius) which are to be used for the parts count calculations if this environment is selected. Specify the temperature value for integrated circuits, and then the temperature for all other component types. 

When a User-defined environment is added to a User-Defined Values file, a part type of Any Type is automatically added in the User-Defined Item Definition window. This part type is used as the default part type if the part being analyzed in a Project file does not match any of the other part types specified for this environment in the User-Defined Values file. The Any Type entry is required in a User-Defined Values file for all environment entries and cannot be deleted. This entry is also automatically assigned a model of All Models. This means that if a part does not match any of the other Part Types/Model combinations listed, the value for the Any Type/All Models combination is used.

For each part type added for the selected user-defined environment, the following information is to be entered:

	Field
	Description

	Part Type
	Type of part that the entered information applies to if the selected environment is used in a Project file. The choice list displays a list of available categories and category/subcategory combinations. General or specific category/subcategory combinations can be selected. For instance, if Integrated Circuit is selected, the environment value is used for all integrated circuits. However, if Integrated Circuit, Linear is selected, the environment value is used specifically for integrated circuits with a subcategory of Linear.

	Model
	Model under which the selected environment is applicable. The Model field is a required field and must be completed in order for the Part Type to be added for the environment. The choice list displays a list of all available models.

	Value
	The Value entered is the environment factor (or e) used for the specified component under the specified model if the selected environment is used in a Project file.


xe "User-Defined Quality Levels"User-Defined Quality Levels

User-defined quality levels are assigned in a User-Defined Values file. User-defined quality levels are used when the standard quality levels that are available from the reliability prediction model do not suit the specific needs of a Project file.

Any quality level that is added to a User-Defined Values file is available on the Prediction Data tab. This applies to part types that have been included for that particular quality once the User-Defined Values file is enabled in the Project file. To select the quality level for use, select it from the choice list available on the Prediction Data tab of the component.

To insert a new quality level, select Insert>Insert Record from the main menu and enter a new name. Select Quality from the Type choice list. When a user-defined quality is added to a User-Defined Values file, the User-Defined Item Definition window must be completed to include any part types that are applicable to that particular quality level. For each part type added for the selected quality level, the following information is to be entered:

	Field
	Description

	Part Type
	Type of part for which the entered information applies. The choice list displays a list of available categories and category/subcategory combinations. General or specific category/subcategory combinations can be selected. For instance, if Integrated Circuit is selected, the quality value is used for all integrated circuits. However, if Integrated Circuit, Linear is selected, that quality value is used specifically for integrated circuits with a subcategory of Linear.

	Model
	Model under which the selected quality level is applicable for the selected parts. The Model field is a required field and must be completed in order for the part type to be added for the quality level. The choice list displays a list of all available models.

	Value
	The Value is the quality factor (or Q) used for the specified component under the specified model.


Mission Profile Files
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Figure 7 - 11. Sample Mission Profile File

Relex provides you with the ability to create your own mission profile. The mission profile information is applicable for both Relex Reliability Prediction and Relex FMEA. Within Relex Reliability Prediction, the information stored in the Mission Profile file is used to perform the Mission Calculations. The file stores the total mission time of the system, as well as detailed information about each phase in which the system operates. Once a Mission Profile file is enabled in a Project file, the mission calculations, or reliability prediction calculationsxe "Reliability Prediction Calculations" based on different environments and temperatures, may be calculated. You may enter the following information in a Mission Profile file:

	Field
	Description

	Total Mission Time
	The mission time of the system.

	Total Percentage
	The total of the percent of each mission. This field cannot be edited.

	Phase Code
	A short description of the mission phase.

	Mission Phase
	Descriptive information concerning the Mission Phase.

	Environment
	The operating environmentxe "Operating Environment" for the given phase.

	Temperature
	The operating temperature for the given phase.

	Percent
	Represents the percentage of the total mission time that the system operates in the given phase.

	Remarks
	General remarks regarding the entry.


xe "Global Changes" \r "D2HBGlobal_Chang34"Global Changes

The Global Change capabilities in Relex allow you to make changes, evaluate design proposals, run trade studies,xe "Trade Studies" and more. You may perform global changes and evaluate the effects of any potential design modifications on reliability. Note that global changes cannot be undone.

The Relex Global Change feature allows you to globally change stress levels, quality levels, and temperatures for components. To modify assembly and System Tree temperatures and environments, make changes to the Temperature and Environment fields on the General Property tab for any assembly.

To use the Relex Global Change feature, select Project>Global Change from the main menu. The following tabs are displayed in the Global Change window:

Global Change Select Tab

The Select tab allows you to select exactly which portions of the Project file are affected by the Global Changes. The options are:

	Option
	Description

	Selected Assembly
	Global Changes are made to only the selected assembly in the Project file.

	Selected Assembly and all Children
	Global Changes are made to the selected assembly in the Project file and all children of that assembly.

	System
	Global Changes are made to the entire system in the selected Project file.


xe "Stress Ratio"Global Change Stress Ratio Tab

The Stress Ratio tab allows you to globally change stress parameters (voltage ratios, power ratios, and current ratios) in the Project file. This tab displays the various part types that may be modified with the Global Change feature. For each part type, you may specify a Stress Ratio value as a percentage. You may also enable the Clear checkbox. Enabling the Clear checkbox resets the selected stress ratio to its default value.

Note: Relex does not modify any stress parameters that were originally left blank.
Global Change Temperature Tab

Using the temperature Global Change capability, you can modify the temperature rises and temperature overrides of the various part types. Enter the desired values in degrees Celsius into the appropriate locations. You may also enable the Clear checkbox. Enabling the Clear checkbox resets the selected temperature property to its default value. Relex does not modify any temperature values that were originally left blank.

Global Change Quality Level Tab
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Figure 7 - 12. Global Changes, Quality Level

To change quality levels, select the Quality Level tab. For the various part types there are three columns:

	Column
	Description

	MIL-HDBK-217 Quality
	Allows you to specify the quality level for the selected part type. This applies to only the parts being calculated under the MIL-HDBK-217 Model.

	Telcordiaxe "Telcordia (Bellcore)" Quality
	Allows you to specify the quality level for the selected part type. This applies to only the parts being calculated under the Telcordia (Bellcore) Model.

	Step
	Allows you to increment or decrement the quality levels of each part type. For example, enter a -1 to make the new quality level one level higher (better quality) than the current level, and enter a 2 to make the new quality level two levels lower (lower quality) than the current level. Note that once the highest quality level is reached for a certain part, entering negative numbers has no effect. Likewise once the lowest quality level is reached for a certain part, entering positive numbers has no effect.


Note: When the list of MIL-HDBK-217 qualities are displayed using the choice list, quality levels for 217 are listed best through the worst (top of list is best, bottom of list is worst). In contrast, quality levels for Telcordia (Bellcore) are listed worst through the best (top of the list is worst, bottom of list is best).

xe "Building and Updating"Building and Updating

The Building and Updating feature in Relex allows you to build and update Library and Project files with part data. The Building and Updating feature is accessed by selecting Project>Build/Update from the main menu. The Building and Updating features perform the following functions:

· Creates a new Library from a Project file.

· Updates an existing Library from a Project file.

· Updates a Project file from a Library.
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Figure 7 - 13. Library Build/Updatexe "Library Build/Update" Feature

Creating a New Library from a Project

Building a new Library from project data is most commonly used when an assembly or System Tree has been created and prediction part data has been completed for the parts in the Parts Table. At that point, it is often helpful to save all of that data into a library so that it may be retrieved for use in other Project files. To use this feature, follow these steps:

1. Open the Project file containing the assembly or System Tree that is to be used to create the new library.

2. Make the System Tree window or Parts Table window the active window in the Project file.

3. Select Project>Build/Update from the main menu.

4. The Build/Update window appears. Select Selected Assembly if you wish to include only the parts in the currently selected assembly. Choose Selected Assembly and all children if you wish to include the parts in the selected assembly and the parts in the children of the assembly. Select System to include all parts in the Project file.

5. Select Create New Library for the Update type.

6. In the Library field, enter the name of the new Library file that is to be created. You may use the <Browse> button to assist in entering the proper path information.

7. Press <Update> when you are ready to create the new Library file.

8. The Update process creates a Library file with all of the parts that were included in the selected portion of your file. The entries in the Library are made according to the specifications outlined under Tools>Options on the Library Updates tab.xe "Library Updates tab" \r "D2HBLibrary_Upda37" For more information on these specifications, see the detailed description provided in the section titled “Library Update Options”xe "Library Update Options" \r "D2HBLibrary_Upda37".

Updating an Existing Library From a Project

Updating an existing library from project data is most commonly used when an assembly or System Tree has been created and all prediction part data has been completed for the parts in the Parts Table. Perhaps a large number of the parts in that assembly or System Tree are new parts that do not currently exist in the user libraries. At that point, it is often helpful to save all of that data into an existing library so that it may be retrieved for other Project files along with the other parts that already exist in the Library file. To use this feature, follow these steps:

1. Open the Project file containing the assembly or System Tree that is to be used to update the existing Library.

2. Make the System Tree window or Parts Table window the active window in Project file.

3. Select Project>Build/Update from the main menu.

4. The Build/Update window appears. Select Selected Assembly if you wish to include only the parts in the currently selected assembly. Choose Selected Assembly and all children if you wish to include the parts in the selected assembly and the parts in the children and the assembly. Select System to include all parts in the Project file.

5. Select Update Existing Library for the Update type. 

6. In the Library field, enter the name of the existing Library file that is to be updated. You may use the <Browse> button to assist in entering the proper file name and path information.

7. Press <Update> when you are ready to update the existing library.

8. The update process performs the following tasks:

· New part numbers that do not currently exist in the Library file are added.

· Part numbers that do exist in the Library are updated if the Ignore Duplicate Part Numbers option on the Library Updates tab in Options is not selected.

9. The entries in the library are made according to the specifications outlined in Options on the Library Updates tab. For more information on these specifications, see the detailed description provided in the section titled “Library Update Options”.

xe "Updating a Project"Updating a Project from a Library

Updating a Project file with part data from a Library file is most commonly used when changes have been made to the Library file since the System Tree or assembly was created. When parts are retrieved from a Library during part entry or import, the information from the Library is retrieved into the Parts Table and stored there. At that point, you have the ability to change the part data without changing the underlying Library. However, if changes have occurred to a library part, and you want these changes to be applied to parts in a Project file, it is necessary to update your Project file with the modified part data from a Library file. To use this feature, follow these steps:

1. Open the Project file containing the assembly or System Tree that is to be updated.

2. Make the System Tree or Parts Table the active window in the Project file.

3. Select Project>Build/Update from the main menu.

4. The Build/Update window appears. Select Selected Assembly if you wish to include only the parts in the currently selected assembly. Choose Selected Assembly and all children if you wish to include the parts in the selected assembly and the parts in the children and the assembly. Select System to include all parts in the Project file.

5. Select Update Project as the Update type.

6. In the Library field, enter the name of the Library file that you want to use for the update. You may use the <Browse> button to assist in entering the proper file name and path information.

7. Press <Update> when you are ready to update the existing Project file.

8. The update process updates the prediction part data for the appropriate parts in the Project file with prediction part data from the Library file. 

9. The updates to the Project file are made according to the specifications outlined in Options on the Library Updates tab. For more information on these specifications, see the detailed description provided in the section titled “Library Update Options”.

Library Update Options

You may customize the library update process in Relex. To configure these options, select Tools>Options from the main menu, and select the Library Updates tab. The following options are available:

	Heading
	Option

	Library Build/Updatexe "Library Build/Update"
	Ignore Duplicate Part Numbers. Duplicate parts are not permitted in a Library file, so if this checkbox is disabled, Relex automatically overwrites duplicate parts in the library. The result is that the last instance of any particular part number is the one transferred. If the checkbox is enabled, duplicate part numbers are ignored and no action is taken.

Ignore Relex Part Numbers. Relex part numbers are stored in the Relex Libraries. When updating or creating a User Library, enable this checkbox to ignore all Relex part numbers. In this case, any Relex part numbers that are detected during the Build/Update are not added to the User Library. If the checkbox is disabled, Relex part numbers that appear in the project are added to the User Library.

	Do not update these data fields
	Additive Adjustment 

Alternate Part Numberxe "Alternate Part Number"
CAGE Codexe "CAGE Code"
Cost

Description

LCN 

Multiplicative Adjustment

Quantity

Reference Designator

Operating Parameters from Relex Libraries

Operating Parameters from User Libraries

Each of these fields represents a field located on the Parts Table tab or General Data tab. If enabled, the selected field is not updated in the Library file when building or updating a Library file or a Project file. For example, you may not want Relex to update the reference designator during updates, so that reference designators in the Project files would not be changed. The Operating Parameters fields encompass the operating stress fields such as operating voltage, operating power, operating current, etc.


xe "Reliability Prediction Calculations" \r "D2HBReliability_40"Reliability Prediction Calculations

To calculate and display the failure rate for an assembly or entire System Tree, press the <Calculate> button on the Standard toolbar, or select Project>Calculate from the main menu. The Calculate window appears. On the Calculation Selection tab, enable the Reliability Prediction checkbox.

To perform calculations using the information based on the active Mission Profile file, enable the Mission Calculations checkbox. To perform reliability allocations,xe "Reliability Allocations" enable the Allocations checkbox. Note that these computations are performed in addition to the standard reliability prediction calculations.

Once calculations are completed, the top-level assembly results are displayed on the system results window. The calculation results include failure rate, MTBF, Reliability, and Availability.xe "Availability" A list of maintainability parameters is also displayed if maintainability calculationsxe "Maintainability Calculations" are performed. The following values are displayed:

	Calculation
	Description

	Failure Rate
	Total failure rate in units as specified on the Project Definitions tabxe "Project Definitions tab" of the File Properties.

	MTBF
	Mean Time Between Failures

= 1/failure rate (units are always in hours)

	Reliability
	= 
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(t = total time from the Mission Profile file)

(
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 = Failure rate in failures per hour)

	Availability
	MTBF/(MTBF + MTTRxe "MTTR")

Uses the entered MTTR if maintainability calculations are not performed. Otherwise, uses the MTTR from the maintainability calculations.


Once you have calculated, you may view the calculation results for any assembly included in the System Tree by selecting the assembly in the System Tree window and accessing the Calculation Results tabxe "Calculation Results tab" in the Parts Table window. You may also choose to display the calculated results in the System Tree and/or Parts Table using an Input Format file. 

Note: If only Reliability Prediction is installed in your Relex configuration, the Calculation window allows you to select whether you wish to calculate the selected assembly or the entire tree.
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Figure 7 - 14. Calculation Selection

The Equations

The parameters requested on the Prediction Data tab varies with each part type and each standard, or model. For example, parameters such as the number of pins and the operating temperature are used for integrated circuits, while operating power and resistance value are used for resistors. A sample calculation for integrated circuits taken from MIL-HDBK-217 is as follows:
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Each factor in this equation is dependent upon certain part parameters. For example, the Q factor is assigned a value based on the quality level entered on the Prediction Data tab. You do not need to know the specifics of this or any other equation. This sample equation is used to illustrate the type of calculations that Relex performs. The end result of this equation is the failure rate of the integrated circuit.

You may refer to the model handbooks for more details on the equations, or you may refer to equation references in the Docs directory on your Relex CD.

Entering 217 General Integrated Circuits

Following are the part parameters required for the general Integrated Circuits in Relex 217. Integrated Circuits covered under this Guide topic include:

· Logic, CGA, or ASIC

· PAL, PLA

· Linear

· Microprocessors

· Memory

· EEPROM

Type: 

Choice List [Parts Count also]

Required for Memory, EEPROM Integrated Circuits.

For Memory, the type of the memory device, i.e. ROM, PROM, UVEPROM, etc.

For EEPROM, either Flotox or Textured-Poly. If unknown, select Flotox.

Error Correction Code: 

Choice List

Required only for EEPROM Integrated Circuits.

The error correction code of the EEPROM. If there is no on-chip error correction, select None. If there is on-chip hamming code, select Hamming Code. Select Redundant Cell if using the two-needs-one redundant cell approach. If unknown, select None.

Programming Cycles: 

Integer

Required only for EEPROM Integrated Circuits.

The total number of programming cycles over the life of the EEPROM.

Technology Type: 

Choice List [Parts Count also]

Not required for Linear, EEPROM Integrated Circuits.

The technology type of the device, e.g. TTL, Linear, CMOS.

217 Quality Levels
# of Gates:

Integer [Parts Count also]

Required for Logic, CGA, or ASIC, PAL, PLA Integrated Circuits.

The number of active gates in the package. You can determine the gate count from the logic diagram. A J-K or R-S flip flop is equivalent to 6 gates when used as part of an LSI circuit. For the purposes of a Relex 217 prediction, a gate is considered to be any one of the following functions: AND, OR, exclusive OR, NAND, NOR, and inverter. When a logic diagram is not available, use device transistor count to determine gate count using the following equations:

Bipolar: Gates = # Transistors/3

CMOS: Gates = # Transistors/4

All other MOS, except CMOS: Gates = # Transistors/3

# of Transistors: 

Integer [Parts Count also]

Required for Linear Integrated Circuits.

The number of active transistors in the package, can be determined from logic diagrams.

# of Bits:

Integer [Parts Count also]

Required for Memory, EEPROM Integrated Circuits.

The number of bits in the memory device. Use this field in conjunction with the next field, Bit Units, to enter the memory device bits.

Bit Units:

Choice List [Parts Count also]

Required for Memory, EEPROM Integrated Circuits.

The Units that the # of Bits field is to be multiplied by, i.e. B, KB, MB, GB where B is bits, KB is 1024 bits, MB is 1,048,576 bits, and GB is 1,073,741,824 bits. You can enter the bits several ways. For example, a 1 kilobyte memory chip can be entered as 1 for # of Bits and KB for Units, or 1024 for # of Bits and B for Units.

Word Size: 

Choice List [Parts Count also]

Required for Microprocessors.

The length of the data word used by the microprocessor.

Pins:

Integer

The number of active pins in the package.

Package Type:

Choice List

Indicates how the chip is packaged.

Years in Production:

Choice List [Parts Count also]

The number of years the device has been in production. 

217 Temperature Fields
Entering 217 VHSIC/VLSI Integrated Circuits

Following are the part parameters required for VHSIC/VLSI Integrated Circuits in Relex 217.

Type:

Choice List [Parts Count also]

The type of device, either Logic & Custom, or Gate \Keyword "OR Gate"  Array & Memory.

Manufacturing Process:

Choice List [Parts Count also]

The type of manufacturing process of the VHSIC device.

Feature Size:

Real (microns) [Parts Count also]

The feature size of the VHSIC device. Common values range from 1.0 to 2.5.

Die Area:

Real (sq cm) [Parts Count also]

The die area of the VHSIC device. Common values range from 0.1 - 3.0.

ESD Susceptibility:

Integer (volts) [Parts Count also]

The voltage which will cause the part to fail. Common values range from 0 to 16000 volts. If unknown, use 0.

Seal:

Choice list [Parts Count also]

Whether the package seal is Hermetic or Non-hermetic.

217 Quality Levels
Pins:

Integer [Parts Count also]

The number of active pins in the package.

Package Type:

Choice List [Parts Count also]

Indicates how the chip is packaged.

Years in Production:

Choice List [Parts Count also]

The number of years the device has been in production. 

217 Temperature Fields
Entering 217 GaAs Integrated Circuits

Following are the part parameters required for Gallium Arsenide MMIC and Gallium Arsenide Digital Integrated Circuits in Relex 217.

Complexity:

Choice List [Parts Count also]

The number of active elements in the device. Active elements include transistors and diodes.

Application:

Choice List

Required for GaAS MMIC Integrated Circuits.

The type of application of the GaAs MMIC. If unknown, select Unknown.

217 Quality Levels
Pins:

Integer

The number of active pins in the package.

Package Type:

Choice List

Indicates how the chip is packaged.

Years in Production:

Choice List [Parts Count also]

The number of years the device has been in production. 

217 Temperature Fields
Entering 217 Bubble Memories

Following are the part parameters required for Bubble Memories in Relex 217.

Type:

Choice List [Parts Count also]

Either Seed Bubble Generator or Non-seed Bubble Generator.

Chips/Package:

Integer [Parts Count also]

The number of bubble chips in the package.

Dissipative Elements:

Integer [Parts Count also]

Indicate the total number of dissipative control elements. This includes generate, replicate and detector elements.

217 Quality Levels
# of Bits:

Integer [Parts Count also]

The number of bits in the bubble memory. Use this field in conjunction with the next field, Bit Units, to enter the memory device bits.

Bit Units:

Choice List [Parts Count also]

The Units that the # of Bits field is to be multiplied by, i.e. B, KB, MB, GB where B is bits, KB is 1000 bits, MB is 1E6 bits, and GB is 1E9 bits. You can enter the bits several ways. For example, a 1 megabit memory device can be entered as 1 for # of Bits and MB for Units, or 1000 for # of Bits and KB for Units, or 1048576 for Bits and B for Units.

Pins:

Integer [Parts Count also]

The number of active pins in the package.

Years in Production:

Choice List [Parts Count also]

The number of years the device has been in production. 

Reads/Writes:

Integer [Parts Count also]

The ratio of the number of memory reads for every memory write. If this ratio is less than 1, just enter 0.

Average Data Rate:

Real [Parts Count also]

Average data rate over the time that power is applied to the equipment using the device. This Average Data Rate is divided by the Maximum Data Rate to yield the Duty Cycle \Keyword "Duty Cycle"  Ratio.

Maximum Data Rate:

Real [Parts Count also]

The manufacturer's maximum rated data rate. This Maximum Data Rate is divided into the Average Data Rate to yield the Duty Cycle Ratio.

Duty Cycle:

Real (0.0 - 100.0) [Parts Count also]

The Average Data Rate is divided by the Maximum Data Rate to yield this Duty Cycle Ratio, i.e. Duty Cycle Ratio = Average Data Rate / Maximum Data Rate * 100. Overstress flag is set if:Duty Cycle Ratio > 100.0

Temperature Rise: \Keyword "Temperature Rise" 
Real (Degrees C)

The temperature rise from the subassembly to the bubble memory case.

Maximum Rated Temp:

Real (Degrees C)

The manufacturer's stated maximum junction \Keyword "Junction"  temperature, defaults to 175 Degrees C for bubble memories.

Overstress flag is set if:

Temperature Rise to Case + Subassembly Temp + 10 > Maximum Junction Temp

Case Temperature Override:

Real (Degrees C)

Generally this field is left at 0.0. The Case Temperature is normally calculated by Relex by adding the Temperature Rise and the Subassembly Operating Temperature. If you enter a value for this Override, Relex will not compute the temperature, but use the temperature you enter. Leave this at 0.0 if you want Relex to compute the temperature.

Entering 217 SAWs

The only part parameter required for Surface Acoustic Wave (SAW) devices is quality level in Relex 217.

Quality Level:

Choice List

Either that the device is a High or a Lower quality level.

217 Quality Levels

Either a Quality Level or a Pi Q Value Override.

Quality Level:

Choice List [Parts Count also]

The appropriate quality screening of the device. If the device is screened to custom or intermediate programs, you may enter a Pi Q value directly in the "Pi Q Value" field. See help below on the Pi Q Value field for more information on determining Pi Q values from screening programs.

In MIL-HDBK-217F Notice 1 the accepted quality levels are:

S:

1. Procured in full accordance with MIL-M-38510, Class S requirements.

2. Procured in full accordance with MIL-I-38535 and Appendix B thereto (Class U).

3. Hybrids: \Keyword "Hybrids"  Procured to Class S requirements (Quality Level K) of MIL-H-38534.

B:

1. Procured in full accordance with MIL-M-38510, Class B requirements.

2. Procured in full accordance with MIL-I-38535, (Class Q).

3. Hybrids: Procured to Class B requirements (Quality Level H) of MIL-H-38534.

B-1:

Fully compliant with all requirements of paragraph 1.2.1 of MIL-STD-883 and procured to a MIL drawing, DESC drawing, or other government approved documentation. (Does not include hybrids.) For hybrids, use custom screening factors.

D-1:

Commercial part with no screening or unknown screening level.

Pi Q Value:

Real [Parts Count also]

You may directly enter in a value for the quality factor (Pi Q). If the Pi Q value is left at 0.0, the value entered in the Quality field is used to determine the quality (Pi Q) factor. For custom and other screening and quality programs, the value of Pi Q can be computed from the following criteria:

Pi Q = 2 + [87 / (Sum of the Point Valuations of the Screenings)]

[the Point Valuations are given in the table below]

	Group 
	MIL-STD-883 Screen/Test
	Point Valuation

	1(#)
	TM 1010 (Temperature Cycle, Condition B Minimum) and TM 2001 (ConstantAcceleration, Condition BMinimum) and TM 5004 (or 5008 for Hybrids \Keyword "Hybrids" ) (FinalElectricals at Temp Extremes) and TM 1014 (Seal Test,Condition A, B, or C) and TM 2009 (External Visual)
	50

	2(#)
	TM 1010 (Temperature Cycle, Condition B Minimum) or TM 2001 (Constant Acceleration, Condition B Minimum) TM 5004 (or 5008 for Hybrids) (Final Electricals at Temp Extremes) and TM 1014 (Seal Test, Condition A, B, or C) and TM 2009 (External Visual).
	37

	3
	Pre-Burn Electricals TM 1-15 (Brun-n B Level/S-Level) and TM 5004 (or 5008 for Hybrids) (Post Burn-in \Keyword "Burn-In"  Electricals at Temp Extremes)
	30(B Level)
36(S Level)

	4(#)
	TM 2020 Pind (Particle Impact Noise Detection)
	11

	5
	TM 5004 (or 5008 for Hybrids) (Final Electricals at Temp Extremes)
	11 (~)

	6
	TM 2010/17 (Internal Visual)
	7

	7(#)
	TM 1014 (Seal Test, Condition A, B, or C)
	7 (%)

	8
	TM 2010 (Radiography)
	7

	9
	TM 2009 (External Visual) 
	7 (%)

	10 
	TM 5007/5013 (GaAs) (Wafer Acceptance)
	1

	11
	TM 2023 (Non-Destructive Bond Pull)
	1


#: NOT APPROPRIATE FOR PLASTIC PARTS

~: Point valuation only assigned if used independent of Groups 1, 2, or 3

%: Point valuation only assigned if used independent of Groups 1 or 2.
Note:
1. TM refers to the MIL-STD-883 Test Method.

2. Sequencing of test within groups 1, 2, and 3 must be followed.

3. Nonhermetic parts should be used only in controlled environments (i.e., Ground Benign and other temperature/humidity controlled environments).

Examples:

1. Mfg. performs Group 1 test and Class B burn-in: \Keyword "Burn-In"  
Pi Q = 2 + (87 / (50 + 30)) = 3.1

2. Mfg. performs internal visual test, seal test and final electrical test:
Pi Q = 2 + (87 / (7 + 7 + 11)) = 5.5

217 Temperature Fields

The first five data fields below are related to calculating the junction \Keyword "Junction"  temperature of the device. The junction temperature is then used in the reliability calculations. All of the other parameters are used solely to arrive at the operating junction temperature. The formula is simply:

TJ = TSub + TInit + (PwrDiss * ThermalRes), where

TJ = calculated junction temperature

TSub = subassembly temperature on subassembly definition screen

TInit = Initial Temperature Rise explained below

PwrDiss = Power Dissipation explained below

ThermalRes = Thermal Resistance \Keyword "Thermal Resistance"  explained below.

Initial Temperature Rise:

Real (Degrees C)

Rise from the subassembly temperature to the location specified in the Thermal Resistance Units, e.g. if the Thermal Resistance Units are from Junction - Case, then this value is the temperature rise from subassembly to the case. Many times this initial temperature rise can be assumed to be 0. See the above equation.

Power Dissipation:

Real (Watts)

The operating power dissipation of the device, used in junction temperature calculation. See the above equation.

Thermal Resistance:

Real (Degrees C/Watt)

The Thermal Resistance (Degrees C/watt) between the Junction \Keyword "Junction"  and the Units location specified at the right of this entry. See the above equation.

For Integrated Circuits

For integrated circuits, Thermal Resistance values from the Junction to the Case (also known as Theta JC) taken from MIL-M-38510H Appendix C can be used. These are:

	Description
	Package Size
	Max Theta JC(*)

	Flatpack (FP)
	10, 14, 16, 18, 20, 24, 28 lead
	22

	Dual-In-Line Package (DIP)
	8,14,16,18,20,22,24,28,40,50, 64 lead
	28

	Can
	8 lead
	70

	Rect. Leadless Chip Carrier  (LCC)
	10,12 lead
	65

	Square Leadless Chip Carrier (LCC)
	16,20,24,28,44,52,68,84 terminal
18, 20, 28, 32 terminal
	20
20

	J Bend  Leaded Chip Carrier  (JCC)
	44, 68, 84 terminal
	20

	Gullwing Leaded Chip Carrier (GCC)
	44,68,84 terminal
	20

	Unformed-Lead Chip Carrier
	84,100,132,144,172,196 terminal
	20

	Pin Grid Array (PGA)
	81,100,121,144,169,196,225,256, 289,324,361,400 pin
	20


(*) For device die sizes greater than 14400 sq. mil., use the values given in the table below. If Theta JC cannot be determined, use the worst case defaults shown in the table below.

	Package Type
	Die Area > 14,400 sq mi
	Worst Case Default

	Dual-In-Line
	11
	28

	Flat Package
	10
	22

	Chip Carrier
	10
	20

	Pin Grid Array
	10
	20

	Can
	(
	70


For Semiconductors: \Keyword "Semiconductors" 
For Semiconductors, values from the following table, extracted from MIL-HDBK-217E Notice 1 can be used. If the Package Type is unknown then use a Thermal Resistance of 70 Degrees C/W.

	Package Type
	Therm. Res.
	Package Type
	Therm. Res.

	TO-1
	70.0
	TO-205AD
	70.0

	TO-3
	10.0
	TO-205AF
	70.0

	TO-5
	70.0
	TO-220
	5.0

	TO-8
	70.0
	DO-4
	5.0

	TO-9
	70.0
	DO-5
	5.0

	TO-12
	70.0
	DO-7
	10.0

	TO-18
	70.0
	DO-8
	5.0

	TO-28
	5.0
	DO-9
	5.0

	TO-33
	70.0
	DO-13
	10.0

	TO-39
	70.0
	DO-14
	5.0

	TO-41
	10.0
	DO-29
	10.0

	TO-44
	70.0
	DO-35
	10.0

	TO-46
	70.0
	DO-41
	10.0

	TO-52
	70.0
	DO-45
	5.0

	TO-53
	5.0
	DO-204MB
	70.0

	TO-57
	5.0
	DO-205AB
	5.0

	TO-59
	5.0
	PA-42A, B
	70.0

	TO-60
	5.0
	PD-36C
	70.0

	TO-61
	5.0
	PD-50
	70.0

	TO-63
	5.0
	PD-77
	70.0

	TO-66
	10.0
	PD-180
	70.0

	TO-71
	70.0
	PD-319
	70.0

	TO-72
	70.0
	PD-262
	70.0

	TO-83
	5.0
	PD-975
	70.0

	TO-89
	22.0
	PD-280
	70.0

	TO-92
	70.0
	PD-216
	70.0

	T0-99
	70.0
	PT-2G
	70.0

	TO-126
	5.0
	PT-6B
	70.0

	TO-127
	5.0
	PH-13
	70.0

	TO-204
	10.0
	PH-15
	70.0

	TO-204AA
	10.0
	PY-58
	70.0

	PY-373
	70.0
	
	


Thermal Resistance Units:

Choice List or User-Definable

Any five character designation is allowed. Specifies the units for the Thermal Resistance. This parameter is not used in any calculations. It is provided for your convenience so that you can record the thermal resistance units entered.

Temperature Rise:

Real (Degrees C)

Relex automatically computes the Temperature Rise by adding the Initial Temperature Rise value to the product of the Power Dissipation and Thermal Resistance. If you enter a value which differs from the computed value, the Initial Temperature Rise and/or Power Dissipation will be ignored and set to zero. You can directly enter in a value for Temperature Rise, without entering values for Initial Temperature Rise, Power Dissipation and Thermal Resistance. The Temperature Rise value is added to the Operating Temperature of the subassembly to compute the device Junction \Keyword "Junction"  Temperature for calculations. If you prefer, you can directly enter in a value for the Junction Temperature in the Junction Temp Override field. 

For components inside a hybrid, if the temperature rise from case to junction cannot be determined, use the following defaults:

1. Integrated.Circuits: 10 Degrees C

2. Transistors: 25 Degrees

3. Diodes: 20 Degrees C

Maximum Rated Temperature:

Real (Degrees C)

The manufacturer's stated maximum junction temperature, normally is 175 Degrees C for silicon integrated circuits.

The device is flagged as overstressed if the sum of the Temperature Rise and Subassembly Temperature is greater than the Maximum Junction Temperature.

Junction Temperature Override:

Real (Degrees C)

Generally this field is left at 0.0. Relex normally calculates the Junction Temperature by adding the Temperature Rise and the Subassembly Operating Temperature. If you enter a value for this Override, Relex will not compute the temperature, but use the temperature you enter. Leave this at 0.0 if you want Relex to compute the temperature. This way, Relex automatically takes any changes to the subassembly temperature or to factors contributing to temperature rise into account.

217 Semiconductors

Entering 217 Diodes
Entering 217 General Transistors
Entering 217 Microwave Transistors
Entering 217 High Frequency Transistors
Entering 217 General Optoelectronic Devices
Entering 217 Laser Diodes
Entering 217 Diodes

Following are the part parameters required for the general Diodes in Relex 217. Diodes covered under this Guide topic include:

· Low Frequency

· Microwave, RF

· Thyristor, SCR

Type:

Choice List [Parts Count also]

Not required for Thyristor, SCR.

The type of diode, i.e. General Purpose, Switching, Rectifier, etc. for Low Frequency, or Si Impatt, Gunn, Tunnel, etc. for Microwave RF.

Quality Level:

Choice List [Parts Count also]

The screening level of the device.

Operating Voltage:

Real (Volts)

Not required for Transient Suppressors, Current and Voltage Regulators, Microwave RF.

The operating maximum reverse diode voltage.

Rated Voltage:

Real (Volts)

Not required for Transient Suppressors, Current and Voltage Regulators, Microwave RF.

The rated reverse diode voltage.

Voltage Ratio:

Real (0.0 - 100.0)

Not required for Transient Suppressors, Current and Voltage Regulators, Microwave RF.

The ratio of Operating to Rated Voltage. If operating and rated voltages are entered, Relex automatically computes the voltage ratio. You may override this calculation, or set the ratio directly, by entering a value in this field.

Overstress flag is set if:

· Any power or voltage stresses are > 100.0, or

· The power stress ratio \Keyword "Stress Ratio"  is over the maximum power stress ratio per each Mil-Spec and the MIL-HDBK-217 stress tables. This is dependent on the derating and the rated temperatures.

# of Stacks:

Integer

Required only for High Voltage Diode Stacks.

The quantity of diodes stacked upon each other.

Construction Type:

Choice List

Required for Low Frequency only.

The contact construction of the diode, either metallurgically or non-metallurgically bonded. Non-metallurgically bonded includes spring loaded contacts.

Power Rating: \Keyword "Power Rating" 
Real (Watts)

Required for Microwave RF PIN Diodes only.

The rated power of the device.

Rated Forward Current:

Real (Amps)

Required for Thyristors, SCRs only.

The maximum rated forward rms current of the thyristor or SCR.

217 Temperature Fields
Entering 217 General Transistors

Following are the part parameters required for the general Transistors in Relex 217. Transistors covered under this Guide topic include:

· General, Bipolar

· General, Si FET

· Unijunction

· Microwave, Low Noise

Application:

Choice List

Required for General, Bipolar and General Si FET Transistors.

The application of the transistor in the circuit, whether used as a switching diode, amplifier, etc.

Type:

Choice List

Required for General, Si FETs only.

FET type, either MOSFET or JFET.

Quality Level:

Choice List [Parts Count also]

The screening level of the device.

Two Sided:

Checkbox

Required for General, Bipolar and General Si FET Transistors.

Enable this checkbox if using a 2-sided transistor. If this checkbox is enabled, data entry fields for the second side appear on the data entry form. Otherwise, these fields do not appear. The fields for side 2 apply only to side 2. The Thermal Resistance and Maximum Rated Temperature for side 2 are assumed to be the same as for side 1.

Operating Voltage:

Real (Volts)

Required for General, Bipolar and Microwave, Low Noise.

The applied Vce of the transistor.

Rated Voltage:

Real (Volts)

Required for General, Bipolar and Microwave, Low Noise.

The rated Vce0 of the transistor.

Voltage Ratio:

Real (0.0 - 100.0)

Required for General, Bipolar and Microwave, Low Noise.

The ratio of Operating to Rated Voltage. If operating and rated voltages are entered, Relex automatically computes the voltage ratio. You may override this calculation, or set the ratio directly, by entering a value in this field.

Overstress flag is set if:

· Any power or voltage stresses are > 100.0, or

· The power stress ratio \Keyword "Stress Ratio"  is over the maximum power stress ratio per each Mil-Spec and the MIL-HDBK-217 stress tables. This is dependent on the derating and the rated temperatures.

Power Rating: \Keyword "Power Rating" 
Real (Watts)

Required for General, Bipolar and Microwave, Low Noise.

The rated power of the whole device.

217 Temperature Fields
Entering 217 Microwave Transistors

Following are the part parameters required for High Power Microwave Transistors in Relex 217.

Application:

Choice List

The application of the transistor in the circuit, either Continuous Wave (CW) or Pulsed.

Quality Level:

Choice List [Parts Count also]

The screening level of the device.

Metallization:

Choice List

The metallization type for the microwave transistor, either Gold or Aluminum.

Internal Matching:

Choice List

The internal matching of the transistor.

Operating Voltage:
Real (Volts)

The applied Vce of the transistor.

Rated Voltage:

Real (Volts)

The rated Vce0 of the transistor.

Voltage Ratio:

Real (0.0 - 100.0)

The ratio of Operating to Rated Voltage. If operating and rated voltages are entered, Relex automatically computes the voltage ratio. You may override this calculation, or set the ratio directly, by entering a value in this field.

Overstress flag is set if:

· Any power or voltage stresses are > 100.0, or

· The power stress ratio \Keyword "Stress Ratio"  is over the maximum power stress ratio per each Mil-Spec and the MIL-HDBK-217 stress tables. This is dependent on the derating and the rated temperatures.

Average Output Power:

Real (Watts)

The average output power of the device. Refers to the power level for the overall packaged device, not individual components within the device.

Frequency (GHz):

Real (GHz)

The operating frequency of the device in gigahertz.

Duty Cycle:

Real (0.0 - 100.0)

Required for Pulsed devices only.

The duty cycle of the device expressed as a percentage.

217 Temperature Fields
Entering 217 High Frequency Transistors

Following are the part parameters required for the High Frequency Transistors in Relex 217. Transistors covered under this Guide topic include:

· High Frequency, GaAs FETs

· High Frequency, Si FETs

Application:

Choice List

Required for High Frequency, GaAs FETs only.

The application of the transistor in the circuit, either Continuous Wave (CW) or Pulsed.

Type:

Choice List

Required for High Frequency, Si FETs only.

FET type, either MOSFET or JFET.

Quality Level:

Choice List [Parts Count also]

The screening level of the device.

Two Sided:

Checkbox

Enable this checkbox if using a 2-sided transistor. If this box is enabled, data entry fields for the second side appear on the data entry form. Otherwise, these fields do not appear. The fields for side 2 apply only to side 2. The Thermal Resistance and Maximum Rated Temperature for side 2 are assumed to be the same as for side 1.

Average Output Power:

Real (Watts)

Required for High Frequency GaAs FETs only.

The average output power of the device. Refers to the power level for the overall packaged device, not individual components within the device.

Frequency (GHz):

Real (GHz)

Required for High Frequency GaAs FETs only.

The operating frequency of the device in gigahertz.

Internal Matching:

Choice List

Required for High Frequency GaAs FETs only.

The internal matching of the transistor.

217 Temperature Fields
Entering 217 General Optoelectronic Devices

Following are the part parameters required for the General Optoelectronic Devices in Relex 217. Devices covered under this Guide topic include:

· Detector, Isolator, Emitter (LED)

· Alphanumeric Display

Type:

Choice List [Parts Count also]

The optoelectronic device type, i.e. Detector, Isolator, LED, etc. For Alphanumeric Display, whether a logic chip is included or not.

Application:

Choice List

Required for Alphanumeric Displays only.

The application of the alphanumeric display, either segment or diode array display.

Quality Level:

Choice List [Parts Count also]

The screening level of the device.

# of Characters:

Integer

Required for Alphanumeric Displays only.

The quantity of characters in the display.

217 Temperature Fields
Entering 217 Laser Diodes

Following are the part parameters required for Laser Diode Devices in Relex 217.

Type:

Choice List

Identify the Laser Diode as Continuous Wave (CW) or Pulsed.

Material Type:

Choice List [Parts Count also]

The material that the Laser Diode is made from.

Construction Type:

Choice List [Parts Count also]

The package construction type: hermetic or non-hermetic with or without facet coating.

Duty Cycle:

Real (0.0 - 100.0)

Required for Pulsed devices only.

The duty cycle of the device expressed as a percentage.

Forward Peak Current:

Real

The peak forward current of the Laser Diode.

Required Optical Power:

Real (Watts)

The required optical power output of the Laser Diode.

Rated Optical Power:

Real (Watts)7

Optical Power Ratio:

Real (0.0 - 1070.0)

The ratio of required to rated optical power output, expressed as a percentage, i.e. Power Ratio = Required Power / Rated Power * 100

Overstress flag is set if:

· Temperature Rise + Subassembly Temp > Maximum Rated Junction \Keyword "Junction"  Temp, or

· Optical Power Output Ratio > 100.0

217 Temperature Fields
Entering 217 Fixed Resistors

Following are the part parameters required for all Fixed Resistors in Relex 217. Exceptions for certain part types are noted.

Quality Level:

Choice List [Parts Count also]

The level of screening of the resistor.

Operating Power:

Real (Watts)

The operating power of the resistor in the circuit.

Rated Power:

Real (Watts)

The rated power of the resistor.

Power Ratio:

Real (0.0 - 100.0)

The Operating Power is divided by the Rated Power to yield this Stress Ratio \Keyword "Stress Ratio"  expressed as a percentage, i.e. Power Ratio = Operating Power/Rated Power * 100

Overstress flag is set if:

· Stress Ratio > Max Stress Ratio for the subassembly temperature as given in the applicable Mil-Spec or MIL-HDBK-217 stress tables.

Resistance:

Real [MIL-HDBK-217F Notice 1 only]

The resistance value of the resistor. Enter in the resistance numerical value, the units are entered to the right. 

Resistance Units:

Choice List [MIL-HDBK-217F Notice 1 only]

Units of the entered Resistance, either ohm, Kohm, or Mohm where Kohm is ohm * 1000 and Mohm is ohm * 1E6.

Style: \Keyword "Style" 
Choice List [MIL-HDBK-217F Notice 1 only]

Required for certain resistor types only, i.e. RE, RER, RW, RWR.

The MIL-R style number of the device.

Winding:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for resistor type RE only.

Specify whether the winding of inductive or noninductive.

Thermistor Type:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for RTH thermistors only.

Identify the thermistor as of the bead, disc, or rod type.

Resistor Quantity:

Integer [MIL-HDBK-217F Notice 1 only]

Required for RZ network resistors only.

The number of film resistors in use. Do not include resistors that are not used.

Temperature Rise:

Real

This is the temperature rise from the subassembly temperature to the case of the resistor. It is normally left equal to 0.0.

Case Temperature Override:

Real

This is the Override case temperature. Normally resistor case temperature = subassembly temperature + temperature rise. If you wish to override this calculation, enter a value here.

Entering 217 Variable Resistors

Following are the part parameters required for all Variable Resistors in Relex 217. Exceptions for certain part types are noted.

Quality Level:

Choice List [Parts Count also]

The level of screening of the resistor.

Potentiometer/Rheostat:

Checkbox [MIL-HDBK-217F Notice 1 only]

Identify the way that the variable resistor is connected in the circuit. Several data entry fields as well as the calculations are modified depending on the type.

Operating Power/Current:

Real (Watts/Amps)

The operating stress of the resistor in the circuit. Power is used for potentiometers, while current is used for rheostats.

Rated Power/Current:

Real (Watts/Amps)

The rated stress of the resistor. Power is used for potentiometers, while current is used for rheostats.

Power/Current Ratio:

Real (0.0 - 100.0)

The Operating Stress is divided by the Rated Stress to yield this Stress Ratio \Keyword "Stress Ratio"  expressed as a percentage, i.e. Power/Current Ratio = Operating Power/Current / Rated Power/Current * 100

Overstress flag is set if:

· Stress Ratio > Max Stress Ratio for the subassembly temperature as in each Mil-Spec and the MIL-HDBK-217 stress tables.

Operating Voltage:

Real (Volts) [MIL-HDBK-217F Notice 1 only]

The operating voltage of the resistor in the circuit.

Rated Voltage:

Real (Volts) [MIL-HDBK-217F Notice 1 only]

The rated voltage of the resistor.

Voltage Ratio:

Real (0.0 - 100.0) [MIL-HDBK-217F Notice 1 only]

The Operating Voltage is divided by the Rated Voltage to yield this Voltage Ratio expressed as a percentage, i.e. Voltage Ratio = Operating Voltage / Rated Voltage * 100

Overstress flag is set if:

· Voltage Ratio > 100.0

Resistance:

Real [MIL-HDBK-217F Notice 1 only]

The resistance value of the resistor. Enter in the resistance numerical value, the units are entered to the right.

Resistance Units:

Choice List [MIL-HDBK-217F Notice 1 only]

Units of the entered Resistance, either ohm, Kohm, or Mohm where Kohm is ohm * 1000 and Mohm is ohm * 1E6.

Load Resistance:

Real [MIL-HDBK-217F Notice 1 only]

Required for Potentiometers only.

The total resistance between the wiper arm and one end of the potentiometer. Used in the actual Power Stress ratio calculations.

Load Resistance Units:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for Potentiometers only.

Units of the entered Load Resistance, either ohm, Kohm, or Mohm where Kohm is ohm * 1000 and Mohm is ohm * 1E6.

Number of Sections:
Integer (0 - 6) [MIL-HDBK-217F Notice 1 only]

The number of sections on the variable resistor. This is used in the actual Power Stress ratio \Keyword "Stress Ratio"  calculations.

Section Used:

Integer (0 – # of Sections) [MIL-HDBK-217F Notice 1 only]

The section of the potentiometer that is used. This number cannot be greater than the Number of Sections. This is used in the Power Stress calculations.

Number of Taps:

Integer (0 - 32) [MIL-HDBK-217F Notice 1 only]

The number of variable resistor taps, including the wiper and end terminations.

Construction Type:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for RP resistors only.

The construction class of the resistor, enclosed or unenclosed. The construction class can be determined from the resistor style number. See MIL-HDBK-217 for more information.

Style:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for RR, RT, RTR, RJ resistors only.

The MIL-R style number of the device.

Temperature Rise:

Real

This is the temperature rise from the subassembly temperature to the case of the resistor. It is normally left equal to 0.0.

Case Temperature Override:

Real

This is the Override case temperature. Normally resistor case temperature = subassembly temperature + temperature rise. If you wish to override this calculation, enter a value here.

Entering 217 Capacitors

Following are the part parameters required for all Capacitors in Relex 217. Exceptions for certain part types are noted.

Quality Level:

Choice List [Parts Count also]

The level of screening of the capacitor.

Applied DC Voltage:

Real (Volts)

Applied DC voltage to the capacitor (VDC). Used in Voltage Ratio calculation.

AC RMS Voltage:

Real (Volts)

AC RMS Voltage applied to the capacitor (VAC). Used in Voltage Ratio calculation.

Rated Voltage:

Real (Volts)

Rated Voltage of the capacitor (VDC). Used in Voltage Ratio calculation.

Voltage Ratio:

Real (0.0 - 100.0)

The voltage ratio of the capacitor, expressed as a percentage.

Voltage Ratio = ( sqrt(2) * AC RMS Voltage + Applied DC Voltage ) / Rated Voltage * 100

Overstress flag is set if:

· For CSR, CL & CLR. Voltage Ratio > Max Voltage Ratio for the subassembly temperature as in each Mil-Spec and the MIL-HDBK-217 stress tables.

· For all others, Voltage Ratio > 100.0

Overstress flag also set if:

· Case Temperature > Subassembly Temperature

Capacitance:

Real

Not required for CA, CG, CT, CV, PC capacitors.

The capacitance value of the capacitor excluding the units. Enter the capacitance numerical value, the units are entered to the right.

Capacitance Units:

Choice List

Not required for CA, CG, CT, CV, PC capacitors.

Units of the entered Capacitance, either F, uF, nF, pF where uF=F/1E6, nF=F/1E9, and pF=F/1E12.

Construction Type:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for CM, CL, CLR capacitors only.

The method of construction of the capacitor, dipped or molded.

Series Resistance:

Choice List (Ohms/Volt)

Required for CSR and CWR capacitors only.

Circuit Resistance of the capacitor.

Configuration:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for CG capacitors only.

Whether the capacitor is fixed or variable.

Maximum Rated Temp:

Choice List (Degrees C) [MIL-HDBK-217F Notice 1 only]

Not required for CCR, CDR, CA, CRH, CYR, CE, CLR, CSR, CT capacitors.

The maximum rated operating temperature of the capacitor.

Overstress flag is set if:

· Case Temperature > Maximum Rated Temperature

Temperature Rise:

Real

This is the temperature rise from the subassembly temperature to the case of the capacitor. It is normally left equal to 0.0.

Case Temperature Override:

Real

This is the Override case temperature. Normally capacitor case temperature = subassembly temperature + temperature rise. If you wish to override this calculation, enter a value here.

Entering 217 Inductive Devices

Following are the part parameters required for all Inductors and Transformers in Relex 217. Exceptions for certain part types are noted.

Quality Level:

Choice List [Parts Count also]

The level of screening of the inductor.

Family Type:

Choice List [Parts Count also]

Required for Transformer, Audio, Power, and Pulse only.

Identify the device as audio, power, pulse, or flyback.

Maximum Rated Temp:

Choice List [MIL-HDBK-217F Notice 1 only]

The maximum rated temperature of the inductive device. The corresponds to the insulation class, as follows.


	Specification
	Insulation Class

	MIL-T-27
	Q
R
S
V
T
U

	MIL-T-21038
	Q
R
S
T
U
V

	MIL-T-55631
	O
A
B
C
-
-

	Max Rtd Temp.
(Degrees C)
	85
105
130
155
170
>170


Overstress flag is set if:

· Temp Rise + Subassembly Temp > Max Rated Temp

Temp Rise to Hot Spot:

Real (Degrees C)

The temperature rise from the subassembly to the hot spot temperature.

Hot Spot Temperature:

Real (Degrees C)

This is the Override hot spot temperature. Normally inductor temperature = subassembly temperature + temperature rise to hot spot. If you wish to override this calculation, enter a value here.

Entering 217 Rotating Devices

Following are the part parameters required for all Rotating Devices in Relex 217. Exceptions for certain part types are noted.

Operating Time:

Integer (Hours) [MIL-HDBK-217F Notice 1 only]

Required for Motors only.

The motor operating time period for which the average failure rate will be calculated. Each motor must be replaced when it reaches the end of this operating period to make the calculation valid.

Life Cycle (Hours):

Integer (Hours) [MIL-HDBK-217F Notice 2 only]

Required for Motors only.

The system design life cycle, or the motor preventive maintenance interval, if motors will be periodically replaced or refurbished.

Size:

Choice List

Required for Synchros and Resolvers only.

The synchro/resolver device size.

Number of Brushes:

Choice List

Required for Synchros and Resolvers only.

The number of brushes in the synchro/resolver.

Type:

Choice List [Parts Count also]

Required for ETI Meters and also Motors in MIL-HDBK-217F Notice 2 only.

The type of ETI meter: AC, Inverter Driven, or DC Commutator, or the type of motor: Electrical (General), Sensor, Servo, or Stepper.

Maximum Rated Temperature:

Real (Degrees C)

Required for Synchros, Resolvers, and ETI Meters only.

The rated maximum operating temperature of the device.

Overstress flag is set if:

· Temp Rise + Subassembly Temp > Rated Temp

Temp Rise:

Real (Degrees C)

The temperature rise from the subassembly to the frame temperature.

Frame Temperature Override:

Real (Degrees C)

This is the Override frame temperature. Normally rotating device temperature = subassembly temperature + temperature rise. If you wish to override this calculation, enter a value here.

Entering 217 Relays

Following are the part parameters required for all Relays in Relex 217. Exceptions for certain part types are noted.

Quality Level:

Choice List [Parts Count also]

The screening level of the device.

Construction Type:

Choice List

Required for all types except for Solid State.

The construction type of the relay.

Type:

Choice List [Parts Count also] 

[MIL-HDBK-217F Notice 1 only]

Required for Solid State only.

The type of solid state relay, i.e. Solid State, Time Delay, or Hybrid.

Contact Form:

Choice List

Required for all types except for Solid State.

The number and type of active conducting contacts, e.g. SPST, DPST, SPDT, etc.

Maximum Rated Temperature:

Real (Degrees C)

Required for all types except for Solid State.

The relay maximum temperature rating. 

Overstress flag is set if:

· Subassembly Temp + Temp Rise > Rated Temp

Load Type:

Choice List

Required for all types except for Solid State.

The type of load connected external to the device, i.e. Lamp, Inductive, or Resistive.

Cycling Rate:

Real

Required for all types except for Solid State.

The average number of switching cycles per hour.

Operating Current:

Real (Amps)

Required for all types except for Solid State.

The operating load current of the device in the circuit. Used to calculate the Current Stress Ratio, \Keyword "Stress Ratio"  i.e. Current Stress Ratio = Operating Load Current / Rated Resistive Current

Rated Current:

Real (Amps)

Required for all types except for Solid State.

The rated current of the device with a resistive load. Used to calculate the Current Stress Ratio, i.e. Current Stress Ratio = Operating Load Current / Rated Resistive Current

Current Stress Ratio:

Real (0.0 - 100.0)

Required for all types except for Solid State.

The current stress ratio of the device, expressed as a percentage. It is calculated automatically as follows.

Current Stress Ratio = Operating Load Current / Rated Resistive Current

Overstress flag is set if: Current Ratio > 100.0

Temperature Rise:

Real (Degrees C)

Required for all types except for Solid State.

The temperature rise from the subassembly to the case temperature.

Case Temperature Override:

Real (Degrees C)

Required for all types except for Solid State.

This is the Override case temperature. Normally device temperature = subassembly temperature + temperature rise. If you wish to override this calculation, enter a value here.

Entering 217 Switches

Following are the part parameters required for all Switches in Relex 217. Exceptions for certain part types are noted.

Quality Level:

Choice List [Parts Count also]

The screening level of the device.

Type:

Choice List [Parts Count also]

Require for Toggle or Pushbutton, Rotary Switches for      MIL-HDBK-217F Notice 1 and Circuit Breakers only.

The type of switch, i.e. Snap Action or Non-Snap Action for Toggle or Pushbutton, Ceramic RF Wafer or Medium Power Wafer for Rotary, and Magnetic Power Switch or Other Nonswitch for Circuit Breakers.

Actuation Differential:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for Basic Sensitive Switches only.

The actuation differential, either <0.002 inches or >0.002 inches.

# of Active Contacts:

Integer [MIL-HDBK-217F Notice 1 only]

Required for Basic Sensitive, Rotary, Thumbwheel Switches only.

The quantity of active conducting contacts.

Contact Form:

Choice List

Require for Toggle or Pushbutton Switches and Circuit Breakers only.

The number and type of active conducting contacts, e.g. SPST, DPST, SPDT, etc.

Load Type:

Choice List

Not required for Circuit Breakers.

The type of load connected external to the device, i.e. Lamp, Inductive, or Resistive.

Cycling Rate:

Real [MIL-HDBK-217F Notice 1 only]

Not required for Circuit Breakers.

The average number of switching cycles per hour.

Operating Current:

Real (Amps)

Not required for Circuit Breakers.

The operating load current of the device in the circuit. Used to calculate the Current Stress Ratio, \Keyword "Stress Ratio"  i.e. Current Stress Ratio = Operating Load Current / Rated Resistive Current

Rated Current:

Real (Amps)

Not required for Circuit Breakers.

The rated current of the device with a resistive load. Used to calculate the Current Stress Ratio, i.e. Current Stress Ratio = Operating Load Current / Rated Resistive Current

Current Stress Ratio:

Real (0.0 - 100.0)

Not required for Circuit Breakers.

The current stress ratio of the device, expressed as a percentage. It is calculated automatically as follows.

Current Stress Ratio = Operating Load Current / Rated Resistive Current

Overstress flag is set if: Current Ratio > 100

Entering 217 Standard Connectors

Following are the part parameters required for Connector \Keyword "Connector"  types below in Relex 217. Exceptions for certain part types are noted.

· General Connector

· PCB Connector

· IC Socket Connector

Quality Level:

Choice List [Parts Count also]

Not required for IC Socket Connector.

The screening level of the device.

Type:

Choice List

Required for General, PCB Connector, and IC Socket Connectors for MIL-HDBK-217F Notice 2 only.

For General, PCB, whether the connector is a mated pair or a single connector. And the type for IC Socket Connectors.

Connector Type:

Choice List [MIL-HDBK-217F Notice 2 only]

Required for General Connectors only.

The type of connector, whether it is Circular/Cylindrical, Hexagonal, Rack and Panel, etc.

Insert Material:

Choice List [MIL-HDBK-217F Notice 1 only]

Required for General Connector only.

The type of insert material used within the connector.

The types are :

· A - 250 Degrees C. Vitreous glass, alumina ceramic, polyamide.

· B - 200 Degrees C. Diallyl phthalate, melamine, fluorosilicone, silicone rubber, polysolfone, epoxy resin.

· C - 125 Degrees C. Polytetrafluoroethylene (teflon), chlorotrifluoroethylene (kel-f).

· D - 125 Degrees C. Polyamide (nylon), polychloroprene (neoprene), polyethylene.

See MIL-HDBK-217 for a further explanation.

# of Mating Cycles:

Choice List (#/1000 hours)

Not required for IC Socket Connector.

The number of mating/unmating cycles per 1000 hours. One cycle includes both the connect and disconnect.

# of Active Contacts:

Integer [Parts Count also]

Required for IC Socket Connectors only.

The quantity of conductive elements in the connector which mate with another element for the purpose of transferring electrical energy.

Temperature Rise:

Real (Degrees C)

Not required for IC Socket Connector.

The temperature rise from the subassembly to the case temperature. In most cases, this can be left equal to 0.0.

Case Temperature Override:

Real (Degrees C)

Not required for IC Socket Connector.

This is the Override case temperature. Normally device temperature = subassembly temperature + temperature rise. If you wish to override this calculation, enter a value here.

Entering 217 Boards with Plated through Holes

Following are the part parameters required for Boards with Plated through Holes in Relex 217.

Quality Level:

Choice List

The screening level of the device.

Type:

Choice List

Whether the board is classified as a printed wiring assembly or whether it is discrete wiring.

# of Wave Soldered PTHs:

Integer

The quantity of wave soldered functional plated-thru holes.

# of Hand Soldered PTHs:

Integer

The quantity of hand soldered plated-thru holes.

# of Circuit Planes:

Integer

The quantity of board planes. If the board uses discrete wiring with plated thru holes, assume # of Circuit Planes = 1.

Auto Calc Adjustment:

Integer

Auto Calc is used to allow Relex to automatically count up the number of connections in a particular subassembly. When Auto Calc is selected for a particular connection type, Relex will automatically count up the number of connections and enter it into that connection type. You may either increase or decrease this automatically calculated number by entering a positive or negative value into the Auto Calc Adjustment field.

Entering Other 217 Connectors

Following are the part parameters required for Other Connectors in Relex 217.

# of Hand Soldered Connections:

Integer [Parts Count also]

The quantity of hand soldered connections.

# of Crimped Connections:

Integer [Parts Count also]

The quantity of crimped connections. The quality grade of the crimped connections must be entered below.

# of Welded Connections:

Integer [Parts Count also]

The quantity of welded connections.

# of Solderless Wrapped Connections:

Integer [Parts Count also]

The quantity of solderless wrapped connections.

# of Wrapped and Soldered Connections:

Integer [Parts Count also]

The quantity of wrapped and soldered connections.

# of Clip Termination Connections:

Integer [Parts Count also]

The quantity of clip termination connections.

# of Reflow Soldered Connections:

Integer [Parts Count also]

The quantity of reflow soldered connections.

# of Spring Contact Connections:

Integer [Parts Count also] [MIL-HDBK-217F Notice 2 only]

The quantity of spring contact connections.

# of Terminal Block Connections:

Integer [Parts Count also] [MIL-HDBK-217F Notice 2 only]

The quantity of terminal block connections.

Crimped Quality:

Choice List [Parts Count also]

[MIL-HDBK-217F Notice 1 only]

The Quality Grade for crimp connections are as follows:

1. Automated - Daily pull tests recommended.

2. Upper Manual Tool - Only MIL-SPEC or equivalent tools and terminals, pull test at beginning and end of each shift, color coded tools and terminations.

3. Standard Manual Tool - Only MIL-SPEC tools, pull test at beginning of each shift.

4. Lower Manual Tool - Anything less than standard criteria.

Auto Calc Adjustment:

Integer

Auto Calc is used to allow Relex to automatically count up the number of connections in a particular subassembly. When Auto Calc is selected for a particular connection type, Relex will automatically count up the number of connections and enter it into that connection type. You may either increase or decrease this automatically calculated number by entering a positive or negative value into the Auto Calc Adjustment field.

Entering SMT Interconnect Assemblies

Following are the part parameters required for SMT Interconnect Assemblies in Relex 217. This model is only available in MIL-HDBK-217F Notice 2.

Design Life Cycle:

Real

The design life cycle of the equipment in which the circuit board is operating.

Equipment Type:

Choice List

The type of equipment in which the circuit board is operating, whether it is in automotive, consumer, computer, etc. equipment.

Cycling Rate Override:

Real

The Equipment Type yields a certain number of temperature cycles per hour. You may override this and enter your own cycling rate if you desire. If you leave this number as 0.00, then Relex will use the value entered for the Equipment Type, otherwise Relex will use the value that you enter.

Max Joint Distance (mils):

Real

The distance from the center of the device to the furthest solder joint in thousands of an inch.

Joint Height (mils):

Real

The solder joint height in mils for leadless devices. Use 8 mils for all leaded configurations.

Board Substrate:

Choice List

The substrate material of which the board is made, such as FR-4 Laminate, Ceramic Multilayer, Copper Clad Molybdenum, etc.

Package Substrate:

Choice List

Whether the package substrate material is Plastic or Ceramic.

Lead Configuration:

Choice List

The types of leads on the packages, whether they are Leadless, J or S Lead, or Gullwing.

Now enter the temperature rise due to power dissipation on the board by entering in the Initial Temperature Rise, Power Dissipation, Thermal Resistance, and the Temperature Rise.

217 Temperature Fields
Case Temperature Override:

Real (Degrees C)

Generally this field is left at 0.0. The Case Temperature is normally calculated by Relex by adding the Temperature Rise and the Subassembly Operating Temperature. If you enter a value for this Override, Relex will not compute the temperature, but use the temperature you enter. Leave this at 0.0 if you want Relex to compute the temperature.

Entering 217 Miscellaneous Parts

Following are the part parameters required for all Miscellaneous Parts in Relex 217. Exceptions for certain part types are noted.

Quality Level:

Choice List [Parts Count also]

Required for Quartz Crystals, Meters, Filters only.

The screening level of the device.

Type:

Choice List [Parts Count also]

Required for Vibrators, Incandescent Lamps, Meters, Ferrite Devices, Dummy Load only.

The type of the device. For vibrators, 60 cycle, 120 cycle, 480 cycle. For Incandescent Lamps and Meters, AC or DC. For Ferrite Devices, Lo Isolator/Circulator, Hi Isolator/Circulator, or Phase Shifter. For Dummy Loads, <100W, 100 to 1000W, or >1000W.

Frequency (MHz):

Real

Required for Quartz Crystals only.

The rated frequency of the Quartz Crystal.

Illuminate Hrs/Operate Hrs:

Choice List

Required for Incandescent Lamps only.

The ratio of illumination hours to total equipment operating hours.

Rated Voltage:

Real (Volts)

Required for Incandescent Lamps only.

The rated voltage of the incandescent lamp.

Length (Km):

Real [Parts Count also]

Required for Fiber Optic Cables only.

The length of the fiber optic cable in kilometers.

Function:

Choice List [Parts Count also]

Required for Meters only.

Indicates the function of the meter. Choose "Other" for meters whose basic meter movement construction is an ammeter with associated internal conversion elements.

Composition:

Choice List [Parts Count also]

Required for Filters only.

The composition of the filter, i.e. Ceramic Ferrite, Discrete LC, etc.

Entering User-Defined Parts

There are three methods which can be used to determine the failure rate of a user defined part in Relex 217 or Relex Bellcore.

The first method is to directly enter the known failure rate. Any value entered in this field is used as the failure rate and any data entered below is ignored. The second method uses the Weibull Hazard Rate and the third method uses the Arrhenius Model. These methods are described below.

Fixed Failure Rate Computation

Failure Rate:

Real [Parts Count also]

The failure rate of the device in failure/million hours for Relex 217 or in FITs (failures/billion hours) for Relex Bellcore. This number will be used in all calculations with this device. This failure rate of this device is assumed to be constant, i.e. there is no dependence on temperature, environment, or any other variable.

Weibull Hazard Rate Computation

The second method to determine the failure rate of a user defined part uses the Weibull Hazard Rate computation. The Weibull Hazard Rate is equivalent to the failure rate at a point along the hazard rate curve. In our case, we are assuming that the failure rate (or hazard rate) is constant when evaluated at time 't'. This allows us to add these failure rates to others. The equation used to determine failure rate is:

Failure Rate = 1E6 * B/Q * [((t-t0) / Q) ^ B-1]

Where:

   
B = Shape Parameter

   
Q = Characteristic Life

   
t = Time at which to Evaluate Hazard Rate

 
t0 = Minimum Life

   
^x = to the x power

Relex asks for the following parameters:

Shape Parameter:

Real [Parts Count also]

The value to describe the shape of the hazard curve. For example, when the shape parameter is:

· < 1 the curve takes on a Gamma distribution

· = 1 the curve takes on an Exponential distribution (this is the constant failure rate curve)

· = 2 the curve takes on a Lognormal distribution

· = 3.5 the curve takes on a Normal distribution (approximately).

Characteristic Life (or Scale Parameter):

Real [Parts Count also]

The time at which 63.2% of the device population will have failed.

Minimum Life (or Failure Free Time or Location Parameter):

Real [Parts Count also]

The minimum time. If failures occur after time = 0, enter the time. Generally this value is 0.

Time:

Real [Parts Count also]

The time at which to evaluate the hazard rate.

Arrhenius Model Computation

The third method to determine the failure rate of a user defined part uses the Arrhenius Model computation.

The equation used to determine failure rate is:

Failure Rate = 1E6 * K * e^(-E/kT)

   
Where: 

   
K = User Defined Constant

  
E = Activation Energy (eV)

   
k = Boltzmann's Constant (8.63 E-5 ev/Degrees K)

   
T = Absolute Temperature (Degrees K)

   
^x = to the x power

Note that Relex asks for Degrees C.

Relex asks for the following parameters:

Activation Energy (eV):

Real [Parts Count also]

The activation energy for the process.

Constant K Factor:

Real [Parts Count also]

The user defined constant needed to model the failure rate.

Temperature Rise:

Real (Degrees C) [Parts Count also]

The temperature rise from ambient to the device. This is added to the Operating Temperature of the subassembly to yield to device temperature.

Case Temperature Override:

Real (Degrees C) [Parts Count also]

This is the Override case temperature. Normally device temperature = subassembly temperature + temperature rise. If you wish to override this calculation, enter a value here.

For more information on these equations, please refer to reliability textbooks and/or documents such as "Practical Reliability Engineering" by Patrick O'Connor or MIL-STD-338.

Entering Software Reliability

Relex has the ability to calculate software reliability. This software reliability equation built into Relex is from the Rome Laboratory Reliability Engineer's Toolkit April 1993 issue, page 124-125, and which was extracted from the Rome Laboratory Technical Report RL-TR-92-15, "Reliability Techniques \Keyword "Reliability Techniques"  For Combined Hardware and Software Systems".

The following data is requested from Relex to perform the calculations:

Processor Speed (MIPS):

Real [Parts Count also]

The host processor speed in millions of instructions per second.

Fault Exposure Ratio:

Real [Parts Count also]

The fault exposure ratio is a function of program data dependency and structure. The default is 4.2e-7.

Est. Faults (/1000 lines):

Real [Parts Count also]

The estimated total number of faults in the initial program. The default is 6 faults/1000 lines of source code.

Lines of Source Code:

Int [Parts Count also]

The total number of lines of source code.

Programming Language:

Choice List [Parts Count also]

The language that the source code is written in. This is used to determine that number of object instructions. Higher level languages have more object instructions per line of source code than lower level languages.

Fault Reduction Factor:

Real [ Parts Count also]

The fault reduction factor. The default is 0.955.

CPU Seconds/Hour:

Int [Parts Count also]

The number of seconds that the CPU operates per clock hour.

Time (Hours):

Real [Parts Count also]

The CPU execution time in hours.

Relex performs the calculation and converts failures/CPU second into failures/million hours (or whatever time you have set up in Relex Options).

Entering 217 Tubes

Following are the part parameters required for Tubes in Relex 217. Exceptions for certain part types are noted.

Type:

Choice List [Parts Count also]

Not required for CRTs, Thyratrons, Low Power Klystrons.

The type of the device.

Years in Production:

Real [Parts Count also]

Not required for Magnetrons.

The numbers of years that the tube has been in production.

Radiate Hrs/Filament Hrs (%):

Real (0.0 - 100.0) [Parts Count also]

Required for Magnetrons only.

The utilization frequency ratio of the magnetron, equals radiate hours / filament hours * 100

Rated Peak Power (MW):

Real [Parts Count also]

Required for Magnetrons only.

The rated peak power of the tube in megawatts.

Average Power Output:

Real (0.1 - 100 KW) [Parts Count also]

Required for CW Klystrons only.

The average output power of the tube.

 Power must be <= 8.0 * 10E6 * Frequency^-1.7

Peak Power Output:

Real (0.01 - 25 MW) [Parts Count also]

Required for Pulsed Klystrons only.

The peak output power of the tube.

Power must be ó 490 * Frequency^-2.95

Rated Power (W):

Real (0.001 - 20,000 W) [Parts Count also]

Required for TWTs only.

The rated power of the tube. This should be the peak rated power if pulsed.

Operating Frequency (GHz):

Real [Parts Count also]

Required for Magnetrons, Pulsed Klystrons, TWTs only.

The operating frequency of the tube in gigahertz.

Operating Frequency (MHz):

Real (300 - 8000 MHz) [Parts Count also]

Required for CW Klystrons only.

The operating frequency of the tube.

Entering 217 Lasers

Following are the part parameters required for all Lasers in Relex 217. Exceptions for certain part types are noted.

Number Optical Surfaces:

Integer [Parts Count also]

Required for Sealed CO2, Flowing CO2, Nd:YAG Rod, Ruby Rod Lasers only.

The quantity of active optical surfaces with which the laser energy or beam interacts. Internally reflecting surfaces should be not counted.

Current (mA):

Real (10 - 150 mA) [Parts Count also]

Required for Sealed CO2 Lasers only.

The current through the discharge tube of the carbon dioxide sealed laser.

CO2 Overfill Percent:

Integer (0 - 100) [Parts Count also]

Required for Sealed CO2 Lasers only.

The percent increase over the optimum CO2 partial pressure which is normally in the range of 1.5 to 3 Torr for most carbon dioxide sealed lasers.

% Ballast Volume Increase:

Integer [Parts Count also]

Required for Sealed CO2 Lasers only.

The percent of ballast volumetric increase.

Beam Avg Power (kW):

Real (kW) [Parts Count also]

Required for Flowing CO2 Lasers only.

The laser beam average power output in kilowatts.

Cleanliness Level:

Choice List [Parts Count also]

Required for Nd:YAG Rod, Ruby Rod only.

The cleanliness level which is critical to the reliability of the part. Contamination is the major cause of solid state laser malfunction. The choices are :

1. Rigorous cleanliness procedures, equipment, and trained maintenance personnel. Plus bellows provided over optical train.

2. Minimal precautions during opening, maintenance, repair, and testing. Plus bellows provided over optical train.

3. Minimal precautions during opening, maintenance, repair, and testing. No bellows provided over optical train. 

Cooling Media:

Choice List [Parts Count also]

Required for Nd:YAG Rod, Ruby Rod only.

Whether the cooling media of the laser is a gas or liquid.

Arc Length (inches):

Integer [Parts Count also]

Required for Nd:YAG Rod, Ruby Rod only.

The flashlamp or flashtube arc length in inches; its value is determined from the actual design parameter of the flashlamp utilized.

Energy Density (J/cm2):

Real [Parts Count also]

Required for Ruby Rod only.

The energy density in Joules per cm2 per pulse over the cross-sectional area of the laser beam which is nominally equivalent to the cross-sectional area of the laser rod. Its value is determined from the actual design parameter of the laser rod utilized.

Pulse Rate (pps):

Real [Parts Count also]

Required for Nd:YAG Rod, Xenon, Ruby Rod only.

The pulse or repetition rate in pulses per second. This is generally in the 1 to 20 pps range for military solid state lasers.

Input Energy/Pulse (J):

Real [Parts Count also]

Required for Nd:YAG Rod, Xenon, Ruby Rod, Xenon only.

The flashlamp or flashtube input energy per pulse in joules. Its value is determined from the actual or design input energy parameter.

Inside Diameter (mm):

Real [Parts Count also]

Required for Nd:YAG Rod, Xenon, Ruby Rod, Xenon only.

The flashlamp or flashtube inside diameter in millimeters. Its value is determined from the actual design parameter for the flashlamp utilized.

Pulse Width (usec):

Real [Parts Count also]

Required for Nd:YAG Rod, Xenon, Ruby Rod, Xenon only.

The truncated pulse width in microseconds. Its value is determined from the actual design parameter of the pulse forming network (PFN) used to pulse the flashlamp or flashtube.

Avg Input Power (kW):

Real [Parts Count also]

Required for Nd:YAG Rod, Krypton, Ruby Rod, Krypton only.

The average input power in kilowatts. Its value is determined from the actual design parameter for the flashlamp utilized.

 \Keyword "Telcordia (Bellcore)" Telcordia (Bellcore) Quality Levels

Enter the appropriate quality level as shown below.

Quality Level:

Choice List

The quality level of the device, and is one of the following:

Quality Level 0: (lowest quality)

This level shall be assigned to devices considered to be commercial-grade or reengineered/remanufactured components.

Quality Level I:

This level shall be assigned to commercial-grade devices that are procured and used without thorough device qualification or lot-to-lot controls by the equipment manufacturer. However, 

· Steps must have been taken to ensure that the components are compatible with the design application and the manufacturing process; and

· An effective feedback and corrective action program must be in place to identify and resolve problems quickly in manufacture in the field.

Quality Level II :

This level shall be assigned to devices that meet requirements (a) and (b) of Quality Level I, plus the following:

· (c) Purchase specifications must explicitly identify important characteristics (electrical, mechanical, thermal) and acceptable quality levels (i.e., AQLs, DPMs) for lot control;

· (d) Devices and vendors must be qualified and identified on approved parts/vendor lists (device qualification must include appropriate life and endurance tests);

· (e) Lot-to-lot controls, either by the equipment manufacturer or the device manufacturer, must be in place at adequate AQLs/DPMs to ensure consistent quality.

Quality Level III: (highest quality)

This level shall be assigned to devices that meet requirements (a) through (e) of Quality Levels I and II, plus the following:

· (f) Devices must be requalified periodically;

· (g) Lot-to-lot controls must include 100% screening (temperature cycling and burn-in \Keyword "Burn-In" ) which, if the results warrant it, may be reduced to a "reliability audit" (i.e., on a sample basis) or to an acceptable "reliability monitor" with demonstrated and acceptable cumulative early failure values out to 10,000;

· (h) Where burn-in screening is used, the percent defective allowed (PDA) should be specified; and

· An ongoing, continuous reliability improvement program must be implemented by both the device and equipment manufacturer.

Note: It is the manufacturer's responsibility to provide justification for all levels other than Level I.

 \Keyword "Telcordia (Bellcore)" Entering Telcordia (Bellcore) Integrated Circuits

Following are the part parameters required for the general Integrated Circuits in Relex Telcordia (Bellcore). Integrated Circuits covered under this Guide topic include:

· Logic

· PAL, Gate Array

· Linear/Analog

· Microprocessor

· Memory

Technology Type:

Choice List

The technology type of the device, e.g. Bipolar, NMOS, CMOS.

Telcordia (Bellcore) Quality Levels
# of Gates:

Integer

Required for Logic, PAL, Gate Array, Microprocessor only.

The number of active gates in the package. You can determine the gate count from the logic diagram. A J-K or R-S flip flop is equivalent to 6 gates when used as part of an LSI circuit. For the purposes of a Relex Telcordia (Bellcore) prediction, a gate is considered to be any one of the following functions: AND, OR, exclusive OR, NAND, NOR, and inverter. When a logic diagram is not available, use device transistor count to determine gate count using the following equations:

Bipolar: Gates = # Transistors/3

CMOS: Gates = # Transistors/4

All other MOS, except CMOS: Gates = # Transistors/3

# of Transistors:

Integer

Required for Linear, PAL, Gate Array only..

The number of active transistors in the package, can be determined for logic diagrams.

# of Bits:

Integer

Required for Memory only.

The number of bits in the memory device. Use this field in conjunction with the next field, Bit Units, to enter the memory device bits.

Bit Units:

Choice List

Required for Memory only.

The Units that the # of Bits field is to be multiplied by, i.e. B, KB, MB, GB where B is bits, KB is 1000 bits, MB is 1E6 bits, and GB is 1E9 bits. You can enter the bits several ways. For example, a 1 megabit memory chip can be entered as 1 for # of Bits and MB for Units, or 1000 for # of Bits and KB for Units, or 1048576 for Bits and B for Units.

Package Type:

Choice List

Indicates how the chip is packaged, either Hermetic or Plastic.

 \Keyword "Telcordia (Bellcore)" Entering Telcordia (Bellcore) Discrete Semiconductors

Following are the part parameters required for the Semiconductors in Relex Telcordia (Bellcore). Semiconductor devices covered under this topic include:

· Diode, Low Frequency

· Diode, Microwave, RF

· Thyristor, SCR

· Transistor, General, Bipolar

· Transistor, General, Si FET

· Transistor, Unijunction

· Transistor, Microwave, Low Noise

· Transistor, High Freq., GaAs FET

· Opto, Detector, Isolator, Emitter

· Opto, Alphanumeric Display

Type:

Choice List

Required for Diode, Low Frequency; Diode, Microwave RF; Transistor, General, Bipolar; Opto, Detector, Isolator, Emitter only.

The type of the device.

Application:

Choice List

Required for Transistor, General, Si FET; Transistor, Microwave, Low Noise; Transistor, High Freq., GaAs FET; Optos only.

For Transistor, General, Si FET, whether the device application in the circuit is linear, switch, or high frequency. For Transistor, Microwave, Low Noise, whether CW or pulsed. For Transistor, High Freq., GaAs FET, whether Low Noise or Driver. For Optos, pick an item from the choice list.

Telcordia (Bellcore) Quality Levels
Package Type:

Choice List

Indicates how the chip is packaged, either Hermetic or Plastic.

Operating Current:

Real (Amps)

Required for Diode, Low Frequency, General Purpose, Thyristor only.

The operating current of the device in Amps.

Operating Power:

Real (Watts)

Required for Diode, Low Frequency, Voltage Regulator; Transistor, General, Bipolar only.

The operating power of the device in Watts.

 \Keyword "Telcordia (Bellcore)" Entering Telcordia (Bellcore) Resistors

Following are the part parameters required for the Fixed and Variable Resistors in Relex Telcordia (Bellcore).

Telcordia (Bellcore) Quality Levels
Resistance:

Real

Not required for Fixed, Wirewound, Power.

The resistance value of the resistor. Enter in the resistance numerical value, the units are entered to the right. 

Resistance Units:

Choice List

Not required for Fixed, Wirewound, Power.

Units of the entered Resistance, either ohm, Kohm, or Mohm where Kohm is ohm * 1000 and Mohm is ohm * 1E6.

Thermistor Type:

Choice List

Required for Thermistors only.

Whether the thermistor is of the bead, disc, or rod types.

Type:

Choice List

Required for Network Film only.

Whether the network resistor is discrete elements, or thick or thin film.

Resistor Quantity:

Integer

Required for Network Film only.

The number of film resistors in use. Do not include resistors that are not used.

Construction Type:

Choice List

Required for Variable, Wirewound, Power only.

The construction type of the resistor, enclosed or unenclosed.

 \Keyword "Telcordia (Bellcore)" Entering Telcordia (Bellcore) Capacitors

Following are the part parameters required for the Capacitors in Relex Telcordia (Bellcore).

Telcordia (Bellcore) Quality Levels
Capacitance:

Real

Required for Electrolytic, Aluminum only.

The capacitance value of the capacitor excluding the units. Enter the capacitance numerical value, the units are entered to the right.

Capacitance Units:

Choice List

Required for Electrolytic, Aluminum only.

Units of the entered Capacitance, either F, uF, nF, pF where uF=F/1E6, nF=F/1E9, and pF=F/1E12.

Entering Telcordia (Bellcore) Inductors

Following are the part parameters required for the Inductors in Relex Telcordia (Bellcore).

Telcordia (Bellcore) Quality Levels
Family Type:

Choice List

Required for Transformer, Audio, Power, and Pulse only.

Whether the device is audio, power, or pulse.

Entering Telcordia (Bellcore) Rotating Devices

The only part parameter required for Rotating Devices in Relex Telcordia (Bellcore) is the Quality Level.

Telcordia (Bellcore) Quality Levels
Entering Telcordia (Bellcore) Relays

The only part parameter required for Relays in Relex Telcordia (Bellcore) is the Quality Level.

Telcordia (Bellcore) Quality Levels
Entering Telcordia (Bellcore) Switches

Following are the part parameters required for the Switches in Relex Telcordia (Bellcore).

Telcordia (Bellcore) Quality Levels
Number of Contact Pairs:

Integer

The number of contact pairs equals n x (2 raised to the power of m-1), where n equals the number of poles and m equals the number of throws. For example, a single pole double throw (SPDT) switch has: 

1 x (2 pow(2-1)), or a total of 2, contact pairs.

 \Keyword "Telcordia (Bellcore)" Entering Telcordia (Bellcore) Connections

Following are the part parameters required for the Connectors and Connections in Relex Telcordia (Bellcore).

# of Active Contacts:

Integer

The quantity of conductive elements in the connector which mate with another element for the purpose of transferring electrical energy.

Entering Telcordia (Bellcore) Miscellaneous Parts

Following are the part parameters required for all Miscellaneous Parts in Relex Telcordia (Bellcore). Exceptions for certain part types are noted.

Type:

Choice List

Required for Vibrators, Circuit Breakers, Incandescent Lamps, Ferrite Devices, Batteries only.

The type of the device. For vibrators, 60 cycle, 120 cycle, 480 cycle. For Circuit Breakers, Protection Only or Power On/Off. For Incandescent Lamps and Meters, 5 VDC, 12 VDC, or 48 VDC. For Ferrite Devices, Transmit or Receive. For Batteries, Nickel Cadmium or Lithium.

Number of Poles:

Integer

Required for Circuit Breaker only.

The number of poles of the circuit breaker.

Telcordia (Bellcore) Other Components

Entering Telcordia (Bellcore) Miscellaneous Parts
Entering User-Defined Parts
Entering Software Reliability
Entering Mechanical Parts

To enter a mechanical part in Relex Telcordia (Bellcore), you first need to define the Part Category and Part SubCategory in the General Part Form, then press <OK>. See the appropriate choice below for the type of part you are entering.

Each of the specific part entry screens has a listing of all part parameters required for each of the device types. Listed are:

1. The name of the part parameter (the same as the prompt on the screen).

2. Whether the item is a Choice List, an Integer, or a Real Number.

3. Limits of the parameter as well as its units, if applicable.

4. A description of the entry. 

Entering Seals

Following are the part parameters required for seals. Exceptions for certain part types are noted.

Meyer Hardness:

Real (psi). Used in Ch calculation.

The Meyer Hardness factor in psi. Young's modulus is equivalent to Meyer's Hardness for Rigid Material. Meyer Hardness can be calculated from:

Meyer Hardness = 4 * Pf / (square(Din)) * pi

   
Where:

   
Pf = Load applied to sample, lbs.

   
Din = diameter of indentation of sample, in.

Contact Pressure:

Real (psi). Used in Ch calculation.

The minimum contact pressure in psi. Some common values are:

Asbestos and Rubber: 800-2000

Cellulose and Rubber: 1000-2000

Cork: 500-1000

Rubber: 400- 600

It can also be calculated using C = Fc/Asc

Where:

C = contact pressure in psi

Fc = force compressing seals in lbs.

Asc = Area of seal contact in square inches.

Surface Finish:

Real (micro inches). Used in Cf calculation.

The surface finish in micro inches. Common values range from 0 to 100.

# of Particles/Hr/GPM:

Real (N10). Used in Cn calculation.

The Number of Particles (mg) under 10 Micron per Hour per GPM (N10)

Typical Quantities of Particles Produced by Hydraulic Components, Particle Material:

N10

Piston Pump, steel: 1.7

Gear Pump, steel: 1.9

Vane Pump, steel: 0.6

Cylinder, steel: 0.8

Sliding Action Valve, steel: 0.04

Hose, rubber: 0.13

Allowable Leakage:

Real (inches cubed/minute/Max Rated GPM). Used in Cq calculation.

The allowable leakage in inches cubed/minute/Max Rated GPM. Range is commonly from .005 to .1.

Inner Seal Diameter:

Real (in). Used in Cdl calculation.

Required for Seal, Static only.

Common values range from 0 to 2.

Fluid Pressure:

Real (psi). Used in Cp calculation.

Required for Seal, Static only.

The Fluid Pressure in psi. Range is commonly from 0 to 9000.

Actual PV:

Real. Used in Cpv calculation.

Required for Seal, Dynamic only.

Pressure-Velocity Coefficient factor of the actual seal operation.

PV can be calculated from:

PV = (DP (b-k) + Fsp /Ao) Vm

   
Where:

 
DP = pressure differential across seal face in psi.

b = seal balance, ratio of hydraulic closing area to seal face area.

   
k = pressure gradient factor

   
Fsp = seal spring load in lbs.

   
Ao = seal face area in inches squared.

   
Vm = velocity at the seal mean diameter in ft/min.

Some typical values for k are:

· Light-specific-liquids: 0.3

· Water-base solutions: 0.5

· Oil-base solutions: 0.7

Rated PV:

Real. Used in Cpv calculation.

Required for Seal, Dynamic only.

Pressure-Velocity Coefficient factor of the original design. This indicates the affect of wear from seal face pressure and fluid velocity. See Actual PV above for equation.

Filter Size:

Real (microns). Used in Cn calculation.

The system filter size in microns.

Viscosity:

Real (Lb Min/Sq In * E-8). Used in Cv calculation.

The viscosity of the fluid. Entered values are automatically multiplied by 1E-8 to obtain actual viscosity.

Fluid Viscosity will change with temperature. A table of common viscosity values is given below:

Viscosity * E-8:

	
	Temperature (Degrees F)

	Fluid Type
	-50
	0
	50
	100
	150
	200
	250

	MIL-H-83282
	3.3
	2.86
	2.5
	2.2
	2.2
	0.5
	0.67

	MIL-H-5606
	2.86
	2.5
	2.35
	2.2
	2.2
	0.5
	-

	Aircraft Phosphate Esters
	-
	2.5
	2.35
	2.0
	2.0
	0.5
	-

	Industrial Phosphate Esters
	-
	-
	2.86
	2.5
	2.35
	2.2
	-

	Water Glycol
	-
	2.86
	2.5
	2.5
	2.2
	-
	-

	SAE \Keyword "SAE"  10 Oil
	-
	-
	2.86
	2.5
	2.0
	2.0
	0.5

	SAE 60 Oil
	-
	-
	-
	2.86
	2.5
	2.35
	2.0


Temperature Rise:

Real (Degrees C). Used in Ct calculation.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Rated Temperature:

Real (Degrees F). Used in Ct calculation.

The Maximum Temperature Rating specified by the manufacturer, or the Maximum Design Temperature.

Some typical rated temps for seals:


	Seal Material
	Rated Temps (Degrees F)

	Natural Rubber
	162

	Ethylene Propylene
	248

	Neoprene
	48

	Nitrile 
	262

	Polyacrylate
	298

	Fluorosilicone
	385

	Fluorocarbon
	471

	Silicon
	471


Rated Flow Rate:

Real (Gallons/Minute). Used in Cn calculation.

The Maximum Rated Flow in Gallons/Minute.

Entering Springs

Following are the part parameters required for springs.

Type:

Choice List.

Enter the type of spring, i.e. Compression Spring, Torsion Spring, Curved Washer, Wave Washer, Belleville Washer, Cantilever Spring, or Beam Spring.

Tensile Strength:

Real (10^3 psi). Used in Cy calculation.

Measure of spring material deformation, or a function of stress.

Common Values:


	Material
	Tensile Strength

	Brass
	90

	Phophor Bron
	100

	Monel 400
	100

	Inconel 600
	150

	Monel K500
	175

	Copper-Beryllium
	190

	Stainless Stell 301, 302
	190

	17-1 PH RH 950
	210

	Spring Temper Steel
	245


Corrosion Factor:

Real. Used in Cr calculation.

The corrosion factor is a factor rating the corrosive properties of the spring and the operating environment. \Keyword "Operating Environment"  If corrosive protection is known to be applied to the spring during the manufacturing process a Corrosion Factor of 1.0 can be used, otherwise a higher number should be used based on previous experience.

Manufacturing Factor:

Real. Used in Cm calculation.

The effects of sharp corners and similar stress risers, as well as the effects of the hardness of the spring material during plating and baking operations is taken into account in the Manufacturing Factor. A factor of 1.0 should be used for known acceptable quality control procedures, otherwise a higher number should be used based on previous experience.

Cycles/Hour:

Real. Used in Ccs calculation.

The Number of Cycles/Hour. This is required to convert failure ratings from failures/cycle to failures/million hour.

Modulus of Rigidity:

Real (psi * E6) [Gm]. Used in Cg calculation.

Required for Compression Springs only.

Measure of elasticity in shear for the spring material. 

Common values:


	Material
	Modulus of Rigidity

	Ferrous:
	

	Music Wire
	11.5

	Hard Drawn Steel
	11.5

	Chrome Steel
	11.2

	Silicon-Manganese
	10.8

	Stainless, 302, 304, 316
	10.0

	Stainless 17-7 PH
	10.5

	Stainless 420
	11.0

	Stainless 431
	11.4

	Non-Ferrous:
	

	Spring Brass
	5.0

	Phosphor Bronze
	6.0

	Beryllium Copper
	7.0

	Iconel
	10.5

	Monel
	9.5

	Misc:
	

	Carbon Steel
	11.5

	Alloy Steel
	11.5

	Stainless Steel
	10.0 – 11.0

	Copper Base Alloy
	5.7 – 7.0

	Nickel Base Alloy
	9.7 - 11.5


Spring Deflection:

Real (in). Used in Cl calculation.

Required for Compression and Torsion Springs only.

For Compression Springs, deflection in inches. Common 
values range from 0.3 to 2.2.

Can be calculated using: Dl = L1 - L2

   
Where:

  
Dl = Spring Deflection

  
L1 = Initial deflection of spring, in

   
L2 = Final deflection of spring, in

For Torsion Springs, deflection is in degrees. Common values range from 10 to 125 degrees.

Modulus of Elasticity:

Real (psi * E6) [Ge]. Used in Ce calculation.

Required for all but Compression Springs.

Measure of elasticity in shear for the spring material. 

Common values:

	Material
	Modulus of Elasticity

	Ferrous:
	

	Music Wire
	29.0

	Hard Drawn Steel
	28.5

	Chrome Steel
	29.0

	Silicon-Manganese
	29.0

	Stainless, 302, 304, 316
	28.0

	Stainless 17-7 PH
	29.5

	Stainless 420
	29.0

	Stainless 431
	29.5

	Non-Ferrous:
	

	Spring Brass
	15.0

	Phosphor Bronze
	15.0

	Beryllium Copper
	17.0

	Iconel
	31.0

	Monel
	26.0


Wire Diameter:

Real (in). Used in Cdw and Ck calculations.

Required for Compression and Torsion Springs only.

Common values for wire diameter range from .05 to .15.

Coil Diameter:

Real (in). Used in Cdc and Ck calculations.

Required for Compression and Torsion Springs only.

Common values for coil diameter range from 0.3 to 0.99.

Number of Coils:

Integer. Used in Cn calculation.

Required for Compression and Torsion Springs only.

The number of coils in the spring. Common values range from 6 to 22.

Outside Diameter/Length:

Real (in). Used in Cd and Cs calculations.

Required for Spring Washers, Beam and Cantilever Springs only.

For spring washers, enter the outside diameter of the spring.  For beam or cantilever springs, enter the length of the beam.  Common values range from 0.5 to 3.0 inches.

Washer Deflection:

Real (in). Used in Cf calculation.

Required for Spring Washers, Beam and Cantilever Springs only.

The length of deflection of the spring. Common values range from 0.02 to 0.13 inches.

Material Thickness:

Real (in). Used in Ct calculation.

Required for Spring Washers, Beam and Cantilever Springs only.

The thickness of the spring material, generally 0.01 to 0.08 inches.

Number of Waves:

Integer. Used in Cnw calculation.

Required for Wave Washers only.

The number of waves in the wave washer. Common values range from 3 to 8 waves.

Inside Diameter:

Real (in). Used in Cs calculation.

Required for Belleville Washers only.

The inside diameter of the belleville washer.

Entering Solenoids

Following are the part parameters required for solenoids.

Piston Wear Life:

Real. Used in Lambda p calculation.

The wear life of the piston in number of cycles.

Load Type:

Choice List. Used in Cv, Ci, and Cpf calculations.

Enter the type of load, i.e. AC resistive, AC inductive, or DC load.

Operating Voltage:

Real (Volts). Used in Cv calculation.

The operating voltage in volts across the contactor.

Rated Voltage:

Real (Volts). Used in Cv calculation.

The rated voltage in volts of the contactor.

Operating Current:

Real (Amperes). Used in Ci calculation.

The operating current in amps through the contactor.

Rated Current:

Real (Amperes). Used in Ci calculation.

The rated current in amps of the contactor.

Power Factor:

Real. Used in Cpf calculation.

Required only for AC inductive loads.

The multiplying factor for power factor for the contactor. Common values are from 0.25 to 1.0.

Temperature Rise:

Real (Degrees C). Used in Ct calculation.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Rated Temperature:

Real (Degrees F). Used in Ct calculation.

The Maximum Temperature Rating specified by the manufacturer, or the Maximum Design Temperature.

Cycles/Hour:

Real

The Number of Cycles/Hour. This is required to convert failure ratings from failures/cycle to failure/hour.

Entering Bearings

Following are the part parameters required for bearings.

Design B10 Life:

Real. Used in Lambda b calculation.

Design B10 life for each individual bearing. Used to calculate the base failure rate of the bearing. It can be obtained by using:

L10 = (N^0.9 * MTBF) / 5.45

Where:

L10 = B10 life of bearing

N = number of bearings

MTBF = Design MTBF of bearing

Equivalent Radial Load:

Real (lbs). Used in Cy calculation.

Can be computed from various equations depending on bearing type and number of bearings, load factors, diameters, etc. See tables 7-2 through 7-4 in Handbook of Reliability Prediction Procedures for Mechanical Equipment.

Rated Radial Load:

Real (lbs). Used in Cy calculation.

The specification radial load in lbs.

Actual Lubricant Viscosity (xE-8):

Real (Lb-Min/Sq In * E-8). Used in Cv calculation.

The operating viscosity of the lubricant. Entered values are automatically multiplied by 1E-8 to obtain actual viscosity. Fluid Viscosity will change with temperature. A table of common viscosity values is given below:

Viscosity * E-8:


	
	Temperature (Degrees F)

	Fluid Type
	-50
	0
	50
	100
	150
	200
	250

	MIL-H-83282
	3.3
	2.86
	2.5
	2.2
	2.2
	0.5
	0.67

	MIL-H-5606
	2.86
	2.5
	2.35
	2.2
	2.2
	0.5
	-

	Aircraft Phosphate Esters
	-
	2.5
	2.35
	2.0
	2.0
	0.5
	-

	Industrial Phosphate Esters
	-
	-
	2.86
	2.5
	2.35
	2.2
	-

	Water Glycol
	-
	2.86
	2.5
	2.5
	2.2
	-
	-

	SAE 10 Oil
	-
	-
	2.86
	2.5
	2.0
	2.0
	0.5

	SAE 60 Oil
	-
	-
	-
	2.86
	2.5
	2.35
	2.0


Specification Lubricant Viscosity (xE-8):

Real (Lb-Min/Sq In * E-8). Used in Cv calculation.

The specified lubricant viscosity. Entered values are automatically multiplied by 1E-8 to obtain actual viscosity. See the above table for standard viscosity numbers.

% of Water in Oil:

Real. Used in Ccw calculation.

Percentage of water in oil (0.0 - 100.0). Accounts for the reduction in fatigue life due to leakage of water into the oil lubrication.

Bearing Type:

Choice List. Used in Cy calculation.

Whether the bearing is of the ball or roller type.

Cycles/Hour:

Real

The Number of Revolutions or Cycles/Hour. This is required to convert failure ratings from failures/cycle or revolution to failures/hour.

Entering Gears and Splines

Following are the part parameters required for gears and splines.

Base Failure Rate:

Real (Failures/Million Operating Hours for Gears, or Failures/Million Revolutions for Splines). Used in Lambda b calculation.

The base or manufacturer supplied base failure rate. For Gears, this MUST be entered in order to determine the failure rate. For Splines, the Base Failure Rate may be entered to override the calculated Base Failure Rate. In this case, if the Base Failure Rate is set at 0.0, Relex will compute the Base Failure Rate from the data values entered.

Operating Load:

Real. Used in Cgp calculation.

Required for Gears only.

Operating load factor to determine effect of torque.

Rated Load:

Real. Used in Cgp calculation.

Required for Gears only.

Rated load factor to determine effect of torque.

Spline Length:

Real (in). Used in Lambda b calculation.

Required for Splines only.

Length of spline in inches. Used in determining base failure rate of spline.

Spline Diameter:

Real (in). Used in Lambda b calculation.

Required for Splines only.

Diameter of spline in inches. Used in determining base failure rate of spline.

Torque:

Real (lbs). Used in Lambda b calculation.

Required for Splines only.

The torque in pounds applied to the spline. Used in determining base failure rate of spline.

Tooth Hardness:

Real (Brinnell) (Kg/sq mm). Used in Lambda b calculation.

Required for Splines only.

The hardness of the spline teeth. Used in determining base failure rate of spline.

Misalignment Angle:

Real (radians). Used in Cga and Lambda b calculation.

Effect of alignment.

Operating Lubricant Viscosity (xE-8):

Real (Lb-Min/Sq In * E-8). Used in Cgl calculation.

The operating viscosity of the lubricant. Entered values are automatically multiplied by 1E-8 to obtain actual viscosity. Fluid Viscosity will change with temperature. A table of common viscosity values is given below:

Viscosity * E-8:


	
	Temperature (Degrees F)

	Fluid Type
	-50
	0
	50
	100
	150
	200
	250

	MIL-H-83282
	3.3
	2.86
	2.5
	2.2
	2.2
	0.5
	0.67

	MIL-H-5606
	2.86
	2.5
	2.35
	2.2
	2.2
	0.5
	-

	Aircraft Phosphate Esters
	-
	2.5
	2.35
	2.0
	2.0
	0.5
	-

	Industrial Phosphate Esters
	-
	-
	2.86
	2.5
	2.35
	2.2
	-

	Water Glycol
	-
	2.86
	2.5
	2.5
	2.2
	-
	-

	SAE 10 Oil
	-
	-
	2.86
	2.5
	2.0
	2.0
	0.5

	SAE 60 Oil
	-
	-
	-
	2.86
	2.5
	2.35
	2.0


Specification Lubricant Viscosity (xE-8):

Real (Lb-Min/Sq In * E-8). Used in Cgl calculation.

The specified lubricant viscosity. Entered values are automatically multiplied by 1E-8 to obtain actual viscosity. See the above table for standard viscosity numbers.

Temperature Rise:

Real (Degrees C). Used in Cgt calculation.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Rated Temperature:

Real (Degrees C). Used in Cgt calculation.

The Maximum Temperature Rating specified by the manufacturer, or the Maximum Design Temperature.

Operating Speed:

Real. Used in Cgs calculation.

Gear or spline operating speed. Effect of Speed Deviation on design.

Design Speed:

Real. Used in Cgs calculation.

Gear or spline rated speed. Effect of Speed Deviation on design.

AGMA Service Factor:

Real. Used in Cgv calculation.

Provided by manufacturer to adjust for conditions found in typical industries, such as vibration, shock, contamination, temperature, and usage rate. See table below for nominal values.


	           
	Character of Load on Driven Member

	Prime Mover
	Uniform
	Medium Shock
	Heavy Shock

	Uniform
	1.0
	1.25
	1.75

	Medium Shock
	1.25
	1.50
	2.00

	Heavy Shock
	1.50
	1.75
	2.25


Revolutions/Hour:

Real

Required for Splines only.

The Number of Revolutions/Hour for the Spline. This is required to convert failure rating from failures/rev to failures/hour.

Entering Filters

Following are the part parameters required for filters.

Base Failure Rate:

Real (Failures/Million Hours)

The base or manufacturer supplied base failure rate. The Base Failure Rate may be entered to override the calculated Base Failure Rate. In this case, if the Base Failure Rate is set at 0.0, Relex will compute the Base Failure Rate from the data values entered.

Lifetime (minutes):

Integer. Used in Lambda b calculation.

Lifetime is used in determining base failure rate. Enter this value or base failure rate. If base failure rate is entered, this value if ignored.

Radius - Inside:

Real (in). Used in Cdp and Ccf calculations.

The inside radius of the filter in inches. Used to determine the Cdp factor which considers the effects of filter differential pressure.

Radius - Outside:

Real (in). Used in Cdp and Ccf calculations.

The outside radius of the filter in inches. Used to determine the Cdp factor which considers the effects of filter differential pressure.

Design Pressure - Inside:

Real. Used in Cdp calculation.

Rated Pressure on the inside of the filter. Used to determine the Cdp factor which considers the effects of filter differential pressure.

Design Pressure - Outside:

Real. Used in Cdp calculation.

Rated Pressure on the outside of the filter. Used to determine the Cdp factor which considers the effects of filter differential pressure.

Radius at Maximum Stress:

Real (in). Used in Cdp calculation.

The radius of the filter in inches at the point of maximum stress. For filters which flow from outside to inside (most filters), this is equal to the outside radius.

Off Design Pressure - Inside:

Real. Used in Cdp calculation.

Used to determine the Cdp factor which considers the effects of filter differential pressure.

Off Design Pressure - Outside:

Real. Used in Cdp calculation.

Used to determine the Cdp factor which considers the effects of filter differential pressure.

Inside Pressure - Min:

Real. Used in Ccf calculation.

The minimum inside pressure. Used to determine Ccf factor which considers the effects of cyclic flow.

Inside Pressure - Max:

Real. Used in Ccf calculation.

The maximum inside pressure. Used to determine Ccf factor that considers the effects of cyclic flow.

Outside Pressure - Min:

Real. Used in Ccf calculation.

The minimum outside pressure. Used to determine Ccf factor that considers the effects of cyclic flow.

Outside Pressure - Max:

Real. Used in Ccf calculation.

The maximum outside pressure. Used to determine Ccf factor that considers the effects of cyclic flow.

Tensile Strength:

Real (10^3 psi). Used in Ccf calculation.

The tensile strength of the filter media.

Cold Start Temperature:

Real (Degrees C). Used in Ccs calculation.

Used to determine the ratio of cold start fluid viscosity in relation to normal operating fluid viscosity.

% Water Volume:

Real. Used in Ce calculation.

Percentage of water in system fluid. Considers the effect of incompatible fluids and materials.

System Fluid Type:

Choice List. Used in Ccs and Ce calculations.

Type of fluid in filter, either Kerosene or Other. Used in determining viscosity factors. 

Temperature Rise:

Real (Degrees C). Used in Ct and Ccs calculations.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Entering Poppets and Spools

Following are the part parameters required for poppets, sliding action valves, spools. Exceptions for certain part types are noted.

Fluid Pressure:

Real (psi). Used in Cp calculation.

The Fluid Pressure Differential across the valve in psi. It is equal to the Upstream Fluid Pressure minus the Downstream Fluid Pressure. Range is commonly from 0 to 9000.

Allowable Leakage:

Real (inches cubed/minute/Max Rated GPM). Used in Cq calculation.

The allowable leakage in inches cubed/minute/Max Rated GPM. Range is commonly from .005 to .1.

Viscosity (xE-8):

Real (Lb Min/Sq In * E-8). Used in Cv calculation.

The viscosity of the fluid. Entered values are automatically multiplied by 1E-8 to obtain actual viscosity. Fluid Viscosity will change with temperature. A table of common viscosity values is given below:

Viscosity * E-8:

	
	Temperature (Degrees F)

	Fluid Type
	-50
	0
	50
	100
	150
	200
	250

	MIL-H-83282
	3.3
	2.86
	2.5
	2.2
	2.2
	0.5
	0.67

	MIL-H-5606
	2.86
	2.5
	2.35
	2.2
	2.2
	0.5
	-

	Aircraft Phosphate Esters
	-
	2.5
	2.35
	2.0
	2.0
	0.5
	-

	Industrial Phosphate Esters
	-
	-
	2.86
	2.5
	2.35
	2.2
	-

	Water Glycol
	-
	2.86
	2.5
	2.5
	2.2
	-
	-

	SAE 10 Oil
	-
	-
	2.86
	2.5
	2.0
	2.0
	0.5

	SAE 60 Oil
	-
	-
	-
	2.86
	2.5
	2.35
	2.0


Filter Size:

Real (microns).  Used in Cn calculation.

The System Filter Size in Microns.

# of Particles/Hr/GPM:

Real (N10). Used in Cn calculation.

The Number of Particles (mg) under 10 Micron per Hour per GPM (N10)

Typical Quantities of Particles Produced by Hydraulic Components, Particle Material:

N10

· Piston Pump, steel: 1.7

· Gear Pump, steel: 1.9

· Vane Pump, steel: 0.6

· Cylinder, steel: 0.8

· Sliding Action Valve, steel: 0.04

· Hose, rubber: 0.13

Actual Flow Rate:

Real (Gallons/Minute). Used in Cw calculation.

The Actual Flow in Gallons/Minute.

Rated Flow Rate:

Real (Gallons/Minute). Used in Cn and Cw calculations.

The Maximum Rated Flow in Gallons/Minute.

Surface Finish:

Real (micro inches). Used in Cf calculation.

Required for Poppets only.

The surface finish in micro inches. Common values range from 0 to 100.

Seat Stress Ratio: \Keyword "Stress Ratio" 
Real (lb/sq in). Used in Cs calculation.

Required for Poppets only.

The apparent seat stress is found by actual measurement or design specifications. Common values range from 1.0 to 1.5. It can be calculated by:

Ss = (Ps * Ds^2) / (4 * Dm *Lw)

Where:

   
Ss = Seat Stress

   
Ps = Fluid Pressure

   
Ds = Diameter of seat exposed to fluid pressure Ps

  
Dm = Mean Land Width Diameter

   
Lw = Land Area Width

Mean Diameter:

Real (in). Used in Cdt calculation.

Required for Poppets only.

Mean diameter of poppet seat. Typical values range from 0 to 2 inches.

Land Width:

Real (in). Used in Csw calculation.

Required for Poppets only.

Land width of poppet seat. Typical values range from 0.05 to 0.38. Valid range is 0 to 0.6.

Friction Coefficient:

Real. Used in Cu calculation.

Required for Sliding Action Valves, Spools only.

Common values for coefficient of friction are:

	Materials
	Dry
	Lubricated

	Steel on steel
	0.8
	0.5

	Aluminum on steel
	0.6
	0.5

	Copper on steel
	0.5
	0.4

	Brass on steel
	0.5
	0.4

	Cast iron on steel
	0.4
	-

	Brass on nylon
	0.3
	-

	Steel on nylon
	0.3
	-

	Teflon on nylon
	0.05
	0.04

	Hard carbon on carbon
	0.2
	0.1

	Copper on copper
	1.3
	0.8

	Aluminum on aluminum
	1.1
	-

	Nickel on nickel
	0.7
	0.3

	Brass on brass
	0.9
	0.6


Spool Clearance:

Real (microinches). Used in Cb calculation.

Required for Sliding Action Valves, Spools only.

The spool to sleeve clearance in microinches. Common values range from 400 to 1600.

Spool Diameter:

Real (in). Used in Cds calculation.

Required for Sliding Action Valves, Spools only.

The diameter of spool. Common values range from 1.0 to 3.4.

Cycles/Hour:

Real

The Number of Cycles/Hour. This is required to convert failure ratings from failures/cycle to failure/hour.

Entering Pistons and Cylinders

Following are the part parameters required for pistons and cylinders.

Base Failure Rate:

Real (Failures/Million Cycles). Used in Lambda b calculation.

The base or manufacturer supplied base failure rate. The Base Failure Rate may be entered to override the calculated Base Failure Rate. In this case, if the Base Failure Rate is set at 0.0, Relex will compute the Base Failure Rate from the data values entered.

Wear Factor:

Real. Used in Lambda b calculation.

Will be equal to 0.2 for materials that have a high susceptibility to adhesive wear, in which the wear process involves a transfer to material from one surface to the other. It will be equal to 0.54 for materials that have little tendency to transfer material in which the material is subject to micro-gouging of the surfaces by the asperities on the material surface.

Yield Strength:

Real (psi). Used in Lambda b calculation.

The yield strength of softer material in psi.

Traverse Load:

Real. Used in Lambda b calculation.

The traverse or side load on the actuator.

Piston Length:

Real (in). Used in Lambda b calculation.

The length of the piston in inches.

Piston Diameter:

Real (in). Used in Lambda b calculation.

The diameter of the piston in inches.

Cylinder Diameter:

Real (in). Used in Lambda b calculation.

The diameter of the cylinder in inches.

Contact Surface Area:

Real (sq. in). Used in Lambda b calculation.

The surface area contacting both the piston and cylinder.

Poisson's Ratio - Cyl:

Real. Used in Lambda b calculation.

Poisson's Ratio for the cylinder.

Poisson's Ratio - Piston:

Real. Used in Lambda b calculation.

Poisson's Ratio for the Piston.

Modulus of Elast. - Cyl:

Real (psi * E6). Used in Lambda b calculation.

Modulus of Elasticity for the Cylinder.

Common values:


	Material
	Modulus of Elasticity

	Ferrous:
	

	Music Wire
	29.0

	Hard Drawn Steel
	28.5

	Chrome Steel
	29.0

	Silicon-Manganese
	29.0

	Stainless, 302, 304, 316
	28.0

	Stainless 17-7 PH
	29.5

	Stainless 420
	29.0

	Stainless 431
	29.5

	Non-Ferrous:
	

	Spring Brass
	15.0

	Phosphor Bronze
	15.0

	Beryllium Copper
	17.0

	Iconel
	31.0

	Monel
	26.0


Modulus of Elast. - Piston:

Real (psi * E6) [Ge]. Used in Lambda b calculation.

Modulus of Elasticity for the Piston. See above for common values.

Penetration Hardness:

Real (psi). Used in Lambda b calculation.

The penetration hardness of the material in psi.

Wear Coefficient:

Real. Used in Lambda b calculation.

The value of the wear coefficient in the severe-wear region.


	Material
	Wear Coefficient

	4130 Alloy Stell (piston)
	0.0218

	4130 Alloy Stell (cylinder)
	0.0221

	17-4 PH Stainless Steel (piston)
	0.0262

	17-4 PH Stainless Steel (cylinder)
	0.0262

	9310 Alloy Steel (piston)
	0.0272

	9310 Alloy Steel (cylinder)
	0.0272


Applied Load:

Real (lb). Used in Lambda b calculation.

The applied load in pounds of force.

Sliding Distance:

Real (in). Used in Lambda b calculation.

The total distance that the piston slides, or the stroke length.

Leakage Rate:

Real (in cubed/sec). Used in Lambda b calculation.

The leakage rate past the piston.

Viscosity (xE-8):

Real (Lb Min/Sq In * E-8). Used in Lambda b calculation.

The viscosity of the fluid. Entered values are automatically multiplied by 1E-8 to obtain actual viscosity. Fluid Viscosity will change with temperature. A table of common viscosity values is given below:

Viscosity * E-8:

	
	Temperature (Degrees F)

	Fluid Type
	-50
	0
	50
	100
	150
	200
	250

	MIL-H-83282
	3.3
	2.86
	2.5
	2.2
	2.2
	0.5
	0.67

	MIL-H-5606
	2.86
	2.5
	2.35
	2.2
	2.2
	0.5
	-

	Aircraft Phosphate Esters
	-
	2.5
	2.35
	2.0
	2.0
	0.5
	-

	Industrial Phosphate Esters
	-
	-
	2.86
	2.5
	2.35
	2.2
	-

	Water Glycol
	-
	2.86
	2.5
	2.5
	2.2
	-
	-

	SAE 10 Oil
	-
	-
	2.86
	2.5
	2.0
	2.0
	0.5

	SAE 60 Oil
	-
	-
	-
	2.86
	2.5
	2.35
	2.0


Pressure Differential:

Real (psi). Used in Lambda b calculation.

The pressure differential in psi across the piston.

Material Hardness Ratio:

Real. Used in Ccp calculation.

The ratio of the hardest particle to the cylinder hardness expressed as a percentage. Material Hardness values are shown in the table below. Be sure to use the ratio.


	Material
	Hardness (Hv)

	Plain Carbon Steels:
	

	Low stength steel
	140

	High strength steel
	220

	Low-alloy Steels:
	

	4320
	640

	4340
	560

	Stainless Stells:
	

	303
	170

	304
	160

	631 (17-7 PH hardened)
	520

	631 (17-7 PH annealed)
	170

	Austenitic AISI 201 (annealed)
	210

	Martenistic 440C (hardened)
	635

	630 (17-4 PH hardened)
	470

	Nickel Alloys:
	

	201
	100

	Nickel-copper Alloys:
	

	Monel (annealed)
	120

	Monel K-500 (annealed)
	162

	Ni-Cr-Mo-Fe Alloys:
	

	Inconnel 625
	140

	Hastelloy
	200

	Aluminum:
	

	AISI 1100 (annealed)
	25

	AISI 1110 (cold worked)
	45

	AISO 2024 (annealed)
	50

	AISI 2024 T4 (heat treated)
	125

	AISI 6061 (annealed)
	32

	AISI 6061 T6 (heat treated)
	100


Filter Size:

Real (microns).  Used in Ccp calculation.

The System Filter Size in Microns.

Contaminant Rate:

(Real). Used in Ccp calculation.

The expected rate of contaminant generation per hour. Sample rates per gram/gpm are shown below.


	Component
	Contaminant Rate

	Gear Pump
	7.5 g/gpm rated flow

	Vane Pump
	25.0 g/gpm rated flow

	Piston Pump
	6.8 g/gpm rated flow

	Directional Valve
	0.008 g/gpm rated flow

	Cylinder area
	3.2 g/in squared swept


Activation Energy Constant (K):

Real (Degrees K). Used in Ct calculation.

Must be given in Degrees K. Valid range is 1200 to 6000.

Temperature Rise:

Real (Degrees C). Used in Ct calculation.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Cycles/Hour:

Real

The Number of Cycles/Hour. This is required to convert failure ratings from failures/cycle to failure/hour.

Entering Shafts

Following are the part parameters required for shafts.

Base Failure Rate:

Real (Failures/Million Cycles). Used in Lambda b calculation.

This MUST be entered in order to determine failure rate. It can be calculated from the equation Lambda b = 1E6 / N where N = the Number of cycles to failure at the material endurance limit.

Tensile Strength:

Real (kpsi). Used in Cf calculation.

The tensile strength of the shaft material.

Common values:


	Material
	Tensile Strength

	G43400 steel
	140, 190, 230, 260

	G43500 steel
	300

	R50001 – series titanium alloy
	145

	A97076 aluminum alloy
	76

	C63000 aluminum bronze
	117

	C17200 beryllium copper
	175


Filter Size:

Real (microns).  Used in Ccp calculation.

The system filter size in microns.

Flow Rate - Actual:

Real (Gallons/Minute). Used in Ctlf calculation.

The Actual Flow in Gallons/Minute.

Max Specified Flow:

Real (Gallons/Minute). Used in Ctlf calculation.

The Maximum Pump Specification Flow in Gallons/Minute.

Surface Finish:

Choice List. Used in Cf calculation.

The appropriate type of Surface Finish, i.e. Polished, Ground, Hot Rolled, etc.

Casing Type:

Choice List. Used in Ctlf calculation.

The correct pump casing type, i.e. Ordinary Volute, Modified Concentric, or Double Volute.

Unbalanced Force:

Real (lb). Used in Cdy calculation.

Force created from unequal distribution of forces on pump shaft from varying fluid pressures.

Modulus of Elasticity:

Real (psi). Used in Cdy calculation.

The modulus of elasticity in psi.

Moment of Inertia:

Real (in^4). Used in Cdy calculation.

The moment of inertia in inches to the fourth power.

Measurement of Shaft N:

Real (in). Used in Cdy calculation.

See drawing below or Figure 10.4 in Handbook of Reliability Prediction Procedures for Mechanical Equipment. Used in measuring shaft deflection.

Shaft Thrust Bearing     Radial Bearing     Impeller

 ||     \/                    \/               \/

\||/   ---                    -               _______

 \/   |   |                  | |___          |      |

 |----|   |------------------| |   |__       |      |

 |    |   |                  | |      |______|      |

 |    |   |                  | |       ______|      |

 |____|   |_________________ | |    __|      |      |

      |   |                  | |___|         |      |

      |   |                  | |             |      |

      -----                  ---             --------

                                       |-N-----|

                                    |----M-----|

       |--------X-------------|----------L-----|
Measurement of Shaft M:

Real (in). Used in Cdy calculation.

See drawing above or Figure 10.4 in Handbook of Reliability Prediction Procedures for Mechanical Equipment. Used in measuring shaft deflection.

Measurement of Shaft L:

Real (in). Used in Cdy calculation.

See drawing above or Figure 10.4 in Handbook of Reliability Prediction Procedures for Mechanical Equipment. Used in measuring shaft deflection.

Measurement of Shaft X:

Real (in). Used in Cdy calculation.

See drawing above or Figure 10.4 in Handbook of Reliability Prediction Procedures for Mechanical Equipment. Used in measuring shaft deflection.

Temperature Rise:

Real (Degrees C). Used in Ct calculation.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Cycles/Hour:

Real

The Number of Cycles/Hour. This is required to convert failure ratings from failures/cycle to failure/hour.

Entering Fluid Drivers

Following are the part parameters required for fluid drivers.

Base Failure Rate:

Real (Failures/Million Hours)

The base or manufacturer supplied base failure rate. The Base Failure Rate may be entered to override the calculated Base Failure Rate. In this case, if the Base Failure Rate is set at 0.0, Relex will compute the Base Failure Rate from the data values entered.

Type:

Choice List

The type of fluid driver which moves the fluid from intake to exhaust. Select a fluid driver from the list of choices and the base failure rate is extrapolated from the listing below. Enter in the Base Failure Rate directly and the choice list selection will be ignored.

	Pump Type
	Base Rate

	Cent, Axial, Closed/Open
	0.1 – 0.3  

	Cent, Mixed, Open/Semi-Open/Closed
	0.1 – 0.14

	Cent, Peripheral, Single Stage
	0.1 – 0.3

	Disp, Recip, Piston/Plunger
	1.0 – 1.35

	Disp, Recip, Diaphragm
	0.4 – 0.75

	Disp, Rotary, Vane
	0.2 – 0.6

	Disp, Rotary, Piston
	0.9 – 1.2

	Disp, Rotary, Gear
	0.6 – 0.9

	Disp, Rotary, Lobe
	0.4 – 0.5

	Disp, Rotary, Screw
	0.2 –0.95


Entering Brake and Clutch Friction Linings

Following are the part parameters required for brake and clutch friction linings. Exceptions for certain part types are noted.

Base Failure Rate:

Real (Failures/Million Hours). Used in Lambda b calculation.

The base or manufacturer supplied base failure rate. The Base Failure Rate may be entered to override the calculated Base Failure Rate. In this case, if the Base Failure Rate is set at 0.0, Relex will compute the Base Failure Rate from the data values entered.

Applications/Mile:

Real. Used in Lambda b calculation.

The number of brake/clutch applications per mile.

Lining Thickness:

Real (in). Used in Lambda b calculation.

The friction lining thickness in inches.

Lining Area:

Real (sq in). Used in Lambda b calculation.

The friction lining area in square inches.

Lining Type:

Choice List. Used in Ct calculation.

The type of lining, i.e. Sintered Metallic, Carbon-carbon, etc.

Brake Type:

Choice List. Used in Cbt calculation.

Required for Brake Friction Linings only.

The type of brake, i.e. Drum, Disk, Pad, etc.

Binder Resin:

Choice List. Used in Crd calculation.

Required for Brake Friction Linings only.

The type of binder resin, i.e. Phenolic, Oil, Rubber, etc.

Specific Wear Rate:

Real (in^3/ft-lbf). Used in Lambda b calculation.

Required for Brake Friction Linings only.

The Specific Wear Rate of the Friction Material in in^3/ft-lbf units.

Vehicle Weight:

Real (lbf). Used in Lambda b calculation.

Required for Brake Friction Linings only.

The weight of the vehicle in pounds.

Average Velocity Change:

Real (ft/s). Used in Lambda b calculation.

Required for Brake Friction Linings only.

The average change in velocity per brake action in feet/second.

Miles/Year:

Real. Used in Lambda b calculation.

Required for Brake Friction Linings only.

The number of miles traveled per year.

Braking Load:

Real. Used in Lambda b calculation.

Required for Brake Friction Linings only.

Proportion of weight carried by lining during braking action. For a four wheel drive vehicle, each front brake typically carry 3/10 of the braking load.

Surface Roughness:

Real (microinches). Used in Csr calculation.

Required for Brake Friction Linings only.

The Surface Roughness of the Countersurface in microinches.

Energy Dissipated:

Real (ft-lbf). Used in lambda b calculation.

Required for Clutch Friction Linings only.

The Average Energy Dissipated per Application in ft-lbf.

Average Wear Value:

Real (h.p.-hr/in^3). Used in lambda b calculation.

Required for Clutch Friction Linings only.

The Average Wear Value of the Material in (h.p.-hr/in^3).

Number of Discs:

Integer. Used in Cnp calculation.

Required for Clutch Friction Linings only.

The number of disks in the clutch.

Entering Housings and Casings

Following are the part parameters required for housings and casings.

Type:

Choice List

The type of casing, i.e. Valve, Pump/Stator, Brake, or Compressor.

Cycles/Hour:

Real

Required for Pump/Stators and Compressors only.

The Number of Cycles/Hour. This is required to convert failure ratings from failures/cycle to failure/hour.

Entering Compressor Diaphragms

Following are the part parameters required for metal and rubber compressor diaphragms.

Base Failure Rate:

Real (Failures/Million Hours)

The base or manufacturer supplied base failure rate. The Base Failure Rate may be entered to override the calculated Base Failure Rate. In this case, if the Base Failure Rate is set at 0.0, Relex will compute the Base Failure Rate from the data values entered.

Maximum Strain %:

Real. Used in Cp and Cac calculations.

The Maximum Strain % for the diaphragm. See the Handbook of Reliability Prediction Procedures for Mechanical Equipment for more information. Generally between 0 to 800%.

Ozone %:

Choice List. Used in Cac calculation.

The percentage of ozone in the atmosphere.

Anti-Ozonant Coating:

Choice List. Used in Cac calculation.

Enter "Yes" if a chemical anti-ozonant coating on the surface of the diaphragm is used to reduce crack growth. Otherwise enter "No".

Liquid Contaminant Factor:

Real. Used in Clc calculation.

The liquid contaminant multipler factor.  See the Handbook of Reliability Prediction Procedures for Mechanical Equipment for more information. A nominal value is 1.0.

Temperature Rise:

Real (Degrees C). Used in Ct calculation.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Entering Electric Motor Windings

Following are the part parameters required for electric motor windings.

Base Failure Rate:

Real (Failures/Million Hours)

This should be entered in order to determine failure rate. It can be calculated given the expected winding life from the manufacturer, i.e. Lambda b = 1E6 / L, where L is the expected winding life in hours. If not entered, 5.65 is assumed.

Actual Voltage:

Real. Used in Cv calculation.

The actual or operating voltage of the electric motor winding (any units, must be same as Rated Voltage units). A standard motor will operate successfully when the voltage does not exceed +/- 10% of normal. The actual voltage is used to correct the failure rate determination for voltage variations outside the normal limits.

Rated Voltage:

Real. Used in Cv calculation.

The rated voltage of the electric motor winding (any units, must be same as Actual Voltage units). A standard motor will operate successfully when the voltage does not exceed +/- 10% of normal. The rated voltage is used to correct the failure rate determination for voltage variations outside the normal limits.

Altitude:

Integer (ft x 1000). Used in Calt calculation.

The altitude of the motor. This value must be in the range 0 (Sea Level) to 60 (60,000 ft). The altitude value is used to adjust the failure rate for the effects of altitude on the motor. The failure rate is only affected for non-enclosed motors. For totally enclosed motors, altitudes to 60,000 feet will have no impact on motor life. For enclosed motors, leave the altitude at 0.

Temperature Rise:

Real (Degrees C). Used in Ct calculation.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Rated Temperature:

Real (Degrees C). Used in Ct calculation.

The rated temperature of the electric motor windings in degrees C.

Entering Motor Brushes

Following are the part parameters required for motor brushes.

Base Failure Rate:

Real (Failures/Million Hours)

The base or manufacturer supplied base failure rate. The Base Failure Rate may be entered to override the calculated Base Failure Rate. In this case, if the Base Failure Rate is set at 0.0, Relex will compute the Base Failure Rate.

Entering Threaded Fasteners

Following are the part parameters required for threaded fasteners.

Tensile Strength:

Real (psi). Used in Cl calculation.

The ultimate tensile strength of the fastener material.

Endurance Limit:

Real (psi). Used in lambda b calculation.

The endurance or fatigue limit. On the S-N curve (stress plotted against number of cycles to failure), the stress values become less as the data is plotted against an increasing number of failures. After the material has been stressed for a certain number of cycles, the graph becomes horizontal in the case of ferrous metals and alloys. This is referred to as the endurance limit. Common endurance limits for various bolting devices are shown below:


	Material Grade or Class
	Size Range
	Endurance Limit

	SAE 5
	1/4 - 1 in
	18.6 kpsi

	SAE 5
	1 1/8 - 1 1/2 in
	16.3 kpsi

	SAE 7
	1/4 - 1 1/2 in
	20.6 kpsi

	SAE 8
	1/4 - 1 1/2 in
	23.2 kpsi

	ISO 8.8
	M16 - M36
	129 Mpa

	ISO 9.8
	M1.6 - M16
	140 Mpa

	ISO 10.9
	M5 - M36
	163 Mpa

	ISO 12.9
	M1.6 - M36
	190 Mpa

	Metric M16, CL 8.8
	M16
	10.2 ksi

	Metric M14 x 1.5
	M14 x 1.5
	7.1 - 11.4 ksi

	SAE J429, GR 8             
	
	18 ksi

	Metric CL 10.9
	M12 x 1.25
	8 ksi

	M10, grade 12.9
	
	6.9 - 10.7 ksi


Formulas for Estimating the Endurance Limits of S-N Test Specimens are:

· For Steels with Tensile Strength <= 200 kpsi

· Endurance Limit = 0.5 * Tensile Strength

· For Steels with Tensile Strength > 200 kpsi

· Endurance Limit = 100 kpsi

· For wrought Aluminum Alloys

· Endurance Limit = 0.4 * Tensile Strength

· For cast Aluminum Alloys

· Endurance Limit = 0.3 * Tensile Strength

Note: The endurance limit of nonferrous alloys is taken to occur at approximately 1E8 cycles.

Load Type:

Choice List. Used in Csz and Cl calculations.

Type of load applied to the fastener. Choices available are Axial, Bending, and Torsional. Enter Torsional for torsion and shear load types. 

Diameter:

Real (in). Used in Csz calculation.

The basic major diameter of the fastener. For axial loading, this entry may be ignored. For bending or torsional loads, the value must be from 0 - 2 inches.

Impact Category:

Choice List. Used in Ci calculation.

The type of impact, one of the following:

· Light (rotating machinery - motors, turbines, centrifugal pumps)

· Medium (rotary & reciprocating motion machines - compressors, pumps)

· Heavy (presses for tools & dies, shears)

· Very Heavy (hammers, rolling mills, crushers)

Surface Coating:

Choice List. Used in Csc calculation.

The type of coating the surface of the fastener is treated with. Choices available are Zinc Electroplating, Other Electroplating, and Metal Spraying. Other Electroplating includes chromium, nickel, and cadmium electroplating.

Thread Type:

Choice List. Used in Ck calculation.

The type of fastener thread. Choices available are Rolled and Machined.

SAE Grade:

Choice List. Used in Ck calculation.

The range which defines the SAE Grade of the fastener, either 0-2 or 4-8.

Temperature Rise:

Real (Degrees C). Used in Ct calculation.

The temperature rise from the ambient Subassembly temperature to this component. The temperature rise plus the ambient temperature is equal to the operating temperature of the device.

Entering Sensors and Transducers

The only part parameter required for sensors is the type. The complete modeling of a sensor may consist of adding failure rates for transmission lines, computational devices, power sources, etc. These failure rates must be derived from other sources.

Sensor/Transducer Type:

Choice List. Used in Lambda b calculation.

Enter the type of sensor or transducer.

Failure Rate, MTBF, Reliability, and Availability

After entering your parts, select Project>Calculate from the main menu to compute the failure rate of the parts. For this discussion, assume that the resulting failure rate is shown in failures per million hours. This is the number of failures expected to occur in a million hours of operation of the equipment. Failure rates for many basic devices are well below 1 failure per million hours, so these values may seem insignificant. But if you have hundreds of parts in a design and have a thousand systems operating in the field, you can see that the failure rates add up. 

MTBF, or Mean Time Between Failures, is the inverse of the failure rate and is the average time between failures. The units for MTBF are always hours. MTBF is calculated from the failure rate as follows:

MTBF = 1,000,000/failure rate

Another common failure rate unit used, besides failures/million hours, is failures per billion hours, which is also known as FITs (Failures in Time). As a very general rule, calculations based on MIL-HDBK-217 equations typically consider the failure rate in failures/million hours. Calculations based on Telcordiaxe "Telcordia (Bellcore)" \r "D2HBTelcordia117" (Bellcore) typically consider the failure rate in failures/billion hours. However, with Relex you have the ability to select the units that you prefer.

Reliability and availability calculations are represented by a probability value ranging from 0 to 1. Reliability is the probability that an item will perform a required function without failure under stated conditions for a stated period of time. Availability is the probability that an item is in an operable state at any time. The availability calculation takes repair times into account.

xe "Temperature Calculations" \r "D2HBTemperature_117"Temperature Calculations

In Relex 217 there are several fields that deal with the temperature of integrated circuits and discrete semiconductors. The following discussion explains each of these fields and how they are used to determine the junctionxe "Junction" \r "D2HBJunction116" temperature of the device. All temperatures are in degrees Celsius.

The junction temperature is the average surface temperature of an integrated circuit or the temperature at the core of the semiconductor material. The failure rates of integrated circuits and semiconductor devices are highly dependent on the junction temperature, so accurate temperature modeling is important.

The first field of interest is the Operating Temperature. This is the assembly or System Tree temperature and is defined when the assembly or System Tree is initially created. You may modify this parameter by selecting the desired assembly in the System Tree and selecting the General Data tab in the Parts Table window. Normally, the operating temperature is defined to be the ambient temperature of the surrounding air, but it can also be a board temperature, the temperature of the heat sink rails, or any other specified temperature.

The other fields of interest for calculating junction temperature are included on the Prediction Data tab for integrated circuits and discrete semiconductors. The second field is the Initial Temperature Rise. This rise is defined as the rise in temperature between the Operating Temperature and the unit of the thermal resistance. For example, assume that the thermal resistance is specified in units of Junction to the Case and the Operating Temperature is the ambient or air temperature. Here the rise is known to be from the case to the junction and what is needed is the rise between the air and the case. So the Initial Temperature Rise would be the temperature rise between the case and the air. Quite often, the value of this field is left blank (defaulted to zero) as there is a negligible temperature rise, especially for low power devices.

The third field is the Operating Power (power dissipation) and is the power dissipation of the device in watts, normally available in the manufacturer’s databook. You are to use the actual rather than the maximum rated power dissipation. For integrated circuit and semiconductor devices, the operating power can generally be calculated as: Operating Power = Icc * Vcc + Iol * Vol, where each of the parameters are found in the databook tables.

The fourth field is the Thermal Resistance (in degrees C/watt units, referred to as ThetaJC). It is also generally found in the manufacturer’s databook. Just as there is electrical resistance to the movement of electricity, there is a phenomenon known as thermal resistance that is resistance to the movement of temperature. The lower the thermal resistance, the easier the heat is able to escape or dissipate. When a device is operating, it generates heat at its junction. This heat is transmitted through the device to the surface of the device and is then dissipated into the air (or the heat sink).

The fifth field is labeled Junction and is provided for you to record the units of the thermal resistance value. Thermal resistance is specified as Junction-Case, or Junction-Air, Junction-Board, etc. If thermal resistance is specified as Junction-Case, this means that the thermal resistance value is the actual resistance to temperature movement between the device junction and the device case. You may enter any information you prefer in this field. It is a text field available for your use and is not used in the calculations. It is left to your judgment to use the correct units for all temperature parameters.

The sixth field is the Temperature Rise and is the rise in temperature between the operating temperature and the junction. The Initial Temperature Rise, Power Dissipation, and Thermal Resistance fields are all used to derive this Temperature Rise. The Temperature Rise is calculated in Relex with the following equation:

Temperature Rise = Initial Temperature Rise + Power Dissipation * Thermal Resistance.

The junction temperature of the device is then the sum of the operating temperature and the temperature rise.

Note: Rather than allowing Relex to calculate the temperature rise, you can enter a value directly. Relex then uses your manually entered temperature rise, and does not perform the calculation.

To provide more flexibility there is a seventh field, Junction Temperature Override. If you enter a value into this field, Relex uses this value for its calculations and ignores all of the other temperature calculations. If you have information from an infrared scanner or from a thermal engineer, you may choose to enter this override value directly. Using the CAD Interface,xe "CAD Interface" you may import this value automatically. Note that when a Junction Temperature Override is entered for a particular part, Relex does not perform the temperature calculations for this part. Therefore, if you change the Operating Temperature, the resulting failure rate of the part is unchanged.

Note: The value of the junction temperature (whether calculated or entered as a Junction Temperature Override) is the temperature that is shown on the Pi Factors window for any part.

xe "Calculation Methods" \r "D2HBCalculation_118"Calculation Methods

The calculation methods in Relex are based on those outlined in the Telcordia (Bellcore) “Reliability Prediction Procedure for Electronic Equipment” document. These calculation methods can be used for both Telcordia (Bellcore) and MIL-HDBK-217 reliability predictions with Relex.

The general purpose of these calculation methods is to take into account additional information regarding the devices, units, and systems under analysis. The calculation methods used by Relex take into account various burn-inxe "Burn-In" \r "D2HBBurn_In118" data, field data,xe "Field Data" and laboratory test data. These methods also give you the ability to calculate the infant mortality rate, or first year drop out, for the systems under analysis.

Relex conforms to all of the methods and cases from the Telcordia (Bellcore) Reliability Prediction Procedure document. Even if you are performing MIL-HDBK-217 calculations, you may still use the calculation methods defined in the Telcordia (Bellcore) standard. When using any of the 217 Models that are available, you may also select a calculation method. If any method other than Method I Case 1 is selected, you have the ability to calculate the first year drop out rates that are based on the first year multiplierxe "First Year Multiplier" or FY. If computed, this pi factor is displayed from the <Pi Factors> button on the Prediction Data tab. 

Your choice of a particular method and case depends upon your analysis requirements and the amount of data available. Included below is a description of each of the methods and cases. See the Telcordia (Bellcore) Reliability Prediction Procedure document for more detailed descriptions and details.

Before looking at the methods in detail, it is important to understand the basic terminology used when describing these methods:

	Term
	Definition

	Device
	Any electrical part (e.g., integrated circuit, diode, resistor) with distinct electrical characteristics.

	Unit
	An assembly of devices (e.g., circuit pack, module, plug-in, racks, and power supplies).

	System
	A complete assembly that performs an operational function.

	First-Year Multiplier
	Ratio of the first-year failure rate to the steady-state failure rate.

	Steady-State Failure Rate
	The constant failure rate after one year of operation.


Method I

Method I is generally referred to as the Parts Count method. Case 1 and 2 are very general, and are usually used when specific data regarding parts is not available. Case 1 and 2 both assume 40 degrees Celsius as the operating temperature, and 50% stress. Case 1 assumes a burn-in of < 1-hour. Case 2 assumes a burn-in of > 1-hour. Method I Case 1 is most similar to MIL-HDBK-217 Parts Count predictions. Method I Case 3 uses variable temperature and stress values. Method I Case 3 is most similar to MIL-HDBK-217 Part Stress predictions. Method I calculations provide a steady state failure rate, and with use of the first year multiplier, also supplies first year drop out calculations.

In Relex, Telcordia (Bellcore) calculations conform to Method I methods, while MIL-HDBK-217 calculations use the standard part stress predictions.

	Case 1:
	Predictions are based on the Black Box Option, which assumes unit/system burn-in <= 1 hour, and no device burn-in.xe "Device Burn-In" All devices are assumed to be operating at 40 degrees Celsius and at 50% rated electrical stress. 

	Case 2:
	Predictions are based on the Black Box Option with unit/system burn-in, which assumes unit/system burn-in > 1 hour, and there is no device burn-in. All devices are assumed to be operating at 40 degrees Celsius and at 50% rated electrical stress. 

	Case 3:
	This is the xe "Stress Data"general case for Method I reliability predictions, which encompasses all types except Cases 1 and 2. This case can take into account device burn-in and varying temperature and stress data.


Note: Method I Case 1 and Method I Case 3 are the most commonly used calculation methods.

Method II

The purpose of Method II is to adjust unit or device predicted MTBF based on laboratory data.xe "Laboratory Data" Method II is calculated as a weighted average of the measured laboratory failure rate and the parts count generic failure rate, with the weights determined by the laboratory data. When laboratory tests are very informative, the Method II base failure rate is determined primarily from the laboratory data. When laboratory tests are less informative, the Method II base failure rate is heavily influenced by the parts count generic failure rate. 

Reliability predictions for device and/or unit reliability are based on a combination of Method I information and laboratory test data. In Relex, both Telcordia (Bellcore) and MIL-HDBK-217 calculations use these equations.

	Case L1:
	Devices are laboratory tested, and have no burn-in. 

	Case L2:
	Units are laboratory tested, and there is no unit/device burn-in. 

	Case L3:
	Devices are laboratory tested and have had burn-in. 

	Case L4:
	Units are laboratory tested and units/devices have had burn-in. 


Method III

The purpose of Method III is to adjust unit or device predicted MTBF based on field tracking data. Method III is calculated as a weighted average of the observed field failure rate and the parts count prediction, with the weights determined by the field data. When there is a large number of total operating hours for a device or unit during a field tracking study, the Method III failure rate prediction is heavily influenced by the field data. When there are a small number of total operating hours, the Method III failure rate prediction is more heavily influenced by the parts count prediction.

Reliability predictions for device and/or unit reliability are based on a combination of Method I information and field experience. In Relex, both Telcordia (Bellcore) and MIL-HDBK-217 calculations use these equations.

	Method III(a):
	This method provides for statistical failure rate predictions of devices, units, or subsystems based on actual in-service performance. 

	Method III(b):
	This method provides for statistical failure rate predictions of devices, units, or subsystems based on in-service performance as part of another system. 

	Method III(c):
	This method provides for statistical failure rate predictions of devices, units, or subsystems based on the in-service performance of similar equipment. 


To assign a method to a particular assembly or System Tree, make your selection from the Calculation Method field on the General Data tab in the Parts Table window by displaying the choice list and selecting the desired method. Enter the appropriate values for the burn-in, laboratory, and field data if requested. 

Note: Certain parameters, such as laboratory, field, and burn-in data, are requested on the Method Data tabxe "Method Data tab" depending upon the calculation method selected.

Performing a Reliability Prediction Calculation

To calculate and display the failure rate for an assembly or entire System Tree, press the <Calculate> button on the Standard toolbar, or select Project>Calculate from the main menu. Select Reliability Prediction and press <OK>. Once calculations are completed, the results are displayed. The calculation results include failure rate, MTBF, reliability, and availability. 

In addition to these standard calculations, Relex also supports mission calculations and reliability allocations.xe "Reliability Allocations" \r "D2HBReliability_120"
Mission Calculations

Any Project file in Relex may include Mission Profile information. Relex provides you with the ability to perform mission calculations based on the information in the Mission Profile file. This makes it possible to calculate failure rate, MTBF, reliability, and availability for a Project file based on a combination of various environments and temperatures. The following is an example of a Mission Profile:

	Phase
	Environment
	Temperature
	Percent

	Take Off
	Ground Fixed
	30
	15

	Flight
	Airborne, Inhabited Cargo
	10
	75

	Landing
	Ground Mobile
	30
	10


In this case, 15% of the mission would be calculated using an environment of Ground Fixed at a temperature of 30 degrees Celsius. 75% of the mission would be calculated using an environment of Airborne, Inhabited Cargo at 10 degrees. The last 10% of the mission would be calculated using an environment of Ground Mobile at 30 degrees.

To perform a mission calculation, follow these steps:

1. Create a new Mission Profile file by selecting File>New>Prediction>Mission Profile from the main menu. Define the mission phases.

2. Enable the Mission Profile file in the Project file. Access the File Properties by selecting View>File Properties from the main menu. Select the Prediction/General Files tab.xe "Prediction/General Files tab" To select a Mission Profile file, press <Browse> to display a list of Mission Profile files. Choose your file by selecting it with your cursor and pressing <Open>. Save the changes to properties by pressing <OK>.

3. Calculate the Project by selecting Project>Calculate from the menu.

4. When the Calculate window appears, select Reliability Prediction, and select Mission Calculations. Press <OK> and Relex calculates the mission failure rate, mission MTBF, mission reliability, and mission availability based on the various mission phases that are assigned for the current Project file.

5 When completed, Relex displays the Mission Failure Rate, MTBF, Availability, and Reliability values. Mission calculation information can also be placed on reports.

Reliability Allocations

The purpose of using reliability allocations is to set reliability goals. Allocations allow you to allocate a failure rate to an assembly, and then, based on weight factors, calculate the projected failure rate of components and/or assemblies within that assembly. Relex uses the apportionment method for allocation calculations. In this method, you enter the desired failure rate of a particular assembly as a failure rate goal or MTBF goal, and then assign weight factors for each assembly. Relex then determines the allocated values by totaling the weight factors and allocating failure rates based on percentages.

Implementing the Allocation Feature

1. Assign a Failure Rate Goal or MTBF Goal to a portion of a Project file.

a) Select the assembly in the System Tree.

b) On the Calculation Data tab,xe "Calculation Data tab" \r "D2HBCalculation_121" select Allocated, and specify a Failure Rate Goal or MTBF Goal. This establishes the total goal for all lower levels.

1. Assign a Weight Factor to each component and/or assembly associated with that portion of the Project.

a) If a component or assembly is to have a calculated or specified failure rate (non-allocated), enter these parts or assemblies as usual. 

b) If assigning a weight factor to a component, on the General Data tab for the component, select Allocated, and enter a Weight Factor.

c) If assigning a weight factor to an assembly, on the Calculation Data tab for the assembly, select Allocated, and enter a Weight Factor.

3. Calculate Allocations.

a) Select Project>Calculate from the main menu to calculate the project.

b) Select Reliability Prediction calculationsxe "Reliability Prediction Calculations" \r "D2HBReliability_122" and select Allocations.

c) Click <OK> when ready.

d) The allocations for each part and/or assembly are displayed as the failure rate.

xe "Allocation Calculation"Allocation Calculation

The equation used for calculating an allocated failure rate:xe "Allocated Failure Rate"
Failure Rate Goal * Weight Factor for individual part or assembly / Total of all Weight Factors

As an example, if an assembly has a specified failure rate of 100, and 4 parts are in the assembly with weight factors 1, 2, 3, and 4, the allocated failure rate for part 1 = 100 * (1/(1+2+3+4)) = 10. The other allocated failure rates are 20, 30, and 40 respectively. If other parts are present in the assembly with calculated or specified failure rates (non-allocated), these failure rates are subtracted from the total. Using the above example, if other parts in the assembly have a total failure rate of 50, then the allocated failure rate of part 1 = (100-50) * (1/1+2+3+4)) = 5. The other parts would have failure rates of 10, 15, & 20 respectively.

xe "Calculated Failure Rate"Changing from an Allocated Failure Rate to a Calculated Failure Rate

1. Mark the previously allocated portion of the Project file as a failure rate of Calculated.

a) Select the assembly in the System Tree window that was allocated.

b) On the Calculation Data Tab, select a failure rate of Calculated.

c) Click <OK> to save changes.

2. Mark all lower levels of the system as having a failure rate of Calculated.

a) For a component, on the General Data tab for the component, select a failure rate of Calculated.

b) For an assembly, on the Calculation Data tab for the assembly, select a failure rate of Calculated.

c) If a component or assembly already has a calculated or specified failure rate (non-allocated), leave these components as entered.

3. Calculate.

a) Select Project>Calculate from the menu to calculate the project.

b) Select Reliability Prediction calculations and disable the Allocations checkbox.

c) Click <OK> when ready.

d) Relex calculates the failure rates.

xe "Non-Operating"

xe "Dormant"Non-Operating (Dormant) Calculations

Relex Reliability Prediction supports the calculations of non-operating, or dormant, failure rates. The dormant failure rate of a system is estimated through the use of conversion factors, as described in the Dormant Analysis section of “The Rome Laboratory Reliability Engineer's Toolkit”.

The estimation is performed by converting active failure rates of each component to dormant conditions. For example, when an integrated circuit is in a ground environment when active and also when dormant, the failure rate of the component in the dormant environment is estimated to be 0.08 times its active failure rate. The same component placed in an active environment of space and a passivexe "Passive" environment of ground, has an estimated dormant failure rate of 0.30 times its active failure rate. For a listing of the conversion factors, refer the Docs directory on your Relex CD.

Relex first computes the active failure rate of each component, then based on the active to passive conversion factor, computes the passive, or dormant, failure rate. The total failure rate of the component is then computed by using the duty cycle:
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The assembly failure rates are computed by adding up all individual component failure rates.

Performing Dormant Analysis

To perform a dormant analysis in your reliability analysis follow these steps:

1. Select the assembly in the System Tree for which you want to assign a dormant environment.

2. Select the General Data tab in the Parts Table window.

3. In the Dormant Environment field, select the dormant environment.

4. Select the Calculation Data tab in the Parts Table window.

5. Enter the appropriate duty cycle.

6. Calculate.

Note: If you do not enter a dormant environment, non-operating calculations are not performed.

Reliability Prediction Calculation Results

Once a reliability prediction calculation has been performed, the Calculation Results window automatically displays with the results of the calculations. In addition to this display window, the results of the reliability prediction calculations can also be reviewed for any assembly in the Project file by accessing the Calculation Results tab in the Parts Table window.

These techniques for reviewing calculation results display the results in a window. If you wish to print the calculation results, it is necessary to generate a report that includes the reliability prediction calculation results. 

Generating Reports in Relex Reliability Prediction

As with other Relex modules, Relex Reliability Prediction supports the use of customized report designs. Several standard reliability prediction report designs are supplied with Relex Reliability Prediction, but others can be created and/or customized to suit your needs. A list of supplied reliability prediction Report Design files is included in the Docs directory on the Relex CD.

In addition to the supplied reliability prediction report designs, Relex also includes report designs for a number of the Reliability Prediction Value-Added files. These reports are generated from within the Parts Library, Correlation, Defaults and Mission Profile files.

For more information regarding customizing the Report Design files to suit individual needs, refer to the “Reporting and Graphing” chapter of this manual.

Chapter 8 Reliability Block Diagram (RBD)

Introduction

Many hardware/software systems are complex in their configuration. The evaluation of the reliability of such systems requires sophisticated mathematical algorithms. With Relex RBD, you draw blocks on the screen, assign their properties, and connect them together with ease. You can calculate reliability,xe "Calculate Reliability" availability,xe "Availability" and MTBF.xe "MTBF" Relex RBD handles everything from simple series-parallel configuration to complex networks using Relex RBD’s powerful built-in Monte Carlo simulator.
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Figure 8 - 1. Sample Relex Project filexe "Project file" with RBD

Getting Started with RBD

What is the Goal of an RBD?

The Relex Reliability Block Diagram (RBD) provides you with complete flexibility in the design of your RBD. The RBD can include items from the System Treexe "System Tree" and Parts Table,xe "Parts Table" or it can be completely independent from the individual parts of the Project file. 

The RBD is used when you need to calculate complex redundant systems that cannot be computed using the Relex Reliability Predictionxe "Reliability Prediction" portion of the program alone. A reliability prediction analysis can provide important calculated values like failure rate, MTBF, reliability, and availability. These calculations are based on established reliability prediction models.xe "Reliability Prediction Models" Unfortunately, a reliability prediction model assumes that the configuration of your system is a simple one. As system configurations become more complex, more complex calculation methodsxe "Calculation Methods" are required to calculate values like failure rate, MTBF, reliability, and availability. The Relex RBD module provides the ability to perform these complex calculations.

A Reliability Block Diagram can also be used to provide a visual representation of the structure of a system. Visual tools are often helpful when attempting to simplify an explanation, and an RBD can be used for that purpose. The RBD can be as simple or complex as you wish. It can include simple geometric shapes to represent the portions of your system, or you can use bitmapxe "Bitmap" images or symbols to represent objects in your RBD.

How Do You Begin an RBD?

At the core, an RBD is a drawing and calculation tool used to model complex systems. The goal of an RBD is to produce a series of figures representing portions of a system that is to be analyzed. Once the figures are configured properly, and data for these figures is provided, calculations can be performed in order to calculate failure rate, MTBF, reliability, and availability. As the configuration of the blocks changes, the calculations results also change. Therefore, an RBD provides a way to compare various configurations in an attempt to find the best overall system design.

Starting Relexxe "Starting Relex" is similar to starting any Windows program. To start Relex, select Relex from the Start menu.

In order to use Relex RBD, you must have first purchased the Relex RBD option, and you must initialize the RBD capability in Options. Follow these steps to verify that the Relex RBD option is available with your Relex installation and make sure Relex RBD is enabled:

1. If any files or windows in Relex are open, close them.

2. Select Tools>Options from the menu. 

3. Select the Product Options tab,xe "Product Options tab" and, if not already enabled, select the Reliability Block Diagram (RBD) checkbox to enable Relex RBD. Press <OK>.

4. To view an RBD, open any Project file. The RBD Table appears in the System Tree window, and the associated RBD appears in the Parts Table window.

What Are the Main Steps for Creating an RBD in Relex?

This section of the chapter is designed to get you started creating an RBD with a few steps. Additional details regarding various options and features are covered in more detail in the remaining sections in this chapter, but this should be used as your starting point. The main steps in entering figures and data in order to create a Reliability Block Diagram are as follows:

1. Create the RBD.

2. Add figures to the diagram and assign properties to these figures.

3. Connect all figures in the diagram and complete the chain from the start nodexe "Start node" to the end node.

4. Calculate the RBD.

Step #1 – Create the RBD

The first step is to create a new Reliability Block Diagram. The steps involved in this are outlined in the section titled “Creating/Opening an RBD”.

Step #2 – Add Figures to the Diagram and Assign Properties to These Figures
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Figure 8 - 2. RBD Table and RBD window

Once a blank RBD has been created, you may begin adding your figures to the diagram. Your goal is to add figures to the diagram in order to create a representation of the structure of your system. As described in the section titled “Adding Figures to an RBD
”xe "Adding Figures to an RBD", you can add figures of almost any stylexe "Style" to the diagram. These figures can be added independently by selecting Insert>Figure from the menu, or they can be added as representations of items in a Project file by clicking and dragging an item from a Project file into the RBD.

Once figures have been added to the RBD, the properties of each of the items can be assigned. Every figure in a diagram has properties associated with it. Selecting Visual Propertiesxe "Visual Properties" and Calculation Propertiesxe "Calculation Properties" from the right mouse menu on any figure can access these properties. For more details regarding the properties of a figure, refer to the section titled “Assigning Properties to Figures in the RBD”.

Step #3 – Connect All Figures in the Diagram and Complete the Chain from the Start Node to the End Node

Once figures have been placed into the RBD, it is necessary to connect all of the figures to illustrate the true structure of the system. The chain of connection must start at the start node (in the upper left-hand corner of the RBD) and finish at the end node (in the upper right-hand corner of the RBD). Lines referred to as connectors connect the figures. These connectors can be used to attach the figures in nearly any conceivable configuration. For instance, you may choose to connect your figures in a series configuration where the figures are joined by one continuous chain from the start to the end. Or, you may need to connect your figures in a parallel configuration, or in a combination of series and parallel redundancies.xe "Parallel Redundancies" \r "D2HBParallel_Red5" Diagrams can be series or parallel, or they can be connected together in a network arrangement. 

A series configuration is created by beginning at the start node, and connecting all figures through the end node. A parallel configuration includes the creation of junctions that allow a connectorxe "Connector" to be split into multiple connectors. For additional information regarding creating a simple series configuration, refer to the section titled “Connecting Figures
”xe "Connecting Figures". 

Redundancies can be represented in one of two ways. If all redundant elements are identical, a figure can be added to the RBD and multiple elements can be noted by accessing Calculation Properties from the right mouse menu and assigning multiple elements, quantity, and quantity required on the Redundancyxe "Redundancy" tab. Another option is to actually add multiple figures to the RBD to represent the multiple elements. Quantity and quantity required would then be assigned through the junction.xe "Junction"
Step #4 – Calculate the RBD

Once all figures have been added and connected, you may perform calculations on the RBD. 

What Decisions Must be Made to Determine How to Structure Your RBD?

There are a few key decisions that should be made regarding the structure of an RBD analysis before proceeding. A few common decisions are:

What will be the Source of Your Failure/Repair and Sparing Data for Figures?

Figures in the RBD can be linked to items in the System Tree or Parts Table. When these links are created, the failure/repair information and spares data for the figures are automatically retrieved from the System Tree and Parts Table data. In this case, it is not necessary to manually enter calculation data regarding figures. However, if the data for the figures is coming from some other source (other than Relex), it is necessary to enter each block and to enter all of the associated data regarding these figures manually.

What Level of Your System Will the Figures in the RBD Represent?

You have complete control over the configuration of an RBD. A common question for some is “What level of my system should the blocks in the RBD represent?” You may prefer to represent individual components in the RBD for completeness, or you may prefer to represent only higher level assemblies. One common rule of thumb that can be applied is to use figures to represent these levels of your system which include redundancies. 

Since one of the main purposes of the RBD is to calculate reliability and availability of a system based on redundancies, it is often useful to only analyze the system at the level that includes redundancies. The reason for this is that if no redundancies are included at a level (at the part level, for instance), the calculation of reliability and availability is based on a series configuration. The calculation of failure rate for series configurations is a sum of the lower level failure rates. By representing all of the lowest level series items with one higher level figure, you can save time and simplify your diagram.

At What Level Do You Wish to Present Your RBD Calculation Results?

It is also important to determine at what level you want to present RBD calculation results. If you are creating an RBD with the purpose of presenting results to management or to a customer, you may choose to perform the analysis at a very detailed level, but also prepare a higher level of your RBD in order to summarize the results. This provides you with a very detailed analysis and supporting documentation, and also a simplified higher level for easy explanation and illustration. If you are interested in summarizing at a higher level RBD refer to the section titled “Managing Multiple Figures and RBDs”.

Improving System Reliability and Availability Using the Relex RBD

There are several techniques you can employ to improve the reliability, and/or availability of your design. Three common techniques that may be used are parallel redundancy, standby redundancy, and spares. By using Relex's Reliability Block Diagram (RBD) tool, you can see the effects of these methods, then determine if any of these techniques should be used before making design changes.

For example, you can select an assembly in your RBD with a high failure rate and change that assembly's configuration to be a 1 out of 2 parallel redundant block. Then rerun the RBD calculationsxe "RBD Calculations" and see how the reliability values have improved. If you see significant improvement, it may be worth changing the design for the improved reliability your system experiences.

Look at these three techniques more closely and see how Relex RBD can make your analysis much easier.

Parallel Redundancies

As an example of parallel redundancies, assume there are two units which are both activexe "Active" when performing a particular function. However, only one of the active units is actually required for system operation. In this case, if one unit fails, the remaining active unit can continue to operate, thus, preventing a system failure.

The use of parallel redundancies can be analyzed in the Relex RBD module by selecting the properties for that block, and specifying the Redundancy Type as Parallel. Then specify the number of units in the redundant configuration and the number of units required for operation. You may have a simple 1 out of 2 case, where two identical units are operating simultaneously, but only 1 is required for the system to continue operating. However, you may also model more complex cases, where there are several units operating, and more than one is needed for operation to continue. RBD allows you to make these changes and rerun calculations to see the resultant reliabilities.

If you have cost information provided, you can also see the increase to your system cost. In most cases, you reach a point where the additional redundant blocks are not worth the cost of the reliability improvement. This point varies dependant on your system requirements.

xe "Standby Redundancies"Standby Redundancies

An even more effective method to improve reliability is the use of standby redundancies. Standby redundancy offers the ability to protect a system through the use of cold, warm, or hot standby units. In an example standby redundancy, there may be two units, but only one of the units is active. If the active unit fails, the non-operational unit is then switched on to take over operation of the failed unit. Again, in this case, a system failure is prevented. 

The use of standby redundancies can be analyzed in the RBD module by selecting the properties for that block, and specifying the redundancy type as Standby. By then specifying the number of total units and the number of units in standby, Relex can again calculate the reliability of the system. Standby redundancy is more effective than parallel redundancy because the units are not always operating. The standby units are called into action only when needed, so they do not fail at the same rate as a parallel unit.

The standby units can even be specified at any level of cold, warm, or hot activity. For example, assume that your standby unit is not operational, but is still powered on to be ready to activate. In this case, the standby unit's failure rate is higher than if it was in cold standby. In Relex RBD, this is referred to as a quiescent or shelf failure rate. This failure rate can be specified directly, or may be specified as a percentage of the assembly's failure rate. For example, specifying the shelf failure rate of a standby unit as 100%, you have basically made the configuration equivalent to a parallel redundant system.

Again, use RBD to change the configuration of your system until you see the level of desired reliability, then implement design changes.

Sparing

A technique for increasing availability is to make spares available for critical systems. When a failure does occur, it generally takes less time to replace the failed unit with a spare than it does to repair the failed unit. Therefore, the use of spares would increase the availability of a system by decreasing downtime.

The Relex RBD module includes the functionality to optimize the number of spares to achieve a desired availability. You can either specify the number of spares available for a system component, or you can allow Relex to determine the optimal number of spares. You can mix the two together, so you can specify the number of spares for some blocks, and allow Relex to determine the number of spares for others.

When computing the optimal number of spares, Relex requests the desired availability. Then, based on the desired availability, the number of spares required to reach this goal is determined. The use of spares does not effect your system design, but it allows you to best determine where and how many spares you should specify for your system during operation. The results are a system with improved availability.

Conclusion

The Relex RBD provides the tools required to implement all of these techniques for improving reliability and availability. To assist in understanding these features and capabilities further, refer to other sections of this chapter.

RBD Reference

xe "Sample RBD Files"Sample RBD Files

Before you begin to create your own RBD, it may be helpful for you to review one that already exists. The Relex Sample Projectxe "Sample Project" is a Relex Project file that includes reliability prediction, FMEA, maintainability, fault tree, and RBD data. This is a completely integrated file that shares data from the various Relex modules.
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Figure 8 - 3. Sample Relex Project file with RBD

To review the Sample Relex Project, follow these steps:

1. Open the Sample Relex Project file by selecting File>Open>Project from the menu.

2. When the sample project appears the System Tree and Parts Table windows are shown as usual. To access the RBD portion of the Project file, click on the RBD tab in the Parts Table window. [image: image75]
3. When reviewing the RBD, the following is a list of terms you should be familiar with:

	Term
	Description

	Start and End Nodes
	The start node (displayed on the left) and the end node (displayed on the right) represent the start and end of the RBD. The diagram is evaluated from the start node, and then through all paths until the end node is reached.

	Figure
	Used to describe all of the blocks that appear in the RBD. Figures can be linked to items in the System Tree or the Parts Table or can be completely independent.

	Connector
	Used to describe all of the lines that connect the figures in the RBD. All connectors enter figures on the left input arrow and exit on the right output arrow.

	Junctionxe "Junction"
	Used to describe a point where two or more connectors are joined to form one connector.


Creating/Opening an RBD

To create/open a Project file containing an RBD, follow these steps:

1. Select File>New>Project or File>Open>Project from the menu. Enter the new file name or select the file to be opened and press <Create> or <Open> to continue.

2. If creating a new file, the tabs displaying the properties of the Project file are displayed. Edit these properties if necessary and press <OK> when ready.

3. When the Project file appears, select the RBD tab in Parts Table window. This accesses the standard RBD graphical view window that is referred to as the RBD window in this documentation. In addition to the RBD window, you may also access the RBD Table window by selecting the RBD Table tab in the System Tree window.
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Figure 8 - 4. Sample Relex Project file with RBD

xe "Adding Figures to an RBD"Adding Figures to an RBD

When using the Relex RBD, you have the flexibility of creating figures that are independent of the assemblies and parts in the Project file, or of selecting figures that are linked to assemblies and parts in the Project file. This section describes both techniques.

Creating Independent Figures

An Independent Figure in an RBD is a figure that has been drawn or inserted by you, and that has properties manually assigned to it. There are two ways to add this type of figure to an RBD:

Insert Figure from the Menu

1. Select Insert>Figure from the menu.

2. When the Insert Figure window appears, select a figure style from the choice list.

3. A figure is attached to your cursor. Press the left mouse button to place the figure.

4. The ability to add additional figures remains available from your cursor until the right mouse button is selected (to disable the capability).

Note: A figure can also be inserted from the menu by selecting Insert>Default Figure. When selected, this option automatically inserts a figure of the default style. The Default Figure Style is assigned under the Format>Figure Styles option. 

Insert Figure from the Toolbar

1. Select the figure style from the choice list or select the Default Figure option from the Insert Diagram Objects toolbar.

2. A figure is attached to your cursor. Press the left mouse button to place the figure.

3. The ability to add additional figures remains available from your cursor until the right mouse button is pressed (to disable the capability).

Creating Figures That Are Linked to Assemblies, Parts, or Failure Modes

In a RBD, a figure can be created that is automatically linked to an assembly or part in the current Project file. When this type of figure is created, Relex automatically applies the calculation properties of the associated assembly or part to the figure. As calculation properties regarding the linked assembly or part change, the properties of the figure are also changed. To create this type of figure, follow these steps:

Click and Drag an Item into the RBD

1. Select an assembly from the System Tree, a part from the Parts Table, or a failure mode from the FMEA Treexe "FMEA Tree" with your cursor.

2. Click and drag the item into the RBD.

3. Release the left mouse button to place the figure.

4. All of the properties of the linked item automatically are applied to the figure.

Items that can be dragged to the RBD are:

· A part from the Parts Table

· A part from the System Tree

· An assembly from the System Tree

· A failure mode from the FMEA Tree window

Link Existing Figures to Project Items

Existing independent figures in the RBD can be linked to items in the System Tree, Parts Table, or FMEA Tree. When a figure is linked, it assumes all of the properties associated with that item. As changes occur to the calculation properties of the linked item, the calculation properties of the figure change automatically. To link an existing figure, just follow these steps:

1. Select the figure in the RBD window with your cursor.

2. From the right mouse menu, select Set Data Link.

3. The Set Data Link window appears. Select the part or assembly in the System Tree, Parts Table, or FMEA Tree that you want to link the figure to. Click the <Set Data Link> button.

4. After selecting the <Set Data Link> button, the selected figure assumes the characteristics and data associated with the selected assembly or component.

Unlink Figures from Project Items

If at a later time, you wish to remove the data link, you can do so by following these steps:

1. Select the figure with your cursor.

2. From the right mouse menu, select Remove Data Link.

3. The figure no longer is linked to the item. However, it retains the last calculation properties that the two items shared.

Note: When a Data Link has been removed, changes that occur to the item from the link source are no longer automatically reflected in the figure. 

xe "Editing the RBD Layout"Editing the RBD Layout

Once the figures have been placed into the diagram, you have several options regarding aligning and editing the placement of these figures. These options include:

xe "Moving Figures"Moving Figures

There are two basic choices for moving a figure:

The Click and Drag technique is useful when you wish to move a Figure within a single diagram. To move a figure within a diagram, follow these steps:

1. Select the figure by clicking on it with your mouse. The figure is selected when dots appear around it.

2. Click and drag the figure to its new location (any connectors associated with the figure automatically adjust to the new location).

3. Release your mouse button to release the figure and place it in its new location.

The Cut and Pastexe "Cut and Paste" technique to move a figure is useful when you wish to move a figure from one diagram to another. To move a figure from one diagram to another, follow these steps:

1. Select the figure by clicking on it with your mouse. The figure is selected when dots appear around it.

2. Select Cut from the right mouse menu or Edit>Cut from the menu. The figure is cut to the clipboard.

3. Place your cursor in the window where the figure is to be placed, and make that window the active window in Relex.

4. Select Paste from the right mouse menu or Edit>Paste from the menu. This pastes the figure from the clipboard to its new location within the diagram.

5. Click and drag the figure to the location in the diagram that you prefer.

xe "Copying Figures"Copying Figures

The Copy and Pastexe "Copy and Paste" technique to copy a figure is used when you wish to create a copy of a figure within a diagram, or to copy a figure from one diagram to another. To copy a figure, follow these steps:

1. Select the figure by clicking on it with your cursor. The figure is selected when dots appear around the figure.

2. Select Copy from the right mouse menu or Edit>Copy from the menu. The figure is copied to the clipboard.

3. Place your cursor in the window where the figure is to be placed, and make that window the active window in Relex.

4. Select Paste from the right mouse menu or Edit>Paste from the menu. This pastes the figure from the clipboard to its new location within the diagram.

5. Click and drag the figure in the diagram to the location that you prefer.

xe "Overlapping Figures"Overlapping Figures

There are times during the creation of an RBD when certain figures overlap. You can manipulate how these figures are displayed by using the Bring to Front and Send to Back option. To do this, select the figure that you wish to manipulate, and select Format>Bring to Front to move the selected figure to the front of the stack, or select Format>Send to Back to move the selected figure to the back of the stack.

xe "Deleting Figures"Deleting Figures

Deleting figures from a diagram is very simple. The steps are as follows:

1. Select the figure by selecting it with your cursor. The figure is selected when dots appear around the figure.

2. Select Delete from the right mouse menu; select Edit>Delete from the menu; or press the <Delete> key on the keyboard.

3. The figure is deleted.

xe "Selecting a Group of Figures"Selecting a Group of Figures

When selecting figures to be moved, copied, or deleted within a diagram, you can select an individual or multiple figures with your mouse. Once the multiple figures have been selected, they can be moved, copied, or deleted. 

To select multiple figures in a diagram, use any of these techniques:

· Hold the <Shift> key while clicking each of the figures to be selected. As each item is selected with your mouse, boxes or dots surrounding the items highlight it.

· Click and drag your mouse to create a box enclosing all of the figures to be selected. Upon releasing your mouse button, all of the enclosed items are selected.

· Select Edit>Select All from the menu to automatically select all figures in the current diagram.

xe "Automatic Aligning of Figures"Automatic Aligning of Figures

Once figures have been added to a diagram, they may be moved manually by using the techniques previously described in this chapter. Relex provides you with an additional feature of automatically aligning the selected figures to your specifications. To automatically align figures, follow these steps:

1. Select the figures to be aligned by using one of the techniques described in the section titled “Selecting a Group of Figures
”. 

2. To align the selected figures, access the Format menu and select from any of the following options:

	Menu Item
	Description

	Align
	Left. Aligns the left sides of the selected figures vertically.

	
	Right. Aligns the right sides of the selected figures vertically.

	
	Top. Aligns the top of the selected figures horizontally.

	
	Bottom. Aligns the bottom of the selected figures horizontally.

	
	Horizontal Center. Aligns the center of the selected figures horizontally.

	
	Vertical Center. Aligns the center of the selected figures vertically.

	Make Same Size
	Height. Makes all of the selected figures the same height.

	
	Width. Makes all of the selected figures the same width.

	
	Both. Makes all of the selected figures the same height and width.

	Space Evenly
	Across. Spaces the selected figures evenly across the diagram (horizontally).

	
	Down. Spaces the selected figures evenly down the diagram (vertically).

	Size to Text
	Adjusts the size of the selected figures to match the size of the text.


Note: When selecting multiple figures, the first figure selected is highlighted with solid black dots, while the others are highlighted with hollow dots. The solid black dots signify that the highlighted figure is the model figure for any changes to the selected figures. For example, if three figures are selected, and the Make Same Size feature is applied to these three figures, the size of the three figures matches that of the model figure.

xe "Sizing Figures"Sizing Figures

The process of sizing itemsxe "Sizing Items" (making them larger or smaller) within an RBD is the same regardless of the type of item you are moving. Therefore, the following steps are the same for figures, labels, and bitmaps: 

1. Select the item to be sized by placing your cursor over it until it becomes a four-sided arrow. Then press the left mouse button. The item is selected when the box enclosing the item is displayed with highlighted dots.

2. When sizing an item, you may choose from any of the following techniques:

	Purpose
	Technique

	Size an item to a selected size
	Select any of the highlighted dots on the exterior of the box containing the item to make the item larger or smaller. Place your cursor over any of the highlighted dots to get a 2-sided arrow cursor. Click and drag to make the object its desired size. 

	Size an object proportionately
	Place your cursor over any of the highlighted dots to get a 2-sided arrow cursor. Click and drag while holding down the shift key. This sizes the item both horizontally and vertically while retaining the basic proportions of the item. Bitmaps resize proportionately to their original bitmap size.

	Re-size a bitmap to True Size
	Select any bitmap image item, and from the right mouse menu, select Size to True Bitmap Size. The true bitmap size is the original size of the bitmap.


3. Release your mouse button when the desired size is reached.

xe "Redo"Undo and Redo Capabilities

In Relex RBD, you have up to 99 levels of undo and redo capability. This is especially helpful when editing an RBD. If you have made a change that you wish to undo, select Edit>Undo from the menu and your last change is undone. Redo redoes a change that you undid. 

xe "Multi-Page RBD"

xe "Creating a Multi-Page RBD"Creating a Multi-Page RBD

A single RBD can consist of multiple pages to allow the creation of large diagrams. Relex has a built- in utility that allows you to view multiple pages of the RBD as one diagram. Each page of the RBD is the size of the default printer page in Windows. If multiple pages are created, you can print the diagram with crop marks to allow the creation of a large printed diagram.

The Diagram>View Pages option is used when a diagram is so large that it overlaps multiple pages when printed. When selected, the View Pages window appears. From the window, select the number of rows and columns to be included in the view of the diagram.

xe "Zooming"Zooming Your Diagram

You can change the view of the diagram by selecting the following from either View on the menu or from the right mouse menu:

	View
	Description

	Zoom In
	This view option can be selected from the right mouse menu, from the View menu, or from the Diagram Tools toolbar. Zoom In enlarges the diagram.

	Zoom Out
	This view option can be selected from the right mouse menu, from the View menu, or from the Diagram Tools toolbar. Zoom Out shrinks the view of the diagram.

	Zoom To
	This view option can be selected from the right mouse menu or from the Diagram menu. Zoom To has the following options:

Page Width: Zooms to the width of the page.

Whole Page: Zooms to display the whole page.

All Objects: Zooms to display all objects.

Selected Objects: Zooms to display only the selected objects.


The Diagram Tools toolbar includes an additional icon that allows you to drag to zoom on a particular section of the diagram and to select a particular zoom percentage.

Assigning Properties to Figures in the RBD

RBD Figure Calculation Properties

Figures that are linked to items in the System Tree, Parts Table or FMEA Tree have calculation properties automatically associated with them. They inherit the calculation properties of the items from which they were created. When creating figures that are not linked, these items need to be assigned calculation properties. You can access the Calculation Properties of a figure by any of the follow methods:

· Double-click your mouse over the figure.

· Select the figure by clicking on it once with your mouse. Select Calculation Properties from the right mouse menu.

· Select the figure by clicking on it once with your mouse. Select View>Properties from the menu.
· Select View>Figure Table from the menu. This feature allows you to view general information regarding all figures, and allows quick access to the Calculation Properties of each figure through the <Properties> button. 

The Calculation Properties consist of the following tabs:

General Tab

The General tab includes the general descriptive information regarding the figure. If the figure is linked, the information on this tab is completed for you automatically. If the figure is not linked, you have the flexibility of assigning these items yourself.
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Figure 8 - 5. RBD Figure Calculation Properties, General Tab

	Property
	Description

	ID
	Relex automatically assigns each figure in the RBD an ID number. The number displayed in the ID field is the unique identification number assigned to the selected figure. This field cannot be edited.

	Linked to Item in Tree/Assembly
	If checked, this item is linked to a System Tree, Parts Table or FMEA Tree item. If it is linked, the remaining fields are completed with the information from the linked item. If it is not linked, you can enter the data in the remaining fields.

	Assembly
	The name of the assembly item in the RBD.

	Part Numberxe "Part Number"
	The part number of the item in the RBD.

	Reference Designatorxe "Reference Designator"
	The reference designator of the item in the RBD.

	Description
	The description of the item in the RBD.

	Repeated
	A figure can be duplicated in various areas within an RBD by using the copy/paste command. However, there are times when a figure is used in multiple locations, but is actually representing the same item. During calculations, the figure is only accounted for once, regardless of the number of repeated blocks that are included in the diagram. During the Monte Carlo simulation,xe "Simulation"

xe "Monte Carlo Simulation" if that element is assumed to fail during random simulation, it also fails in all related locations. Follow these steps to make a block a repeated block:

1. Create multiple copies of a figure by using the copy and pastexe "Copy and Paste" feature in the Relex RBD.

2. Select one of the copies with your cursor and select Calculation Properties from the right mouse menu.

3. On the General tab in Calculation Properties, select the option labeled Repeated.

4. If the figure is a repeated figure of another figure in the diagram, place a check mark in the option marked Repeated on the Repeated Block window.

5. Select the figure ID number of which the selected figure is a repeat. This information is displayed on the General Data tabxe "General Data tab" under Calculation Properties for a figure.

6. Press <OK> to save the changes.

7. A message displays on the General tab stating that the figure is the “Same as ID <Number>”.


xe "Failure/Repair tab" \r "D2HBFailure_Repa16"Failure/Repair Tab

The Failure/Repair tab allows you to assign failure rate and repair values.
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Figure 8 - 6. RBD Figure Calculation Properties, Failure/Repair Tab
	Property
	Description

	Failure: Distribution
	The distribution method of the failure rate or MTBF that was entered. These distribution methods are described in more detail in the following section.

	Failure: Failure Rate
	The failure rate for the RBD figure. You may enter a failure rate or an MTBF. The units of the failure rate are taken from the failure rate multiplierxe "Failure Rate Multiplier" in the Project Properties.

	Failure: MTBF
	The MTBF for the RBD figure. You may enter a MTBF or failure rate.

	Repairablexe "Repairable" Component
	If marked, this item is considered to be repairable, and the mean corrective time (MCT) entered is used in the availability calculation.

	Repair: Distribution
	The distribution method of the repair time that was entered. These distribution methods are described in more detail in the following section.

	Repair: Mean Corrective Time
	The mean corrective time or repair time.

	Repair: Hours or Minutes
	Allows you to specify the units of the mean corrective time as either hours or minutes.

	Mean Logistics Down Time (in hours)
	The time period associated with the repair of a block, including time spent filling the logs, time spent for the maintenance personnel or spares to arrive, etc. This time affects the sparing and operational availability calculations.

	Additional Fields
	Depending on the failure or repair distribution selected, additional fields may display on the Failure/Repair tab.


Failure/Repair Distribution Methods

The following list describes each of the distribution methods in more detail. Depending on the distribution method selected, additional parameters of information are required. The additional parameters needed for the various distribution methods are:

	Distribution
	Description

	Exponential
	Mean and Standard Deviation. Normal distribution is probably the most important and widely used distribution in the entire field of statistics and probability. The Normal (or Gaussian) distribution is the best-known two-parameter distribution. All Normal distributions are symmetric, and the two distribution parametersxe "Distribution Parameters" are its mean and standard deviation. Normal distributions are frequently used to describe equipment that has increasing failure rates with time. 

	Lognormal
	Mean and Standard Deviation. Similar to a Normal distribution except that the logarithm of the values of random variables, rather than the values themselves, are assumed to be normally distributed. Thus all values are positive; the distribution is skewed to the right. Lognormal distributions are encountered frequently in metal-fatigue testing, maintainability dataxe "Maintainability Data" (time to repair), and chemical-process equipment failures and repairs.

	Weibull
	Characteristic Life and Shape Factor. Among all the distributions available for reliability calculations, the Weibull demonstration is the only one unique to the field. In his original paper, “A Distribution of Wide Applicability”, Professor Weibull, who was studying metallurgical failures, argued that normal distributions require that initial metallurgical strengths be normally distributed, and that what was needed was a function that could embrace a great variety of distributions (including the Normal). The Weibull distribution is a three-parameter distribution including time, characteristic life, and a shape parameter.

	Rayleigh 
	Characteristic Life. Rayleigh distribution can be viewed as a special case of the Weibull distribution. It is however an important distribution in its own right and finds application not only in reliability problems but also in noise problems associated with communication systems. The Rayleigh distribution is a single parameter distribution similar to the exponential distribution. Rayleigh distribution can be used to describe the root-mean-square value of error sources.

	Uniform Distribution
	Lower bound and Upper bound. Uniform (or rectangular) distribution is the simplest of all distributions. This distribution can be interpreted as meaning that the random variable can only exist in the range a to b (lower to upper) and that the probability of occurrence is directly proportional to the interval length.

	Time Independent
	Unreliability. The Time Independent distribution is the unreliability or unavailability of the unit. It is the probability that the unit will not operate properly. This probability remains constant, and does not vary with time.


Distribution Parameters

Depending on which distribution method is selected, additional parameters of information are required. These additional distribution parameter fields are described as follows:

	Property
	Description

	Mean
	Required for Normal and Lognormal distributions. Generally the MTBF.

	Standard Deviation
	Required for Normal and Lognormal distributions. This value is the square root of the variance that is defined as the amount of spread, or more correctly dispersion, of a distribution measured by the second central moment of the distribution. In general, standard deviation is small if the spread or dispersion of values is small.

	Characteristic Life
	Required for Weibull and Rayleigh distributions. Defined as the time at which 63.2% of the device population will have failed.

	Shape Factor
	Required for Weibull distributions. The value is used to describe the shape of the hazard curve. For example, when the shape parameter is :

< 1 the curve takes on a Gamma distribution, 

= 1 the curve takes on an Exponential distribution (this is the constant failure rate curve), 

= 2 the curve takes on a Lognormal distribution, 

= 3.5 the curve takes on a Normal distribution (approximately). 

	Lower Bound & Upper Bound
	Required for Uniform distributions. This distribution can be interpreted as meaning that the random variable can only exist in the range of a to b and that the probability of occurrence is directly proportional to the interval length. In this equation, a refers to the lower bound, and b refers to the upper bound when defining the linear range.

	Unreliability
	Required for Time Independent distributions. This is that probability that the unit will not operate properly for a specified period of time, under the design operating conditions. This probability remains constant, and does not vary with time.


Redundancy Tab

The Redundancy tab allows you to specify information regarding the redundancy of the selected item. You can specify the number of items, number of items required, and redundancy type.
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Figure 8 - 7. RBD Figure Calculation Properties, Redundancy Tab

	Property
	Description

	Quantity
	Represents the total quantity of the selected item that is present in the system.

	Quantity Required
	This field is used for a system that has redundancy. Represents the quantity of the selected item that is required for operation. This number must always be less than or equal to the total quantity of items.

	Redundancy
	Defines the type of redundancy. Choices are:

Series. A system consisting of a series or chain of subsystems. If one of the subsystems fail, the entire system fails.

Parallel Operating.xe "Parallel Operating" A system consisting of subsystems with alternate components existing within the system to help it operate successfully in case of failure of one or more of the original components. In this model, all subsystems are active at all times. In the case of failure, backup units automatically take over when original units fail.

Standby. A system consisting of subsystems with alternate components existing within the system to help it operate successfully in case of failure of one or more of the original components. In this model, only the subsystems required for operation are active. In the case of failure, backup units are automatically activated to take over for the failed units.

	Switch Probability of Success
	For Standby Redundancy. A probability value, between 0 and 1, that the switch will be operable at the time the start up of the non-operatingxe "Non-Operating" system is required.

For Parallel Redundancy. A probability value, between 0 and 1, that the switch will be operable at the time the active unit fails and the backup unit is made fully active.

	Quiescent (Shelf) Failure Rate
	When a figure is assigned a redundancy of standby in the Relex RBD, the standby units are assumed to have a failure rate of 0.00. This option provides the ability to assign a quiescent or shelf failure rate for standby units. 

If the option of “Percentage of component unit failure rate” is selected, a dormancy factor can be entered as a ratio from 0 to 100%. This represents the ratio of the failure rate of an item when it is in standby mode as compared to active mode. If the dormancy factor is 100%, then standby reliability is equal to active reliability. 

If the option of “Specified failure rate” is selected, you may select to assign a specified failure rate to the standby units rather than assigning a dormancy percentage factor. 


xe "Sparing tab" \r "D2HBSparing_tab21"Sparing Tab

The Sparing tab allows you to specify spares information regarding the selected figure. For additional information regarding spares and sparing calculations, refer to the section titled “Spares Optimization Calculations
”xe "Spares Optimization Calculations".
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Figure 8 - 8. RBD Figure Calculation Properties, Sparing Tab

	Property
	Description

	Unit Cost per spare
	Enter the unit cost per spare in the field. This information is used in calculating the system cost.

	Maximum quantity of spares
	Used in calculating the optimal number of spares needed. The value entered sets an upper limit.

	Actual quantity of spares
	Used to specify the number of spares instead of calculating the optimal number of spares for this block.


xe "Calculation Results tab"Calculation Results Tab

The Calculation Results tab displays all calculation data regarding the selected figure. Any of the following results may appear:

	Value
	Description

	Optimal Number of Spares
	If the spares optimization feature is used, the optimal number of spares added for the figure displays.

	Time
	The time at which the calculated result occurs.

	Availability
	The calculated availability of the figure.

	Reliability
	The calculated reliability of the figure.

	Unavailability
	The calculated unavailability of the figure.

	Unreliability
	The calculated unreliability of the figure.


Note: An RBD calculation must be performed before calculation data displays on the Calculation Results tab.

RBD Figure Visual Properties

Each figure and connector in the RBD has properties associated with it. Access the visual properties of a figure or connector by performing either of these actions:

· Select the figure by clicking on it once with your mouse. Then select Visual Properties from the right mouse menu.

· Select the figure by clicking on it once with your mouse. Then select View>Figure Visual Properties from the menu.
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Figure 8 - 9. RBD Figure Visual Properties

The Visual Properties consist of the following tabs:

General Tab

The General tab contains the Bind to style checkbox. When this box is enabled you cannot modify the appearance of the selected figure. If the box is disabled, you can modify the figure’s appearance.

xe "Text tab"Text Tab

The Text tab allows you to specify the font to be used as the label for the selected figure.

	Property
	Description

	Font
	Select the font for the text from the choice list.

	Size
	Select the size of the font from the choice list or type it in.

	Justification
	Select the justification for the text by selecting the icon illustrating left, center, or right justification. Also select the icon to display whether to place the text near the top, center, or bottom of the figure.

	Bold
	If selected, the text is displayed in a bold font.

	Italic
	If selected, the text is displayed in an italic font.

	Keep sized to text
	If selected, the size of the figure is automatically adjusted to keep to the size of the text.


Graphic Tab

The Graphic tab allows you to specify the shape and style of the figure and the connector points of the figure. On this tab, you can also specify if the figure is to display as a bitmap graphic.

	Property
	Description

	Connector Points
	Select the style of the connector points for the figure by picking triangle, square, or circle.

	Size
	Allows you to specify the size of the connector points in pixels.

	Hide
	If selected, the connector points are hidden, and do not display or print in the RBD.

	Fill with Color
	If selectexe "Color tab"d, the connector points are filled with the color specified on the Color tab.

	Symbol
	Produces a list of available symbol shapes and styles. Select the desired symbol from this list and press <OK>.

	Image File
	Allows you to select an image for your figure. You can choose from JPEG, Bitmap, PCX, Targa, and TIFF file formats.


xe "Size tab"Size Tab

The Size tab allows you to specify the dimensions of the selected figure.

	Property
	 Description

	Width
	Specifies the width of the figure in inches or centimeters.

	Height
	Specifies the height of the figure in inches or centimeters.

	Left
	Specifies the coordinates of the figure in inches or centimeters. This value is the distance in inches or centimeters from the left side of the diagram.

	Top
	Specifies the coordinates of the figure. This value is the distance in inches or centimeters from the top of the diagram.

	Border
	Specifies the thickness of the border in pixels.

	Use True Image Size
	Resizes the image to its true size.


Note: The size of a figure can also be edited directly from the RBD window. By selecting a figure, you can click and drag on the corners of the block to size.

Color Tab

The Color tab allows you to specify the colors of the various components of the selected figure.

	Property
	Description

	Text Color
	Specifies the color of the text in the figure.

	Border Color
	Specifies the color of the border of the figure.

	Fill Color
	Specifies the fill color of the figure.

	Connection Point Color
	Specifies the color of the connection points of the figure.


xe "Display Tab"Text Display Tab

The Text Display tab allows you to specify the fields of information to be included in the label of the selected figure.

	Property
	Description

	Available Fields
	Displays a list of the fields that are available to be included in the label of the figure.

	Fields to Display
	Displays a list of the fields that are currently selected to display in the label of the figure.

	Placement
	Specifies the placement of the label in relation to the figure. A label can be placed inside, on the top (above), or on the bottom (below). If the figure is an image, the label can only be on the top or bottom (above or below).


Using the buttons on the tab marked <Add>, <Add All>, <Remove>, and <Remove All>, you can move items from the Available Fields list to the Fields to Display list. Adjust the list until it includes all fields of information that you want to be displayed on the label of the selected figure. You can also reorder the fields to display by dragging them with your mouse.

Available Fields

The following fields are available for text display in a figure. A brief description of the data source of each field is provided.

	Field
	Data Source

	Assembly Namexe "Assembly Name"
	The assembly name as entered on the General tab in Calculation Properties, or the name of the linked assembly.

	Availability
	The availability of the figure based on the results of the most recent RBD calculation.

	Description
	The description as entered on the General tab in Calculation Properties, or the description of the linked assembly or part.

	Failure Properties
	For a linked figure, this is the failure rate of the linked assembly or part. For a figure that is not linked, this is the specified failure rate or MTBF of the figure from the Failure/Repair tabxe "Failure/Repair tab" \r "D2HBFailure_Repa25" in Calculation Properties.

	Part Number
	The part number as entered on the General tab in Calculation Properties, or the part number of the linked assembly or part.

	Quantity
	The quantity as entered on the Redundancy tab in Calculation Properties.

	Quantity Required
	The quantity required as entered on the Redundancy tab in Calculation Properties.

	Reference Designator
	The reference designator as entered on the General tab in Calculation Properties, or the reference designator of the linked item.

	Reliability
	The reliability of the figure based on the results of the most recent RBD calculation.

	Repair Properties
	For a linked figure, this is the MTTRxe "MTTR" of the linked item. For a figure that is not linked, this is the specified mean corrective time of the figure from the Failure/Repair tab in Calculation Properties.

	Unavailability
	The unavailability of the figure based on the results of the most recent RBD calculation.

	Unreliability
	The unreliability of the figure based on the results of the most recent RBD calculation.


Assigning Properties Using the Figure Table

You may edit Figure Calculation Properties by right-clicking on the figure and selecting Calculation Properties from the right mouse menu or by selecting View>Properties from the menu. This works well when you are working on each figure individually. However, if you are working on a larger Project file, you may wish to view the information regarding figures in a simpler, tabular format. By accessing View>Figure Table from the menu, you can view general information regarding all of the figures in the diagram in one easy to read table. The information can be edited from this table. To access the other Calculation Properties from this table, double-click on any figure or select the <Properties> button at the bottom of the window to display the Calculation Property tabs for that figure. Any changes made from the Figure Table are automatically applied to the diagram.

xe "Connecting Figures"Connecting Figures

xe "Auto-Connecting Figures"Auto-Connecting Figures

Relex has an Auto-Connect Figures feature that connects all of the figures in a standard Series configuration in the order in which the figures were placed on the diagram. To use this feature, select Tools>Auto Connect Figures from the menu.

Manually Connecting Figures

Once figures have been added to the RBD, they need to be connected at the start node and end node. The start node (displayed on the left) and the end node (displayed on the right) represent the start and end of the RBD. The diagram is evaluated from the start node, and then through all paths until the end node is reached. If a figure in the diagram is to be included when calculating, it is to be added to the chain of nodes in the RBD. The nodes in the diagram are connected using connectors. Connectors are the lines that connect the figures in the RBD. All connectors enter figures on the left input arrow and exit on the right output arrow of each figure. Follow these steps to connect the figures in your RBD:

1. Place your mouse cursor over the connection point coming out of the start node. Note that your cursor changes to an elongated arrow. 

2. Click and hold the left mouse button and drag your mouse. As you drag it a connector appears. Drag your mouse until it is over the first figure in your RBD chain. When you are positioned correctly your mouse cursor is filled in with a black color. Release your mouse button. If you are not positioned over a valid figure when you release your mouse button, Relex does not allow you to draw the connector. 

3. Once the first connector is placed from the start node to the first figure, you may begin connecting the other items in your RBD. Place your mouse cursor over the connection point coming out of the right output arrow of the first figure. When an elongated arrow appears, click and hold the right mouse button and drag your mouse. Again, your connector appears. Drag your mouse until it is over the second figure in your RBD chain. When positioned correctly, release your mouse button again to create the second connector. 

4. Follow these steps until you have connected your last figure to the connection point of the end node. You may also drag backwards from the destination figure's input arrow to the source figure's output arrow. 

Note: Also, you may drag a connector from a junctionxe "Junction" \r "D2HBJunction27" by holding the <Alt> key while dragging. Junctions are special object types that allow you to make multiple connectors.

xe "Connector Properties"Connector Properties

To assign the visual properties for a connector in a diagram, follow these steps:

1. Select the connector by clicking it with your cursor. The connector is highlighted with dots showing that it is selected.

2. From the right mouse menu, select Properties.

3. The Connector Properties tabxe "Connector Properties tab" display appears.

Connector Properties Tab

The Connector Properties tab allows you to specify the general style of the selected connector.

	Property
	Description

	Thickness
	Specifies the thickness of the connector line in pixels.

	Style
	Specifies the style of the connector line. The choice list displays various styles of solid and dashed lines.

	Color
	Specifies the color of the connector line.

	Use these settings when creating connectors
	If selected, the specified settings become the default connector style when new connectors are created.


Inserting a Junction to Create Redundant Configurations

You can select Insert>Junction to insert a small junction which can be used to connect multiple connectors together such as in a parallel redundant configuration. You can drag a connector to a junction to connect a figure to a junction. Pressing <Alt> while dragging allows you to drag a connector from a junction to another location. 
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Figure 8 - 10. Sample Redundant Configuration with Junctions

Just like all other objects in a diagram, a junction has properties associated with it. To access the properties, select the junction and select Properties from the right mouse menu or View>Properties from the menu. The Junction Properties window consists of the following items:

	Property
	Description

	Quantity Required
	Is defined at the junction point where multiple connectors are entering the junction (for instance, connectors would enter a junction point after a set of parallel items and would enter the junction at the left side). The quantity required specifies the number of units necessary for the system to operate. For instance, in a parallel system consisting of 3 parallel units, if 2 of 3 units were required for the system to operate, a value of 2 would be entered into this field. For a junction point before a set of parallel units, the quantity required would generally be 1, representing the number of connectors entering that particular junction at the left.

	Color
	The color of the junction point. The choice list allows this color to be changed.

	Use this color when creating junctions
	If selected, the color selected becomes the default color for all new junctions being created.


Note: If you have an existing connector in your diagram, you can insert a junction in the connector. Select the connector with your mouse and select Split from the right mouse menu.

Adding Labels to an RBD

Oftentimes it is necessary to insert descriptive labels into an RBD for added effect. Labels can be inserted in the following ways:

Insert Label from the Menu

1. Select Insert>Label from the menu.

2. When the Insert Label window appears, select a label style from the choice list.

3. A label is attached to your cursor. Press the left mouse button to place the label.

Note: A label can also be inserted from the menu by selecting Insert>Default Label. When selected, this option automatically inserts a label of the default style. The default label style is assigned under the Format>Label option. 

Insert Label from the Toolbar

1. Select the label style from the choice list or press the <Default Label> button from the Insert Diagram Objects toolbar.

2. A label is attached to your cursor. Press the left mouse button to place the label.

xe "Label text"Editing Label Text

The text contained in a label can be accessed and edited by first selecting the label, and then selecting Edit from the right mouse menu.

Assigning Properties to Labels in an RBD

Each label in the RBD has properties associated with it. To access the properties of a label, double-click on it, select it and choose Properties from the right mouse menu, or select it and choose View>Properties from the menu.
The Label Propertiesxe "Label Properties" consist of the following tabs:

General Tab

The General tab allows you to specify the general style of the selected label. If a label is marked as Bind to Style, any changes made to the associated style are automatically made to the label. In addition, changes cannot be made manually to the properties of the label. Instead all changes must be made to the style itself. Manual changes can be made if this feature is disabled.

xe "Text tab"Text Tab

The Text tab allows you to specify the font to be used for the selected label.

	Property
	Description

	Font
	Select the font for the text from the choice list.

	Size
	Select the size of the font from the choice list or type it in.

	Justification
	Select the justification for the text by selecting the icon illustrating left, center, or right justification. Also select the icon to display whether to place the text near the top, center, or bottom of the figure.

	Bold
	If selected, the text is displayed in a bold font.

	Italic
	If selected, the text is displayed in an italic font.


xe "Color tab"Color Tab

The Color tab allows you to specify the colors of the various components of the selected label.

	Property
	Description

	Text
	Specifies the color of the text in the label.

	Background Color
	Specifies the color of the text background in the label.

	Transparent Background
	If marked, no background displays for the selected label.


Customizing Object Styles in the RBD

Defining Styles of Figures, Labels, and Connectors

When adding items to a diagram, there are predefined styles to choose from. You can use the predefined styles, or define your own custom styles. You can create custom styles for figures, labels, and connectors.

Creating Custom Figure Styles

To create a new custom figure style, follow these steps:

1. Select Format>Figure Styles from the menu.

2. When the Figure Styles tabs appear, select the General Tab.

3. On the General tab, select the style that you would like to modify. This list displays all figure styles that currently exist. If you want to add a new figure style, press <New Style>, enter a name, and press <OK>.

4. Customize the style by accessing the tabs for the style. For a more detailed description of each property, refer to the section titled “RBD Figure Visual Properties”.

5. When finished, press <OK> to save the new style.

Creating Custom Label Styles

To create a new custom label style, follow these steps:

1. Select Format>Label Styles from the menu.

2. When the Label Styles tabs appear, select the General tab.

3. On the General tab, select the style that you would like to modify. This list displays all label styles that currently exist. If you want to add a new label style, press <New Style>, enter a name, and press <OK>.

4. Customize the style by accessing the tabs for the style. For a more detailed description of each property, refer to the section titled “Assigning Properties to Labels in an RBD”.

5. When finished, press <OK> to save the new style.

Creating the Default Connection Style

By selecting Format>Default Connector Propertiesxe "Connector Properties" from the menu, you can define the characteristics of the default connection style. This style is then used when connectors are added to the RBD. Under default connector properties, the window that appears allows you to assign the thickness, style, and color of the connector from the available choice lists.xe "Choice Lists"
xe "Junction"Creating the Default Junction Style
By selecting Format>Default Junction Properties from the menu, you can define the characteristics of the default junction style. This style is then used when junctions are added to the RBD. The default junction properties window allows you to assign the color of the junction from the available choice list.

RBD File Properties

Just like the individual objects within a diagram, the RBD has properties that apply to the entire RBD. To assign the Properties for an RBD, follow these steps:

1. Make sure that no objects in the diagram are selected by clicking your mouse in an empty space in the RBD. Select View>Properties from the menu or select Properties from the right mouse menu.

2. The properties for the RBD display and are described as follows:

	Property
	Description

	Page Color
	Specifies the color of the page of the diagram (or the area inside of the page boundaries).

	Non-Print Area
	Specifies the color of the non-print area of the diagram (or the area outside of the page boundaries)

	Grid Lines
	Specifies the color of the grid lines.


Managing Multiple Figures and RBDs

Managing Figures Using the Figure Table

The figure table in Relex RBD can be used to automatically go to a selected figure. To access this feature, you must first select the RBD tab in the Parts Table window. Next, select View>Figure Table from the menu. The figure table includes assembly, part number, reference designator, and description information for each figure. Select any data in the row of the figure of interest. [image: image83]The <Go To> button at the bottom of the figure table can be used to automatically go to the specified figure on the RBD tab in the Parts Table window. The <Properties> button at the bottom of the figure table allows you to access the calculation properties a specific figure. This can be very helpful when working on a large diagram. 

Managing Multiple RBDs

Creating Additional RBDs Within a Project file

A Project file can include multiple RBDs. To create additional RBDs within a Project file, follow these steps:

1. Activate the RBD Table.

2. Select Insert>RBD from the menu.

3. Save changes to the current RBD as desired.

4. A new RBD is added on the RBD Table and its corresponding graphical view is displayed on the RBD tab in the Parts Table window. The new RBD is given a default name. The default name may be changed as described in the following section.

Renaming RBDs within a Project File

A Project file can include multiple RBDs. To rename any RBD within a Project file, follow these steps:

1. Select the appropriate RBD in the RBD Table.

2. Double-click on the Diagram field and reenter the appropriate RBD name. The change is shown in the RBD Table and on the RBD tab in the Parts Table window.

Deleting RBDs within a Project File

A Project file can include multiple RBDs. To delete an RBD from a Project file, follow these steps:

1. Select the appropriate RBD in the RBD Table.

2. Press the <Delete> key on the keyboard or select the Delete option from the right mouse menu or select Edit>Delete from the menu.

3. Confirm that you want the selected RBD to be deleted. 

Note: RBD deletion cannot be undone.
xe "Linking Multiple RBDs"Linking Multiple RBDs

Relex allows you to link diagrams together to form large, complex systems. RBDs are linked to each other through a single figure. The linked diagrams are then an integral part of the figure. During the calculation of the entire RBD, Relex extends the calculation to include the figures and configuration contained in the linked RBD. In this way, during a calculation, Relex analyzes the diagram (including all linked RBDs), as though it were one very large single diagram (even though it has been broken into smaller components for simplicity and convenience).

Creating a Linked RBD

1. In your current RBD, select the figure to which you wish to create the link.

2. To create a link from this figure to another diagram, select Tools>Set Diagram Link from the menu or Set Diagram Link from the right mouse menu.

3. In the next window, either select a diagram from the list or you create a new diagram by pressing <New>.

4. If you select <New>, the New RBD window appears requesting a name for the new diagram. Enter the name and optional description and then press <OK> to continue. You are now returned to the Set Diagram Link window. To select the new diagram that was just created, highlight the diagram name and press <Select>.

5. Upon creating the link, a link icon (a small box enclosing a +) appears just above and to the right of the selected figure. If you place your cursor over the box, a link cursor appears that depicts two interlocking rings. The linked diagram details the configuration of the selected figure. You can then view the linked RBD as described in the following section.

Accessing a Linked RBD

1. To access a linked diagram, place your cursor over the link icon in the upper right hand corner of the figure until your cursor changes to a link cursor (two rings linked together). 

2. Click the left mouse button once to follow the link. You may be asked to save any changes to the current RBD before following the link. You may also select the figure in the diagram by clicking it once with the left mouse button and then selecting Tools>Follow Diagram Link from the menu or Follow Diagram Link from the right mouse menu.

3. Relex then follows the link to the linked diagram and the linked RBD is displayed in the RBD tab on the Parts Table window.

4. To return to the original (parent) diagram, click the left mouse button in any open area in the linked diagram so that no objects are selected. Next, select Tools>Follow Parent Diagram Link from the menu or Follow Parent Diagram Link from the right mouse menu to return to the parent diagram.

Note: At any point, you can select an RBD in the RBD Table to access any diagram in the current Project file. This provides the ability to move freely from one diagram to another without following the specified links.

Moving from a Linked RBD to Another
Once several RBDs have been created and linked together, you can move from one RBD to the other by using any of these techniques:

· Select a linked figure with your cursor and select Tools>Follow Diagram Link from the menu.

· Within a linked RBD (with no figures selected), select Tools>Follow Parent Diagram Link from the menu. 

· Activate the RBD Table and select the RBD you want to display in the RBD tab in the Parts Table window.

Deleting a Link from a Figure to Another RBD

Once a figure in an RBD has been linked to another RBD, the link can later be removed from the figure using one of the following methods:

· Select the linked figure and select Remove Diagram Link from the right mouse menu.

· Select the linked figure and select Tools>Remove Diagram Link from the menu.

xe "RBD Calculations" \r "D2HBRBD_Calculat33"RBD Calculations

Performing a Reliability Block Diagram Calculation

Once all figures have been added and connected from the start node to the end node in an RBD, the process of calculating an RBD is easy to perform. With the RBD selected as the active window, select Diagram>Calculate from the menu or press the <Calculate> button on the Standard toolbar. This displays the Calculate window.

On the Calculation Selection tab of the Calculate window, make sure the Reliability Block Diagram is selected, and then select the RBD tab. The information requested on the RBD is described in the following section.

RBD Calculation Tab
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Figure 8 - 11. RBD Calculations, RBD Tab

	Field
	Description

	From Start Time
	The starting time for the calculation in hours. The start time and end time specify the time range for the calculation.

	Through End Time
	The end time for the calculation in hours. The start time and end time specify the time range for the calculation. This range of time is intended to represent the period of time that the system is operating.

	Number of Data Points
	Specifies the number of calculations to be taken within the specified period of time. For instance, if the range of time is from 0 to 300, and the number of data points is 3, 3 calculations are taken for the period of time of 300 hours. In this example, calculations are output for 0 hours, 150 hours, and 300 hours.

	Number of Simulation Iterations
	Specifies the number of Monte Carlo simulations to be performed on the RBD. A Monte Carlo simulationxe "Monte Carlo Simulation" \r "D2HBMonte_Carlo_34" performs random tests on the specified system in order to provide an analysis of the overall reliability and availability of the system. The result of these simulations determines the reliability and availability of the RBD. The more simulation iterations that are requested, the more random analyses that are performed, and the more accurate the results are.

	Display Results for Figures at Time
	If a value (in hours) is entered into the field, Relex calculates and displays the reliability, availability, unreliability, unavailability, and failure rate for each figure. These values are also displayed on the Calculation Results tab for the entire diagram after the calculation is completed. It is displayed under the heading of “Results at Time <value>”.

	Force Monte Carlo Simulation
	If checked, this option forces Relex to perform a Monte Carlo simulation for the RBD calculation. If this option is not checked, Relex only performs a Monte Carlo simulation if reliability and availability cannot be calculated by standard analytical methods.

	Repeat Last Simulation
	When performing a Monte Carlo simulation, a random series of simulations are performed on the RBD. Because it is a simulation, results between successive runs with the same diagram may be different. If this option is checked (before the first simulation is performed), Relex repeats the last simulation. This option forces Relex to duplicate the seed used in the random number generator of the last Monte Carlo simulation. This duplication repeats the last series of simulations performed to provide an identical result. 

Note: This option only affects results generated when Relex performs a Monte Carlo simulation. Results generated analytically are always identical for each run for identical diagrams.

	Calculations
	Select the types of calculations you wish to be performed on the RBD by marking the desired calculation type. The calculation options are outlined in the following section.


	RBD Calculation Options
	Description

	Reliability
	The probability that an item will perform its desired function without failure under stated conditions for a stated period of time.

	Availability
	The probability that an item is in an operable state at any time.

	MTBF
	The expected time between failures of a repairable item.

	MTTF
	The Mean Time To Failure or the expected time before failure for non-repairable items.

	Failure Rate
	The rate of occurrence of failures, or the numbers of times an item is expected to fail in a given time period.

	Steady-State Availability
	The inherent availability at time infinity. This includes only the corrective repair times and excludes other times involved (like logistic delay time).

	Operational Availability
	Includes logistics time and administrative down time for maintenance.

	Cost
	The cost of an item in the RBD configuration.


Reviewing RBD Calculation Results

In Relex, RBD calculation results can be displayed in several ways:

Calculation Results Tab

Upon calculating an RBD, the results display in the form of a Calculation Results tab. The contents of this tab are selected at the time of the calculation on the RBD tab under the heading of Calculations. The results that to be performed are displayed on the RBD Calculation Results tab.

Calculation results for any individual figure can be reviewed by accessing the Calculation Properties of the figure, by selecting Calculation Properties from the right mouse menu, and selecting the Calculation Results tab. 

Customized RBD Report

A report can be generated to a printer or to a file by selecting File>Print Preview from the menu. Standard reports that are provided with Relex can be used, or custom reports can be created. 

Text Tags on an RBD Figure 

Calculation results can be displayed directly on a figure within the RBD. Select Visual Properties from the right mouse menu and select the Text Display tabxe "Display Tab" to customize the data displayed. 

Monte Carlo Simulation

When Relex performs an RBD calculation, it first analyzes the diagram in order to decide the type of calculation to be performed. If the configuration of the diagram can be calculated using available analytical methods, Relex uses these analytical methods to perform the calculations. 

If after analyzing the diagram, Relex finds that the diagram is too complex to be evaluated using analytical methods, Relex performs a Monte Carlo simulation on the diagram to compute calculation results.

When performing a Monte Carlo simulation, a random series of simulations are performed on the RBD. These simulations are test runs through the system (from the start node through the end node) in order to determine if the system completes its task or fails. During each iteration or test, Relex uses the properties of each figure to decide whether that figure is operating or not, and then determines if the system is operating. For each test run Relex keeps track of the number of successful states. You have the ability to control the number of iterations that are performed (under the Number of Simulation Iterations option available from the RBD Calculation options). The results of the Monte Carlo simulation are the results found from this series of tests. As a general rule, the more simulations performed, the more accurate the results become. 

Coin Toss Analogy

It is common to explain the concept of Monte Carlo Simulation with the use of a coin toss analogy. As an example, you might want to analyze the probability of a coin toss resulting in heads or tails. If you were to perform a Monte Carlo simulation in an effort to gather these results, you would perform a number of tests (or tosses), and record the results of each test. As you can imagine, if you tossed the coin five times, you may find that the results are that 4 of the 5 tosses were heads and 1 of the 5 tosses was tails. Although these results are recorded from actual testing, do they offer accurate values for anticipating the probability of tossing heads? If you extend your testing to include additional iterations (or tosses), you may find that your results change drastically. Perhaps after 100 iterations or tosses, you may find that the probability of tossing heads or tails comes very close to 50%. Therefore, the more tosses (or simulation iterations), the more accurate your probability values become.

How Many Simulation Iterations Should I use?

Based on the coin toss analogy, it is clear that the number of simulation iterations set for a Monte Carlo simulation is very important. A common question is, “How many simulation iterations should I use in my model?” Unfortunately, there is no set answer to this question.

It should be noted that when a Monte Carlo simulation is performed in the Relex RBD, the time required to complete the calculations is significantly higher than the amount of time required to complete an analytical calculation. As the number of simulation iterations increases, the amount of time increases. Therefore, if your system is very large and very complex, you may attempt to calculate with fewer simulation iterations in an effort to save time. (For example, you may choose to start with 10,000 simulation iterations, but if the time required for the calculation is too high, you may choose to decrease the number in order to save time.)

If enabled, the Force Monte Carlo Simulation option forces Relex to perform a Monte Carlo simulation for the RBD Calculation. If this option is disabled, Relex only performs a Monte Carlo simulation if reliability and availability cannot be calculated by standard analytical methods.

Because it is a simulation, results between successive runs with the same diagram may be different. If the Repeat Last Simulation option is enabled (before the first simulation is performed), Relex repeats the last simulation. This option forces Relex to duplicate the seed used in the random number generator of the last Monte Carlo simulation. This duplication repeats the last series of simulations performed to provide an identical result. 

xe "Analytical Calculations"Analytical Calculations versus Monte Carlo Simulation

As described in the section titled “Monte Carlo Simulation”, a Monte Carlo simulation is used to calculate the diagrams for which analytical equationsxe "Equations" are not available. Rather than using a standard equation to calculate reliability, availability, failure rate, and MTBF, a Monte Carlo simulation performs a series of tests on a system in order to gather data regarding the success and failures in the system.

The results of an analytical calculation are generally more accurate and much faster than the results gathered from a Monte Carlo simulation. For this reason, when analyzing a system, Relex chooses to perform an analytical calculation when possible. However, in certain instances you may prefer to perform a Monte Carlo simulation. For these instances, the option to “Force a Monte Carlo Simulation” is available in the Relex RBD Calculation options. It should be noted that this option should not be selected unless you specifically want Monte Carlo simulation results (in lieu of analytical results).

RBD Calculation Equations

Relex RBD calculates the reliability, availability and failure rate of the system as a function of time. It can also calculate the MTTF (Mean Time To Failure), MTBF (Mean Time Between Failuresxe "Mean Time Between Failures") and the Steady State Availability of the system. Relex RBD can handle units with different distributions and different connection types. 

Depending upon the type of interconnection of various blocks of the system, Relex provides the analytical or the simulated results for the system. Though Relex can handle different types of distributions, this document describes the methodologies used in reliability, availability and failure rate calculations for exponential distributions.

RBD Reliability Calculations

The reliability of a single unit, having an exponential failure distribution, with constant hazard rate is calculated at each time point with the equation: 
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Where R(t) is the reliability at time t and  is the constant failure rate. For multiple series units the failure rate is given by:
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Where, i is the failure rate of the ith unit in series and System is the effective failure rate of the n units in series. For Parallel (identical) units with switch probability of success = 1, the failure rate is given by:
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Where,  is the failure rate of a single unit in the parallel configuration, D is the number of units needed for operation in the parallel configuration and n is the total number of units in the parallel configuration. 

In Relex, the flow of the reliability calculation is as follows:

Starting from the input node, the paths (leading from input to the output) are determined. For each of these paths, the reliability of the units between junctions (if there are any junctions) is calculated and stored. For each of the units, the redundancy information is used to evaluate the reliability and availability. If the RBD module does not recognize the block connections as simple series parallel connections, a Monte Carlo simulation is performed to compute the reliability. In simulation mode, the failure time history of each of the components in a path from input to output is stored and the reliability of each path is calculated. For each time interval of the simulation, the reliability of each block (a single unit or units with redundancies) is determined by checking for the operation of the block at each iteration of the simulation. A counter value is updated every time the operation (not the failure) of the unit is encountered. System reliability is determined by determining the operation of units leading to system success, which increments another counter. Unit or system reliabilities are determined by dividing these counter values by the total number of simulation iterations.

xe "RBD availability"RBD Availability Calculations

The calculation of availability is more complex than the reliability calculation. The failure and repair time histories of the components are calculated from the failure and repair information. The time of operation of the unit is estimated from the inverse probability density function of the failure distribution. If the unit is repairable, the repair time is estimated from the inverse probability density function of the repair distribution. The availability values are incremented during the operational time of the unit and not incremented during the repair times. (This procedure is more like simulation, although the stochastic nature of the simulation is missing in this procedure). When the simulation is performed in Relex, the failure of a component is determined by a random number, which is compared with the probability of that unit working at that time. (For example: For a unit without repair, the inverse failure density function at time of interest is compared with a random number. If the random number is greater than the inverse density function evaluated at that time, the unit is assumed to be in the failed state).

It should be noted that in the RBD, there are several different availability results that are calculated. The following list provides a brief description of each value:

	Value
	Description

	Availability
	The availability calculation for each data point over a period of time. This calculation includes corrective repair times.

	Steady-State Availability
	The steady state availability is the inherent availability at time infinity. This includes only the corrective repair times and excludes other times involved (like logistic delay time).

	Operational Availability
	A steady state value that takes into account repair time, and mean logistics down time (or logistics time and administrative down time for maintenance).

	Achieved Availabilityxe "Achieved Availability"
	A calculation based on a stated mission time. This calculation takes into account repair time, mean logistics down time, and spares.


RBD Failure Rate Calculations

Relex calculates and reports the instantaneous failure rate (hazard rate) of the system. The hazard rate can be used to study the behavior of the system’s failure over time. The limiting state probabilities of systems having non-exponential distributions are identical to those evaluated under the assumption that the states are exponentially distributed. If the components are statistically independent and the state values are required, it is not necessary to be overly concerned about the underlying distributions. This means that the failure rate can be approximately evaluated by fitting an exponential distribution to the reliability curve. The hazard rate in Relex is calculated as:
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Where, R(t) is the reliability at time t and (t) is the failure rate at time t. A fourth order forward difference scheme is implemented in Relex to perform this calculation.

Even if a system is composed of units with exponential failure distributions, the overall failure rate of the entire system may not be exponentially distributed. Plotting a curve of the reliability function over time for a simple 2 unit parallel system with exponential failure rates with 1 unit required for operation can prove this. Now take these same 2 units, put them in series and plot the reliability function over time. It is seen that the reliability curve for the parallel system is not a smoothly decaying exponential curve as you get from the series system. Thus, even though a system is comprised of constant failure exponentially distributed units, the failure rate of the system is not necessarily a constant failure rate.

Further Description of the RBD Failure Rate Calculation

The failure rate or the hazard function h(t) is an important representation in the lifetime modeling of the system due to its intuitive interpretation as the amount of risk associated with an item at time t. The hazard rate is calculated as:
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Where R(t) is the reliability at time t. In Relex, the Reliability curve for the system is calculated and then the hazard rate is calculated by dividing the derivative of the Reliability function by the Reliability function itself. A 4th order differentiation scheme is employed and the cutoff limit on Reliability is fixed at 1e-10 to avoid numerical problems in the software due to very small reliability values in the above equation.

Simple Exponential Series System

For the first example, examine a series system consisting of 2 components with exponential hazard rates connected in series.
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The Reliability curve follows the standard exponential decay as shown in the following graph. Then using the above method, Relex calculates the failure rate as shown in the following graph. You can see that the hazard rate is constant over time.
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xe "2 Unit Parallel Exponential System"2 Unit Parallel Exponential System

Take a simple case of these same 2 components in parallel with:
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In this case, the Reliability curve is as shown. Note the different shape of this curve. Because this curve does not have an exponentially decaying shape as the curve in the series system, the hazard rate is expected not to be constant. And, in fact, this is the case as you can see from the hazard rate curve. So just because the items in a system have exponential failure or hazard rates, the system itself is not necessarily exponential. Redundancy in a system causes fewer failures to occur early in the lifetime of a system.
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Failure Rate vs. MTTF

In simple series exponential cases, the failure rate is calculated as the reciprocal of the MTTF. In other cases, this calculation leads to a poor approximation. For these cases, there is not necessarily a correlation between failure rate and MTTF. 
xe "RBD Calculations"RBD Calculations and Redundancies

Relex RBD can handle series, parallel and standby redundancies.xe "Standby Redundancies" The following lists the equations used in Relex RBD in calculating MTTF and the Reliability:

· N = Number of units in series/parallel or standby redundancies

· D = Number of units needed for operation

·  = Failure rate of individual unit

· Block = Effective failure rate of the block (made of redundant units)

· RUnit = Reliability of an individual unit

A. Series Redundancy: 
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B. Parallel Redundancy (with switch probability of success = 1):
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For a 1-out-of-2 system with switch probability of success equal to Ps,
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This formula is extended for D out of N parallel systems. (Note that when the switch probability of success is 0, the reliability of parallel system is the same as that of a series system.)

C. Standby Redundancy (with switch probability of success = 1 and standby failure rate = 0):
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The following example for a 1 out of 2 standby system illustrates the methodology used when taking into account the switching probabilities for standby units. Similar formulae are used for a D out of N standby system: Let A and B be two systems with A operating and B in Standby. Let no be the failure rate of B when it is in standby mode.

The two mutually exclusive events leading to system success are:
1. The main unit does not fail in the interval (0,t).

2. The main unit fails at <t, the standby unit has not failed at , and the standby unit does not fail in the interval (,t).

Accordingly, 
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Adding the reliabilities of events a and b and introducing the switch probability of success Ps, the system reliability is obtained: 
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xe "Spares Optimization Calculations"Spares Optimization Calculations

In Relex RBD, you can supply sparing data for the figures, and Relex uses that information to perform its achieved availabilityxe "Achieved Availability" \r "D2HBAchieved_Ava41" and cost calculations. In addition, Relex RBD also includes a built-in spares optimization algorithm to optimize the costs and number of spares needed to achieve a desired availability.

Calculations Effected by Spares Data

	Calculation
	Effect

	Cost of Configurationxe "Cost of Configuration"
	Calculates the cost of the RBD without considering any spares. Unit costs from the Sparing tabxe "Sparing tab" \r "D2HBSparing_tab44" are used. For linked items, cost values are taken from the linked item’s cost data.

	Cost of Sparesxe "Cost of Spares" \r "D2HBCost_of_Spar43"
	The calculated cost of spares. Unit costs from the Sparing tab are used along with the number of spares. The number of spares is either based on the value defined in the Actual Quantity of Spares field or from the number of spares added during spares optimization.

	Achieved Availability
	Achieved availability with sparing.


xe "Sparing Options"Sparing Options

Assigning a Specific Number of Spares

If the number of spares for figures in the RBD is known, these values can be applied to figures, and Relex can calculate the achieved availability for the system based on the number of spares assigned. To use this technique, follow these steps:

1. Select the figure to which spares are to be assigned.

2. Select Calculation Properties from the right mouse menu.

3. On the Sparing tab, enter the actual quantity of spares. Unit cost of spare can also be entered if you wish to calculate the total Cost of Spares of the system. If the figure is linked to an assembly in the System Tree, and Cost and/or Number of Spares was entered on the Calculation Data tabxe "Calculation Data tab" for the assembly, this information is automatically retrieved for the linked figure.

4. Press <OK> to save the changes to the figure properties.

Performing a Spares Optimization

Spares optimization is calculated during the calculation process of the RBD. The benefit to using the Relex built-in spares optimization is the ability to obtain the most cost-effective use of spares. It is obvious that the use of spares can increase the availability of a model. However, the increase in the number of spares used also increases the overall cost. Relex uses a method of optimization known as the Steepest Descent Method. During this analysis process, Relex determines the increase in availability of each block in the diagram as compared to the cost incurred by adding a spare to the unit. This ratio is stored for all units for which adding a spare is allowed (this is the case if the number of spares has not been specified for a block). A spare unit is then added to the block for which this ratio is the highest. During each iteration of the optimization loop, spares are added to units only if the number of spares has not reached the maximum value for the block.

During this analysis process, if adding a spare to a block does not increase the achieved availability by 1e-6, no spare is added to that block. Also, if the cost of adding the spares exceeds the cost saved by increasing the availability, no spare is added. Overall, the maximum total number of spares added is limited by the maximum number of iterations.

This process attempts to meet a desired availability value, but, in doing so, also takes into account cost limitations. The final goal is the modeling of a system to achieve the highest availability for the least cost.

To assign the sparing data, follow these steps:

1. Select the figure with your cursor in the RBD tab.

2. Select Calculation Properties from the right mouse menu.

3. Select the Sparing tab with your cursor.

4. The following fields of information are available for entry:

	Field
	Description

	Unit Cost per spare
	Enter the Unit Cost per spare in the field. This information is used in calculating the system cost.

	Maximum quantity of spares
	Used in calculating the optimal number of spares needed. The value entered sets an upper limit.

	Actual quantity of spares
	For a spares optimization of the unit, leave this field blank. Otherwise, if there is a definite quantity of spares, enter the value.


To calculate and perform spares optimization, follow these steps:

1. Select the <Calculate> button from the toolbar.

2. On the Calculation Selection tab, select the Reliability Block Diagram option.

3. Complete the options on the RBD tab as described in the section titled “Performing a Reliability Block Diagram Calculation”.

4. Select the RBD-Sparing tab.

5. When performing a spares optimization, the following data may be entered. These fields are to be completed in order to supply sufficient data for the calculation process:


	Field
	Description

	Optimization
	Used to minimize the cost of the system to achieve the desired availability. If enabled, the optimized number of spares for the units for which the number of spares is not specified is calculated. If disabled, the number of spares specified by you is used to calculate the cost of spares and the achieved availability. 

	Calculate Cost of Spares
	If enabled, the cost of spares is calculated based on the number of spares and the cost. Unit costs from the Sparing tab are used. For linked items, cost values are taken from the linked item’s cost data.

	Mission Time
	Used for optimization calculations. Enter the mission time (in hours) at the desired availability. Mission time is automatically retrieved if the RBD and the blocks contain linked items.

	Desired Availability
	Used for the optimization calculations. Enter the desired availability at the mission time. This is the goal used in calculating the number of spares.

	Cost/Hour of Downtime
	Used for the optimization calculations. Enter the cost per hour of downtime for the RBD. 

	Maximum Iterations for Optimization
	Enter the number of iterations desired for the spares optimization algorithm. Note that during each iteration only one spare is assigned for the entire diagram.
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Figure 8 - 12. RBD Calculations,xe "RBD Calculations" RBD – Sparing Tab

Note: If Cost of Spares and Optimization are enabled on the RBD Sparing tab, any block for which the actual number of spares is not specified, the optimal number of spares is calculated subject to the Maximum Quantity of Spares and the Maximum Iterations for Optimization values. This number is then used in calculating the system operational availability and the cost of spares.

1. Press <OK> to perform the calculation.

2. The achieved availability calculation result displays the results of the spares optimization.

3. Additionally, if spares were added to the RBD, you can review each figure by selecting Calculation Properties from the right mouse menu and selecting the Calculation Results tab. If spares were added to a particular block, a number is applied under the heading Optimal Number of Spares.

Generating Reports in Relex RBD

As with other Relex modules, Relex RBD supports the use of customized report designs. A sample RBD report design is supplied with Relex RBD, but others can be created and/or customized to suit your needs.

For more information regarding customizing the Report Design files to suit individual needs, refer to the “Reporting and Graphing” chapter of this manual.

Chapter 9 FMEA

Introduction

The task of performing Failure Mode and Effects Analysesxe "Failure Mode and Effects Analyses" (FMEAs) is invaluable for analyzing and improving product reliability. A FMEA consists of defining what can fail and the ways it can fail, i.e. the failure modes, and determining the effect each failure mode has on the system. An important part of a FMEA also includes analyzing the criticality, or how harmful the effects are on system operation. A FMEA is sometimes referred to as a FMECA, an acronym for Failure Mode, Effects, and Criticality Analysis. In Relex and throughout this documentation, the term FMEA is used, but refers to any type of FMEA or FMECA procedure.

Relex FMEA provides a systematic method that allows you to organize and automate the FMEA process. It allows you to efficiently analyze your design and identify critical failure modes in order to eliminate them or lessen their probability of occurrence.

Getting Started with FMEA

What is a FMEA?

FMEA is an acronym that stands for Failure Mode and Effects Analysis. Sometimes the acronym FMECA is used to refer to Failure Mode, Effects and Criticality Analysis. Relex generally uses the term FMEA to be more inclusive. There are several other variations of this term and several pronunciations, but the methodology is the same.

A FMEA is an inductive bottoms-up method of analyzing a system design or manufacturing process in order to evaluate the potential for failures. It involves identifying all potential failure modes, determining the end effect of each potential failure mode, and determining the criticality of these failure effects. FMEAs can take many forms, but at the core, these analyses are used to study a particular system and determine how that system can be modified to improve overall reliability and avoid failures. 

In a very simple design FMEA example, you may have a computer monitor that has a capacitorxe "Capacitor" as one component. By looking at the design, you determine that if the capacitor was open (one failure mode), the display would appear with wavy lines (the failure effect). If shorted (a second failure mode), the effect would be that the monitor goes blank. Then rank the second failure mode to be more critical than the first since the monitor becomes completely unusable. At this point, you could try to find ways to prevent this failure, or at least to lessen its severity.

You can see from this simple example how a complete analysis could grow and become hard to manage without an organized framework, and also how vital FMEAs are for targeting potential design problems.

What is the Goal of a FMEA?

The goal of performing a FMEA is to review all of the functions or components of your system in order to determine ways in which a failure can occur, and to define the resulting effects of the failures on your system. Once this is completed, a FMEA can be used to determine the most critical failure modes, and then determine how these critical failures can be minimized or eliminated. 

A FMEA can be performed at a number of different levels of detail, but regardless of the level of detail being reviewed, the purpose is the same.

How Do You Begin a FMEA?

To begin a FMEA in Relex, you start by defining your system structure in a Project file.xe "Project file" The Project file contains all elements of a particular system. The System Treexe "System Tree" and Parts Tablexe "Parts Table" are components of the Project file. The System Tree contains the structure of the system in the current project, and the Parts Table is used to enter the individual parts of each assembly.

Once the structure of a Project file has been established, the next step in performing a FMEA depends on the type of FMEA being performed.

Types of FMEAs

There are various types of FMEAs. Each type of FMEA is based on a standard. The most common FMEA types are:

xe "Style"

xe "MIL-STD-1629 Style FMECAs"MIL-STD-1629 Style FMECAs

MIL-STD-1629 is a long-recognized standard that describes a method of performing Failure Mode, Effects, and Criticality Analyses. It is used by government, military, and commercial organizations worldwide. MIL-STD-1629 provides calculations for criticality and allows ranking of failure modes dependent on severity classification. 

MIL-STD-1629 is broken down into various types of analysis. The methods are similar to each other, but generally analyze different data. Using Relex FMEA, all of the following analyses from MIL-STD-1629 can be performed:

	Task Title
	Description

	Task 101: Failure Mode and Effects Analysis
	A Failure Mode and Effects Analysis (FMEA) is used to study the results or effects of item failure on system operation and to classify each potential failure according to its severity.

	Task 102: Criticality Analysis
	A Criticality Analysis (CA) is used to rank each potential failure mode identified in the FMEA according to the combined influence of severity classification and its probability of occurrence.

	Task 103: FMEA–Maintainability Information
	The purpose of the FMEA–Maintainability Information is to supply early criteria for maintenance planning, logistics support analysis, test planning, inspection and checkout requirements, and to identify maintainability design features that require corrective action.

	Task 104: Damage Mode and Effects Analysis
	A Damage Mode and Effects Analysis (DMEA) is used to provide early criteria for survivability and vulnerability assessments.


xe "Automotive Style FMEAs"Automotive Style FMEAs

Many organizations, notably companies in the automotive industry, perform FMEAs according to several very similar standards, i.e., the SAE,xe "SAE" AIAG, and Ford FMEA documents. For the sake of simplicity, these types of FMEAs are referred to as Automotive FMEAs in this documentation.

There are two general categories of Automotive FMEAs: Design and Process FMEAs.

xe "Design FMEAs"Design FMEAs

Design FMEAs are used to analyze a system design and determine how the various failure modes affect the system operation. A system design can be analyzed at any level, from the piece part level up to the system level. At the lowest level, a FMEA can be performed by looking at every component on a board, determining the ways in which the components can fail, and then seeing how these failures affect the system. At higher levels, a FMEA is performed by looking at the functions of an assembly or higher level component, determining ways in which these functions can fail, and then seeing how these failures affect the system. The lowest level FMEA is sometimes termed a piece part FMEA, while the higher level FMEA is generally called a functional FMEA.

Process FMEAs

Process FMEAs are similar to Design FMEAs, except that they are used to analyze how failures in the manufacturing or service process effect the system operation. Using the same computer monitor from the example described in the section titled “What is a FMEA?”, a process FMEA is used to identify what problems in the manufacturing process could potentially effect the operation of the system. For example, one potential problem could be improper soldering of the wires to the CRT. A potential effect of this failure mode would be that the monitor goes completely blank. Identify the probability of this occurrence and its severity, and then try to find ways to prevent or minimize the probability of this failure occurring.

SAE ARP 5580 FMEA Standard

Recently, in an effort to define a broad, widely accepted standard for performing FMEAs, a new FMEA standard was developed by the Society of Automotive Engineers (SAE). A subcommittee was established that included professionals representative of government, industry, and academia. This subcommittee worked to develop a standard that not only reflects current commercial practices, but also meets the strict guidelines of the Department of Defense. This effort produced the SAE ARP5580 FMEA Standard.

This new standard combines the capabilities of both MIL-STD-1629 and the Automotive standards in order to produce a model that would be widely accepted across military and commercial barriers. The most notable difference in this new standard is the support of fault equivalencies. Fault equivalencies allow you to focus on the management of failure consequences rather than managing individual failure modes. This reduces repetition and improves consistency.

xe "FMEA Module"Activating the FMEA Module

In order to use Relex FMEA, you must have first purchased the Relex FMEA option, and you must initialize the FMEA capability in Options. Follow these steps to verify that the Relex FMEA option is available with your Relex installation and make sure Relex FMEA is enabled:

5. If any files or windows in Relex are open, close them.

6. Select Tools>Options from the main menu. 

7. Select the Product Options tab,xe "Product Options tab" and, if not already enabled, select the FMEA checkbox to enable Relex Failure Mode and Effects Analysis (FMEA). Press <OK>.

Other sections of this manual describe the System Tree and Parts Table. If you do not have an understanding of the System Tree or Parts Table, refer to the “File Types” chapter of this manual. The System Tree and Parts Table in a Project file provide access to all data regarding a component or an assembly. To access the FMEA data, select the component or assembly, then select the FMEA Data tabxe "FMEA Data tab" in the Parts Table window.

What Are the Main Steps in Performing a FMEA?

The main steps in entering data to perform a FMEA are detailed below; however, this is just a broad overview. To review any individual step in more detail, refer to section titled “FMEA Reference”.

Step #1 – Create or Edit the FMEA Input Format If Necessary

The FMEA Input Format allows you to customize the information that is included on the FMEA Data tab. When creating a FMEA Input Format, you select the specific data fields that you want Relex to display on the FMEA Data tab and their order. You can create your own FMEA Input Formats, however, a set of FMEA Input Formats is supplied with Relex that you may use or modify. A list of supplied Input Format filesxe "Input Format Files" and a brief description of each is included in the Docs directory on the Relex CD. For more information on creating or editing FMEA Input Formats, refer to the section titled “FMEA Input Format Files
”.

Step #2 – Create or Edit the Modes File If Necessary

The Modes file is useful when performing a piece part FMEA. The Modes file provides the ability to create lists of failure modes associated with the different part types available in the Relex Reliability Predictionxe "Reliability Prediction" module. When parts are entered into the Parts Table, Relex automatically creates the failure modes for each of the parts based on the information in the Modes file. You can create your own Modes files,xe "Modes files" however, a set of Modes files is supplied with Relex that you may use or modify. A list of the supplied Modes files and a brief description of each is included in the Docs directory on the Relex CD. For more information regarding Modes files, refer to the section titled “FMEA Value-Added Files”.

If you are not using a Modes file, then you may enter your failure modes manually. In this case, refer to the section titled “Entering FMEA Data”xe "Entering FMEA data".
xe "Mission Profile"Step #3 – Create or Edit the Mission Profile File If Necessary

The Mission Profile file allows you to define the mission phases of your system. The Mission Profile file contains a Total Mission Time which represents the total operating time of your system, a listing of mission phases, and descriptive information regarding each phase. Information for each phase includes the percentage of operating time that the phase is active,xe "Active" the environment and temperature of the phase, and any descriptive remarks about the phase. Each failure mode may have different effects depending on the mission phase.

xe "FIN Definition"Step #4 – Create a FIN Definition File

FIN (Fault equivalence Identification Number) files are based on the concept of fault equivalence groups. A fault equivalence group contains the failure consequences of the failure mode, i.e. the local effect, next effect, end effect, severity, and other consequences of a failure. Using FIN Definition files allows you to group together failure modes that exhibit identical consequences. If you are planning to use FINs in your FMEA, you can define them at this point, however, FINs may also be added to the active FIN Definition file as you are editing your FMEA.

Step #5 – Create the Project File

Create the Project file by selecting File>New>Project from the main menu, entering a new filename, and pressing <Create> when finished.

Step #6 – Set up the Structure of the System Tree in the Project File

Once the Project file has been created, you may define the hierarchical structure of your system using the System Tree.

Step #7 – If Performing a Piece Part FMEA, Enter the Parts for Each Assembly into the Parts Table

If you are performing a piece part FMEA (sometimes referred to as a Detailed FMEA), the easiest way to begin entering FMEA data is to enter your parts list first. Relex begins adding FMEA data for the components based on the active Modes file. Relex creates failure modes for all parts entered into the Parts Table by referencing the part categories and subcategories to the associated entry in the Modes file. If you have access to the Reliability Prediction module,xe "Reliability Prediction Module" you may want to perform this portion of your analysis first. The reliability prediction portion of the analysis completes the process of entering partsxe "Entering Parts" into the Parts Table, and it also completes the process of calculating failure rates for the list of parts. These failure rates are automatically carried over into FMEA. If a reliability prediction is not being performed and failure rates are required, specified failure rates can be entered into the Failure Rate field in the Parts Table.

Note: Selecting a categoryxe "Category" of FMEA Part and selecting a subcategoryxe "Subcategory" from the supplied list can retrieve the user-defined FMEA Parts from the Modes file. The list of FMEA Part subcategories is based on the data entered in the Modes file. The FMEA Parts capability allows you to add part types to the Parts Table that are not covered by any reliability prediction standard.

Step #8 – Starting at the Lowest Level of the FMEA, Assign or Verify Failure Modes and Causes for All Components and Items

As discussed in Step #7 above, in a piece part FMEA failure modes for each of the parts are automatically assigned from the active Modes file. These failure modes are displayed in the FMEA Treexe "FMEA Tree" window.

If you are performing a functional level FMEA, you need to enter items, modes, and causes manually into the FMEA Tree window. For more information on entering data into the FMEA Tree window refer to the section titled “Entering FMEA Data”.
Step #9 – Starting at the Lowest Level, Assign FMEA Data

Once items, modes, and causes have been added to a Project file, the details for each can be entered. This process is completed by entering data through the FMEA Data tab, which is activated by selecting the FMEA Data tab at the bottom of the Parts Table window. For more information on entering FMEA Data, refer to the section titled “Entering Data on the FMEA Data Tab”.

This process is to be completed systematically throughout the Project file, generally beginning with the lowest levels and progressing through the system hierarchy one level at a time. Once FMEA data is entered at the top level of the system, the entry of FMEA data is complete.

Step #10 – Calculate the Project

Once the data for all assemblies and parts has been entered, you may perform a calculation.

Step #11 – Output the FMEA Data

Once all information in your analysis has been entered, you may want to output the information for review. To output the information in Relex FMEA, follow the steps outlined in the section titled “Generating Reports in Relex FMEA”.

What Decisions Must be Made to Determine How to Structure Your FMEA?

There are a few key decisions that are to be considered regarding the structure and data sources of a FMEA. A few common decisions include:

On What FMEA Model Will the Analysis be Based?

As described in the section titled “Types of FMEAs”, there are several different models on which to base a FMEA. Before you begin to perform the analysis, first determine which basic model you wish to use. This decision determines the types of data fields gathered during the FMEA process and the methods by which the process is performed.

On What Level Will the FMEA be Performed?

Relex supports FMEA analyses performed at the functional level, interface level, or piece part (detail) level. Functional FMEAs are used to analyze a system at a functional block level, interface FMEAs are concerned with the inputs and outputs of the various assemblies, and piece part FMEAs look at the individual components. You may plan to perform your analysis at one of these levels, or you may perform a portion of your analysis at one level and other portions at other levels. In other cases, you may be required to initially perform a functional level analysis, and then later progress to an interface level, and finally progress to a piece part level. Relex supports analyses at all of these levels.

FMEA Reference

xe "Sample FMEA file"Relex Sample FMEA File

Relex provides a sample file named Sample Relex Project that includes sample data for the various Relex modules. This file can be opened by selecting File>Open>Project from the main menu and selecting the file name Sample Relex Project. This sample file provides examples of FMEA data associated with assemblies and components.
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Figure 9 - 1. Sample Relex Project, FMEA Data

Creating/Opening a FMEA File

Data regarding a FMEA is stored in a Project file. Details regarding Project files are provided in the “File Types” chapter of this manual. Creating or opening a Project file is performed by selecting File>New>Project or File>Open>Project from the main menu.

Entering Data on the FMEA Data Tab

The FMEA Data tab provides you with an area to enter FMEA data regarding parts and assemblies. The fields available on the FMEA Data tab are dependent upon the FMEA Input Format that was enabled for use with the Project file. For a complete list of FMEA field descriptions, refer to the Docs directory on your Relex CD.

Levels of Data in Relex FMEA

Relex FMEA allows you to build your analysis from information in a Modes file, or to manually enter your own items along with the associated failure modes and causes. Generally, for a piece part FMEA, you build your failure modes and causes automatically from a Modes file. This process looks at each of the parts in your analysis and assigns failure modes and causes to each part based on part type information provided in the selected Modes file. However, when you are performing a functional level FMEA, it is necessary to enter your own failure modes and causes. Relex provides you with the ability to enter items, failure modes, and causes to your FMEA analysis manually.

Information in a FMEA is organized in various levels. Items, failure modes, and causes each represent a level of information in a FMEA.

An Item is a component, assembly, or functional block that you wish to evaluate. At the component or part level of a FMEA, there is generally only one item. At the assembly or system level, items can be entered through the FMEA Tree window. For more information regarding adding an item to a FMEA, refer to the section titled “Inserting Modes into a Project File”. Each item is then described further by entering data on the FMEA Data tab.

A Mode (or Failure Mode) refers to the individual failure modes within each item or part. In a FMEA, most items have more than one failure mode. Relex allows the definition of failure modes for individual items or components. At the part level, failure modes are automatically defined from the Modes file. Each mode is then described further by entering data on the FMEA Data tab. For more information regarding adding a mode to a FMEA, refer to the section titled “Inserting Modes into a Project File”.

A Cause (or Failure Cause) refers to the individual failure causes within each failure mode. Just as an item can have multiple failure modes, an individual failure mode can have multiple causes. These causes can be used to describe the possible causes of the failure modes. At the part level, failure causes are automatically defined from the Modes file. Each cause is then described further by entering data on the FMEA Data tab. For more information regarding adding a cause to a FMEA, refer to the section titled “Inserting Causes into a Project File”. 

Entering FMEA Data

The entry of FMEA data begins with the addition of items, modes and causes to a Project file. This is accomplished through the FMEA Tree window.

If a piece part FMEA is being performed, and a Modes file is enabled in the Project file, components in a Project file automatically have modes and causes assigned to them. However, as your FMEA progresses to higher levels in the hierarchy, it is necessary to create the items, modes, and causes associated with each level. For instructions regarding inserting items,xe "Inserting Items" \r "D2HBInserting_Mo8" modes, and causes, refer to the following sections.

For each item, mode, and cause, FMEA information can be entered into the FMEA Data window. The fields that are displayed on the FMEA Data tab are based on two factors:

· The FMEA Input Format filexe "Format file" \r "D2HBInserting_Ca8" specifies all of the fields that are available on the FMEA Data tab.

· The level of data selected in the FMEA Tree window determines which of the FMEA data fields from the FMEA Input Format are displayed on the FMEA Data tab. When creating a FMEA Input Format file, you assign a Level to each field. Only the fields marked Item are displayed at the item level, only the fields marked Modes are displayed at the mode level, and only the fields marked Cause are displayed at the cause level.

Inserting Items into a Project File

Inserting Items for Parts

If a Modes file is enabled in the Project file, as new parts are entered, failure modes are automatically added for the parts. To view the item and modes associated with a component, select the component in either the System Tree or Parts Table. The item and failure modes associated with the part are listed in the FMEA Tree window.

Inserting Items for Assemblies

An assembly may have multiple items associated with it, with these items generally describing the functions associated with the assembly. To add an item to an assembly, follow these steps:

1. Select the assembly in the System Tree with your cursor.

2. Place your cursor in the FMEA Tree window.

3. Select Insert>Insert Item from the main menu or select the <Insert Item> button from the FMEA Tree window toolbar.

4. A new item is inserted in the FMEA Tree window. At this point, a description of the item may be entered into the Item/Mode/Cause field in the FMEA Tree window.

Inserting Modes into a Project File

Inserting Modes for Parts

If a Modes file is enabled in the Project file, as new parts are entered failure modes are automatically added for the parts. To view the modes associated with a component, select the component in either the System Tree or Parts Table. The failure modes associated with the part are then listed in the FMEA Tree window.

Failure modes can be added to a component by following these steps:

1. Select the component in the System Tree or Parts Table with your cursor.

2. Place your cursor in the FMEA Tree window.

3. Select Insert>Insert Mode from the main menu or select the <Insert Mode> button from the FMEA Tree window toolbar.

4. A new mode is inserted into the FMEA Tree window. At this point, a description of the mode may be entered into the Item/Mode/Cause field in the FMEA Tree window.

Inserting Modes for Assemblies

Failure modes for assemblies are associated with either the assembly or individual items within the assembly. Items can be created for an assembly to represent the various functions of the assembly. Once the items are created, they may have failure modes associated with them. It is also possible to have modes associated with the assembly only (with no items present). The steps for creating modes with or without items present are identical.

1. Select the assembly in the System Tree window with your cursor.

2. Place your cursor in the FMEA Tree window. To add failure modes to an individual item, select that item with your cursor. 

3. Select Insert>Insert Mode from the main menu or select the <Insert Mode> button on the FMEA Tree window toolbar.

4. A new mode is inserted into the FMEA Tree window. At this point, a description of the mode may be entered into the Item/Mode/Cause field in the FMEA Tree window.

Inserting Causes into a Project File

Inserting Causes for Parts

If a Modes file is enabled in the Project file, as new parts are entered failure modes and failure causes are automatically added for the parts. A part in a Project file can have multiple failure modes associated with it, and each failure mode may have multiple causes. To view the causes associated with a failure mode, select the component in either the System Tree or Parts Table. The failure modes and causes associated with the part are listed in the FMEA Tree window.

Failure causes can be added by following these steps:

1. Select the component in the System Tree or Parts Table with your cursor.

2. Select the failure mode for which you want to enter a cause in the FMEA Tree window.

3. Select Insert>Insert Cause from the main menu or select the <Insert Cause> button on the FMEA Tree window toolbar.

4. A new cause is inserted into the FMEA Tree window. At this point, a description of the cause may be entered into the Item/Mode/Cause field in the FMEA Tree window.

Inserting Causes for Assemblies

Failure modes for assemblies are associated with either the assembly or individual items within the assembly. It is also possible to have modes associated with the assembly only (with no items present). To add causes to the failure modes, follow these steps:

1. Select the assembly in the System Tree window with your cursor.

2. Select the failure mode for which you want to enter a cause in the FMEA Tree window.

3. Select Insert>Insert Cause from the main menu or select the <Insert Cause> button on the FMEA Tree window toolbar.

4. A new cause is inserted into the FMEA Tree window. At this point, a description of the cause may be entered into the Item./Mode/Cause field in the FMEA Tree window.

Entering FMEA Data on the FMEA Data Tab

As items, modes, and causes are added to a Project file, the details for each may be entered. Entering data on the FMEA Data tab in the Parts Table window completes this process.

The fields that display on the FMEA Data tab are controlled by two key factors:

· The FMEA Input Format file specifies all of the fields that are available during FMEA data entry.

· The level of data selected in the FMEA Tree window determines which of the FMEA data fields from the FMEA Input Format are displayed on the FMEA Data tab. When creating a FMEA Input Format file, you assign a Level to each field. Only the fields marked Item are displayed at the item level, only the fields marked Modes are displayed at the modes level, and only the fields marked Cause are displayed at the cause level.

When creating the FMEA Input Format file, all of the fields to be entered during a FMEA are specified. For each field, a level is also specified. Below is a small example of the fields that might be included in a FMEA Input Format:

	Field Name
	Level

	Item/Description
	Item

	Name/Function
	Item

	Failure Mode
	Mode

	Cause of Failure
	Cause

	Local Effect
	Mode

	Failure Rate
	Item

	Failure Mode Ratio
	Mode


For each of the fields above, when a level is assigned on the FMEA Input Format file, that level determines when the field is available data entry on the FMEA Data tab. For instance: 

· When an item is selected from the FMEA Tree window and the FMEA Data tab is selected, only the fields assigned to the Item level appear on the FMEA Data tab. Using the above example, the following fields appear on the FMEA Data tab:


	Field Name
	Level

	Item/Description
	Item

	Name/Function
	Item

	Failure Rate
	Item


· When a mode is selected from the FMEA Tree window and the FMEA Data tab is selected, only the fields assigned to the Mode level appear on the FMEA Data tab. Using the above example, the following fields appear on the FMEA Data tab:


	Field Name
	Level

	Failure Mode
	Mode

	Local Effect
	Mode

	Failure Mode Ratio
	Mode


· When a cause is selected from the FMEA Tree window and the FMEA Data tab is selected, only the fields assigned to the Cause level appear on the FMEA Data tab. Using the above example, the following field appears on the FMEA Data tab:


	Field Name
	Level

	Cause of Failure
	Cause


By using this form of organization, Relex simplifies the process of entering FMEA data. You only need to enter the fields of data displayed on the FMEA Data tab for each item, mode, or cause.

FMEA and Fault Tree

It is quite common to compare fault tree analyses with FMEAs. Because these two analyses collect similar types of data, they are sometimes considered to be quite similar. A fault tree analysis is generally much faster to perform than a FMEA, but it is much more targeted. A fault tree is most effective when an undesired event or top event is what needs to be analyzed, while a FMEA is much broader. FMEA terms such as failure mode and end effect can be equated to fault tree terms such as basic eventxe "Basic Event" and top event. Taking a given FMEA end effect, a fault tree may be created with the top event of the fault tree being the same as the FMEA end effect. Similarly, failure modes from the FMEA become basic events in the fault tree.

Note: One limitation of FMEAs is that all failures are assumed to be mutually exclusive and not dependent on each other. This is in contrast to standard fault trees where certain events may all need to occur to cause the top event to occur, i.e. those that are joined using AND gates. 

Relex provides a function in the FMEA modulexe "FMEA Module" that allows you to automatically create a fault tree from the final results of your FMEA. Select Project>Build Fault Tree from FMEA main menu option to build a fault tree from your FMEA. Select from the list of end effects and mission phases from which to build the fault tree. The selected end effect becomes the top event in the fault tree. If the option “Prune branches with no events” is enabled, Relex does not include fault tree branches that contain no events.

Relex automatically creates a fault tree with a top event, OR gates, and basic events representing the failure modes in the FMEA. Once the fault tree has been created, the link with FMEA is complete. From this point forward, any changes made to the fault tree do not effect the FMEA. Similarly, changes to the FMEA do not effect the fault tree.
FMEA Value-Added Files

Relex FMEA uses several file types that are designed to make the process of performing a FMEA more consistent and less repetitious. These file types are:

	File Type
	Definition

	Modes Files 
	A database which stores lists of failure modes, failure mode ratios, and causes associated with specific part types.

	FIN (Fault Identification Number) Definition Files
	Used to store sets of common failure consequences. This includes local effect, next effect, end effect, compensating provisions, failure detection monitors, failure detection methods, severity, effect probability, and exposure percentage. FIN Definition files are used in a FMEA in order to assign a set of failure modes as equivalent faults. This eliminates repetition and insures consistency.

	Phrases Files
	Special filesxe "Special files" that allow you to save commonly used phrases, for use at a later time. Once a phrase has been added to a Phrases file,xe "Phrases file" it can be retrieved automatically by selecting it from a list of phrases in a Project or FIN Definition file. Also, if you wish to change a phrase globally, you can change it in the Phrases file, and that phrase is automatically changed in all of its locations.

	Mission Profile Files
	Used to store information regarding the various mission phases in which your system operates. The file stores the total mission time and pertinent data regarding each mission phase (phase, environment, temperature, and percentage of mission).

	FMEA Input Format File
	Provides you with the ability to customize the FMEA Data tab in the Parts Table window. You can select the fields to include in your analysis and the order in which they appear.


Modes Files
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Figure 9 - 2. Sample Modes File

Modes files are generally used for piece part FMEAs. Modes files contain, for specified part types, the associated potential modes of failure and the percentage of time that each mode of failure occurs. You do not need a Modes file when defining failure modes in Relex FMEA, but the Modes file provides a centralized storage for all failure modes of all part types.

Any part types and failure modes defined in the Modes file are available to you when editing FMEA data. After entering the part category and subcategory on the Parts Table, Relex FMEA automatically fills in the failure mode, failure mode ratio, and any causes associated with a particular failure mode based on the information in the Modes file.

Several Modes files are provided with Relex FMEA. A list of the supplied Modes files and a brief description of each is included in the Docs directory on the Relex CD. In addition to these, you can create your own Modes file. Once created, you can use them in any Project file.

Creating a Modes File

To create a new Modes file, follow these steps:

1. Select File>New>FMEA>Modes from the main menu.

2. The New File window appears. In the File name field enter the name of the new Modes file and press <Create>.

3. A File Properties window appears with of two tabs. The General tab allows you to specify descriptive information about the Modes file that you are creating, and the Report Format tab allows you to select a default Report Format to be used with the file. Enter the applicable information, and press <OK> when complete.

4. The Modes file window appears. This window is divided into three main sections. These sections are the Part Types window,xe "Part Types Window" \r "D2HBPart_Types_W13" the Failure Modes window,xe "Failure Modes Window" \r "D2HBFailure_Mode13" and the Causes window.xe "Causes Window" \r "D2HBCauses_Windo13"
5. Complete each of the sections of the window as outlined in the following sections.

6. After entering the parameters, close and save the Modes file.

Once a Modes file is created, it can be used in any Project file. To specify that the Modes file is to be used, access the File Properties of the Project file and select the FMEA Files tab.xe "FMEA Files tab" In the field labeled Modes, enter the path and name of the desired Modes file.

Part Types Window

The Part Types window allows you to specify new part types or select existing part types. When a Modes file is created, one part type of Any Type is automatically added to the file. This basic part type is used as the default part type if the part being analyzed in a Project file does not match any of the other part types specified in the Modes file. This part type of Any Type is a required component of a Modes file and cannot be deleted. 

In order to add a part type to the Part Types Window, select Insert>Insert Record from the main menu while the Part Types window is active. This step inserts a new blank part type. Once the record has been created, you may fill in the category, subcategory, and remarks. Select a category and a subcategory from the choice lists.xe "Choice Lists" The list that is available is based on the standard listing that is available for all part types. If a category of FMEA Part is selected, you may define your own subcategory by typing in a new name. These FMEA part types generally represent components that are not covered by any reliability prediction standard, and that do not already exist in the standard list of categories and subcategories. If desired, enter remarks for the new entry.

Once a part type has been created, failure modes associated with that part type can be entered in the Failure Modes window.

Failure Modes Window

The Failure Modes window is used to assign the failure modes to the part type selected in the Part Types window. To insert a new failure mode, select the part type, select the Failure Modes window, and type in the new information. Enter a unique failure mode Code such as Open, the Failure Mode description such as Capacitor Fails Open, and a mode Percentage such as 30.00 for 30%. This percentage is the percentage of time that this particular failure mode occurs, given that the part fails.

Causes Window

Just as any part type can have multiple failure modes, individual failure modes can have multiple causes. These causes are used to describe the possible causes of the component failure modes. To insert a new cause, select the failure mode, select the Causes window, and type in the new information. Enter a unique cause Code and the Cause description.

Fault Equivalence Identification Number (FIN) Files
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Figure 9 - 3. Sample FIN Definition File

Historically, when a FMEA was performed, you were required to analyze individual failure modes. This process is very systematic and complete, but also becomes very tedious, especially when performing a FMEA on a large or complex system. The use of fault equivalence groups was developed in order to allow you to concentrate on the management of failure consequences rather than individual failure modes. It also provides a tool for the assignment of standard wording in order to provide a higher level of consistency and professionalism to the analysis. The concept of fault equivalence groups is described in the SAE ARP5580 FMEA standard, but can be used with any type of FMEA in order to automate and simplify the FMEA process. 

The process of building a FIN (Fault equivalence Identification Number) file is based on the concept of fault equivalence groups. A fault equivalence group contains the failure consequences of the failure mode, i.e. the local effect, next effect, end effect, severity, and other consequences of a failure. Failure modes that exhibit identical consequences should be grouped together. In this case, Relex allows you to assign failure modes a Fault Identification Number (FIN) in order to group the failure modes with common consequences. The FIN file provides an easy way to manage the failure consequences. Any FINs defined in the FIN file are available when editing FMEA data in a Project file. 

Creating a FIN Definition File

To create a FIN Definition file, follow these steps:

1. Select File>New>FMEA>FIN Definition from the main menu.

2. In the File name field enter the name of the new FIN Definition file and press <Create>.

3. Upon creating the new file, a File Properties window appears with two tabs: the General tab which allows you to specify descriptive information about the FIN Definition file you are creating., and the FIN File Data tab which allows you to customize the set up of the FIN Definition file to your needs. The options available in this window are described as follows:


	Option
	Description

	Report Format
	Specifies the default Report Design file to be used with the FIN Definition file.

	Mission Profile
	Specifies the Mission Profile file to be used with the FIN file. A Mission Profile file specifies the mission time and mission phases associated with a mission. If a FIN Definition file is used in a Project file, the Mission Profile file assigned at the Project file level is grayed out and disabled. In this case, Relex automatically uses the Mission Profile file associated with the FIN Definition file.

	Phrases Filexe "Phrases file"
	Specifies the Phrases file to be used with the FIN Definition file. A Phrases file offers you a simple way to store commonly used text phrases. If a FIN Definition file is used in a Project file, the Phrases file assigned at the Project file level is grayed out and disabled. In this case, Relex automatically uses the Phrases file associated with the FIN Definition file.

	Automatically add new phrases to Phrases File
	If enabled, as new phrases are entered into the associated fields in the FIN Definition file, they are automatically added to the Phrases file. If disabled, as new entries are detected, a prompt displays asking if the new phrase is to be added to the Phrases file.

	Severity Level Definition
	Allows you to specify the names and values associated with the severity levels in the FIN Definition file. If a FIN Definition file is used in a Project file, the severity levels fields in the Project file are disabled. In this case, Relex automatically uses the severity levels associated with the FIN Definition file.


4. Enter the applicable information and press <OK> when complete.

5. The FIN Definition file window appears. This window is divided into three main sections. These sections are the FIN Definition window, the FIN Data window, and the FIN Phase/Effect window.xe "FIN Phase/Effect Window" \r "D2HBFIN_Phase_Ef16"
6. Complete each of the sections of the window as outlined in the following sections.

7. After entering the parameters, save and close the FIN Definition file.

Once a FIN Definition file is created, the file can be used in any Project file. To specify that the FIN Definition file is to be used, access the properties of the Project file, and select the FMEA Files tab.xe "FMEA Files tab" In the field labeled FIN Definition, enter the path and name of the desired FIN Definition file. When a FIN Definition file is specified in a Project file, Relex FMEA assumes that FIN codes are being used. In this case, Relex disables any field on the FMEA Data tab that appears in the FIN file. When a FIN code is selected, the corresponding information is filled in. You may use the Override FIN Data field on the FMEA Data tab in order to override the use of FINs for an individual FMEA record.

FIN Definition Window

The FIN Definition window allows you to define the Fault Identification Numbers.

Adding FIN Codes

In order to add a FIN to the FIN Definition window, activate the FIN Definition window, then select Insert>Insert Record from the main menu. Once the record has been created, you may enter a unique alphanumeric FIN Code and a FIN description. Once a FIN has been created in the FIN Definition window, failure consequences associated with that FIN can then be entered in the FIN Data window.

FIN Data Window

The FIN Data window is used to assign the failure consequences associated with the selected FIN in the FIN Definition window. Select the FIN Code from the window by clicking it with your cursor, and then begin adding the data in the FIN Data window.

FIN Phase/Effect Window

Different failure consequences may occur for different phases of a mission. For example, if the system is an airplane, an engine failure has a different set of consequences depending on whether the airplane is on the ground or in the air. And in a given mission phase, there may be multiple effects of a given failure (because of fan-out for example), or a given failure may result in different effects depending on other conditions. Relex provides the flexibility of handling these multiple mission phases and multiple effects using FIN Definition files.

The first step for entering data in the FIN Phase/Effect window is to select the mission phase, which is valid only if a Mission Profile file is defined for the FIN Definition file. As an example, if there are 3 phases of a mission and in the first phase a certain component is not used, the effect of this component failing in Phase #1 is No Effect. However, in the second phase the component is used, and if it fails it causes a fire. This allows you to specify different failure effects for the same failure mode depending on the mission phase. By default, Relex enters a phase of All for each new FIN code entered, which means that if a given phase is not specified in the FIN file, the All phase is used.

For each phase, there can be multiple associated effects. As an example, if a certain component fails, 80% of the time it causes a fire, but 20% of the time it just causes smoke. FIN Definition files allow you to associate more than one failure effect with a given failure mode. You may want to be sure that the failure effect probabilities of all the effects in a given phase add up to 1.0. Relex does not enforce this requirement, but displays the sum as the Total Effect Probability for you to verify.

A Primary checkbox is used to identify the primary failure consequences if there are multiple consequences defined for a given phase.

Adding a FIN to the FIN Definition File through the FMEA Data Tab

Once a FIN Definition file has been activated in a Project file, you select the desired FIN in the FIN Code field from the predefined list. The FIN Definition file that is enabled for the Project file properties controls this list.

To add a new FIN to the FIN Definition file from the FMEA Data tab, enter the new FIN Code into the Code field and press <Tab> to advance to the next field. If the code does not already exist in the FIN file, Relex displays a prompt asking if you wish to add it. If you wish to add the new code, enter all of the FIN data in the fields provided and press the <Yes> button. If you do not wish to add the new FIN Code, press the <No> or <Cancel> button.

If you have not entered a FIN Code for a particular failure mode, or if you wish to override some of the information, you may check the Override FIN Data checkbox on the FMEA Data tab. This field must be defined as part of the FMEA Input Format in order to view and modify it. If you enable the checkbox, you may override some or all of the data normally contained in the FIN Definition file.

xe "Phrases file" \r "D2HBPhrases_file18"Phrases File
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Figure 9 - 4. Sample Phrases File

Phrases files are special filesxe "Special files" that allow you to save commonly used text phrases for use at a later time. Once a phrase has been added to the Phrases file, that same phrase can be retrieved automatically by selecting it from a list of phrases. Also, if you wish to change a phrase globally, you can change it in the Phrases file, and that phrase is changed in all of its locations.

Creating a Phrases File

To create a Phrases file, follow these steps:

1. Select File>New>FMEA>Phrases File from the main menu.

2. In the File name field enter the name of the new Phrases file and press <Create>.

3. Upon creating the new file, a File Properties window appears. This window consists of two tabs. The General tab allows you to specify descriptive information about the Phrases file that you are creating. The Report Format tab allows you to select a default report design to be used with the Phrases file. Enter the applicable information, and press <OK> when complete.

4. The Phrases file window appears. 

5. After entering the parameters as described in the following sections, save and close the Phrases file.

Once a Phrases file is created, it can be used in any Project file. To specify that the Phrases file is to be used, access the properties of the Project file, and select the FMEA Files tab.xe "FMEA Files tab" \r "D2HBFMEA_Files_t18" In the field labeled Phrases File, enter the path and name of the desired Phrases file.

Note: If a FIN Definition file is in use, the Project uses the Phrases file associated with it and the Phrases file field is disabled.

Adding Phrases with the Phrases File Open

When adding a phrase through the Phrases file, it is first necessary to select the FMEA data field to which the phrase is related. Enabling a FMEA field group from the FMEA Field choice list does this. If All is enabled, the phrase is available for all of the fields that support phrases. If All Effects is enabled, the field is available for the Local, Next, and End Effect fields. Enabling any of the other FMEA fields results in that phrase being available for only that field.

Once a FMEA field is enabled, phrase codes and phrases can be entered in the table.

Adding a Phrase to the Phrases File through the FMEA Data Tab

When entering data into the FMEA Data tab for any field that uses the Phrases file, two fields are displayed on the FMEA data tab. The first field is available for the entry or selection of the Phrase Code. The second field is available for the display of the phrase.

To add a new phrase to the Phrases file from the FMEA Data tab, enter the new Phrase Code into the field and press <TAB> to advance to the next field. If the code does not already exist in the Phrases file, Relex displays a prompt asking if you wish to add it. If you wish to add the new code, enter a phrase into the field labeled Phrase and press the <Yes> button. If you do not wish to add the new Phrase Code, and have entered the new Phrase Code in error, press the <No> or <Cancel> button.

New phrases may be added to the Phrases file automatically. Enable this option (Automatically add new phrases to Phrases file) on the FMEA Files tab in the Project file properties (accessed by selecting View>File Properties from the main menu).

Mission Profile Files
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Figure 9 - 5. Sample Mission Profile File

Relex provides you with the ability to create your own mission profile. The mission profile information is applicable for both Relex Reliability Prediction and Relex FMEA. Within Relex FMEA, the information stored in the Mission Profile file is used to identify the mission phase and specify the mission time. The file stores the total mission time of the system, as well as detailed information about each phase in which the system operates. You may enter the following information in a Mission Profile file:

	Field
	Description

	Total Mission Time
	The mission time of the system.

	Total Percentage
	The total of the percent of each mission. The field cannot be edited.

	Phase Code
	A short description of the mission phase.

	Mission Phase
	Descriptive information concerning the mission phase.

	Environment
	The operating environmentxe "Operating Environment" for the given phase.

	Temperature
	The operating temperature for the given phase.

	Percent
	Represents the percentage of the total mission time that the system operates in the given phase.

	Remarks
	General remarks regarding the phase.


xe "Input Format Files"FMEA Input Format Files

Relex provides you with the ability to modify the appearance of the FMEA Data tab through the use of Input Format files. You can define the fields to appear on the form as well as their order. For more information on creating or editing FMEA Input Formats, refer to the “File Types” chapter of this manual.

xe "FMEA Calculations"FMEA Calculations

Performing a FMEA Calculation

Relex FMEA calculates criticality numbers, failure mode probabilities, risk priority numbers, and criticality rank. To perform a calculation, select an existing Project file as the active window and then select Project>Calculate from the main menu. On the Calculation Selection tab of the Calculate window make sure that the FMEA option is selected. 

To the right of the FMEA option, is a field that can be used to select the Phase Code for the FMEA calculations. If a phase is selected, only the failure modes/effects occurring for the selected phase are taken into consideration.

FMEA Calculation Results

To review the actual calculated values, review the associated calculated fields on the FMEA Data tab or report on the FMEA data for a detailed review.

Note: In order to review calculation results through the FMEA Data tab, it is necessary for the associated fields to be included in the FMEA Input Format enabled in the Project file.

xe "Equations"FMEA Calculations and Equations

The calculations Relex FMEA performs include the following:

	Calculation
	Equation Description

	Operating Time
	Mission Time (from the Mission Profile file) * Percent of the particular mission phase * Exposure Percentage

	Mode Failure Rate
	Failure Rate * Failure Mode Ratio

	Mode Criticality
	Failure Effect Probability * Mode Failure Rate * Operating Time

	Item Criticalityxe "Item Criticality" \r "D2HBItem_Critica20"
	The sum of the Mode Criticalities for each severity level

	Risk Priority Number (RPN)
	Severity * Occurrence * Detection

	Risk Priority Number Results (RPN Results)
	Severity Results * Occurrence Results * Detection Results

	Detection Percentxe "Detection Percent"
	The percentage of the assembly detected by testing. It is calculated as a failure rate weighted average of the percent detected assigned to each failure mode. 

	Isolation Percentxe "Isolation Percent"
	The percentage of the assembly isolated by testing. It is calculated as a failure rate weighted average of the percent isolated assigned to each failure mode.

	Criticality Matrixxe "Criticality Matrix" \r "D2HBCriticality_21"
	The Criticality Matrix is a graph or report typically based on severity vs. mode criticality (or probability of occurrence). Note that the parameters considered are user-definable and may include two of the following: Severity, Occurrence, Detection, Severity Results, Occurrence Results, and Detection Results. For more information on the criticality matrix, refer to the section titled “Criticality Matrix”.

	Criticality Rank
	The Criticality Rank is a value based on a multi-criteria, Pareto ranking system. Rank is defined by going through all failure modes, finding non-dominated failure modes, or failure modes which are not out ranked in terms of severity or probability of occurrence. The first set of non-dominated failure modes are assigned a rank of 1, then the next level non-dominated modes are assigned a rank of 2. This procedure continues until all failure modes have been ranked.

	Risk Level
	A value of high, medium, or low based on which area of the criticality matrix a particular failure mode appears. The criticality matrix graph is subdivided into three sections: a high risk area, medium risk area, and low risk area. Failure modes are assigned a risk level based on where they appear on the matrix. In Relex, the risk areas on the graph are user-definable.


xe "Assessing Criticality"Assessing Criticality

One of the most important results from a FMEA is the assessment of failure mode and effect criticality. Criticality analysis is a way of determining the significance of individual failure modes, and prioritizing them for corrective actions. There are several methods used for performing this assessment, all of which Relex FMEA supports. These methods are described as follows.

Mode Criticality

MIL-STD-1629 FMECAs use a defined value, a calculated mode criticality number. The equation for mode criticality is:

Mode Criticality = Failure Effect Probability * Mode Failure Rate * Operating Time

Mode criticalities are summed within a severity level to compute Item Criticality. These two numbers can be used to determine criticality based on their value. Larger values are an indication of more critical items.

RPN Values

Automotive FMEAs often use Risk Priority Number (RPN) values to assess criticality. The equation for RPN is:

RPN = Severity * Detection * Occurrence

In the case of standard automotive FMEAs, severity, detection, and occurrence are values in the range of 1 to 10, with 10 being the most severe, the least detected, or the most frequently occurring. You assign these three values for each failure mode/effect, and Relex then computes the RPN, resulting in a number between 1 and 1000. Higher RPN values are an indication of more critical items.

Note: In Relex, the severity, detection, and occurrence values are user-defined, so the values may not be in the 1 to 10 range, which affects the range of the calculated RPN values.

Criticality Rank

The Criticality Rank is a value based on a multi-criteria, Pareto ranking system. Rank is defined by going through all failure modes, finding non-dominated failure modes, or failure modes which are not out ranked in terms of severity or probability of occurrence. The first set of non-dominated failure modes are assigned a rank of 1, then the next level non-dominated modes are assigned a rank of 2. This procedure continues until all failure modes have been ranked.

The criticality ranking procedure is defined in the SAE ARP5580 FMEA Standard. Refer to this document for more details on criticality ranking.

Note: In Relex, the x and y axes of the criticality matrix are user-definable. The basis for this ranking may not be severity and probability of occurrence, but is based on your selections.

Risk Level

Risk Level is a value of high, medium, or low based on which area of the criticality matrix a particular failure mode appears. The criticality matrix graph is subdivided into three sections: a high risk area, medium risk area, and low risk area. Failure modes are assigned a risk level based on where they appear on the matrix. In Relex, the risk areas on the graph are user-definable.

Risk levels are a concept introduced in “FMEA Failure Modes and Effects Analysis” by Paul Palady. Refer to this text for more details on risk level assessment.

Refer to the section titled “FMEA Risk Levels”xe "FMEA Risk Levels" for more information on generating a risk level graph or report.

Criticality Matrix

A criticality matrix is a graphical representation of the failure mode/effects usually graphed as probability of occurrence vs. severity level. Items with a high probability of occurrence and high severity level are the most critical items, and are detected using this graphical representation. In Relex, the criticality matrix x and y axes are user configurable. You may select from severity, occurrence, detection, severity results, occurrence results, and detection results as a basis for either axis of the criticality matrix. 

Also, Relex allows you to define what is used to determine the probability of occurrence. The probability of occurrence used for the matrix can be based on mode criticality values, occurrence rank values, failure mode probability values, process variation values, or probability of occurrence choice list selection.

Refer to the following section for instructions on generating a criticality matrix graph.

xe "Graphing FMEA Calculation Results"Graphing FMEA Calculation Results

When performing a FMEA, it is often helpful to generate a graph in order to review criticality information. Relex FMEA supports the generation of FMEA Criticality Matrices and FMEA Risk Level Outputs graphs:

FMEA Criticality Matrix

A criticality matrix is a graphical summary of the results of an analysis. A criticality matrix is generally based on probability of occurrence and severity levels, but Relex offers you the freedom to graph on a number of different criteria including severity, occurrence, detection, severity results, occurrence results, and detection results.

Settings for the Criticality Matrix

The criticality matrix is a graph or report that illustrates a comparison of criteria. Many times a criticality matrix is used to compare severity vs. probability of occurrence, but in Relex, you have the ability to customize the graph to contain any of the following options:

	Severity

Occurrence

Detection

Severity Results

Occurrence Results

Detection Results
	VS.
	Severity

Occurrence

Detection

Severity Results

Occurrence Results

Detection Results


In addition, occurrence may be defined to be based on mode criticality, occurrence rank, failure mode probability, process variation, or probability of occurrence. These options are accessed from the FMEA tabxe "FMEA tab" \r "D2HBFMEA_tab23" of the Project file properties by selecting View>File Properties from the main menu from an open Project file.

How to Generate a Criticality Matrix

Before generating a criticality matrix, it is necessary to perform a FMEA calculation. To do this, select Project>Calculate from the main menu. Make sure that the option to perform a FMEA calculation is selected and press <OK> to calculate. After the calculation has been completed, you may generate the criticality matrix.

The criticality matrix can be generated as a report or a graph. The graph version of the criticality matrix displays failure modes in a graphical format so that criticality rank can be interpreted. The report version of the criticality matrix lists the individual items by identifiers that fall under each criticality rank. 

Criticality Matrix Graph

To generate a criticality matrix graph, follow these steps:

1. Select Tools>Graph from the main menu.

2. On the Graph Wizardxe "Graph Wizard" – Select Data window, select the FMEA Criticality Matrix option.

3. Now you may either press <Next> to customize your graph, or press <Finish> to generate a default criticality matrix.

Note: If upon attempting to select FMEA Criticality Matrix in step #2 above, you find that the FMEA Criticality Matrix option is disabled, this is warning sign that the Project file has not yet been calculated. Select <Cancel> and select Project>Calculate from the main menu. Once the FMEA calculation has been successfully completed, the FMEA criticality matrix option is enabled in the Graph Wizard.

Criticality Matrix Report

To generate a criticality matrix report, the report design being used must include the FMEA–Criticality Matrix Ancillary Report. To add the Criticality Report Ancillary Report to the report design, follow these steps:

1. Open the Report Design file by selecting File>Open>Format>Report Design.

2. Select the Report Design file to be edited and press <Open> to open the file.

3. When the report design displays, select View>Properties from the main menu.

4. From the Property tabs, select the Ancillary Reportsxe "Ancillary Reports" tab.

5. On the Ancillary Reports tab, enable the FMEA–Criticality Matrix option.

6. To save the changes to the report design properties, press <OK>.

7. Save and close the Report Design file.

Once the Criticality Matrix Ancillary Report has been added to the report design, it is automatically generated at the end of the report each time the report is printed. 

To print the report, select File>Print or File>Print Preview from the main menu, and select the Report Design file which includes the Criticality Matrix Ancillary Report. The criticality matrix is generated at the end of the report.

FMEA Risk Levels

A FMEA Risk Levels graph is also a visual interpretation of FMEA based on Risk Level ranges. This is based on a concept described in “FMEA Failure Modes and Effects Analysis” by Paul Palady. It allows you to view an area chart that groups the various failure modes into high, medium, and low risk categories.

Settings for the Risk Levels Graph

You can establish the regions of high, medium, and low risk on the criticality matrix by accessing the FMEA tab of the Project file properties by selecting View>File Properties from the main menu from an open Project file. Define the matrix axes using the Criticality Matrix X Axis and Criticality Matrix Y Axis choice list fields. To define the risk regions, set the values for the High Risk X Level, High Risk Y Level, Low Risk X Level, and Low Risk Y Level. These settings correspond to values defined on this tab for severity, occurrence, and detection. 

For example, if you have defined your criticality matrix x axis as severity, and the values you have entered for your severity levels range from 1 to 10, then your x axis settings for risk levels are to be between 1 and 10. For example, maybe your High Risk X Level is 9, and your Low Risk X Level is 4. In this case, anything above severity level 9 is considered a high risk, between severity level 4 and 9 is medium risk, and below 4 is a low risk.

Using these values, two lines are drawn on the risk level chart: one lines starts at the High Risk Y Level and ends at the High Risk X Level, the other starts at the Low Risk Y Level and ends at the Low Risk X Level. These two lines establish the high, medium, and low risk areas. Failure modes plotted above the high risk line are high level risk items, modes between the lines are medium level risk items, modes below the low risk line are low level risk items.

Calculating FMEA Risk Levels Output

Before generating a FMEA Risk Levels output, it is necessary to perform a FMEA calculation. To do this, select Project>Calculate from the main menu. Make sure that the option to perform a FMEA calculation is selected and press <OK> to calculate. After the calculation has been completed, you may generate the FMEA Risk Levels output.

The FMEA Risk Levels output can be generated as a report or a graph. The graph version of the FMEA Risk Levels output displays the modes in a graphical format so that high, medium, and low risk levels can be interpreted. The report version of the FMEA Risk Levels output lists the individual items that fall under each risk level. 

FMEA Risk Levels Graph

To generate a FMEA Risk Levels Graph, follow these steps:

1. Select Tools>Graph from the main menu.

2. On the Graph Wizardxe "Graph Wizard" – Select Data window, enable the FMEA Risk Levels option.

3. Now you may either select <Next> to customize your graph, or <Finish> to generate a default FMEA Risk Levels graph.

Note: If upon attempting to enable FMEA Risk Levels in step #2 above, you find that the FMEA Risk Levels option is disabled, this is warning sign that the Project has not yet been calculated. Select <Cancel> and select Project>Calculate from the main menu. Once the FMEA Calculation has been successfully completed, the FMEA Risk Levels option is enabled in the Graph Wizard.

FMEA Risk Levels Report

A standard FMEA Risk Levels report is provided with Relex. Generate this report using the steps that you would take to generate other Relex reports.

Generating Reports in Relex FMEA

As with other Relex modules, Relex FMEA supports the use of customized report designs. Several FMEA report designs are supplied with Relex FMEA, but others can be created and/or customized to suit your needs. A list of supplied FMEA Report Design files, and a brief description of each, is included in the Docs directory on the Relex CD.

In addition to the supplied FMEA report designs, Relex also includes report designs for the FMEA Value-Added files. These reports can be generated from within the Modes, FIN Definition, Phrases, and Mission Profile files.

For more information regarding customizing the Report Design files to suit individual needs, refer to the “Reporting and Graphing” chapter of this manual.

Chapter 10 Fault Tree

Introduction

Fault Tree Analysis (FTA) is one of the most widely used methods in system reliability analysis. It is a deductive procedure for determining the various combinations of hardware and software failures, and human errors that could result in the occurrence of specified undesired events (referred to as top events) at the system level. A deductive analysis begins with a general conclusion, then attempts to determine the specific causes of this conclusion. This is often described as a top down approach. This is in contrast to a FMEA (Failure Mode and Effects Analysis), which is considered an inductive, or bottoms up, approach.

The main purpose of fault tree analysis is to evaluate the probability of the top event using analytical or statistical methods. Fault tree analysis has the capability of providing useful information concerning the likelihood of a failure and the means by which such a failure could occur. Efforts to improve system safety can be focused and refined using the results of the analysis.

Getting Started with Fault Tree

What Is the Goal of a Fault Tree?

The main purpose of a fault tree analysis is to evaluate the probability of the occurrence of the top event and show the events that cause the top event to occur. In order to determine the probability of occurrence of the top event, system quantitative reliability and maintainability information such as failure probability, failure rate, or repair rate, is used. 

Fault trees provide a convenient symbolic representation of the combination of events resulting in the occurrence of the top event. Events and gates in fault tree analysis are represented by symbols.

As part of the analysis, the minimal cut setsxe "Cut Sets" (MCS) of a fault tree can be determined. A minimal cut set is a smallest group of events that cause the top event to occur when they occur in combination. When doing a qualitative analysis, the minimal cut sets of a given top event may be all of the information that is needed. If detailed numeric information is available for the basic events, a quantitative analysis may be performed to provide the numeric probability of occurrence of the top event.

A fault tree also provides a visual representation of the structure of a system. Visual tools are often helpful when attempting to simplify an explanation, and a fault tree can be used for that purpose.

How Do You Begin a Fault Tree Analysis?

Fault trees may be constructed and modified at any stage of a design. A fault tree analysis may follow a preliminary hazard analysis or a Failure Modes and Effects Analysis (FMEA), although neither a preliminary hazard analysis nor a FMEA is a prerequisite. 

A fault tree in Relex is an integral part of a Project file.xe "Project file" The fault tree is represented in two areas in a Project file. There is a Fault Tree Tablexe "Fault Tree Table" tab in the System Treexe "System Tree" window and a Fault Tree tab (showing a graphical representation) in the Parts Tablexe "Parts Table" window. If these tabs are not available, you need to tell Relex to activate that particular option. To do so, follow these steps:

1. If any files or windows in Relex are open, close them.

2. Select File>Options from the main menu. 

3. Press the Product Options tabxe "Product Options tab" and enable Relex Fault Tree.

4. Press <OK> to activate the Relex Fault Tree module.

5. To view a fault tree, open any Project file. Select the Fault Tree Table tab in the System Tree window or the Fault Tree tab in the Parts Table window. 

Once the Relex Fault Tree module is activated, the steps to creating a fault tree are quite simple. Refer to the following section for information about creating a fault tree.

What Are the Main Steps in Creating a Fault Tree?

This section should be used as your starting point and is designed to get you started creating a fault tree. Additional details regarding various options and features are covered in the remaining sections in this document. The main steps in entering figures and data in order to create a fault tree are as follows:

Step #1 – Create the Fault Tree System Definition

System definition is an essential stage of the fault tree analysis. Usually, a diagram defining all functional interconnections and components of the system is used as the system definition. The system definition must also include the dependencies between the components, their reliability parameters, and conditions when the components are considered to have failed.

It is important that the top event be both clear and concise, as it sets the tone for the series of questionsxe "Questions" that you must consider when constructing the fault tree. For instance, if a top event is too vague, it can make the fault tree far too large and complex, resulting in a very unfocused fault tree. In determining the top event, it is often necessary to define not only the what (meaning what the specific fault is), but also to become more descriptive by including a description of when. The when in a top event may specify a specific mission phase or portion of the mission to which the top event applies. The fault tree results are more concise if the top event is descriptive, rather than vague.

Step #2 – Fault Tree Construction

A fault tree is a diagrammatic representation of the relationship between the lower level events that may represent hardware failures, software failures, human error, etc. and a system level undesirable event. It depicts the propagation of the lower level events that cause a system level undesired event. It is made up of successive levels such that each event is generated from lower levels via various logic operators (gates). The lowermost level events in each branch of the tree are generally referred to as basic events but may also be referred to as terminal events or primary events. The undesirable event at the system level is referred to as the top event.

Step #3 – Qualitative Analysis

Qualitative fault tree analysis is based on determining the minimal cut sets (MCS) for the top event of the fault tree. A minimal cut set is a group of events that cause the top event to occur when they occur in combination. The basic events that belong to the cut sets provide information such as single point failures and the relative contribution of each cut set. Generally, cut sets that have the highest probability of occurrence are the ones that have the least number of basic events.

Step #4 –Quantitative Analysis 

It is often desirable to be able to quantify the probability of occurrence of the top event and each of the minimal cut sets. To perform this task, reliability and maintainability information such as failure probability, failure rate, or repair rate is used. Information about the minimal cut sets obtained in the qualitative stage of the analysis can then be used for computing the unavailability and unreliability of the system. In fault tree analysis, unavailability and unreliability values are used, rather than availabilityxe "Availability" and reliability, because fault trees are organized around failures, unlike reliability block diagrams, which are organized around successes.

Fault Tree Reference

Sample Fault Tree Files

Before you begin to create your own fault tree, it may be helpful to see one that already exists. Relex supplies a Project file named Sample Relex Project that includes Reliability Prediction,xe "Reliability Prediction" FMEA, Maintainability, RBD, and Fault Tree data. This is an integrated file that shares data with the various modules of Relex. 

To review the Sample Relex Project, follow these steps: 

3. Open the Sample Relex Project file by selecting File>Open>Project from the main menu. Select the Sample Relex Project and press <Open>.

4. When the sample projectxe "Sample Project" appears the System Tree and Parts Table windows are shown. To access the fault tree portion of the Project file, select the Fault Tree tab that appears in the Parts Table window.
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Figure 10 - 1. Sample Relex Project File with Fault Tree Analysis

Creating/Opening a Fault Tree

To create/open a Project file containing fault trees, follow these steps:

4. Select File>New>Project or File>Open>Project from the main menu. Enter the new file name or select the file to be opened and press <Create> or <Open> to continue.

5. If creating a new file, the tabs displaying the properties of the Project file are displayed. Edit these properties if necessary and press <OK> when ready.

6. When the Project file appears, select the Fault Tree tab in Parts Table window. This accesses the standard fault tree graphical view window that is referred to as the Fault Tree window in this documentation. In addition to the Fault Tree window, you may also access the Fault Tree Tablexe "Fault Tree Table" window by selecting the Fault Tree Table tab in the System Tree window.

xe "Fault Tree Gates and Events"Fault Tree Gates and Events

Various symbols are used in the construction of the fault tree to represent gates and events. Each of these symbols is described as follows.

xe "AND gate"AND Gate

The AND gate is used to indicate that the output occurs if and only if all the input events occur. All the input events need not occur simultaneously. The output of an AND gate can be the top event or any intermediate event. The input events can be basic events, intermediate events (outputs of other gates), or a combination of both. There should be at least two input events to an AND gate.

Summary of Logic: All events must be TRUE for the output to be TRUE.

Truth Table:

	A
	B
	Output

	T
	T
	T

	T
	F
	F

	F
	T
	F

	F
	F
	F


xe "OR Gate" \r "D2HBOR_Gate5"OR Gate

The OR gate is used to indicate that the output occurs if and only if at least one of the input events occur. The output of an OR gate can be the top event or any intermediate event. The input events can be basic events, intermediate events, or a combination of both. There should be at least two inputs to an OR gate.

Summary of Logic: If at least 1 event is TRUE, the output is TRUE.

Truth Table:

	A
	B
	Output

	T
	T
	T

	T
	F
	T

	F
	T
	T

	F
	F
	F


xe "Voting Gate"Voting Gate (m/n)

The Voting gate is used to indicate that the output occurs if and only if m out of the n input events occurs. The m input events need not occur simultaneously. The output occurs when at least m input events occur. When m = 1, the Voting gate behaves like an OR gate. The output of a Voting gate can be a top event or an intermediate event. The input events can be basic events, intermediate events, or combinations of both.

Summary of Logic: If m = 2 and n = 3, 2 input events must be TRUE for the output to be TRUE.

Truth Table for 2 out of 3:

	A
	B
	C
	Output

	T
	T
	T
	T

	T
	T
	F
	T

	T
	F
	T
	T

	T
	F
	F
	F

	F
	T
	T
	T

	F
	T
	F
	F

	F
	F
	T
	F

	F
	F
	F
	F


xe "Exclusive OR Gate"Exclusive OR Gate (XOR Gate)

The Exclusive OR gate is used to indicate that the output occurs if and only if one of the two input events occurs and the other input event does not occur. The output of an Exclusive OR gate can be the top event or an intermediate event. The input events can be basic events, intermediate events, or combinations of both. An XOR gate can only have two inputs.

Summary of Logic: If 1 and only 1 input event is TRUE, the output is TRUE.

Truth Table:

	A
	B
	Output

	T
	T
	F

	T
	F
	T

	F
	T
	T

	F
	F
	F


xe "Priority AND Gate"

xe "AND gate"Priority AND Gate

The Priority AND gate is used to indicate that the output occurs when both input events are present and one input event precedes the other. The input events are order dependent. The output of a Priority AND gate can be the top event or an intermediate event. The input event can be terminal events, outputs of AND gates, or outputs of OR gates (these gates should have the inputs from basic events or other AND and OR gates). A Priority AND gate can only have two inputs, but they may be cascaded to provide more effective inputs. You may rearrange items entering Priority AND gates by clicking on an item and dragging it to a new location. Items at the left need to fail first in order to trigger the event.

Summary of Logic: Both input events must be TRUE for the output to be TRUE and the first input event must occur prior to the second input event.

Truth Table:

	A
	B
	Output

	T
	T
	T

	T
	F
	F

	F
	T
	F

	F
	F
	F


xe "Inhibit Gate"Inhibit Gate

The Inhibit gate is used to indicate that the output occurs when the input events occur and the input condition is satisfied. The output of an Inhibit gate can be a top event or an intermediate event. The input events can be basic events, intermediate events, or combinations of both.

Summary of Logic: If there is 1 FALSE input event, the output is FALSE.

Truth Table:

	A
	B
	Output

	T
	T
	T

	T
	F
	F

	F
	T
	F

	F
	F
	F


xe "Not Gate"Not Gate

The Not gate is used to indicate that the output occurs when the input event does not occur. The presence of Not gate may give rise to non-coherent trees, where the non-occurrence of an event causes the top event to occur. There is only one input to a Not gate.

Summary of Logic: The output is the opposite of the input gate or event.

Truth Table:

	A
	Output

	T
	F

	F
	T


xe "NOR Gate"NOR Gate

The NOR gate functions like a combination of an OR gate and a Not gate. The NOR gate is used to indicate that the output occurs when all the input events are absent. The output of a NOR gate can be the top event or an intermediate event. The input events can be basic events, intermediate events, or combinations of both. The presence of a NOR gate may give rise to non-coherent trees, where the lack of an event causes the top event to occur.

Summary of Logic: If there is at least 1 TRUE input event, the output is FALSE.

Truth Table:

	A
	B
	Output

	T
	T
	F

	T
	F
	F

	F
	T
	F

	F
	F
	T


xe "NAND Gate"NAND Gate

The NAND gate functions like a combination of an AND gate and a Not gate. The NAND gate is used to indicate that the output occurs when at least one of the input events is absent. The output of a NAND gate can be the top event or an intermediate event. The input events can be basic events, intermediate events, or combinations of both. The presence of a NAND gate may give rise to non-coherent trees, where the non-occurrence of an event causes the top event to occur.

Summary of Logic: If there is at least 1 FALSE event, the output is TRUE.

Truth Table:

	A
	B
	Output

	T
	T
	F

	T
	F
	T

	F
	T
	T

	F
	F
	T


xe "Transfer Gate"Transfer Gate

A Transfer gate is a symbol used to link logic in separate areas of a fault tree. There are two primary uses of Transfer gates. First, an entire fault tree may not fit on a single sheet of paper or you may want to keep the individual trees small in order to view and organize them. Second, the same fault tree logic may be used in different places in a fault tree. Through the use of Transfer gates, you can define this logic once and use it in several places. To use a Transfer gate, you insert a Transfer In gate in a fault tree, which links to a Transfer Out gate, which represents the top gate of another fault tree.

xe "Remarks Gate"Remarks Gate

A Remarks gate is used for the entry of comments. A Remarks gate has no calculation data associated with it, and, therefore, has no effect on calculations. However, the tree branch may continue after a Remarks gate. There can only be one input to a Remarks gate.

xe "Pass-Through Gate"Pass-Through Gate

A Pass-Through gate is used for visually aligning the events and gates in a fault tree. A Pass-Through gate extends a vertical connectorxe "Connector" for visual alignment. A Pass-Through gate has no calculation data associated with it, and, therefore, has no effect on calculations. However, the tree branch may continue after a Pass-Through gate. There can be only one input to a Pass-Through gate.

xe "Basic Event"Basic Event

A Basic event is either a component level event that is not further resolved, or an external event. It is at the lowest level in a tree branch and terminates a fault tree path. Component level events can include hardware or software failures, human errors, and system failures.

xe "House Event"House Event

A House event can be turned on or off. When a House event is turned on (TRUE), that event is presumed to have occurred and the probability of that event is set to 1. When a House event is turned off (FALSE), it is presumed not to have occurred and the probability is set to 0. House events are useful in making parts of a fault tree functional or nonfunctional. When a House event is turned off, the part of the fault tree below that event is inactive. By turning that same House event on, that part of the fault tree is made active.xe "Active" House events are also referred to as trigger events and switching events.

xe "Undeveloped Event"Undeveloped Event

An Undeveloped event is used if further resolution of that event does not improve the understanding of the problem, or if further resolution is not necessary for proper evaluation of the fault tree. It is similar to a Basic event, but is shown as a different symbol to signify that it could be developed further, but you have not done so for the analysis. Undeveloped events may be broken down into associated gates and events.

xe "Inserting Gates and Events"Inserting Gates and Events to a Fault Tree

The graphical user interface of Relex Fault Tree makes it easy to add gates and events. Gates can be added either from the menu or from the toolbar. Events can be created from the menu or from the toolbar, and they can also be added by selecting and dragging items from the System Tree, Parts Table, or FMEA Treexe "FMEA Tree" windows.

Inserting Gates and Events

The structure of a fault tree is a series of gates and events. When a fault tree is initially created, it includes one OR gate.xe "OR Gate" Additional gates and events can be added to this initial OR gate by using any of the following techniques.

Inserting a Gate/Event from the Menu

1. Make sure that the Fault Tree Tablexe "Fault Tree Table" \r "D2HBFault_Tree_T9" tab in the System Tree window or the Fault Tree tab in the Parts Table window is the active window. Select Insert>Gate or Insert>Event from the main menu.

2. When the Insert Gate or Insert Event window appears, select the gate or event type from the choice list and press <OK> to continue.

3. A symbol is attached to your cursor. Hover your cursor over any existing gate until the symbol appears with a zigzag displayed in it. Click the left mouse button to place the gate/event.

4. The ability to add additional gates/events of the same type remains available from your cursor until the right mouse button is clicked to restore the normal cursor.

Inserting a Gate/Event from the Toolbar

1. Make sure that the Fault Tree Table tab in the System Tree window or the Fault Tree tab in the Parts Table window is the active window. Enable the Fault Tree Tools toolbar.

2. Select the toolbar button for the type of gate or event that you wish to insert.

3. A symbol is attached to your cursor. Hover your cursor over any existing gate until the symbol appears with a zigzag displayed in it. Click the left mouse button to place the gate/event.

4. The ability to add additional gates/events of the same type remains available from your cursor until the right mouse button is clicked, restoring the normal cursor.

Inserting a Gate/Event from the Right Mouse Menu

1. Make sure that the Fault Tree Table tab in the System Tree window or the Fault Tree tab in the Parts Table window is the active window. Select the gate to which a gate or event is to be added by clicking on it with your cursor.

2. Select Insert Input from the right mouse menu.

3. When the Insert Input window appears, select the input type from the choice list and select <OK> to place the gate or event.

Note: You may configure Relex to always insert only one symbol at a time by enabling the “Create One Object at a Time” option on the Behavior tab in options accessed by selecting Tools>Options from the main menu.

Inserting Repeated Events

Repeated events are used whenever there is an event that effects multiple portions of a fault tree. If the repeated event occurs, it occurs simultaneously everywhere because it is the same event. You can insert a repeated event by following these steps:

1. Make sure that the Fault Tree Table tab in the System Tree window or the Fault Tree tab in the Parts Table window is the active window. Select Insert>Repeated Event from the main menu. 

2. Upon selecting this option, the Insert Repeated Event window appears listing the events that currently exist in the Project file. Select the event to be repeated and press <OK> to create the event. 

3. An event is attached to your cursor. Hover your cursor over any existing gate until the symbol appears with a zigzag displayed in it. Click the left mouse button to place the event.

Note: In addition to the above steps, manually changing the name of an event to the same name as another existing event creates a repeated event.

Creating Events That Are Linked to Assemblies, Parts, or Failure Modes

In Relex Fault Tree an event can be created that is automatically linked to an assembly, part, or failure mode in the current Project file. When this type of event is created, Relex automatically applies all of the calculation propertiesxe "Calculation Properties" of the associated item to the event. As calculation properties regarding the linked item change, the properties of the figure also change. To create this type of figure, follow these steps:

xe "Basic Event"Creating a New Linked Basic Event

1. Make sure that the Fault Tree Table tab in the System Tree window or the Fault Tree tab in the Parts Table window is the active window. Select an assembly or part from the System Tree window or a failure mode from the FMEA Tree window with your cursor.

2. Click and drag the item into the fault tree window.

3. A symbol is attached to your cursor. Hover your cursor over any existing gate and release the left mouse button to place the event.

Linking Existing Events

Existing events can be linked to items in the System Tree or FMEA Tree windows by following these steps:

1. Select the event with your cursor.

2. From the right mouse menu, select Set Data Link.

3. The Set Data Link window appears. Select the part, assembly, or failure mode that you wish to link to this figure and then press the <Set Data Link> button. The selected event then assumes the characteristics and data associated with the selected item.

You may jump to the item that an event is linked to by selecting Goto Linked Item from the right mouse menu. If you wish to later remove the link, select the event and select Remove Data Link from the right mouse menu.

Gate and Event Types and Styles

When a gate or event is added to a fault tree, the visual propertiesxe "Visual Properties" of that gate or event are automatically established. These visual properties are based on the particular gate and event types. These gate and event types may be customized to suit your individual needs by following these steps:

1. Select Format>Gate/Event Types from the main menu.

2. The Gate/Event Types window appears. This window provides access to all of the Gate and Event Types that are available for use in Relex. 

3. To edit the properties associated with a gate or event type, select that gate or event stylexe "Style" from the list in the upper right hand corner, and make changes to the properties available from the tabs displayed at the bottom of the window.

[image: image115.png]Gate/Event Types

Preview Style:

[House Event
aaexr Inhibit Gate
INAND Gate

INOR Gate b=
NOT Gate

Toxt|coer | RoaitsDeply| Aseraming

Eont;

Size:

[T Abadi MT Condensed

[T brial Black

B arial Narrow 11
T Ban Apetit MT A
™~ Bold

Sarmple: AsBbYyZz
™ fafie T allow to expand for
I~ apply to all styles

Cancel Apply Help





Figure 10 - 2. Gates/Events Types Window

At the top of the window, there is a Preview box and a Style box. The Preview box displays a sample of the selected Gate/Event Type based on the current properties. The Style box allows you to select a different Gate/Event Type to be edited. The lower portion of the window consists of Gate/Event type tabs. These tabs and their descriptions are as follows:

xe "Text tab"Text Tab

The Text tab allows you to specify the text font for the enabled gate or event type. You may change the font, size, justification, and bold and italic settings. If you enable Apply to all styles then any changes you make to the text are applied to all gate and event types. If you enable Allow to expand for text, the size of this type of gate or event is automatically expand horizontally if the text description entered for the enabled gate or event type requires additional space for display.

xe "Color tab"Color Tab

The Color tab allows you to specify the colors of the various components of the selected gate or event types. If you enable Apply to all styles then any changes you make to the colors are applied to all gate and event types.

xe "Results Display tab"

xe "Display Tab"Results Display Tab

The Results Display tab allows you to specify the display of the results for the selected gate or event type.

	Property
	Description

	Unreliability
	If enabled, the calculated unreliability at the primary time point is displayed for the gate or event.

	Unavailability
	If enabled, the calculated unavailability at the primary time point is displayed for the gate or event.

	Significant Digits
	This option sets the number of significant digits displayed in the calculation results.

	Scientific Notation Always
	If enabled, results are always displayed in scientific notation. If disabled, scientific notation is used only when necessary.

	Apply to All Styles
	If enabled, any changes you make to the results display properties are applied to all gate and event types.


xe "Autonaming Tab"Autonaming Tab

When a gate or event is added to the fault tree, it is automatically assigned a name. Each gate or event has its own unique name. There are two types of autonaming schemes available in Relex Fault Tree.

The first scheme uses the function name that may be assigned as a property of each gate or event. For each type of gate or event, Relex creates a new name consisting of the Prefix defined on this tab, followed by the Function name defined on the properties of the actual gate or event, followed by the Suffix defined on this tab. In addition, new gates or events inserted as children of a gate that contain a function name are automatically acquire the function name of the parent gate. Note that changing the naming scheme does not effect any gates or events already inserted into the fault tree. To rename gates and events that exist in the fault tree, select a set of gates and events, choose Tools>Change Function from the main menu, and enter a new function name. Relex renames the selected gates and events using the new function name, prefix, and suffix that are defined.

The second scheme of autonaming is used if a function name is not defined for the various gates and events. In order to configure this method, select Tools>Options from the main menu and select the Fault Tree tab. You may define a Prefix and a Suffix, and a minimum number of digits that Relex uses for autonaming. Relex then creates a unique number for each gate and event using the minimum number of digits specified, and attaches the prefix and suffix to create the name.

Editing the Fault Tree Layout

Once the events and gates have been placed into a fault tree, you can perform simple editing of your fault tree. You may also find it helpful to selectively zoom your diagram to the size that you select from the View menu, right mouse menu, or Diagram Tools toolbar. You can zoom in, zoom out, or zoom to certain sections of your fault tree.

You can perform standard functions such as copying, moving, and deleting on individual or multiple elements. To select multiple items in a fault tree, you may use any of these techniques:

· Hold the <Shift> key while clicking each of the items to be selected.

· Click and drag your mouse to create a box enclosing all of the items to be selected.

· Select Edit>Select All from the main menu.

· Select Edit>Select Branch from the main menu or Select Branch from the right mouse menu to select the current gate and all gates and events below it.

Once you have selected the gates and events, you can delete, copy, or move them. Deleting is accomplished by selecting Delete from the right mouse menu, Edit>Delete from the main menu, or pressing the <Delete> key. To copy an item, select Copy from the right mouse menu or select Edit>Copy from the main menu. To paste the copied item, first select the gate to which the item is to be copied, then select Paste from the right mouse menu or Edit>Paste from the main menu. Moving is described in the following section.

Moving Gates and Events

There are two basic choices for moving a gate or event after selecting the appropriate gates and events.

The Click and Drag technique is useful when you wish to move a gate or event within a single page of a fault tree. Follow these steps:

1. Click and drag the selection to its new location.

2. Hover your cursor over any existing gate until the item appears with a zigzag displayed in the center of the item. Release the left mouse button to place the selection.

Note: You may rearrange the order of items entering gates by clicking on an item and dragging it to a new location.

The Cut and Pastexe "Cut and Paste" technique is useful when you wish to move a gate or event from one page to another. Follow these steps:

1. Select Cut from the right mouse menu or Edit>Cut from the main menu.

2. Select the gate to which the item should be pasted and then select Paste from the right mouse menu or Edit>Paste from the main menu.

Linking a Fault Tree to an RBD

Relex allows you to create a link between a fault tree and a reliability block diagram. The results of your fault tree calculationsxe "Fault Tree Calculations" are then transferred to your RBD. You can link any fault tree gate or event to an RBD figure by following these steps:

1. Select the Fault Tree Tablexe "Fault Tree Table" tab in the System Tree window.

2. Select the RBD tab in the Parts Table window.

3. Click and drag any gate or event onto the RBD tab.

4. A symbol is attached to your cursor. Release the left mouse button to place the new figure. You may connect this figure to other figures in your RBD.

The new symbol is assigned a time independent unreliability equal to the value calculated in the fault tree. If the fault tree is updated, the RBD will also then automatically be updated with the new results.

xe "Event Properties"Gate and Event Properties

xe "Gate Properties" \r "D2HBGate_Propert13"Gate Properties

All gates have properties associated with them that can be accessed by double-clicking your mouse over the gate, selecting Properties from the right mouse menu while the gate is selected, or selecting View>Properties from the main menu while the gate is selected. The property tabs on the Gate Properties window are described in the following sections.
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Figure 10 - 3. Fault Tree Gate Properties Window

General Tab

The General tab includes descriptive information. You may enter a Name or use the Relex default name. Names for gates must be unique. You may also modify the Type of gate from the available choice list. The Function, which can be used for automatically assigning the gate name, may then be entered. The Description is a detailed description of the gate that appears in the fault tree.

xe "Calculation Data tab" \r "D2HBCalculation_14"Calculation Data Tab

The Calculation Data tab allows you to assign calculation data to the gate. You can assign the Logical Condition as Normal, True, or False. Normal signifies that this gate operates normally, while True and False mean that the output of the gate is always set to true or false.

For Voting gates,xe "Voting Gate" the Number of Votes is also available. This is the number of true inputs that are required in order for the output of the Voting gate to be true.

Note: These fields are unavailable for Pass-Through and Remarks gates since these gates have no associated calculation data.

xe "Inputs tab"Inputs Tab

The Inputs tab displays all gates and events that are inputs of the selected gate in a grid format including Name and Type for each input. It also allows for the addition of new inputs. The listing of all inputs is at the top of the window while the bottom allows for additional inputs. To add a new gate or event as input, you may enter a Name or leave it blank for Relex to autoname it. Then enter the Type of gate and press <Add Input>.

Graphic Tab

The Graphic tab allows you to specify the graphic image to be associated with any gate instead of the default Relex image. By using the <Browse> button, you can select any graphic image that is to be used with the selected gate. You can select JPEG, Bitmap,xe "Bitmap" PCX, Targa, and TIFF file formats.

xe "Remarks tab"Remarks Tab

The Remarks tab provides a memo field for the entry of text associated with the selected gate. Up to 32,000 characters may be entered in this field.

xe "Event Properties"Event Properties

All events have properties associated with them that you can access by double-clicking with your mouse over the event, selecting Properties from the right mouse menu while the event is selected, or selecting View>Properties from the main menu while the event is selected. The property tabs on the Event Properties window are described in the following sections.
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Figure 10 - 4. Fault Tree Event Properties Window

General Tab

The General tab includes descriptive information. You may enter a Name or use the Relex default name. Names for events must be unique, unless it is a repeated event. In that case, the names are identical. You also may modify the Type of event from the available list. The Function, which can be used for automatically assigning the event name, may then be entered. The Description is a detailed description of the event that appears in the fault tree.

Calculation Data Tab

The Calculation Data tab allows you to assign various calculation parameters to the event as described as follows:

	Property
	Description

	Logical Condition
	Defines the logical behavior of the event. Select from:

	
	Normal: The event operates normally and is not considered as True or False in calculations.

	
	True: The output for the event is always be True.

	
	False: The output for the event is always be False.

	Parameter Definition
	Sets the source of the calculation data for the selected event. You can enter the following:

User Defined: The specifications under Input Type are used for calculations.

Common Cause Failure Group:xe "Common Cause Failure Group" A Common Cause Failure Group can be enabled from the choice list. This information is obtained from the CCF Groups file.xe "CCF Groups file" For this to be enabled, a CCF Groups file must be enabled in the Project file.

	
	Event Parameter: An Evxe "Event Parameters file"ent Parameter can be enabled from the choice list. This information is obtained from the Event Parameters file.

	
	Linked to Assembly, Part, or FMEA data: If the event is currently linked to an assembly, part, or FMEA data, this checkbox is enabled, and all other options are disabled.

	
	Failure Rate Percentage: You can specify the percentage of the linked item’s failure rate that is used for the event.

	
	Exposure Time Percentage: You can specify the percentage of the overall mission time to use as the exposure time for this event. This percentage is the fraction of the mission time for which the event is valid.

	Input Type
	The basics of each of the input types are described here briefly. For additional information regarding each input type, and how the values effect calculations, refer to the section titled “Fault Tree Input Parameters”.

	
	Constant Probability:xe "Constant Probability" If enabled, the probability of failure is considered to be constant over time. You must enter the Probability as a value from zero to one.

	
	Failure Rate/MTBF:xe "MTBF" If enabled, a specified Failure Rate or MTBF is used. The units of the Failure Rate are defined in the Project file properties. You must enter a specified failure rate or MTBF.

	
	Frequency: The Frequency is defined as the frequency of failures per hour, or the number of failures on average that would occur each hour. You must enter the frequency value.

	
	Failure with Repair:xe "Failure with Repair" If enabled, a specified Failure Rate or MTBF and Mean Corrective Time is used. The units of the Failure Rate are defined in the Project file properties (as Failure Rate Multiplierxe "Failure Rate Multiplier"). You must enter a specified failure rate or MTBF. A Mean Corrective Time in hours or minutes should also be entered.

	
	Failure with Periodic Inspection:xe "Failure with Periodic Inspection" System reliability and availability are improved if the system is maintained periodically (preventive maintenance). If enabled, a specified Failure Rate or MTBF and Inspection Time is used. The units of the Failure Rate are defined in the Project file properties. You must enter a specified failure rate or MTBF. An Inspection Time in hours or minutes should also be entered.


Graphic Tab

The Graphic tab allows you to specify the graphic image to be associated with any event. By using the <Browse> button, you can select any graphic image that is to be used with the selected event instead of the default Relex image. You can select JPEG, Bitmap, PCX, Targa, and TIFF file formats.

xe "Remarks tab"Remarks Tab

The Remarks tab provides a memo field for the entry of text associated with the selected event. Up to 32,000 characters may be entered.

xe "Fault Tree Table"Using the Fault Tree Table

When you are working on a larger project, you may wish to view the information regarding fault tree items in an easy to read, tabular format. By selecting the Fault Tree Table tab in the System Tree window, you can access the fault tree table. This window supplies the properties of the gates and events in one easy to read table. Any changes made to event or gatexe "OR Gate" propertiesxe "Gate Properties" from the fault tree table are automatically applied to the fault tree gates and events.xe "Fault Tree Gates and Events"
xe "Connector Properties"Connector Properties

As events and gates are added to a fault tree, the connectors are drawn automatically. The properties of each individual connector or the default properties used for all connectors may be customized. To assign the properties for an individual connector, follow these steps:

1. Select the connector by clicking it with your cursor. Handles indicate that the connector is selected.

2. From the right mouse menu select Properties or from the main menu select View>Properties to display the Connector Properties window.

You may edit the thickness, style and color of the connector line. By enabling Use these settings when creating connectors, the specified settings become the default connector style when new connectors are created.

By selecting Format>Default Connector Properties from the main menu, you may define the properties for all new connectors that are created. Changes to the default connector properties only effect the connectors created after the change is made.

xe "Inserting Labels"Inserting Labels

Relex allows you to insert text labels onto your fault tree. These labels can be inserted in the following ways:

Insert a Label from the Menu

1. Select Insert>Label from the main menu.

2. When the Insert Label window appears, select a label style from the choice list.

3. A label is attached to your cursor. Click the left mouse button to place the label. Edit the text as needed.

Insert a Label from the Toolbar

1. The Insert Diagram Objects Toolbar must be enabled. 

2. Select from the Label Style choice list or select the <Default Label> button on the toolbar.

3. A label is attached to your cursor. Click the left mouse button to place the label. Edit the text as needed.

The text contained in a label may be edited by selecting the label and then selecting Edit from the right mouse menu. Also, additional label styles may be added by following the instructions outlined in the section titled “Creating/Editing Label Styles”.

xe "Label Properties"Label Properties

Each label in a fault tree has properties associated with it. To access these properties, select the label and then either select Properties from the right mouse menu or select View>Properties from the main menu.

At the top of the Label Properties window, there is a Preview box and a Style box. The Preview box displays a sample of the selected label based on the current properties. The Style box allows you to select a different Label Style to be used with the current label.

The lower portion of the window includes three tabs. The General tab has a Bind to style checkbox. If this is enabled, any changes made to the associated style (by accessing Format>Label Styles from the main menu) are automatically made to the label. If you desire to make changes to an individual label, this checkbox must be disabled. The Text tabxe "Text tab" allows you to specify the font, size, justification, and bold and italic settings for the font. The Color tabxe "Color tab" allows you to specify the text color and the background color. If Transparent Background is enabled, no background is displayed for the label.

Creating/Editing Label Styles

To create or edit a Label Style, follow these steps:

1. Select Format>Label Styles from the main menu to enable the Label Styles window.

2. Select the Style that you wish to change, or on the General tab press <New Style> to create a new style. If you are creating a new label style, enter a name for the new style on the New Label Style window and press <OK>.

3. Customize the style by modifying the data on the tabs.

4. When finished, press <OK> to save the new style or the changes to the existing style.

Fault Tree Appearance

The behavior and appearance of the fault tree is controlled through various settings in options accessed by selecting Tools>Options from the main menu. In addition to these options, you can also control the display of the fault tree through the use of the Fault Tree main menu. These options are described as follows:

Gate and Event Bitmaps

The appearance of the figures displayed in the fault tree can be customized. Each gate or event may be represented by a simple figure, or the fault tree may be enhanced by including a bitmap image for each of the gates and events. Select Fault Tree>Use Bitmaps from the main menu to toggle the bitmap display.

Rulers

The fault tree (on the Fault Tree tab in the Parts Table window) can be shown with or without rulers by selecting Fault Tree>Show Rulers from the main menu to toggle the rulerxe "Ruler" display. The rulers can also be customized to display English or Metric measurements. To toggle this option, select Fault Tree>English Measurements or Fault Tree>Metric Measurements.

Cut Sets

Prior to numeric information being entered into a fault tree, a qualitative analysis may be performed. This analysis determines the minimal cut sets of your fault tree based on the gate logic. A cut set is a set of events that cause the top event to occur. A Minimal Cut Set (MCS) is the smallest set of events, which, if they all occur, cause the top event to occur. In this documentation and in Relex, the term cut set refers to the minimal cut set.

Reviewing Cut Sets

There are various techniques for viewing the cut sets described in the following sections. In addition to the techniques described as follows, a report may be generated listing each of the cut sets.

View Cut Sets

The View Cut Sets option provides the ability to view the cut sets in a tabular format. The View Cut Sets option is activated by following these steps:

1. Perform a qualitative or quantitative fault tree calculation by selecting Project>Calculate. If performing a quantitative analysis, enable the Cut Sets selection for calculations.

2. Select View>Cut Sets from the main menu.

3. In the Cut Sets window, the Gates box lists all of the gates that were calculated in the current fault tree. The Cut Sets area displays the cut sets for the selected gate in a tabular format.

4. The columns in the Cut Sets window display the probability of each cut set and a listing of events in each cut set.

Highlight Cut Sets

The Highlight Cut Sets option provides the ability to visually see the events included in a cut set. The Highlight Cut Sets option is activated by following these steps:

1. Perform a qualitative or quantitative fault tree calculation by selecting Project>Calculate. If performing a quantitative analysis, enable the Cut Sets selection for calculations.

2. Select the gate whose cut sets you wish to view.

3. Select Tools>Highlight Cut Sets from the main menu or Highlight Cut Sets from the right mouse menu.

4. The Cut Set Highlightingxe "Highlighting" window appears. The first choice list field allows you to select the gate of which to view the cut sets. The second choice list field lists all cut sets of the selected gate and allows you to select the cut set to be viewed. There are also previous and next buttons that may be used to sequence through the cut sets. There is also a button to disable cut set highlighting.

5. When a cut set is selected, the gates, events, and connectors associated with that cut set are highlighted for easy viewing. Note that you can change the cut set highlight color by selecting Tools>Options from the main menu and selecting the Fault Tree tab.

xe "Managing Large Fault Trees"Managing Large Fault Trees

Relex provides a work area on the screen to allow you to enter the fault tree logic. For large fault trees, is may be helpful to split the fault tree into smaller trees of more manageable sizes. Relex provides several different techniques that can be used to manage large fault trees.

Transfer Gates

A Transfer gatexe "Transfer Gate" \r "D2HBTransfer_Gat20" is a symbol used to link logic in separate areas of a fault tree. There are two primary uses of Transfer gates. First, an entire fault tree may not fit on a single sheet of paper, or you may want to keep the individual trees small in order to view and organize them. Second, the same fault tree logic may be used in different places in a fault tree, and through the use of Transfer gates you can define this logic once and use it in several places.

The process of inserting a Transfer gate is similar to inserting other gate types as described in the section titled “Inserting Gates and Events”xe "Inserting Gates and Events". However, for a Transfer gate, there are a few extra steps that are required:

1. After selecting to insert a Transfer gate, the Select Transfer from Gate window appears requesting information about where the transfer is from, referred to as the Transfer Out gate. In this window, you may link to a new gate or an existing gate. If New Gate is enabled, you need to specify the Name and Gate Type of the gate to which this Transfer gate is linked. If other Transfer Out gates are available from the current fault tree, these gates are listed in the Existing Gate box. If you wish to link to an existing gate, enable the Existing Gate option and then enable an existing gate from the list.

2. Upon pressing <OK>, if the New Gate option was enabled, the top Transfer Out Gate is displayed in the new fault tree window. If the Existing Gate option was enabled, the current fault tree window remains active.

Following a Transfer In Gate

Once a Transfer In gate is created in a fault tree, the Transfer In gate can be followed to the corresponding Transfer Out gate by selecting the Transfer In gate and using one of the following methods:

· Select Transfer to <gate name> from the right mouse menu

· Select Tools>Transfer <gate name> from the main menu

· Select Tools>Transfer to <gate name> from the main menu

Following a Transfer Out Gate

To follow a Transfer Out gate back to its origin, select Transfer from the right mouse menu or Tools>Transfer from the main menu. A list of the destinations of all associated Transfer In gates is shown. Select the desired destination from the list.

Breaking an Existing Gate into a Transfer Gate 

Relex provides a fast and easy way to create a Transfer gate from an existing gate. Select an existing gate, and select Break into Transfer from the right mouse menu or Tools>Break into Transfer from the main menu. Relex automatically creates both a Transfer In and a Transfer Out gate. All of the fault tree logic that was originally below the selected gate appears below the new Transfer Out gate.

You may also collapse a Transfer Out gate and move the logic connected to it to the location of the Transfer In gate. To do this, select the Transfer Out gate, and select Collapse Transfer from the right mouse menu or Tools>Collapse Transfer from the main menu.

Expand All Transfer Gates for Complete Viewing of the Fault Tree

The use of Transfer gates makes it easy to reduce a large fault tree into more manageable levels. However, Relex also provides the capability to temporarily collapse the Transfer gates to allow viewing of the entire fault tree. This can be accomplished by following these steps:

1. Select Fault Tree>Disable Paging from the main menu.

2. All Transfer gates are expanded to include lower level gates and events, and the entire fault tree can be viewed on one page. If various Transfer In gates refer to the same Transfer Out gate, paging cannot be disabled.

Note: When the Disable Paging option is enabled, the ability to insert Transfer gates is disabled. Transfer gates are not valid gate types when paging is disabled. If you wish to insert a Transfer gate, it is first necessary to deactivate the Disable Paging option.

To revert back to viewing the fault tree with Transfer gates, follow these steps:

1. Select Fault Tree>Disable Paging from the main menu.

2. The fault tree returns to its original configuration with all Transfer gates expanded.

Display an Existing Gate as a Top Gate

If you wish to temporarily simplify your fault tree and focus on a particular area, you can select an existing gate and choose Display as Top Gate from the right mouse menu or select Tools>Display as Top Gate from the main menu. This technique creates a new temporary view of the fault tree and places the selected gate as the top gate. You may remove this temporary view by disabling the Display as Top Gate selection or by selecting another fault tree page.

Creating Multiple Fault Trees in a Project

A Relex Project file may include many fault trees, each with a separate top event. To create a new fault tree with a new top event, select Insert>New Top Gate from the main menu. This creates and displays a new fault tree in the fault tree window, and the top OR gatexe "OR Gate" is automatically inserted.

xe "Fault Tree Table"Fault Tree Table Views

As fault trees become more complex, and multiple fault trees are created in a given Project, it can become more difficult to manage all of the different gates and events. The two fault tree tables that make these larger projects more manageable are described in the following sections.

Fault Tree Table

The Fault Tree Table tab is located in the System Tree window. This technique of viewing the fault tree in a tabular view is especially convenient for viewing the properties and relationships of the fault tree elements.

The Fault Tree Table tab includes a listing of all gates and events currently associated with the Project file. The hierarchical structure of the gates and events are displayed in a different format than the standard graphical fault tree view (on the Fault Tree tab in the Parts Table window), but the information contained is identical. This table is another view of the same information. By selecting a gate or event from the table, Relex automatically displays the associated fault tree on the Fault Tree tab in the Parts Table window. Because of the expandable/collapsible nature of the Fault Tree Table, you can move from one area of the fault tree to another.

Gate/Event Table

The Gate/Event table is a listing of all gates and events contained within the Project file. It allows you to view, edit, filter, and sort the elements of a fault tree. To access this table, select View>Gate/Event Table from the main menu. When the table appears, it is divided into two primary sections as described as follows:

xe "Filter Definition"Filter Definition

The filter definition portion of the window provides various fields for sorting and filtering of the fault tree gates and events.xe "Fault Tree Gates and Events" You can use any combination of these fields to filter the data. When filtering, Relex displays only the gates or events that meet the filter criteria. The fields available from the Filter Definition portion of the window include the Name, Gate/Event Type, Description, Logical Condition, and Sort Field. Relex accepts wildcard character (*) in the Name and Description fields. When the <Filter> button is pressed, Relex displays only the elements that match the filter criteria in the sort order specified.

Table

The table portion of the window lists all gates and events that meet the Filter Definition criteria. If no criteria are enabled, all gates and events are displayed. You have the ability to edit any of the displayed data associated with the gates and events by selecting the field to be changed and editing the data through the cells in the table.

The <GoTo> button located below the table is useful for finding a particular gate or event in the fault tree. Select the gate or event that you wish to find and press the button to automatically bring that gate or event into view.

xe "Toolbar Paging Buttons"

xe "Paging Buttons"Toolbar Paging Buttons

On the Fault Tree Tools toolbar are several buttons that are helpful for moving back and forth through the various fault tree pages. The <Forward> and <Back> buttons are used to move through the fault tree pages in the order in which you have recently viewed them. They work similarly to the buttons of the same name used on Web browsers. Additionally, the first, previous, next, and last buttons are used to move through all of the fault tree pages contained within your Project file.

xe "Value-Added files"Relex Fault Tree Value-Added Files

Relex Fault Tree provides Value-Added files for enhanced functionality. CCF Groups files and Event Parameters files are two types of Value-Added files used in Relex Fault Tree.

CCF Groups Files
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Figure 10 - 5. Sample CCF Groups Filexe "CCF Groups file"
The CCF Groups file in Relex Fault Tree is used to store Common Cause Failure Groups in order to perform a Common Cause Analysis. 

Common Cause Analysis

An event or mechanism that can cause two or more failures (basic events) simultaneously is called a common cause and these failures are called common cause failures. Because common causes can induce the failure of multiple components, they have the potential to increase system failure probabilities. The elimination of these common causes can appreciably improve system reliability. Designers must recognize the failure sources that are responsible for common cause failures and implement specific solutions to deal with them.

Some of the common causes that are frequently encountered include:

Mechanical Common Causesxe "Mechanical Common Causes"
1. Abnormally high or low temperature

2. Abnormally high or low pressure

3. Stress above design limits

4. Impact

5. Vibration

Electrical Common Causes

1. Abnormally high voltage

2. Abnormally high current

3. Electromagnetic Interference

Chemical Common Causes

1. Corrosion

2. Chemical reaction

Other Common Causes

1. Earthquake

2. Tornado

3. Flood

4. Lightning

5. Fire

6. Radiation

7. Moisture

8. Dust

9. Design or production defect

10. Test/maintenance/operation error

xe "Common Cause Models"Common Cause Models

There are several models for quantifying systems subject to common cause failures. Relex supports the Beta Factor model,xe "Beta Factor model" \r "D2HBBeta_Factor_24" Multiple Greek Letter (MGL) model,xe "Multiple Greek Letter (MGL) model" Alpha modelxe "Alpha model" and the Beta Binomial Failure Rate (BFR) model.xe "Beta Binomial Failure Rate (BFR) model" The Beta Factor model is the most basic. A generalization of the Beta Factor model is the Multiple Greek Letter (MGL) model. The Binomial Failure Rate model is also known as a shock model.

The common cause failure groups in Relex Fault Tree consider the combinations of up to four events. This means that the CCF event combinations can be of the order 2, 3 and 4. The models used in Relex Fault Tree do not distinguish CCFs of order 4 or higher. The following illustration is provided as an aid in understanding the mechanism of handling of CCF events in a fault tree.

Illustration

Assume that there are four basic events A, B, C, D belonging to a common cause failure group.xe "Common Cause Failure Group" When Relex does the MCS (minimal cut set) analysis of the fault tree, the following CCF events are automatically created:

AB, AC, AD, BC, BD, CD, ABC, ABD, ACD, BCD, ABCD

For calculation purposes, each of the four original basic events (A, B, C, D) is replaced with an OR gate.xe "OR Gate" The inputs to the OR gate include the individual basic eventxe "Basic Event" and CCF events that contain that basic event. For example, Event A is replaced by an OR gate with A (individual failure), AB, AC, AD, ABC, ABD, ACD and ABCD as its inputs.

The following parameters are used in calculating CCF events:

· Qt = Total unavailability of each basic event in CCF Group

· Qk = unavailability of the CCF event of order k, that is a CCF involving k components

· N = Number of basic events in the CCF group

xe "CCF Groups file"Creating/Opening a CCF Groups File

To create or open a CCF Groups file, follow these steps:

1. Select File>New>Fault Tree>CCF Groups or File>Open>Fault Tree>CCF Groups from the main menu.

2. In the File name field enter the name of the CCF Groups file and press <Create> or <Open>.

3. Upon creating a new file, a File Properties window appears. This window allows you to specify descriptive information about the CCF Groups file that you are creating. This information includes basic descriptive information about the CCF Groups file like Part Number,xe "Part Number" Reference Designator,xe "Reference Designator" and Description, entered on the General tab. The CCF Groups File Information tab allows for the selection of a Report Format and Event Parameters filexe "Event Parameters file" to be used with the CCF Groups file. Press <OK> to accept the CCF Groups file properties.

4. The CCF Groups file window appears. This window is divided into the CCF Groups window and the CCF Group Parameters window.

5. Complete information about your CCF groups as described in the following sections.

6. After entering the parameters, save and close the CCF Groups file.

7. Once a CCF Groups file is created, the file can be used in any Project file. To specify that the CCF Groups file is to be used, access the properties (select View>File Properties from the main menu) of the Project file, and select the Fault Tree Files tab.xe "Fault Tree Files tab" In the field labeled CCF Groups file, enter the CCF Groups file name.

CCF Groups Window

The CCF Groups window allows you to create all of the CCF Groups for a particular CCF Groups file. In order to add a CCF Group to the CCF Groups window, you must select Insert>Insert Record from the main menu. This step inserts a new CCF Group into the CCF Groups window. Once the record has been created, you may enter in a unique name of the CCF group. You must also enable a Model Type from the choice list of Beta, MGL (Multiple Greek Letter), Alpha, and Beta BFR (Binomial Failure Rate).

CCF Group Parameters Window

The CCF Group Parameters window is used to assign detailed information to the CCF Group selected in the CCF Groups window. Select the CCF Group in the CCF Groups window to edit the information in the CCF Group Parameters window. The information entered in the CCF Group Parameters window is described in the following table. 

CCF Group Definition

	Field
	Description

	Model Parameters
	Depending on the Model Type selected in the CCF Groups window, different Model Parameters are displayed.

	
	Beta Factor Model. The Beta Factor Model assumes that all components belonging to a CCF group fail when that common cause occurs. By definition, this model distinguishes between individual failures and CCFs, with the assumption that if the CCF occurs, all components fail simultaneously by a common cause. Multiple independent failures are neglected. 

Input Parameter:
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Qt is the total unavailability of each basic eventxe "Basic Event" in the group and Qk is the unavailability of CCF event of order k.

	
	Multiple Greek Letter Model.
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	Alpha Factor Model.
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	Binomial Failure Rate Model.
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	Calculation Data
	The basics of each of the input types are described here briefly. For additional information regarding each input type, and how the values effect calculations, refer to the section titled “Fault Tree Input Parameters”.

	
	Constant Probability:xe "Constant Probability" The Probability of failure is considered to be constant over time. You must enter the Probability as a value from zero to one.

	
	Failure Rate/MTBF: A specified Failure Rate or MTBF is used. The units of the Failure Rate are defined in the Project file properties. You must enter a specified failure rate or MTBF.

	
	Frequency: The Frequency is defined as the frequency of failures per hour, or the number of failures on average that would occur each hour. You must enter the frequency value.

	
	Failure with Repair:xe "Failure with Repair" A specified Failure Rate or MTBF and Mean Corrective Time are used. The units of the Failure Rate are defined in the Project file properties. You must enter a specified failure rate or MTBF. A Mean Corrective Time in hours or minutes should also be entered.

	
	Failure with Periodic Inspection:xe "Failure with Periodic Inspection" System reliability and availability are improved if the system is maintained periodically (preventive maintenance). If enabled, a specified Failure Rate or MTBF and Inspection Time is used. The units of the Failure Rate are defined in the Project file properties. You must enter a specified failure rate or MTBF. An Inspection Time in hours or minutes should also be entered.


xe "Event Parameters file" \r "D2HBEvent_Parame27"Event Parameters File

The Event Parameters file in Relex Fault Tree is used to store commonly used event parameters. The parameters that are defined in this file are available to you when editing a Project file or a CCF Groups file.xe "CCF Groups file" \r "D2HBCCF_Groups_f27"
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Figure 10 - 6. Sample Event Parameters File

Creating/Opening an Event Parameters File

Follow these steps to create or open an Event Parameters file:

1. Select File>New>Fault Tree>Event Parameters or File>Open>Fault Tree>Event Parameters from the main menu.

2. In the File name field enter the name of the Event Parameters file and press <Create> or <Open>.

3. If creating a new file, a File Properties window appears. This window allows you to specify descriptive information about the Event Parameters file that you are creating. Enter basic descriptive information like Part Number, Reference Designator and Description on the General tab. The Report Format tab allows for the selection of a default Report Format file.xe "Format file"
4. The Event Parameters file window is divided into the Events window and the Event Parameters window.xe "Event Parameters Window" \r "D2HBEvent_Parame28" Enter the information as described in the following sections.

5. Save and close the Event Parameters file.

6. Once an Event Parameters file is created, it can be used in any Project file or CCF Groups file. To specify that the Event Parameters file is to be used in a Project file, access the properties of the Project file (by selecting View>File Properties from the main menu) and select the Fault Tree Files tab.xe "Fault Tree Files tab" In the field labeled Event Parameters, enter the filename. To specify that the Event Parameters file is to be used in a CCF Groups file, access the properties of the CCF Groups file and select the CCF Groups File Information tab. In the field labeled Event Parameters, enter the filename. 

Events Window

The Events window allows you to create the parameters for a particular Events Parameters file. In order to add an event to the Events window, select Insert>Insert Record from the main menu. This step inserts a new event into the Events window. Once the record has been created, type in a descriptive Name for the parameter. You may also enter descriptive Remarks about the event. Details regarding the parameter can be entered in the Event Parameters window.

Event Parameters Window

The Event Parameters window is used to assign detailed information to the event selected in the Events window. Select the event parameter in the Events window and enter the appropriate information as described as follows.

	Option
	Description

	Constant Probabilityxe "Constant Probability"
	The Probability of failure is considered to be constant over time. You must enter the Probability as a value from zero to one.

	Failure Rate/MTBF
	A specified Failure Rate or MTBF is used. The units of the Failure Rate are defined in the Project file properties. You must enter a specified failure rate or MTBF.

	Frequency
	The Frequency is defined as the frequency of failures per hour, or the number of failures on average that would occur each hour. You must enter the frequency value.

	Failure with Repairxe "Failure with Repair" 
	A specified Failure Rate or MTBF and Mean Corrective Time is used. The units of the Failure Rate are defined in the Project file properties. You must enter a specified failure rate or MTBF. A Mean Corrective Time in hours or minutes should also be entered.

	Failure with Periodic Inspectionxe "Failure with Periodic Inspection"
	System reliability and availability are improved if the system is maintained periodically (preventive maintenance). If enabled, a specified Failure Rate or MTBF and Inspection Time are used. The units of the Failure Rate are defined in the Project file properties. You must enter a specified failure rate or MTBF. An Inspection Time in hours or minutes should also be entered.


xe "Fault Tree Calculations"Fault Tree Calculations

Performing a Calculation

Once all gates and events have been added in a fault tree, the process of calculating is initiated by selecting Project>Calculate from the main menu. When selected, the Calculate window appears.

On the Calculation Selection tab of the Calculate window, enable the Fault Tree option, and then select the Fault Tree tab. The information requested on this tab and the Fault Tree – Advanced tab is described in the next section.

Fault Tree Calculation Tab
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Figure 10 - 7. Calculations, Fault Tree Tab

	Field
	Description

	Qualitative Analysis Only
	If enabled, a Qualitative Analysis only is performed and Relex ignores any numeric information. A qualitative analysis results in the listing of minimal cut sets (MCS) and propagation of TRUE/FALSE conditions.

	From Start Time
	Specify the starting time point for the calculation in hours. This is used to perform a time dependent analysis.

	Through End Time
	Specify the ending time point for the calculation in hours.

	Number of Data Points
	Specify the number of time points at which the results are displayed between the start and end times. For instance, if the range of time is from 0 to 300 and the number of data points is 3, 3 calculations at 0, 150, and 300 hours are performed.

	Primary Time Point
	Specify the selected time point for which calculated results are displayed on gates and events in the fault tree graphical view (Fault Tree tab in Parts Table window).

	Perform Exact Calculation
	If enabled, rather than performing an approximation (using cut sets), Relex calculates an exact solution to the fault tree. The exact solution evaluates the probabilities according to gate logic and does not use the cut set information. Approximation options are available on the Fault Tree – Advanced tab.

	Start Calculating At
	Select from:

Topmost Gate: The calculation is performed for the tree originating at the top most gate of the current fault tree.

Current Gate (Top of current page): The calculation is performed for the tree originating at the top gate of the current fault tree viewing page.

	Calculations
	Enable the types of calculations you wish to be performed on the fault tree.

Cut Sets: If enabled, the minimal cut sets (MCS) is generated.

Reliability Importance Measures: If enabled, the relative importance of the various gates is calculated. Importance analysis of components is useful for identifying the design weaknesses and component failures that are crucial to the proper functioning of the system. For more information about Reliability Importance Measures, refer to the section titled “Reliability Importance Measures”.

Unavailability: If enabled, calculation results for unavailability are generated.

Unreliability: If enabled, calculation results for unreliability are generated.

Frequency: If enabled, calculation results for failure frequency are generated.

Number of Failures: If enabled, Relex calculates the number of failures expected in the time period between the start time and the end time. Numerical integration of the failure frequency gives the number of failures. If enabled, Integration Options on the Advanced tab are also enabled.

	Calculate Top Gate Only
	If enabled, calculation results are only generated for the top gate.

	Calculate All Gates
	If enabled, calculation results are generated for all gates in the fault tree.

	Ignore Cut Sets with Probabilities less than
	Specify the cutoff range for cut set calculations. You have the ability to reduce the number of minimal cut sets (MCS) used in generating the results. Ignoring minimal cut sets of low probability generally has a minimal impact on the results and can greatly speed calculations. Enter a value or select one from the available choice list.


xe "Advanced Calculation Tab"Fault Tree - Advanced Calculation Tab
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Figure 10 - 8. Calculations, Fault Tree – Advanced Tab

Calculation Method

	Field
	Description

	Cut Set Summation (equivalent to Cross Product with Order of product terms = 1)
	If enabled, the cut set summation calculation method is used. This method is equivalent to enabling Cross Product with an Order of product terms equal to 1. It takes into account the first order terms only.

	Cross Product
	If enabled, the cross product calculation method is used. Enter the Order of product terms. Higher orders, up to the limit of the number of cut sets, provides more accurate results. This calculation method is described in more detail in the section titled “Probability Evaluation of Fault Trees”.

	Esary Proschan
	If enabled, the Esary Proschan calculation method is used. This calculation method is described in more detail in the section titled “Probability Evaluation of Fault Trees”.

	Exact
	If enabled, the Exact calculation method is used. This method uses the gate logic and does not use the cut set information. This calculation method is described in more detail in the section titled “Probability Evaluation of Fault Trees”.

	Order of product terms
	For cross product calculations, the order of product terms is taken into account in the calculation.


Integration Options (Number of Failures Calculation)

These integration options are only applicable when doing the number of failures calculation. There are four types of numerical integration schemes implemented in Relex Fault Tree, using both the table and explicit integration methods. The Trapezoidalxe "Trapezoidal" method is a table integration (where no time points other than the ones for which the results are displayed are used), while the other three methods are explicit integration methods (where times points other than the ones specified for results are used). Explicit integration schemes are more accurate but they are generally numerically more expensive compared to the table integration scheme.

The Trapezoidal integration scheme approximates the integral region in the time intervals you specify in terms of rectangular areas and triangle end segments. This method may be gross, with the accuracy depending on the time step. This method uses the table integration method. The Trapezoidal method uses the time step specified on the Fault Tree tab.

The Trapezoidal Quadraturexe "Trapezoidal quadreature" scheme uses repeated evaluation of trapezoidal integration with decreasing time steps until the relative error is reached within the tolerance you specify. The maximum number of iterations for this scheme is fixed at 20 and the minimum tolerance used is 1e-6.

The Rombergxe "Romberg" integration scheme extrapolates the successive evaluations of the integral to zero step size and stops when the relative error of the extrapolated value is within the tolerance that you specify. The maximum number of iterations for this scheme is fixed at 20 and the minimum tolerance used is 1e-6.

The Gauss-Legendrexe "Gauss-Legendre" scheme of integration uses nodal points calculated as zeros of Gauss-Legendre Polynomials to get the time values for function evaluations. In the Gauss-Legendre Quadrature scheme, the relative precision used is 3e-11. The nodal points is the order of the Gauss-Legendre Polynomial that is used to get the time points for function evaluations. The relative precision is used to get the roots of the Gauss-Legendre Polynomial. This method of integration evaluates the function at number of time points equal to the nodal points that you specify.

The following guidelines may be useful in deciding which numerical integration method to use:

1. For gross and quick estimation of the number of failures, use the Trapezoidal integration.

2. If the failure rate function is smooth over the time interval of interest, the Gaussian-Legendre method provides more accurate results and takes less time. In this case, a higher order translates to higher accuracy only if the function is smooth.

3. If the failure rate function is not smooth (many jumps are noticed in the failure rate function) Romberg integration provides better results. If the Romberg integration takes a longer time for large trees, the Trapezoidal Quadrature scheme is the next best alternative.

4. If you have no idea about the system failure frequencies or if the tree size is small, enable the Trapezoidal Quadrature scheme initially.

Calculation Results

In Relex, fault tree calculation results can be displayed by numerous methods described in the following sections

Viewing Results from the Fault Tree Graphical View

Calculation results for the primary time point are displayed directly on the fault tree and are shown as a probability value and color flag. These color settings may be changed in the options (accessed via Tools>Options from the main menu) on the Fault Tree tab. All gates and events that are true are displayed in red (representing a failure) along with the probability value of 1. All gates and events that are false are displayed in green (representing no failure) along with the probability value of 0. These events that were assigned a logical condition of Normal display in white along with their assigned or calculated probability values. These values are either the unavailability or the unreliability as defined in the properties of the gate/event styles.

Fault Tree Calculation Results

Once a quantitative fault tree calculation has been performed, View>Fault Tree Calculation Results can be selected from the main menu. When selected, the Calculation Results window displays the results of the last calculation that was performed.

xe "Importance Results"Importance Results

Importance analysis of components is useful for identifying the design weaknesses and component failures that are crucial to the proper functioning of the system. After calculating Reliability Importance Measures, select View>Reliability Importance Measures from the main menu to view a table of all events and their importance to the top event. For more information about Reliability Importance Measures, refer to the section titled “Reliability Importance Measures”.

xe "Customized Fault Tree Report"Customized Fault Tree Report

A report can be generated to a printer or to a file by selecting File>Print from the main menu. Standard reports that are provided with Relex Fault Tree can be used, or custom reports can be created. For more information on generating a reportxe "Generating a Report" in the Relex Fault Tree, refer to the section titled “Generating Reports in Relex Fault Tree”.

xe "Equations"Fault Tree Calculation Equations and Theory

The purpose of this section is to provide additional details regarding the theory and equations used by Relex Fault Tree.

Fault Tree Input Parameters

When entering the properties for an event, several types of input parameters are available, as described as follows.

xe "Constant Probability"Constant Probability

For constant probability models, enter the probability of occurrence of the events. These probabilities are assumed to remain constant throughout the mission time of the system. 

Failure Rate/MTBF

For this kind of input event, specify the failure rate. The probability of this event is calculated as 
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Frequency

The Frequency value is the frequency of failures per hour, or the number of failures on average that would occur each hour.

xe "Failure with Repair"Failure with Repair 

For this type of event, specify the failure rate and the repair rate. The reliability and availability of these events are calculated using:
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where  is the failure rate, 
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is the repair rate and t is the time.

xe "Failure with Periodic Inspection"Failure with Periodic Inspection

System reliability and availability are improved if the system is maintained periodically (preventive maintenance). It is a common practice to assume that the system is as good as new immediately after preventive maintenance has been performed. The availability at time t is given by:
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 is the system availability that includes the effect of periodic maintenance. The time t is expressed as [image: image147.wmf]t
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, where T is the periodic inspection interval and n is zero or a positive integer. System reliability of periodically maintained systems is given by:
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of the same system without periodic maintenance. 
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 is the reliability of the system at time T. Note that the reliability and availability of a periodically maintained event is higher than or equal to the reliability and availability of the same system without periodic maintenance.

Probability Evaluation of Fault Trees

One of the primary purposes of fault tree analysis is to evaluate the probability of the top event. There are several approaches to this problem with these approaches being broadly categorized into two groups: methods using cut sets and method without using cut sets.

Analytical methods without using cut sets have the advantage of time and memory savings for large trees, since the determination of cut sets may take a long time and can consume a great deal of memory. Methods without using cut sets can determine the exact value of the top event probability. At the same time they are applicable for certain types of systems. The non-exponential distributions of failure and repair times and the dependencies between components and repeated events are some of the obstacles for these methods.

Relex Fault Tree uses analytical methods to calculate and display the probabilities of the events and gates at a mission time. For time dependent analysis where the results for many time points are needed, analytical methods without using cut sets may fall short of the methods using cut sets, since the tree is traversed as many times as the number of time points. This poses additional problems with dynamic gates where the previous condition of the gate events should be stored, and is used as the initial condition at the next time point. Methods using cut sets calculate the cut sets once and evaluate the cut set probabilities at different time points. For large number of time points, going through cut set records and evaluating cut set probabilities may be faster than going through the tree and evaluating gate probabilities.

Fault tree evaluation based on minimal cut sets is the most popular approach to system reliability analysis. This method first determines the minimal cut sets of the tree and then uses this cut set information to calculate the probabilities. Relex Fault Tree can calculate the probabilities of the top gate or of every gate in the tree.

There are several methods available to calculate the probabilities of a fault tree using cut set information. Relex uses the following three methods to calculate the probabilities of the top event:

1. Cut Set Summation

2. Cross Product

3. Esary Proschan

4. Exact Method.

Methods 1,2 and 3 use cut sets. Method 4 uses the direct probability evaluation without preliminary determination of cut sets. 

If the Cut Set Summation method is chosen, the gate probability is calculated as the summation of cut set probabilities (of the cut sets of that gate). This approximation is acceptable for small failure probabilities and may give very gross results (cut set probabilities may result in a sum greater than 1.0) for trees with higher cut set probabilities. The probability of each cut set is calculated as the product of event probabilities. The frequency of occurrence is calculated by summing the frequency of occurrences of the cut sets of that gate.

If the Cross Product method is specified, probabilities and frequencies are calculated using the summation and product terms of the cut set probabilities and frequencies using Poincare’s formula. 

The unavailability at a gate is calculated by using:
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The failure frequency is calculated by using:
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Where wij represents the frequency of the cut set made of common events to cut sets i and j. If there are no common events between cut set i and cut set j, this quantity is set to 0. The asterisk in the probability entry is used to denote the cut set probability without accounting for common events. In Relex Fault Tree, you can select the order of product terms that is used to calculate the probabilities and the frequencies. 

If the Esary Proschan method is chosen, the gate probability is calculated as 
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Where Qc is the product of the probabilities of events that are common to cut sets of that gate. The failure frequency is calculated as
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Calculating the Number of Failures in a Given Time Range

The number of failures in a given time range specified is calculated by numerically integrating the failure frequency over that time range. Relex Fault Tree uses different methods of numerical integration as described under the section titled “Fault Tree - Advanced Calculation Tab
”. Depending upon the methods used, the input parameters are different and the accuracy of the results varies. 

Reliability Importance Measures

Importance analysis of components is useful for identifying the design weaknesses and component failures that are crucial to the proper functioning of the system. By doing importance analysis, designers may allocate additional resources or redundancyxe "Redundancy" to improve the overall reliability of the system. An importance analysis is not necessary if the goal of the analysis is to merely calculate the reliabilities and availabilities at different time points. Basic eventxe "Basic Event" importance may be defined with respect to the top event probability at specified times. In Relex Fault Tree, any gate can be treated as the top gate for importance analysis. Relex Fault Tree calculates the following three types of importance factors:

1. Birnbaum Importance Measure: This measures the difference in top event probability when the basic event A occurs (Pr{A}=1) and when event A does not occur (Pr{A} =0). The Birnbaum measure provides the maximum increase in risk associated when component A is failed compared to when component A is operating.
Birnbaum = Pr{top|A=1} - Pr{top|A=0}

2. Criticality Importance Measure: This determines the probability (given that the top event occurs) that the failure is a result of the failure of component A. This results in an equivalent expression to the Fussell-Vesely importance measure.
Criticality = [Pr{top|A=1} - Pr{top|A=0}] * Pr{A} / Pr{Top}

3. Fussell-Vesely Importance Measure: This measures the fractional change in the top event probability for a fractional change in the basic event probability. This can also be interpreted as the weighted fraction of cut sets that contain the basic event.
Fussell-Vesely = Sum of cut set probabilities containing that basic event / top event probability

Generating Reports in Relex Fault Tree

As with other Relex modules, Relex Fault Tree supports the use of customized report designs. Several sample fault tree report designs are supplied with Relex Fault Tree, but others can be created and/or customized to suit your needs. A brief description of the supplied report designs is included in the Docs directory on the Relex CD.

In addition to the supplied fault tree report designs, Relex also includes report designs for the Fault Tree Value-Added files. These reports can be generated from within the CCF Groups and Event Parameters files. Lastly, Relex includes report designs for other components in fault tree analysis. Reports may be generated to output cut set and importance measures data.

For more information regarding customizing the Report Design files to suit individual needs, refer to the “Reporting and Graphing” chapter of this manual.

Chapter 11 xe "Maintainability Prediction"Maintainability Prediction

Introduction

Maintainability prediction analyses provide a method for determining various parameters regarding system repair and maintenance. Minimizing system repair and maintenance times minimizes down time and, therefore, increases system availability.xe "Availability" Maintainability predictions allow you to analyze repair times and identify areas for improvement.

The Relex Maintainability Prediction module is an integral part of the Relex package and can be used alone or in combination with other Relex modules.

This chapter is divided into the following sections:

Getting Started with Maintainability

Provides introductory information regarding maintainability predictions, and offers a general list of steps to getting started with the Relex Maintainability Prediction module.

Maintainability Reference

Provides detailed instructions for performing various tasks in the Relex Maintainability Prediction module.

Maintainability Calculationsxe "Maintainability Calculations"
Provides instructions on performing a calculation in Relex Maintainability Prediction, along with explanations of each of the maintainability calculations that can be performed.

Generating Reports in Relex Maintainability

Provides instructions for generating reports, and explains the various report options.

Getting Started with Maintainability Prediction

What is the Goal of a Maintainability Prediction?

The purpose of a maintainability prediction is to provide calculated information concerning various aspects of maintenance. You supply the input information to the software and it calculates the maintainability parameters. 

How Do You Begin a Maintainability Prediction?

You start at the basics by defining basic maintenance tasksxe "Basic Maintenance Tasks" such as replacing a screw, or removing a circuit card. You then extend your analysis to include all of the Fault Detection and Isolation (FD&I) outputs that are accomplished. You conclude your analysis by running calculations and generating output reports.

In Relex Maintainability, there are several levels of information, described as follows:

	Level
	Description

	Basic Maintenance Tasks
	A basic task is generally defined as a simple task or one step of a task. For instance, a sample basic task would be to remove a screw or to strip a wire. Basic tasks are stored in a Tasks file.xe "Tasks file" \r "D2HBTasks_file2" Relex includes a Tasks file which contains all basic tasks (and the associated times) outlined in MIL-HDBK-472.xe "MIL-HDBK-472" 

	Super Maintenance Tasksxe "Super Maintenance Tasks"
	Several basic tasks together create a super task. An example of a super task is replacement of a video card. This super task, sometimes called a maintenance action, may include several basic tasks, such as the following:

1. Remove screw

2. Remove card

3. Replace card

4. Replace screw

Super tasks are stored in a Tasks file. Several basic tasks are combined to create a super task in a Tasks file. The MIL-HDBK-472 Tasks file that is included with Relex can be edited to include super tasks created from the basic tasks in the file.

	FD&I Outputsxe "FD&I Outputs"
	FD&I (Fault Detection and Isolation) outputs are the indications, symptoms, printouts, readouts, or the results of manual procedures that separately or in combination, identify to the maintenance technician the procedure to be followed. An FD&I output includes a list of all tasks that are to be performed when the output occurs. An example FD&I output is replacement of a video card. FD&I outputs are stored in the FD&I Outputs file.

	Maintainability Analysisxe "Maintainability Analysis"
	The maintainaxe "Project file"bility analysis is used to store information about the particular design that is being analyzed. Included is a listing of replaceable items in the design with the associated part numbers, reference designators, and failure rates. Also listed with each replaceable item are the associated FD&I outputs or tasks. This information is stored in the Project file.


Activating the Maintainability Prediction Module

Starting Relexxe "Starting Relex" is just like starting any Windows program. To start Relex, select Relex from the Start menu.

In order to access Relex Maintainability, you must have first purchased the Relex Maintainability option, and you must initialize the maintainability capability in Options. Follow these steps to verify that the Relex Maintainability option is available with your Relex installation and enable Maintainability, if it has not already been enabled.

1. If any files or windows in Relex are open, close them.

2. Select Tools>Options from the main menu. 

3. Press the Product Options tabxe "Product Options tab" and select Maintainability Prediction to enable it. If it is already enabled, leave it as is. When ready press <OK>.

The main components of a Project file in Relex are the System Treexe "System Tree" and Parts Table.xe "Parts Table" If you do not have an understanding of the System Tree or Parts Table, you may review information concerning Project files in the “File Types” chapter of this manual.

Once the Maintainability Prediction checkbox has been enabled through Options, you can access the maintainability dataxe "Maintainability Data" for any component or assembly. The Parts Table provides access to all data regarding a component or assembly. You can access the maintainability data by selecting the Maintainability tabxe "Maintainability tab" at the bottom of the Parts Table window.

What Are the Main Steps for Performing a Maintainability Prediction in Relex?

The Project file is the top level of organization in Relex. The Project file contains all elements of a particular system. The System Tree and Parts Table are components of the Project file. The System Tree illustrates the structure of the system in the current project, and the Parts Table is used to enter the individual parts of each assembly. 

The following steps help to illustrate the flow of information in Relex. These steps walk you through the process of creating a Project file and eventually entering maintainability data.

1. Create or edit the Tasks file if necessary.

2. Create or edit the FD&I Outputs file if necessary.

3. Create the Project file.

4. Set up the structure of the System Tree in the Project file and review the properties of the items.

5. If performing a maintainability prediction at the piece part level, enter the parts for each assembly into the Parts Table.

6. Enter the maintainability data for each of the repairablexe "Repairable" items in the Project.

7. Calculate the Project.

8. Generate maintainability reports.

This outline is an overview, refer to the appropriate sections of this chapter for more details on specific steps.

Step #1 – Create or Edit the Tasks File If Necessary

The Tasks file allows you to customize the information that is included in your maintainability prediction, and also allows you to store all of this information in one easy to access location. Relex Maintainability includes a Tasks file that contains all basic tasks outlined in MIL-HDBK-472. You can use the data in this Tasks file as is, or as a basis for your own customized Tasks file. For more information on editing a Tasks file, refer to the section titled “Tasks File”.

Step #2 – Create or Edit the FD&I Outputs File If Necessary

The FD&I Outputs file allows you to enter FD&I outputs that can later be used within your Project file. FD&I outputs are the indications, symptoms, printouts, readouts, or results of manual procedures which separately or in combination, identify to the maintenance technician the procedure which is to be followed. An FD&I output includes a list of all tasks that are to be performed when the output occurs. When entering repairable items into the maintainability prediction, you have the option of accessing the FD&I Outputs file or accessing the Tasks file directly. If you are accessing the Tasks file directly, it is not necessary to create the FD&I Outputs file.

Step #3 – Create the Project File

Create the Project file by selecting File>New>Project from the main menu. This process requires only that you give the file a name in the File name field, and press <Create> when finished.

Step #4 – Set Up the Structure of the System Tree in the Project File and Review the Properties of the Items

Once the Project file has been created, define the structure of the system in your Project using the System Tree. Using the various features of the System Tree, add children and sibling components to define your system structure. 

Every item represented in the System Tree has properties associated with it. These properties can be accessed using the View>File Properties option on the main menu, or by selecting File Properties from the right mouse menu within the System Tree. These properties are to be reviewed carefully to make sure they meet your current needs, although they can be changed at any time in the future. The Calculation Data tabxe "Calculation Data tab" provides the ability to specify whether or not the item is repairable.

Under the View>File Properties option on the menu, you can also edit the properties of the Project file. 

The Files tabs provide the ability to specify the other Relex files that are to be used with the selected Project. The files that are specifically related to Relex Maintainability are found on the Maintainability Files tab. These files are the Tasks file, the FD&I Outputs file, and the Maintainability Groups file.

Step #5 – If Performing a Maintainability Prediction at the Piece Part Level, Enter the Parts for Each Assembly into the Parts Table

If you are performing a maintainability prediction at the piece part level (or depot level), the easiest way to begin entering maintainability data is to enter the parts list first. 

If you have access to the Relex Reliability Predictionxe "Reliability Prediction" portion of the Relex program, you may want to perform that portion of your analysis first. The reliability prediction portion of the analysis completes the process of entering partsxe "Entering Parts" into the Parts Table, and also completes the process of calculating failure rates for the list of parts.

Step #6 – Enter the Maintainability Data for Each of the Repairable Items in the Project

For every item represented in the Project, assign maintainability data. This includes individual parts and assemblies in the System Tree. Selecting the Maintainability tabxe "Maintainability tab" at the bottom of the Parts Table accesses the maintainability data.

Step #7 – Calculate the Project

Once the data for all parts and assemblies have been entered, perform a calculation. For more details regarding calculating, refer to the section titled “Maintainability Prediction Calculations
”xe "Maintainability Prediction Calculations".

Step #8 – Report on the Maintainability Data

Once all information in the analysis has been entered and calculations performed, reports can be generated. For details on report generation, refer to the section of this section titled “Generating Reports in Relex Maintainability Prediction”.

What Decisions Must be Made to Determine How to Structure Your Maintainability Prediction?

There are a few key decisions that are to be considered regarding the structure and data sources of a maintainability prediction. A few common decisions include:

xe "Maintainability Analysis"If You Are Performing a Maintainability Analysis Based on MIL-HDBK-472, Which Type of MIL-HDBK-472 Analysis Do You Wish to Perform?

MIL-HDBK-472 is based on various procedures. Relex supports the procedures outlined below and generic maintainability procedures.

MIL-HDBK-472 Procedure 2 

MIL-HDBK-472 Procedure 2 is used to predict the corrective, preventative and activexe "Active" maintenance parameters.

MIL-HDBK-472 Procedure 5A 

This procedure is used to predict the maintainability parameters of avionics, ground and shipboard electronics at the organizational, intermediate and depot levels of maintenance. It can also be applied to any application environment and type of equipment including mechanical equipment. Procedure 5A is more structured than Procedure 5B and segregates maintainability data by both a maintenance philosophy and maintainability groups.

MIL-HDBK-472 Procedure 5B 

This procedure is used to predict the maintainability parameters of avionics, ground and shipboard electronics at the organizational, intermediate and depot levels of maintenance. It can also be applied to any application environment and type of equipment including mechanical equipment. Procedure 5B calculations are similar to those in Procedure 5A but are greatly simplified and far less structured. 

What Will be the Source of Your Task Data?

A maintainability prediction begins with a list of tasks. A task is a simple one step procedure. When tasks are created and stored for use in a maintainability prediction, they generally include a description and an associated time along with other fields that may be available for further definition of the task. Therefore, an important decision when performing a maintainability prediction is the source of the task data.

MIL-HDBK-472 includes a list of tasks and associated times. Relex includes this list of tasks and times in a Tasks filexe "Tasks file" \r "D2HBTasks_file6" labeled MIL-HDBK-472. You can access this Tasks file directly, or you can edit the file to more closely suit your needs. In addition, you can create new Tasks files that are completely independent of MIL-HDBK-472.

Maintainability Prediction Reference

xe "Sample Maintainability"Relex Sample Maintainability File

Relex is supplied with a sample file titled Sample Relex Project that includes sample data for reliability prediction, FMEA, maintainability prediction, RBD, and fault tree. This file can be opened by selecting File>Open>Project from the main menu and selecting the file name Sample Relex Project. This sample file provides examples of tasks associated with assemblies and components.
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Figure 11 - 1. Sample Relex Project, Maintainability Data

Creating/Opening a Maintainability Prediction File

Data regarding a maintainability prediction is stored in a Project file. Details regarding Project files are provided in the “File Types” chapter of this manual. Creating or opening a Project file is performed by selecting File>New>Project or File>Open>Project from the main menu.

Entering Data on the Maintainability Data Tab

For every item in your System Tree, you may assign maintainability data. This includes individual parts, as well as assemblies. Selecting the Maintainability tabxe "Maintainability tab" in the Parts Table window accesses the Maintainability Data table. Regardless of the level at which you are entering data, the data on the Maintainability tab is the same.

	Item
	Description

	Define Repair Times by
	If FD&I Outputs from Outputs File is enabled, the data for this repairable item is retrieved from the FD&I Outputs file.

If Maintenance Tasks from Tasks File is enabled, the data for this repairable item is retrieved from the Tasks file.

	Totals
	Number of Items displays the total number of items listed in the task or FD&I output list for the repairable item.

Manhours (MMH) is the total manhours for all the tasks or FD&I outputs listed for the repairable item. Depending on the repair time units, this field may be labeled Manminutes.

Total Time (Mct) is the total time of all the tasks or FD&I outputs listed for the repairable item.

Note: These fields cannot be edited.

	Repair Levelxe "Repair Level"
	Select Organizational if the item is repairable at the box or system level, Intermediate if the item is repairable at the board or assembly level, or Depot if the item is repairable at the component or part level. 

Note: Relex automatically defaults parts to the depot level and assemblies to the intermediate level, however, the repair level may be modified as needed.

	Remarks
	Allows for the entry of any remarks regarding the repairable item.

	Group Name
	Applicable only for Procedure 5A calculations. Allows you to select the appropriate maintainability group name. The choice list selections are based on entries in the Maintainability Groups file that is enabled for the Project file.

	Maintainability Data Table
	See the following table for a detailed description.




Maintainability Data Table

The information in this table differs depending on whether you selected to define the repair times by outputs from the FD&I Outputs file or tasks from the Tasks file.

FD&I Outputs from Outputs File

	Field
	Description

	FD&I Output Code
	The choice list displays all FD&I outputs available in the FD&I Outputs file for this particular Project file.

	FD&I Output Percent
	Percentage of the item's failure rate that is identified by this particular FD&I output. The default is 100. The percentages for each repairable item should add up to 100%, but this is not enforced.

	Time
	The repair time for this particular FD&I output. This information cannot be edited and is supplied for your reference.

	Manhours or Manminutes
	The total manhours or manminutes for this particular FD&I output. This information cannot be edited and is supplied for your reference. You can select the time units (minutes or hours) on the Project Definition tab in the Project file properties.


Maintenance Tasks from Tasks File

	Field
	Description

	Task Code
	The choice list displays all tasks available in the Tasks file that are enabled for this particular Project.

	Tasks Qty
	Used to specify the number of times the selected task is to be performed.

	Task Frequency
	The frequency of occurrence of the specified task expressed as a percentage from 0.0 to 100.0. The frequency can also be considered to be the probability that the specified task will be performed. The default is 100.

	Time
	The repair time for this particular task. This information cannot be edited and is supplied for your reference.

	Manhours or Manminutes
	The time required for this particular task. This information cannot be edited and is supplied for your reference. You can select the time units (minutes or hours) on the Project Definition tab in the Project file properties.


xe "Value-Added files"Maintainability Value-Added Files

There are three Value-Added files associated with Relex Maintainability, used to help organize your maintainability prediction. These files types are Tasks files, FD&I Output files, and Maintainability Groups files. These Value-Added files are described as follows:

Tasks File
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Figure 11 - 2. Sample Tasks File

The Tasks file in Relex Maintainability is used to store maintenance tasks and times. These tasks can be basic tasks (such as the time to remove a screw or insert a board) or can be combinations of basic tasks to form more complex super tasks. The times stored in the Tasks file can be used as the basis for all of the maintenance calculations.

Any Tasks defined in the Tasks file are available to you when editing an FD&I Outputs file or a Project file. 

Relex Maintainability automatically includes a Tasks file of standard maintenance tasks based on the tasks and repair times from MIL-HDBK-472. In addition to the Maintainability Tasks file that is supplied with Relex, you can also create your own Tasks files. Once you have created your own Tasks files, you can use them in any Project file.

Creating/Editing a Tasks File

Just follow these steps to create a Tasks file:

1. Select File>New>Maintainability>Tasks from the main menu.

2. In the File name field, enter the name of the new Tasks file and press <Create>.

3. Upon creating a new file, the File Properties window appears. This window allows you to specify descriptive information about the Tasks file you are creating. There are two tabs: the General tab and the Tasks File Information tab. The General tab contains fields for entering the part number,xe "Part Number" reference designator,xe "Reference Designator" and a description. After completing these fields, select the Tasks File Information tab and choose the time units you wish to use for the Project and press <OK>.

4. The Tasks File window appears. This window is divided into 2 main sections: the Tasks Definition window and the Task Data window.

5. Enter the data in the window as described in the sections titled “Tasks Definition Window” and “Task Data Window”.

6. Close and save the Tasks file.

7. Once a Tasks file is created, the file can be used with any Project file. To enable a Tasks file for use in a Project file, access the Project properties of the Project file by selecting View>File Properties from the main menu. The Project Properties window appears. Select the Maintainability Files tab. In the field labeled Tasks, enter the path and name of the desired Tasks file. Use <Browse> as needed.

Note: Once a Tasks file has been created, it can be opened for editing by selecting File>Open>Maintainability>Tasks from the main menu.

Tasks Definition Window

The Tasks Definition window allows you to create all of the tasks for a particular Tasks file and to enter general information about each task. To enter a new task, select Insert>Insert Record from the main menu. The following information may be entered for each new task:

	Field
	Description

	Task Code
	Stores the identifying name for a particular task. This information appears in the tasks choice listsxe "Choice Lists" in the Project files when specifying maintainability data in a Project file and in the task code choice list in the FD&I Outputs window in an FD&I Outputs file. The task code may be up to 255 characters long.

	Task Description
	Allows for the entry of descriptive information regarding the particular task. The task may be up to 64,000 characters in length.

	Basic Task
	When enabled, the task is identified as a basic, one-step task. When disabled, the task is a super, or multi-step, task. This checkbox field is enabled by default. 

	Repair Type
	Allows you to identify the type of repair for this task. Select from corrective, preventive, or false alarm. The repair type defaults to corrective. Corrective tasks are used during most calculations including MTTR,xe "MTTR" \r "D2HBMTTR10" MMH/OH, Mean Corrective Maintenance Time, etc. Preventive tasks are used during the MMH/OH, MMH/FH, and Mean Preventive Maintenance Timexe "Mean Preventative Maintenance Time" Calculations. False alarms are detected during normal operation but cannot be repeated during the fault isolation process, or are detected and isolated to a removable item when the removable item does not have an actual fault. The ratio of Type 1 and Type 2 false alarmsxe "Type 2 False Alarms" is defined on the Project Definition tab in the Project properties.

	Preventive Frequency
	Allows for the entry of frequency of occurrence of preventive maintenance actions per million hours. The preventive frequency is set to 0.00 by default. This information is used during MMH/OH, MMH/FH, and Mean Preventive Maintenance Time calculations. The field is disabled if the repair type is not preventive.

	Remarks
	Allows for the entry of any notes or comments regarding the particular task. Enter alphanumeric data up to 64,000 characters.


Task Data Window

The Task Data window is used to assign detailed information to the task selected in the Tasks Definition window. Select the task you wish to edit from the window by clicking it with your cursor, and then begin adding the task information in the Task Data window. The fields to be entered vary based on whether a task is a basic task or a super task.

Basic Task Data

If the Basic Task field is enabled the following fields appear in the Task Data window:

	Field
	Description

	Repair Time
	Time required to complete the task. Time is entered in the time units you selected upon creating the Tasks file. After a Tasks file has been created, you may select View>File Properties to review this information.

	Number of Men
	Total number of men required to complete the task. This value is multiplied by the repair time to find the total time for the selected task.

	MTTR Element
	Portion of the repair this task is related to. You may select from a choice list that includes preparation, fault isolation, disassembly, interchange, reassembly, alignment, checkout and start-up.


Super Task Data

If the Basic Task field is disabled, the following fields are displayed in the Task Data window to define the super task:

	Field
	Description

	Totals
	Number of Subtasks displays the total number of tasks within the super task.

Total Time (Mct) displays the total time for the super task. This is the sum of all the times for the basic tasks listed for this super task.

Manhours (MMH) display the total manhours for the super task. This value is based on the sum of repair time multiplied by the number of men for all basic tasks listed for this super task. This value can be entered in hours or minutes. The units are selected on the Project Definition tab in the Project properties. Depending on the units of time selected, this field may be labeled Manminutes.

Note: These fields cannot be edited.

	Subtasks
	The Subtasks table is used to list all basic tasks that comprise the super task.

The Subtask Code is the code of the basic task to be included for the selected subtask. You can use the choice list to make a selection.

The Qty Subtasks specifies the number of times the selected basic task is to be performed for this super task.


FD&I Output Files
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Figure 11 - 3. Sample FD&I Outputs File

Fault Detection and Isolation (FD&I) outputs are the indications, symptoms, printouts, readouts, or results of manual procedures that identify to the maintenance technician the procedure to be followed. Some common types of FD&I outputs are BIT outputs, meter readings, alarms, display presentation, improper system operation, and system operating alerts. An FD&I output lists the tasks that are to be completed when the output occurs. A given FD&I output can include many different tasks. 

The FD&I outputs you define in the FD&I Outputs file are available to you in a choice list when editing a Project file. When entering maintainability data for a repairable item, you have the choice of entering information from the FD&I Outputs file or directly from the Tasks file. The FD&I Outputs file is only important if you are using the option to enter the maintainability data from the FD&I Outputs file. Otherwise, the FD&I Outputs file is not used.

Creating/Editing an FD&I Outputs File

Follow these steps to create an FD&I Output file:

1. Select File>New>Maintainability>FD&I Outputs from the main menu.

2. In the File name field enter the name of the new FD&I Outputs file and press <Create>.

3. Upon creating a new file, the File Properties window appears. This window allows you to specify descriptive information about the FD&I Outputs file you are creating. There are two tabs on the File Properties window, General and FDI File Information. Complete the part number, reference designator, and description fields on the General tab. 

4. Select the FDI File Information tab. Press <Browse> to select the Report Format, and then select the Tasks file that you wish to use. When finished press <OK>.

5. The FD&I Outputs File window appears. This window is divided into two main sections: the FD&I Outputs Definition window and the FD&I Output Data window.

6. Enter the data in the window as described in the following sections.

7. Close and save the FD&I Outputs file.

8. Once an FD&I Outputs file is created, the file can be used in any Project file. To specify that the FD&I Outputs file is to be used, access the File Properties of the Project file, and select the Maintainability Files tab. In the field labeled FD&I Outputs, enter the path and name of the desired FD&I Outputs file. Use <Browse> as needed.

Note: Once an FD&I Outputs file has been created, it can be opened for editing at any point by selecting File>Open>Maintainability>FD&I Outputs from the main menu.

FD&I Outputs Definition Window

The FD&I Outputs Definition window allows you to create all of the FD&I outputs for a particular FD&I Outputs file and enter general information about each FD&I output. To enter a new FD&I output, select Insert>Insert Record from the main menu. The following information may be entered for each new FD&I output:

	Field
	Description

	FD&I Code
	Stores the identifying name for a particular FD&I output. This information appears in the outputs choice listsxe "Choice Lists" in the Project files when specifying maintainability data in a Project file. The FD&I output code may be up to 255 characters in length.

	FD&I Output
	Allows for the entry of descriptive information regarding the particular FD&I output. The FD&I output may be up to 64,000 characters in length.

	Remarks
	Allows for the entry of any notes or comments regarding the particular FD&I output. Enter alphanumeric data up to 64,000 characters.


FD&I Output Data Table

The FD&I Output Definition table is used to list all tasks that comprise the selected FD&I output. Complete the table as follows:

	Field
	Description

	Task Code
	Select from the choice list that contains all tasks included in the Tasks file you enabled upon creating the FD&I Outputs file.

	Qty Tasks
	Allows for the entry of the total quantity of the particular task in the selected FD&I output.

	Task Frequency
	Allows for the entry of the frequency of occurrence of the particular task as a percentage from 0.0 to 100.0. The frequency can be considered to be the probability that the particular task will be performed. The default value is 100.0.

	Time
	Displays the total time based on the task and quantity of tasks entered.

Note: This field cannot be edited.

	Manminutes or Manhours
	Displays the total time in terms of manminutes or manhours based on the repair time units defined.

Note: This field cannot be edited.


Maintainability Groups Files

Maintainability Groups are used only when performing a MIL-HDBK-472 Procedure 5A analysis. When the Procedure 5A option is enabled for a Project file (on the Project Definitions tabxe "Project Definitions tab" in the File Properties), the Maintainability tabxe "Maintainability tab" for parts and assemblies enables the Group Name field. The list of names available in this choice list field is based on the data stored in the Maintainability Groups file.
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Figure 11 - 4. Sample Maintainability Groups File

Creating/Editing a Maintainability Groups File

To create a Maintainability Groups file, follow these steps:

1. Select File>New>Maintainability>Maintainability Groups from the main menu.

2. In the File name field enter the name of the new Maintainability Groups file and press <Create>.

3. Upon creating a new file, the File Properties window appears. This window allows you to specify descriptive information about the Maintainability Groups file you are creating. There are two tabs on this window, General and Report Format. Complete the part number, reference designator, and description fields on the General tab. 

4. Select the Report Format tab. Use the <Browse> button to select a report format. When finished press <OK>.

5. The Maintainability Groups file window now appears. This window is divided into 2 main sections: the Maintainability Groups Definition window and the Group Data window.

6. Enter the data in the window as described in following sections.

7. Save and close the Maintainability Groups file.

8. Once a Maintainability Groups file is created, the file can be used in any Project file. To specify that the Maintainability Groups file is to be used, access the File Properties of the Project file and select the Maintainability Files tab. In the Maintainability Groups field, enter the path and name of the desired Maintainability Groups file.

Note: Once a Maintainability Groups file has been created, it can be opened for editing at any point by selecting File>Open>Maintainability>Maintainaiblity Groups from the main menu.

Maintainability Groups Table

The Maintainability Groups Definition window allows you to define your maintainability groups. Enter the data in the Maintainability Groups Definition window as follows:

	Field
	Description

	Group Code
	Stores the identifying name for a particular maintainability group. This information appears in the Group Name field on the Maintainability Data tab when specifying maintainability data in a Project file. The group code may be up to 255 characters in length.

	Group
	Allows for the entry of descriptive information regarding the particular maintainability group. The group may be up to 64,000 characters in length.


Group Data Window

The Group Data window is used to assign detailed information to the selected group. Select the group by clicking it with your cursor in the Maintainability Groups Definition window, and then add the group information in the Group Data window. 

	Field
	Description

	Isolation to a Single RI
	If enabled, Isolation to a Single RI is assumed for the calculations. This means that the fault or failure that occurred can be isolated to one particular item. If disabled, the additional data is required on the Group Data window. This option is enabled by default.

Note: RI is an acronym for Replaceable Item.

	Group Replacement Philosophy
	If Group is enabled, it is assumed that an entire group of replaceable items is replaced when the repair is made.

If Iterative is enabled, it is assumed that an attempt is made to replace only the replaceable item that is malfunctioning. If this option is enabled, the Reassembly Required for Checkout option is enabled. 

	Access to Removable Items
	If Single is enabled, it is assumed that the individual making the repairs can replace the one replaceable item that is malfunctioning.

If Multiple is enabled, it is assumed that multiple items must be removed in order to replace the one replaceable item that is malfunctioning.

	Reassembly Required for Checkout
	If enabled, it is assumed that all replaceable items in the group must be reassembled to confirm that the repair is successful. If disabled, it is assumed that the item being replaced can be tested for proper functionality without reassembly. This field is only applicable when the group replacement philosophy is iterative.

	Fault Isolation Ambiguity (S)
	If User-Defined is enabled, the S value is defined as a user-defined value.xe "User-Defined Value" Either enter a value or use the table to enter percentage/number of RIs to compute S.

If Estimated (per Fault Isolation Requirementsxe "Fault Isolation Requirements" below) is enabled, the S factor for the group is calculated based on data entered as fault isolation requirements. Refer to the following section for more information on completing the fault isolation requirements data.


Fault Isolation Requirements

During the calculation of MTBFxe "MTBF" in a MIL-HDBK-472 Procedure 5A calculation, an S factor is required. The S factor is used to compute the average number of RIs in a fault isolation result or the average number of iterations required to correct a fault. By default, the S value is either a user-defined value or computed based on values entered in the estimation table.

When using the table to specify the S factor for the group, Relex expects the data in the form:

X1 % <= N1 RIs, X2 % <= N2 RIs, X3 % <= N3 RIs … 100 % <= Nn RIs.

If you have the data specified in this form:

X1 % to <= N1 RIs,

N1 RIs < X2 % <= N2 RIs

N2 RIs < X3 % <= N3 RIs

….

Nn-1 RIs < Xn % M= Nn RIs

Convert it to the form Relex expects by:

	Value to enter into Relex
	Convert by

	X1
	X1

	N1
	N1

	X2
	X2 + X1

	N2
	N2

	X3
	X3 + X2 + X1

	N3
	N3

	…
	

	Xn
	Xn + Xn-1 + Xn-2 + … X1

	Nn
	Nn

	Where ( Xn + Xn-1 + Xn-2 + … X1 = 100) 


xe "Maintainability Prediction Calculations"Maintainability Prediction Calculations

You can use Relex Maintainability Prediction to perform an analysis on everything from piece part up to system component replacements. Relex Maintainability Prediction supports MIL-HDBK-472 Procedures 2, 5A, and 5B, and generic maintainability procedures. Relex Maintainability Prediction calculates several maintenance parameters including:

· Mean Time to Repair (MTTRxe "MTTR" \r "D2HBMTTR17") 

· Percent Isolationxe "Percent Isolation" \r "D2HBPercent_Isol17" to a Single Removable Item

· Percent Isolation to a Group of Removable Items

· Mean Maintenance Manhoursxe "Mean Maintenance Manhours" per Repair (MMH/Repair)

· Mean Maintenance Manhours per Maintenance Action (MMH/MA) 

· Mean Maintenance Manhours per Operating Hour (MMH/OH) 

· Mean Maintenance Manhours per Flight Hour (MMH/FH)

· Maximum Corrective Maintenance Timexe "Maximum Corrective Maintenance Time" for the Sigma Percentile

· Mean Preventive Maintenance Time 

· Mean Active Maintenance Timexe "Mean Active Maintenance Time"
Performing a Maintainability Prediction

To perform a maintainability prediction calculation, open an existing Project file and select it as the active window. Select Project>Calculate from the main menu or press the <Calculate> button on the Standard toolbar.
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Figure 11 - 5. Calculations, Maintainability Tabxe "Maintainability tab" \r "D2HBMaintainabil17"
The Calculate window appears. To perform maintainability prediction calculations,xe "Maintainability Prediction Calculations" you must enable the Maintainability checkbox on the Calculation Selection tab. On the Maintainability tab you must select the level you wish the calculations to be completed. You may select from the choice list of organizational, intermediate, and depot. The calculations are described in the following section.

Select the calculations to be performed by enabling the checkbox next to the desired calculation options, enter any additional required data, and then press <OK> on the Calculate window to calculate. After calculating, the results are automatically displayed.

Maintainability Prediction Calculations

Mean Time to Repair (MTTR)

MTTR is the most common measurement for maintainability prediction, and is sometimes known as the Mean Corrective Time (MCT). This is the mean time to repair all of the removable items. 

The procedure used in calculating the MTTR is as follows:

1. For the first Removable Item (RI) calculate the sum of the Failure Rate * Percentage * Time for all FD&I outputs.

2. For the first RI calculate the sum of the Failure Rate * Percentage for all FD&I outputs.

3. Get the Mean Repair Time for the first RI by dividing the results of (2) above into (1) above.

4. Calculate the sum of the Mean Repair Time (from steps 1-3 above) * Failure Rate for each RI.

5. Calculate the sum of the Failure Rates for each RI. 

6. Get the MTTR by dividing the results of (5) above into (4) above. 

Note: Only corrective maintenance items are considered in this calculation. 

Percent Isolation to a Single Removable Item 

Percent Isolation to a Single Removable Item is the percentage of all FD&I outputs that result in isolation to a single removable item. This value represents the sum of the failure rates of all FD&I outputs which result in isolation to a single RI divided by the sum of the failure rates for all FD&I outputs.

Percent Isolation to a Group of Removable Items

Percent Isolation to a Group of Removable Items is the percentage of all FD&I Outputs that result in isolation to n or less removable items, where n is entered in the Quantity field. This value is the sum of the failure rates of all FD&I outputs which result in isolation to n or less RIs divided by the sum of the failure rates for all FD&I outputs.

Mean Maintenance Manhours per Repair (MMH/Repair)

The Mean Maintenance Manhours per Repair (MMH/Repair) calculation is identical to the MTTR calculation, except that the number of manhours is used. In the calculations, manhours values are substituted for time values.

Mean Maintenance Manhours per Maintenance Action (MMH/MA)

The Mean Maintenance Manhours per Maintenance Action (MMH/MA) calculation is similar to the MMH/Repair calculation except that the time spent as a result of false alarms is also taken into account. 

The calculation is as follows: 

1. Calculate the sum for all RIs of the (Mean Maintenance Manhours per Repair for each RI) * (Failure Rate of each RI) * (1 + F2n) where F2n is the frequency of occurrence of type 2 false alarmsxe "Type 2 False Alarms" for the RI. 

2. Calculate the sum for all RIs of the (Mean Maintenance Manhours associated with Type 1 false alarmsxe "Type 1 False Alarms") * (Failure Rate of each RI) * (Frequency of occurrence of Type 1 false alarms).

3. Calculate the sum for all RIs of the (Failure Rate of each RI) * (1 + F2n) where F2n is the frequency of occurrence of type 2 false alarms for the RI.

4. Calculate the sum for all RIs of the (Failure Rate of each RI) * (Frequency of occurrence of Type 1 false alarms).

5. Calculate the MMH/MA by dividing the sum of (3) and (4) above into the sum of (1) and (2) above. 

Mean Maintenance Manhours per Operating Hour (MMH/OH)

The Mean Maintenance Manhours per Operating Hour (MMH/OH) calculation includes the sum of all corrective, preventive, and false alarm repair times. It is performed as follows: 

1. Calculate the sum for all RIs of the (Mean Maintenance Manhours per Repair for each RI) * (Failure Rate of each RI expressed in failures per operating hour) * (1 + F2n) where F2n is the frequency of occurrence of type 2 false alarms for the RI.

2. Calculate the sum for all RIs of the (Mean Maintenance Manhours associated with Type 1 false alarms) * (Failure Rate of each RI expressed in failures per operating hour) * (Frequency of occurrence of Type 1 false alarms)

3. Calculate the sum for each preventive maintenance action of the (Mean Maintenance Manhours per Preventive Maintenance Action) * (Frequency of the Preventive Maintenance Action)

4. Calculate the MMH/OH by adding the results of (1), (2), and (3) above. 

Mean Maintenance Manhours per Flight Hour (MMH/FH)

The Mean Maintenance Manhours per Flight Hour (MMH/FH) calculation is the same as the MMH/OH above except flight hours is substituted for operating hours. Enter the Percentage Flight Hours (FH/OH * 100) to convert total hours to flight hours for this calculation.

Mean Corrective Maintenance Time

The Mean Corrective Maintenance Time is the mean time required for corrective maintenance actions. Calculate the Mean Corrective Maintenance Time (MCMT) as follows:

Calculate [the sum of (frequency of occurrence of preventive maintenance tasks) * (Manhours)] divide by the [sum of frequency of occurrence of corrective maintenance tasks].

Maximum Corrective Maintenance Time for the Sigma Percentile 

The Maximum Corrective Maintenance Time for the Sigma Percentile calculation is taken from MIL-HDBK-472 paragraph 3.8.1. It calculates the maximum corrective maintenance time for the sigma percentile that you specify. The sigma value and the maximum corrective maintenance time are calculated per the equation in MIL-HDBK-472. You can also output a summary of Mmax sigma values as an ancillary report by enabling Mmax Summary for a report design.

Mean Preventive Maintenance Time

The Mean Preventive Maintenance Time is the mean time required for preventive maintenance actions. The calculation is taken from MIL-HDBK-472 Procedure 2. Calculate the Mean Preventive Maintenance Time (MPMT) as follows: 

Calculate [the sum of (frequency of occurrence of preventive maintenance tasks) * (Manhours)] divided by the [sum of frequency of occurrence of preventive maintenance tasks].

xe "Mean Active Maintenance Time"Mean Active Maintenance Time

The Mean Active Maintenance Time is the mean time required for all corrective and preventive maintenance actions. The calculation is taken from MIL-HDBK-472 Procedure 2. Calculate the Mean Active Maintenance Time (MAMT) as follows: 

1. Calculate the (Total Failure Rate for all RIs) * (Total MMH/Repair) * (Operating Time During tj (ti)).

2. Calculate the (Sum of all Frequencies of Preventive Maintenance for all RIs) * (Mean Preventive Maintenance Time) * (Calendar Time in Operating Inventory (tj)).

3. Calculate the (Total Failure Rate for all RIs) * ti.

4. Calculate the (Sum of all Frequencies of Preventive Maintenance for all RIs) * tj.

5. Calculate the mean active maintenance time as the results of (1) + (2) above divided by the results of (3) + (4) above.

Maintainability Index

The Maintainability Index is calculated based on MIL-HDBK-472 Procedure 2. This calculation uses both (1) and (2) from the above Mean Active Maintenance Time calculation. Calculate the Maintainability Index as the sum of (1) + (2) from the Mean Active Maintenance Time calculation divided by the operating time (t).

xe "MTTR"MTTR Calculations per Procedure 5A 

Relex Maintainability Prediction implements the MTTR calculations per Procedure 5A if you have the Procedure 5A checkbox enabled on the Project Definition tab of the top-level system properties.

When performing maintainability prediction calculations,xe "Maintainability Prediction Calculations" \r "D2HBMaintainabil20" make sure that you have selected the appropriate repair levelxe "Repair Level" (organizational, intermediate, and depot). To select the repair level for calculations, choose Tools>Calculate from the menu, then select the Maintainability tabxe "Maintainability tab" from the Calculation window that appears, and choose the correct repair level. If you select a repair level and have no RIs defined at that level, the MTTR value is zero.

For a summary of the Procedure 5A calculations, refer to the Docs directory on your Relex CD.

Reviewing Maintainability Prediction Calculation Results

Once a maintainability prediction calculation has been performed, the Calculation Results window automatically displays the results of the calculations. In addition, the results of the maintainability prediction calculations can be reviewed for any assembly in the Project file by accessing the Calculation Results tabxe "Calculation Results tab" in the Parts Table window while the assembly is selected in the System Tree.

If you wish to print the calculation results, it is necessary to generate a report that includes the maintainability calculation results. For more information on generating reports in Relex Maintainability, refer to the following section titled “Generating Reports in Relex Maintainability Prediction”.

Generating Reports in Relex Maintainability Prediction

As with other Relex modules, Relex Maintainability Prediction supports the use of customized report designs. Several standard maintainability prediction report designs are supplied with Relex Maintainability Prediction, but others can be created and/or customized to suit your needs. For a listing of supplied files, refer to the Docs directory on your Relex CD.

In addition to the supplied maintainability prediction report designs, Relex also includes report designs for the Maintainability Value-Added files. These reports can be generated from within the Tasks, FD&I Outputs, and Maintainability Groups files.

For more information on reporting, refer to “Reporting and Graphing” chapter of this manual.

Chapter 12 Life Cycle Cost (LCC)

Introduction

Life cycle cost is a method of analyzing the cost of a system over its lifetime. The Relex LCC module is an integral part of the Relex package and can be used alone or in combination with the other Relex modules.

This document is divided into the following sections:

Getting Started with LCC

Provides introductory information regarding life cycle cost analyses, and offers a general list of steps to getting started with the Relex LCC module.

LCC Reference

Provides detailed instructions for performing various tasks in the Relex LCC module.

LCC Calculationsxe "LCC Calculations"
Provides instructions on performing a calculation in Relex LCC, along with an explanation of each of the Relex LCC calculations that can be performed.

Generating Reports in Relex LCC

Provides instructions for generating reports, and explains the various report options.

Getting Started with LCC

What is the Goal of an LCC Analysis?

The purpose of a life cycle cost analysisxe "Life Cycle Cost Analysis"

xe "Cost Analysis" is to provide the ability to compute the cost of a system over its entire life span. Relex LCC allows you to define the elements included in the life span of a system, and then assign equationsxe "Equations" to each element. These equations represent the calculation of the cost of that particular element. 

How Do You Begin an LCC Analysis?

In general, you begin your LCC analysis by devising a hierarchical breakdown of the system being analyzed. For example, a common breakdown of the life cycle of a large system may include:

· System planning and concept design cost

· Preliminary system design cost

· Detailed design and development cost

· Production cost

· Maintenance cost

· Disposal cost

Relex LCC computes the total life cycle cost of the system based on the total sum of each of these components.

For further detail, elements may be broken down, and a cost model for each of these elements can be developed. For example, the maintenance cost element stated above could be broken down further into the following components:

· Product management cost

· Product operation cost

· Product distribution cost

· Product maintenance cost

· Cost of sparesxe "Cost of Spares"
· Operating and training costs

After defining the cost breakdown, you define cost equations for each of the elements. For example, a possible equation for product maintenance cost could be:

Number of Failures * Time Interval * (Cost of Spare Part + (Repair Time * Labor))

What Are the Main Steps for Performing an LCC Analysis in Relex?

The following step-by-step outline describes how a life cycle cost analysis is performed using the Relex LCC module.

Step #1 - Start the Relex Program

Starting Relexxe "Starting Relex" is just like starting any Windows program. To start Relex, select Relex from the Start menu.
Step #2 - Create or Open a Life Cycle Cost File in Relex

The first step to performing a life cycle cost analysis is to create a Life Cycle Cost (LCC) file by selecting File>New>Life Cycle Cost from the main menu.

Step #3 - Create Overall CBS Structure

Once the Life Cycle Cost file has been created, you should determine the structure of the elements in the analysis. First, determine the Cost Breakdown Structure (CBS) for your analysis. The CBS is basically a hierarchical structure of the analysis. This is accomplished in the Cost Breakdown Structure window of the LCC file. The Cost Breakdown Structure window functions in the same way as the System Tree,xe "System Tree" which is used in a Relex Project file.xe "Project file" Siblings and children can be inserted as needed, and existing CBS items can be moved by clicking and dragging the items. Continue to build your CBS until it includes all key components.

Note: Cost Breakdown Structure (CBS) can also be referred to as Work Breakdown Structure (WBS).

Step #4 - Define Alternatives

Relex LCC allows you to define alternatives. Alternatives are useful for determining which approach to a problem is the most cost effective. Relex LCC allows various alternatives to be defined. Alternatives allow for the calculation of different variations of an LCC analysis. An alternative can be as simple as a description of the particular variation of the analysis, or can be directly related to a portion of a Project file. In the latter case, the alternative could use certain data from the Project file in the calculation process.

Alternatives for an LCC file are accessed by selecting Life Cycle Cost>Edit Alternatives from the main menu. The process of defining alternatives is explained in further detail in the section titled “Alternatives”.

xe "Time Interval"Step #5 - Define Time Intervals

Relex LCC allows you to define the time intervals for determining life cycle costs. For example, if you wanted to analyze the cost of a product over a five-year period, then define five time intervals (Year 1 or the current year, Year 2, Year 3, Year 4, and Year 5). When defining time intervals, interest rates for the time intervals can also be assigned. These values are used in the calculation of the Net Present Valuexe "Net Present Value" (NPV).

Time intervals for an LCC file are accessed by selecting Life Cycle Cost>Edit Time Intervals from the main menu. For more details on defining time intervals, refer to the section titled “Time Intervals”.

Step #6 - Define Variables

In the calculation of life cycle cost, Relex allows you to establish equations for each item in the analysis. In order to simplify these equations, Relex allows you to incorporate variables into the equations to represent values.

Variables for an LCC file are accessed by selecting Life Cycle Cost>Edit Common Variables,xe "Common Variables" Life Cycle Cost>Edit Project Variables, or Life Cycle Cost>Edit Item Variablesxe "Item Variables" from the main menu. The process of defining variables is explained in further detail in the section titled “Variables”.

Step #7 - Enter Equations for Each CBS Item

Once all of the appropriate alternatives, time intervals, and variables have been established, the equations for each element of the life cycle cost analysis can be assigned. This process is completed by using the Equation Definitionxe "Equation Definition" window. For more information on entering equations, refer to the section titled “Entry of Equation Definition”.

Step #8 - Calculate the Analysis

After all equations have been defined for the elements of the analysis, life cycle cost calculations can be performed. To perform a calculation, select Life Cycle Cost>Calculate from the main menu. For more information on calculating life cycle costs, refer to the section of this section titled “Life Cycle Cost Calculations”.

Step #9 - Generate Reports

Once all information in your analysis has been entered and calculations performed, you can generate reports. There are several LCC reports supplied with Relex. You may modify these supplied reports to suit your needs, or create completely new customized reports. The reports are generated using the File>Print Preview option. The report designs can be customized by selecting File>New>Format>Report Design or File>Open>Format>Report Design from the main menu. For additional information regarding reporting, refer to the “Reporting and Graphing” chapter of this manual.

How Do You Determine the Structure of Your LCC Analysis?

There are a few key decisions that must be made regarding the structure of an LCC analysis. A few common decisions would include:

What Cost-Related Portions of Your System Do You Need to Include in the Analysis?

Before you can proceed with an LCC analysis, it is necessary to determine the focus of the analysis. An LCC analysis can be as broad or focused as necessary. The LCC analysis can take into account any and all cost factors, or the analysis can be focused on one particular portion of the total cost (for example, the maintenance costs).

What Will be the Source of Your Cost Data?

Eventually, the cost analysis needs to include various cost data. The source of the data must be determined to insure that the calculations are performed with the most accurate and up-to-date information available.

How Will You Determine the Equations to be Used to Represent Each Level of Your System?

After a system has been broken down into lower cost levels, equations can be assigned to these levels in order to calculate cost based on a variety of factors. The equations that are used are completely customizable. Therefore, it is important for you to determine from what source these equations will be based.

Will the Analysis be Associated with Relex Project Files?

You may find that taking Project related information like failure rate, MTTR,xe "MTTR" and cost of sparesxe "Cost of Spares" into account in an LCC analysis is a task you find yourself doing often. In Relex LCC, you have the ability to take this data from any Project file, any portion of a Project file, or multiple Project files (in order to compare various alternatives). 

Life Cycle Cost Reference

xe "Sample LCC Files"Relex Sample LCC Files

Relex LCC offers two sample LCC files. The first file, Sample Life Cycle Cost, is a simple LCC file that offers a few examples regarding possible uses of an LCC analysis file. This file is small enough to allow those who are limited to the Relex demoxe "Demo" version of the software to access it. A second file, Sample Cost Breakdown, contains a more comprehensive CBS, but is only available for use with Relex LCC module in non-demo mode. The file offers additional levels of information in the cost analysis and additional examples of equations and variables.
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Figure 12 - 1. Sample Life Cycle Cost File

LCC File Properties

All files in Relex have properties associated with them. The properties are accessed from the main menu by selecting View>File Properties when an LCC is open in the activexe "Active" window. The properties available for an LCC file are as follows:

General and Report Format Tabs

The General and Report Format tabs offer access to general properties regarding the LCC file. These properties are:

	Field
	Description

	Part Numberxe "Part Number"
	The part number of the system being analyzed. This field can be left blank if not applicable.

	Reference Designatorxe "Reference Designator"
	The reference designator of the system being analyzed. This field can be left blank if not applicable.

	Description
	The description of the system being analyzed. This field can be left blank if not applicable.

	Report Format
	The Report Design Format filexe "Format file" that is used by default for this LCC file.


xe "Revision Control tab"

xe "Revision Control"Revision Control Tab

The Revision Control tab provides you with the ability to enter comments regarding the current revision of the LCC file. The Revision Control tab only appears after the initial file creation.

Creating/Opening an LCC File

The steps to creating a new Life Cycle Cost file are outlined below:

7. Select File>New>Life Cycle Cost or File>Open>Life Cycle Cost from the main menu. Enter the new file name or select the file to be opened and press <Create> or <Open> to continue.

8. If creating a new file, the tabs displaying the properties of the Life Cycle Cost file are displayed. Edit these properties if necessary and press <OK> when finished.

9. The Life Cycle Cost window is displayed. It is divided into two main windows: the Cost Breakdown Structure window and the Equation Definitionxe "Equation Definition" \r "D2HBEquation_Def6" window. From this window, you can access the Variables, Alternatives and Interval tables.

Entry of Cost Breakdown Structure 

The items in the CBS are displayed in a hierarchical format. The top level of the CBS is displayed at the top of the CBS, and all levels of indenture in the CBS are shown as branches off of the main item. 

Any item in the CBS can be expanded or collapsed. When a branch is expanded, items beneath it are displayed. When a branch is collapsed, only that level is displayed. You can collapse or expand any portion of a CBS by using one of these techniques:

· Click the + (plus) or – (minus) sign beside any item to expand (+) or collapse (–) it.

· Select the item with your cursor, and select CBS>Expand Branch or CBS>Collapse Branch from the main menu.

From the main menu, the CBS>Expand All and CBS>Collapse All expands and collapses all items in the current CBS respectively. 

Adding Items to the CBS

Items within a CBS are added as either a sibling or a child of another item. A sibling is a CBS item that resides at the same indenture level as another item. A child is a CBS item that resides at a lower level of indenture than another item.

Upon creating a new LCC file, the top level of the CBS is automatically defined. You may then build the structure of your system from there. The top level of the system is special in that it may only contain children. The top level of the CBS can never contain a sibling.

To add an item in a CBS, you may use any of the following techniques:

· Select the item with your cursor, and select Insert>Sibling or Insert>Child from the main menu.

· Select the item with your cursor, and select Insert Sibling or Insert Child from the right mouse menu.

Once an item has been added to a CBS enter the name of the child or sibling in the available field.

Moving/Copying Items in a CBS

You have various options for copying and moving items in a CBS.

Drag and Drop to Move

Click and drag the item to be moved. The selected item is positioned as a sibling of the existing CBS item.

Drag and Drop with <Shift> to Move as Child

Click and drag the item to be moved and hold <Shift> while releasing your mouse. The selected item is positioned as a child of the existing CBS item.

Drag and Drop with <Ctrl> to Copy

Click and drag the item to be moved and hold <Ctrl> while releasing your mouse. The selected item is copied to the new location as a sibling of the existing CBS item.

xe "Cut and Paste"Cut and Paste

Select the item to be cut with your cursor. Select Cut from the right mouse menu, or select Edit>Cut from the main menu. Select the new location of the cut item and click it with your cursor. The item is positioned as a sibling of the existing CBS item. To paste the item as a child of the existing CBS item select the CBS item where your item is to be placed and select Paste Child from the right mouse menu, or select Edit>Paste Child from the main menu.

xe "Copy and Paste"Copy and Paste

Select the item to be copied with your cursor. Select Copy from the right mouse menu, or select Edit>Copy from the main menu. Select the new location of the copied item and click it with your cursor. The item is positioned as a sibling of the existing CBS item. To paste the item as a child of the existing CBS item select the CBS item where your item is to be placed and select Paste Child from the right mouse menu, or select Edit>Paste Child from the main menu.

Deleting Items from the CBS

Items in a CBS can be deleted. Select the item to be deleted with your cursor and select Delete from the right mouse menu, or select Edit>Delete from the main menu.
Note: Deleting an item in the CBS deletes that element and all of its children.

Entry of Equation Definition

Using the Equation Definition window, the equations for the selected CBS item can be entered. The Cost Breakdown Structure window and Equation Definition window are synchronized so that the equation that displays corresponds to the selected CBS item. 

	Field
	Description

	Cost Equation
	The Cost Equation field is used to enter the equation for the selected CBS item. The equation is entered using the various buttons and options available in the lower portion of the Equation Definition window. 

	Description
	Accommodates the entry of a description regarding the CBS item. 

	Active
	If enabled, the CBS item is considered active, and is included in the calculation of the life cycle cost. If disabled, the CBS item is considered inactive, and the cost for that element and all of its children is assumed to be zero.


Each of these buttons and options available on the Equation Definition window is described as follows:

	Option
	Description

	Calculator Keypad
	Numbers 0 – 9 insert the number into the Cost Equation field at the point of your cursor.

Symbols +, -, /, *, period and comma inserts the selected symbol into the Cost Equation field at the point of your cursor.

( ) symbols are used to open or close the current level of parentheses. When selected, the open or close brackets are inserted into the Cost Equation field at the point of your cursor.

C clears the current equation from the Cost Equation field.

Fact inserts the factorial command into the Cost Equation field. For example, the equation fact(x) means to take the factorial of x.

Power inserts the power command into the Cost Equation field. For example, the equation power(x, y) means to take x to the power of y.

Sqrt inserts the square root command into the Cost Equation field. For example, the equation sqrt(x) takes the square root of x.

Exp inserts the exponent command into the Cost Equation field. For example, the equation exp(x) takes the exponential of x.

Ln inserts the natural logarithm (base e) into the Cost Equation field. For example, the equation ln(x) takes the natural logarithm of x.

log10 inserts the common logarithm (base 10) into the Cost Equation field. For example, the equation log10(x) takes the common logarithm of x.

	Item Variablesxe "Item Variables" \r "D2HBItem_Variabl8"
	Related only to the selected item in the Cost Breakdown Structure window. The current list of available item variables is displayed. Select the item variable to be added to the cost equation and double-click the primary mouse button. This inserts the selected variable into the Cost Equation field at the point of your cursor.

	Common Variablesxe "Common Variables"
	Global variables that are common to all elements in the CBS or Life Cycle Cost file. The current list of available common variables is displayed. Select the common variable to be added to the cost equation and double-click the primary mouse button. This inserts the selected variable into the Cost Equation field at the point of your cursor.

	Project Variables
	Related to data in a Relex Project file. The current list of available project variables is displayed. Select the project variable to be added to the Cost Equation and double-click the primary mouse button. This inserts the selected variable into the Cost Equation field at the point of your cursor.

	Add/Edit
	Allows you to add or edit variables. Upon selecting the <Add/Edit> button, the window for the Variables file is displayed. Variables can be added and edited as necessary. 

	Insert
	Inserts the selected variable into the equation at the point of your cursor. This same task can also be accomplished by double-clicking the left mouse button on the desired variable.

	Verify
	Verifies the current equation. If the equation is valid, a message appears stating Equation is Valid. If a problem is detected, a message appears stating the cause of the problem.


Customizing a Life Cycle Cost Analysis

Relex LCC allows you to customize your LCC analysis through the use of alternatives, time intervals and variables. Each of these components of a Life Cycle Cost file is described as follows:

Alternatives

Relex LCC allows you to define alternatives. Alternatives are useful for determining which approach to a problem is the most cost effective. For example, suppose that a design change is necessary. One alternative is to completely redesign the system. A second alternative is to modify the current design. Therefore, two alternatives can be compared (new design vs. design modification). In Relex LCC, alternatives are stored in an Alternatives file.
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Figure 12 - 2. Sample Life Cycle Cost, Alternatives File

To edit the contents of the Alternatives file, follow these steps:

1. Open the desired Life Cycle Cost file by selecting File>Open>Life Cycle Cost from the main menu.

2. With the LCC file open in the active window, select Life Cycle Cost>Edit Alternatives from the main menu.

3. Complete each of the sections in the Alternatives windowxe "Alternatives Window" as outlined in the following table.

4. Close the Alternatives window to save the changes.

5. Once alternatives are created, they can be used to perform comparison calculations. Common and item variables may be assigned for individual alternatives when variable values are assigned to Vary over Alternatives.

Alternatives Window

The Alternatives window allows you to create all of the alternatives for an LCC file. The following table reviews all of the fields available from the Alternatives window.

	Field
	Description

	Code
	Enter the code to be assigned to the alternative. This code must be unique. This code may be up to 255 characters in length.

	Description
	Enter a brief description of the alternative. The description may be up to 64,000 characters in length.

	Project Name
	Enter the name of the Project file to be referenced. A <Browse> button is available to the right for easy reference to file names and locations. This field is only used if the alternative is going to be used with project variables. When using project variables, data from an existing Project file can be inserted into a cost equation. If project variables are not going to be used for this alternative you may leave the field blank.

	Assembly Namexe "Assembly Name"
	Using the choice list, select the specific assembly to be referenced from the current Project file. If the top level of the Project is to be used, select the top-level name from the list. If no assembly name is selected, the Project selected for the alternative is not used.


Time Intervals

Relex LCC allows the definition of time intervals for determining life cycle costs. These intervals are user-defined. For example, if life cycle cost over a five-year period was to be analyzed, five time intervals (Year 1 or the current year, Year 2, Year 3, Year 4, and Year 5) would be defined. Similarly, if life cycle cost over five six-month periods was to be analyzed, five time intervals (Period 1 or the first six month period, Period 2, Period 3, Period 4, and Period 5) would be defined. An interval can be any unit of time, but each interval must represent an equivalent duration.

With each time interval, an interest rate (or inflation rate) can be defined. Relex LCC then uses these values to determine the net present valuexe "Net Present Value" \r "D2HBNet_Present_10" (NPV), or the cost in today’s currency, of your system. This can be useful to determine if a particular cost would be better incurred this year, or at a future time when costs may be lower.
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Figure 12 - 3. Sample Life Cycle Cost, Time Intervals File

To edit the Time Intervals file, follow these steps:

1. Open the desired Life Cycle Cost file by selecting File>Open>Life Cycle Cost from the main menu.

2. With the LCC file open in the active window, select Life Cycle Cost>Edit Time Intervals from the main menu.

3. Complete each of the sections of the Time Intervals window as outlined in the following table.

4. Close the Time Intervals window to save the changes.

5. Once time intervals are created, they can be used to perform comparison and net present value calculations. Common and item variables may be assigned for individual time intervals when variable values are assigned to Varies over Time Intervals.

Time Intervals Window

The Time Intervals window allows you to create all of the time intervals for an LCC file. The following table reviews all of the fields available from the Time Intervals window.

	Field
	Description

	Code
	Enter the code to be assigned to the time interval. This code must be unique. This code may be up to 255 characters in length.

	Description
	Enter a brief description of the time interval. This field is optional. The description may be up to 64,000 characters in length.

	Interest Rate
	This field is for the net present value (NPV) calculation is to be performed. In this case, enter the interest rate for the selected time period. If a net present value calculation is not performed, this field may be left blank.


Variables

In order to simplify the process of entering cost equations, Relex LCC provides you with the ability to specify variables to be used in the equations. When entering an equation, lists of all valid variables are displayed in list boxes. Double-click on the variable in order to insert it into the cost equation. In Relex LCC, there are three types of variables: item, common and project variables.

Definitions of Variables

	Variable
	Definition

	Item Variables 
	Related only to the selected item in the CBS window. Because item variables are specifically tied to an individual item in the CBS, they are only available for insertion into a cost equation when that CBS item is selected. 

	Common Variablesxe "Common Variables" \r "D2HBCommon_Varia11"
	Common to all elements in the CBS. 

	Project Variables 
	Related to data in a Project file. As an example, the failure rate determined in the reliability predictionxe "Reliability Prediction" portion of a Project can be used in a cost equation to determine life cycle cost. Project variables allow data from a Relex Project to be inserted into a cost equation automatically. Project variables are automatically created at the time an LCC file is created and cannot be added or deleted, however, the names may be modified.
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Figure 12 - 4. Sample Life Cycle Cost, Common Variables Tablexe "Variables Table"
Accessing a Variables Table

To access variables follow these steps:

1. Open the desired Life Cycle Cost file by selecting File>Open>Life Cycle Cost from the main menu.

2. With the LCC file open on the active window, select Life Cycle Cost>Edit Common Variables, Edit Project Variables, or Edit Item Variables from the main menu, or press <Add/Edit> under the column in the Equation Definitionxe "Equation Definition" window for the variable.

3. Complete each of the sections of the Variables Definition and Variables Data windows as outlined in the following sections.

4. Close the Variables window to save the changes.

5. Once variables are defined, they can be entered into any cost equation in the Equation Definition window of the LCC file.

Variables Definition Window

The Variables Definition window allows you to create the variables for use in the LCC file. To add a new variable select Insert>Insert New Record from the main menu. Below is a description of each of the fields available from the Variables Definition window.

	Field
	Description

	Code
	Enter the code to be assigned to the variable. This code must be unique. This code may be up to 255 characters in length.

	Description
	Enter a brief description of the variable. The description may be up to 64,000 characters in length.

	Variable Definition
	Select Constant if the value assigned for the variable is used any time the variable is used in a cost equation.

Select Varies over Alternatives if different values can be assigned for each alternative that exists. These values are used any time the variable is used in a cost equation. When a calculation is performed, you have the option of calculating any or all existing alternatives. Alternatives must first be created by selecting Life Cycle Cost>Edit Alternatives from the main menu.

Select Varies over Time Intervals if different values can be assigned for each time interval that exists. These values are used any time the variable is used in a cost equation. When a calculation is performed, you have the option of calculating any or all existing time intervals. Time intervals must first be created by selecting Life Cycle Cost>Edit Time Intervals from the main menu.

Select Varies over Alternatives and Time Intervals if different values can be assigned for each time interval that exists within each alternative. These values are used any time the variable is used in a cost equation. When a calculation is performed, you have the option of calculating any or all existing time intervals and/or alternatives. Time intervals and alternatives must first be created by selecting Life Cycle Cost>Edit Time Intervals and Life Cycle Cost>Edit Alternatives from the main menu.


Note: The process of adding a variable is only applicable for common and item variables. Project variables are predefined, and cannot be added or deleted. The codes of project variables can, however, be edited.

Variable Data Window

The Variable Data window is used to assign detailed information to the selected variable in the Variables Definition window. Select the variable from the Variables Definition window by clicking it with your cursor, and then assign values in the Variable Data window. Depending on the variable definition that was assigned to the variable, different information displays on the Variable Data window. The table below outlines the fields that display for each definition type.

	Field
	Definition

	Constant
	Enter the value that is to be applied to the calculation each time that variable is used in an equation in the Value field.

	Varies over Alternatives
	A list of each alternative that exists in the LCC file is displayed in the Alternative column.

Assign a value to each alternative in the Value column.

	Varies over Time Intervals
	A list of each time interval that exists in the LCC file is displayed in the Time Interval column.

Assign a value to each time interval in the Value column.

	Varies over Alternatives and Time Intervals
	A list of each alternative/time interval combination that exists in the LCC file is displayed.

Assign a value to each alternative/time interval in the Value column.


Project Variables 

Relex automatically creates project variables. They are standard variables and cannot be added or deleted. The code of the variables can be edited if desired. Project variables automatically retrieve data from a Project file if a Project file has been used in the alternatives for the LCC file. Relex LCC automatically retrieves the associated data from the specified assembly within the specified Project file. Each of the project variables is listed and described in the following table:

	Definition
	Description

	Availabilityxe "Availability"
	Calculated availability of the assembly in the Project file.

	AvailiabilityMission
	Calculated mission availability of the assembly in the Project file.

	Cost
	Cost of the assembly in the Project. This is generally calculated from lower levels in the Project, or is the value entered in the Cost field for the assembly.

	CostEquipment
	Calculated cost of equipment. This calculation is based on the cost (as previously described) plus the cost of sparesxe "Cost of Spares" (which is calculated as the Cost * Number of Spares for each assembly).

	CostFailure
	Calculated cost of failure, which is the cost of the unit including the cost of anticipated failures during the stated mission. This is calculated as: 

Cost (as previously described) * Failures per Hour * Mission Time

	DutyCycle
	The duty cyclexe "Duty Cycle" of the assembly in the Project. This is generally retrieved directly from the duty cycle field of the assembly.

	FailureRate
	Calculated failure ratexe "Calculated Failure Rate" of the assembly in the Project file. Accounts for both the active and dormantxe "Dormant" failure rates.

	FailureRateActive
	Failure rate calculatexe "Operating Environment"d based on the operating environment.

	FailureRateAllocated
	Allocated failure ratexe "Allocated Failure Rate" of the assembly in the Project file.

	FailureRateDormant
	Failure rate calculated based on the dormant environment. It is a percentage of the active failure rate.

	FailureRateMission
	Mission failure rate of the assembly in the Project file.

	FailureRateSpecified
	Specified failure rate of the assembly in the Project file.

	FailureRateUnit
	Unit failure rate of the assembly in the Project file, which does not take into account the quantity, entered for the assembly.

	MaintIndex
	Maintainability Index of the assembly in the Project file.

	MaximumCorrectiveMaintTime
	Maximum Corrective Maintenance Timexe "Maximum Corrective Maintenance Time" (MCMT) for the sigma percentile for the assembly in the Project file.

	MeanActiveMaintTime
	Mean time required for all active (corrective and preventive) maintenance actions.

	MeanCorrectiveMaintTime
	Mean Corrective Maintenance Time (MCMT) for the assembly in the Project file.

	MeanPreventativeMaintTime
	Mean Preventative Maintenance Time (MPMT) or the assembly in the Project file.

	MeanTimeBetweenFailures
	Calculated Mean Time Between Failuresxe "Mean Time Between Failures" (MTBFxe "MTBF") for the assembly in the Project file.

	MeanTimeToRepairMTTR
	Calculated Mean Time to Repair (MTTRxe "MTTR") for the assembly in the Project file.

	MMHFlightHour
	Mean Maintenance Manhoursxe "Mean Maintenance Manhours" per Flight Hour for the assembly in the Project file.

	MMHMaintAction
	Mean Maintenance Manhours per Maintenance Action for the assembly in the Project file.

	MMHOperatingHour
	Mean Maintenance Manhours per Operating Hour for the assembly in the Project file.

	MMHRepair
	Mean Maintenance Manhours per Repair for the assembly in the Project file.

	MTBFAllocated
	Allocated Mean Time Between Failures for the assembly in the Project file.

	MTBFMission
	Mission Mean Time Between Failures (MTBF) for the assembly in the Project file.

	MTBFSpecified
	Specified Mean Time Between Failures (MTBF) for the assembly in the Project file.

	MTTRSpecified
	Specified Mean Time to Repair (MTTR) for the assembly in the Project file.

	NumberofSpares
	Number of spares of the assembly in the Project file. This value is entered in the Number of Spares field for the assembly.

	Quantity
	Quantity entered for the assembly in the Project file. This value is entered in the Quantity field for the assembly.

	Reliability
	Calculated reliability of the assembly in the Project file.

	ReliabilityMission
	Calculated Mission Reliability of the assembly in the Project file.

	UserDefinedNumeric
	User-defined numeric value of the assembly in the Project file. This value is entered in the User-Defined Numeric field for the assembly.


Life Cycle Cost Calculations

Performing an LCC Calculation

To calculate an LCC file, press the <Calculate> button on the standard toolbar, or select Life Cycle Cost>Calculate from the main menu. The Calculate Life Cycle Cost window appears and displays various options regarding the calculation of life cycle cost. Once all options are set, press <OK> to perform the calculation. A status window appears displaying the progress of the calculation. When the calculation is complete, a total cost value for the LCC file is displayed. The calculations performed by Relex LCC are based on the equations that were assigned for each element in the CBS, and the total cost is the sum of all the lower level calculations (for the first alternative in the LCC file). For more detailed calculation results, a report can be generated.

In Relex LCC, calculating is very closely tied to the generation of reports. Many of the options available when calculating change the output results on the reports. For instance, options when calculating include the selection of alternatives and time intervals, and the performance of a sensitivity analysis.xe "Sensitivity Analysis" \r "D2HBSensitivity_17" After options are selected, and a calculation is performed, reports can be generated to review the results of the calculations.

xe "LCC Calculation Options"LCC Calculation Options
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Figure 12 - 5. Life Cycle Cost Calculation Options

The Calculate Life Cycle Cost window appears after selecting the Calculate function. This window allows certain options to be selected in order to specify the parameters of the LCC calculation. The following table lists all of the calculation options that are available.

	Alternatives
	Description

	All
	When enabled, the calculation is performed on all alternatives in the current LCC file. If all alternatives are calculated, values for all alternatives are output on LCC reports.

	Range
	When enabled, you are able to specify a range of alternatives. The range is selected by using the choice list buttons available from the From and To fields which are active with this option. If a range of alternatives is calculated, values for each of the alternatives in that range are included on LCC reports.

	Selected Alternatives 
	When enabled, you can select only certain alternatives that are included in the calculation. The alternatives are selected from the two boxes that are displayed. The box on the left displays all alternatives that are currently available, and the box displayed on the right displays all alternatives that are currently enabled to be included in the calculation. Alternatives are selected by using the <Add>, <Add All>, <Remove>, and <Remove All> buttons. Values for each of the selected alternatives are included on LCC reports.


	Time Intervals
	Description

	All
	When enabled, the calculation is performed on all time intervals in the current LCC file. If all time intervals are calculated, values for all time intervals are included on LCC reports.

	Range
	When enabled, you can specify a range of time intervals. The range is selected by using the choice list buttons available from the From and To fields which are active with this option. If a range of time intervals is calculated, values for each of the time intervals in that range are included on LCC reports.

	Selected Time Intervals 
	When enabled, you can select only certain time intervals that are included in the calculation. The time intervals are selected from the two boxes that are displayed. The box on the left displays all time intervals that are currently available, and the box displayed on the right displays all time intervals that are currently enabled to be included in the calculation. Time intervals are selected by using the <Add>, <Add All>, <Remove>, and <Remove All> buttons. Values for each of the selected time internals are included on the LCC report.


Sensitivity Analysis

Relex LCC also offers the ability to perform a sensitivity analysis on an LCC file. Sensitivity analysis is used to determine how robust a particular alternative is, and how sensitive the overall cost is to certain variables. When performing a sensitivity analysis, you specify a variable to modify and a percentage range over which to modify the variable. The following fields are related to performing a sensitivity analysis, and are available when calculating an LCC file.

	Option
	Description

	Sensitivity Analysis
	If this option is enabled, a sensitivity analysis calculation is also performed on the LCC file. 

	Variable
	A choice list is available to select the variable on which the sensitivity analysis is performed. Sensitivity analyses may be performed on either common or project variables.

	From % and To %
	A percentage range can be entered in the From % and To % fields. This range determines the percentage range for the sensitivity analysis. This percentage range is included on LCC reports.

	Increment
	An increment is entered to specify the increments to be calculated within the specified percentage range. This increment determines the increments that are included on LCC reports.


Reviewing LCC Calculation Results

After performing a calculation, a dialog box containing the results is displayed. The calculation results that are displayed represent the total life cycle cost of the file. To completely review all calculation results in a detailed format, a report is generated. 

Generating Reports in Relex LCC

As with other Relex modules, Relex LCC supports the use of customized report designs. A sample life cycle cost report design is supplied with Relex LCC, but others can be created and/or customized to suit your needs. A brief description of the sample life cycle cost report design is included in the Docs directory on the Relex CD.

In addition to the supplied life cycle cost report design, Relex also includes report designs for the other components included in Life Cycle Cost files.xe "Life Cycle Cost files" These reports can be generated from within the Alternatives, Time Intervals, and Variables files.

For more information regarding customizing the Report Design files to suit individual needs, refer to the “Reporting and Graphing” chapter of this manual.

Note: It is important to remember that the data included on a life cycle cost report is dependent on the options that were selected during the last LCC calculation. Because the process of calculating determines the results on any generated LCC report, perform a calculation prior to generating a report.xe "Generating a Report"
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